Subject: [rfc-i] Natural Language Processing (NLP) applied to RFCs

From: Michael Welzl <[email-masked]>
Date: Tue, 26 Mar 2019 11:39:01 +0100

Dear all,

I’m planning to do research with colleagues in NLP, with various ideas on applying it to RFCs (and, perhaps more importantly, Internet-drafts, which means that we can give feedback *before* RFC publication).
One example outcome of this is that we could perhaps produce a tool that automatically gives feedback on language clarity - e.g. “You may want to check this sentence again, are you sure it specifies what should go into that header field clearly enough?”  Heck, perhaps we can even give feedback like “shouldn’t this be an uppercase SHOULD here?”.

I’d like to understand what people think about doing such stuff, in general - would a tool that gives some such feedback as a result of using NLP be useful to have?
(obviously, *I* think so…)

Cheers,
Michael

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Ted Lemon <[email-masked]>
Date: Tue, 26 Mar 2019 14:03:05 +0100

> I’d like to understand what people think about doing such stuff, in general - would a tool that gives some such feedback as a result of using NLP be useful to have?

Yes, definitely.   This is a perennial problem.

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 26 Mar 2019 23:40:31 +0000

> Yes, definitely.   This is a perennial problem.

I very much agree with the problem. Of course, it will depend on how 
useful the tool's output is :-).

Regards,   Martin.

---

From: Michael Welzl <[email-masked]>
Date: Wed, 27 Mar 2019 00:44:37 +0100

> On Mar 27, 2019, at 12:40 AM, Martin J. Dürst <[email-masked]> wrote:
> 

Sure - it’s easy to imagine such a tool just producing a long list of useless garbage, and nobody would want to spend their time sifting through this.
It’s just a research idea at this point, knowing that people consider the problem important and support the idea of trying to construct such a tool is good enough for me  :)

Cheers,
Michael

---

From: Colin Perkins <[email-masked]>
Date: Wed, 27 Mar 2019 07:56:21 +0100

> On 26 Mar 2019, at 11:39, Michael Welzl <[email-masked]> wrote:
> 

I definitely think it could be useful. I’ve got a proposal under consideration, with Gareth Tyson and colleagues at QMUL, to try to get funding do something similar – we should sync-up.

Cheers,
Colin

-- 
Colin Perkins
https://csperkins.org/

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Mar 2019 09:10:32 +0100

On Mar 27, 2019, at 00:44, Michael Welzl <[email-masked]> wrote:
> 
> Sure - it’s easy to imagine such a tool just producing a long list of useless garbage,

Well, we have the not-quite-NLP “idnits”, and it certainly is useful.
What is missing from idnits, and should be in anything that has false positives, is a way to acknowledge each false positive that has been identified as such, in the source and suppress the listing of that.

Grüße, Carsten