Subject: Re: [rfc-i] Fwd: Re: [xml2rfc] Change in the results of using the "author" tag

From: Julian Reschke <[email-masked]>
Date: Tue, 9 Apr 2019 19:43:35 +0200

On 09.04.2019 19:30, Charlie Perkins wrote:
> Hello Heather and all,
>
> I was redirected to ask you instead of xml2rfc...
>
> Basically, I think it is wrong to enforce RFC Style Guide limitations
> when showing the authorship of external documents.  So, for instance, if
> an external publication shows that the author is "Francisca Yu", I don't
> think we should require the initialized version in the citation of an
> IETF document.
>
> Regards,
> Charlie P.
>
> PS. No offense to Ms. Yu.
>
> PPS. Can someone tell me how to cite a stable URL?
> ...

As a reference?

For instance:

> <reference anchor="Sniffing" target="https://mimesniff.spec.whatwg.org">
>    <front>
>       <title>MIME Sniffing</title>
>       <author>
>          <organization>WHATWG</organization>
>       </author>
>       <date />
>    </front>
> </reference>

Best regards, Julian
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 9 Apr 2019 10:30:13 -0700

Hello Heather and all,

Regards,
Charlie P.

-------- Forwarded Message --------
Subject: 	Re: [xml2rfc] Change in the results of using the "author" tag
Date: 	Tue, 9 Apr 2019 19:10:37 +0200
From: 	Julian Reschke <[email-masked]>
To: 	Charlie Perkins <[email-masked]>
CC: 	[email-masked]

On 09.04.2019 18:43, Charlie Perkins wrote:
> Hello Julian,
>
> I followed your suggestion.  Now it shows that the author is "D. Stanley".
>
> The actual document shows that the author is "Dorothy Stanley".
>
> Regardless of what the IETF says about handling names for RFCs, I think
> that external citations should reflect the authorship as indicated in
> the external publication.

Well, that contradicts the RFC Style Guide.

> I also tried simply deleting 'initials="D" surname="Stanley"' from the
> citation.  xml2rfc imposes the requirement anyway.
>
> Can we please have it to respect the actual authorship as shown in the
> publications which we cite?

That's a discussion you need to lead with the RFC Editor, not the tools
implementers.

> Regards,
> Charlie P.
>
> PS. How to I get a URI to be shown in the citation?  One way that does
> not work is to use
> <uri>https://mentor.ieee.org/802.11/dcn/15/11-15-1261-03-0arc-multicast-performance-optimization-features-overview-for-ietf-nov-2015.ppt</uri>

<https://greenbytes.de/tech/webdav/rfc7749.html#element.reference.attribute.target>

Best regards, Julian

xml2rfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 12 Apr 2019 13:35:26 +1200

Hi Charlie,

Sad to say I think you are wrong. Every journal I've ever submitted
to has its own required style for citations, and I'd say that overall
styles that require or permit given names rather than initials are unusual.
So the RFC Series is using a fairly standard practice.

For the IEEE's own style, see
https://ieee-dataport.org/sites/default/files/analysis/27/IEEE%20Citation%20Guidelines.pdf

This page is quite informative:
https://pitt.libguides.com/citationhelp

Or this, for the ACM style:
http://www.citethisforme.com/guides/association-for-computing-machinery

Regards
   Brian Carpenter

On 10-Apr-19 05:30, Charlie Perkins wrote:
> Basically, I think it is wrong to enforce RFC Style Guide limitations when showing the authorship of external documents.  So, for instance, if an external publication shows that the author is "Francisca Yu", I don't think we should require the initialized version in the citation of an IETF document.
> 
> Regards,
> Charlie P.
>

---

From: Martin J. Dürst <[email-masked]>
Date: Fri, 12 Apr 2019 08:50:59 +0000

Hello Brian,

On 2019/04/12 10:35, Brian E Carpenter wrote:
> to has its own required style for citations,

Agree; I already said so much in another mail just recently.

> and I'd say that overall

This is true too, but it puts people with names such as "Francisca Yu" 
or "John Smith", and Chinese, Koreans, and Danes in general, at a 
disadvantage.

Regards,   Martin.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Apr 2019 08:43:21 +1200

> or "John Smith", and Chinese, Koreans, and Danes in general, at a 

Fortunately for me, none of the other Brian Carpenters has showed up at the IETF yet, not even https://hackerone.com/geeknik. But nobody is immune to this problem. I'm not unsympathetic to Charlie's underlying issue.

   Brian