Subject: Re: [rfc-i] I-D Action: draft-flanagan-fiftyyears-03.txt

From: Brian E Carpenter <[email-masked]>
Date: Thu, 4 Apr 2019 16:34:22 +1300

Hi,

The txt version is seriously mangled in various places, as it's easy to
see from the diff. Just look for section 2, for example.

The HTML version looks nice. But if we're going to post a txt it
needs to be better, IMHO.

Also, the "html" link in the tracker doesn't actually point to
the HTML version.

Regards
   Brian

On 04-Apr-19 09:41, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Fifty Years of RFCs
>         Author          : Heather Flanagan
> 	Filename        : draft-flanagan-fiftyyears-03.txt
> 	Pages           : 21
> 	Date            : 2019-04-03
> 
> Abstract:
>    This RFC marks the fiftieth anniversary for the RFC Series.  It
>    includes both retrospective material from individuals involved at key
>    inflection points, as well as a review of the current state of
>    affairs.  It concludes with thoughts on possibilities for the next
>    fifty years for the Series.  This document updates and brings current
>    the history started in RFCs 2555 and 5540.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-flanagan-fiftyyears/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-flanagan-fiftyyears-03
> https://datatracker.ietf.org/doc/html/draft-flanagan-fiftyyears-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-flanagan-fiftyyears-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 4 Apr 2019 06:47:09 +0200

Hi Brian,

> see from the diff. Just look for section 2, for example.

Ugh.  This was produced by the 2.22.1 xml2rfc release, which was buggy in
exactly the ways we see here.  Version 2.22.2 was released shortly after
to fix that.  I thought the datatracker copy had been updated, but not so.

In this case, the buggy .txt version has been produced by the datatracker
running xml2rfc on the uploaded v3 .xml source, so the .txt does not come
from the submitter.  I'll fix in place this particular time, as part of
getting the 2.22.2 version in place.

Regards,

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 5 Apr 2019 09:22:03 +1300

Thanks Henrik.

And FYI to the list administrator: gmail flagged Henrik's message
as spam, because this list is not rewriting the From in the
way that IETF lists now do.

Regards
   Brian

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 4 Apr 2019 16:24:57 -0400

Brian,

Not my gmail, I got Henrik's email just fine. :-) Perhaps because we've
corresponded in the past?

Cheers,
Andy

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 5 Apr 2019 15:52:15 +0200

Hmm, -04 has the same problems.

https://tools.ietf.org/html/draft-flanagan-fiftyyears-04
https://datatracker.ietf.org/doc/draft-flanagan-fiftyyears/

Grüße, Carsten

> On Apr 4, 2019, at 06:47, Henrik Levkowetz <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Brian,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 5 Apr 2019 17:05:25 +0200

Hi Carsten,

> Hmm, -04 has the same problems.

Ugh.  Thanks.   Mumble, mumble.  Ok, this time I'm going to do a re-start
of apache, to make sure it loads the latest version of the xml2rfc lib.

> https://datatracker.ietf.org/doc/draft-flanagan-fiftyyears/

Thank you, Carsten.

Best regards,

	Henrik