Subject: [rfc-i] SVG tools?

From: Brian E Carpenter <[email-masked]>
Date: Mon, 20 May 2019 16:07:25 +1200

Hi,

Who has experience to share about success with tools to generate SVG drawings for v3 format?

At the moment I can only report failures: SVG files produced by LibreOffice and by https://onlineconvertfree.com/convert-format/png-to-svg/ both defeat the checking tool at https://xml2rfc.tools.ietf.org/experimental.html#svg12checker

(This is a change: an SVG 1.1 file that I generated with LibreOffice in 2014, when Nevil was developing the checker, still checks OK today, with a minor warning. When I regenerate it today with LibreOffice, it purports to be SVG 1.2 but the checker crashes with "RuntimeError: dictionary changed size during iteration".)

Regards
   Brian Carpenter
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Mon, 20 May 2019 06:38:28 +0200

> (This is a change: an SVG 1.1 file that I generated with LibreOffice in 2014, when Nevil was developing the checker, still checks OK today, with a minor warning. When I regenerate it today with Lib…

I did some tests a new months ago, and also included some
down-conversion in my version of the preptool
(<https://github.com/reschke/xml2rfc/blob/master/prep-xml2rfc.xslt>).
For me the main issue that was hard to fix was the lack of markers.

Best regards, Julian

---

From: Jim Schaad <[email-masked]>
Date: Mon, 20 May 2019 15:18:19 -0700

Brian,

When I loaded your file into LibreOffice, it wanted to open it as a
presentation rather than a drawing.  Are you using Impress Presentation or
Draw to create the file?  The text at
https://www.rfc-editor.org/rse/wiki/doku.php?id=svg_files is saying that you
should be using Draw.

Jim

> -----Original Message-----
> From: rfc-interest <[email-masked]> On Behalf Of
Brian
> E Carpenter
> Sent: Sunday, May 19, 2019 9:07 PM
> To: [email-masked]
> Subject: [rfc-i] SVG tools?
> 
> Hi,
> 
> At the moment I can only report failures: SVG files produced by
LibreOffice
> and by https://onlineconvertfree.com/convert-format/png-to-svg/ both
> defeat the checking tool at
> https://xml2rfc.tools.ietf.org/experimental.html#svg12checker
> 
> (This is a change: an SVG 1.1 file that I generated with LibreOffice in
2014,
> when Nevil was developing the checker, still checks OK today, with a minor
> warning. When I regenerate it today with LibreOffice, it purports to be
SVG
> 1.2 but the checker crashes with "RuntimeError: dictionary changed size
> during iteration".)
> 
> Regards
>    Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 May 2019 13:45:31 +1200

> https://www.rfc-editor.org/rse/wiki/doku.php?id=svg_files is saying that you

Very possibly that is better, but the origin of my drawing was an IETF slide set for a particular draft that contained an ASCII art version of the same drawing. So my "use case" was transferring a drawing from a slide set to a v3 draft. We'll debug this off list, perhaps, and report back.

Thanks
    Brian