Subject: [rfc-i] artwork width in v3?

From: Julian Reschke <[email-masked]>
Date: Tue, 27 Aug 2019 15:32:06 +0200

Hi there,

looking at <https://tools.ietf.org/html/rfc6949#section-3.3>:

> 3.3.  Requirements to Be Retired
>
>    Some of the original requirements will be removed from consideration,
>    but detailed rules regarding how these changes will be implemented
>    will be documented in a future RFC.
>
>       *  Pagination ("Each page must be limited to 58 lines followed by
>          a form feed on a line by itself.")
>
>       *  Maximum line length ("Each line must be limited to 72
>          characters followed by carriage return and line feed.")
>
>       *  Limitation to 100% ASCII text ("The character codes are
>          ASCII.")

...and <https://tools.ietf.org/html/rfc7994#section-4.3>:

> 4.3.  Line Width
>
>    Each line must be limited to 72 characters followed by the character
>    sequence that denotes an end-of-line (EOL).  The EOL sequence used by
>    the RFC Editor will be the two-character sequence CR LF (Carriage
>    Return followed by Line Feed).  This limit includes any left-side
>    indentation.
>
>    Note that the EOL used by the RFC Editor may change with different
>    transports and as displayed in different display software.

I *thought* that we discussed relaxing that limit (to ~90)? Is my
recollection incorrect?

Best regards, Julian
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Kent Watsen <[email-masked]>
Date: Wed, 28 Aug 2019 15:48:54 +0000

> I *thought* that we discussed relaxing that limit (to ~90)? Is my

With PDF-output, a smaller font could be used, but how would ~90 chars work in the plain-text output?  

Perhaps, in conjunction with the artwork-folding draft, currently in IESG Last Call?  https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding>

Kent

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Aug 2019 18:06:11 +0200

> work in the plain-text output?

Well, just like 80 chars output, just wider :-)

> Perhaps, in conjunction with the artwork-folding draft, currently in
> IESG Last Call?
> https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding

That's an interesting proposal. From the abstract it sounds like it's
not going to be needed in HTML output, right?

Best regards, Julian

---

From: Kent Watsen <[email-masked]>
Date: Wed, 28 Aug 2019 16:20:19 +0000

> Well, just like 80 chars output, just wider :-)

You mean, the text runs off the Right side of the page?  Information lost?

> not going to be needed in HTML output, right?

Yes.  Ideally the HTML-output would have the original/unfolded inclusion text, rendering a horizontal scrollbar when needed, enabling the full-width to the viewed on screen. 

Kent

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Aug 2019 19:25:52 +0200

> You mean, the text runs off the Right side of the page?  Information lost?

Resize your terminal window, or set it to wrap long lines?

> Yes.  Ideally the HTML-output would have the original/unfolded inclusion
> text, rendering a horizontal scrollbar when needed, enabling the
> full-width to the viewed on screen.

Ack. FWIW, I don't think we should spend too much time on optimizing
plain text output.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Aug 2019 22:58:06 +0200

> Ack. FWIW, I don't think we should spend too much time on optimizing

No, we shouldn’t.

We still might have a very different concept for what “too much time” would be…

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 29 Aug 2019 10:42:47 -0400

> work in the plain-text output?

I wouldn't want to do that.

    > <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding>

This seems like a totally reasonable thing to do, and to teach xml2rfc
to do automatically when generating .txt format documents.
Seems odd for this to be in the netmod WG though :-)
But, I can see why you guys need it.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 29 Aug 2019 08:03:13 -0700

> I wouldn't want to do that.

<early morning humor>

Why not?  With PDF and zoom-able documents, size no longer matters.  You
can finally zoom to that bottom turtle.

See, here's a good document in a small font:

A

Here's that same document zoomed:

      #     
     # #    
    #   #   
   #######  
  #       #
 #         #

Good stuff!

Or even

      #     
     # #    
    #   #   
   #######  
  #       #
 #         #

Which, in some forms, may need to turn into

      #     
     # #    
    #   #   
   #######  
  #       \
\#
 #        \
\ #

</early morning humor>

> But, I can see why you guys need it.

Yeah, I agree...  This really belongs in a different group and is good
work that others may want to comment on.  I suppose that's why we have
IETF last call, but I think most general people that see "netmod" in the
title won't read the document, thinking it's specific to a particular
sub-technology.
-- 
Wes Hardaker
USC/ISI
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest