Subject: [rfc-i] community member or not Re: [IAB] RFC Series Editor (RSE) Statement of Work

From: "Leslie Daigle" <[email-masked]>
Date: Fri, 02 Aug 2019 11:30:45 -0400

Replying to just one point in this, as I am still trying to chew through 
the larger problem:

> - unless you're going for the acting RSE approach, please do
> not encourage applications from members of the IETF community
> as I think we don't want an RFC author for the RSE role but
> rather a series editor and those are IMO quite different things

This didn’t fit Jon Postel.  Nor did it fit Bob Braden or Joyce 
Reynolds.  All were IETF community members.

I could ask if your point is a reflection on the IETF community being 
less luminary than it used to be.

But, ISTM that part of the larger problem is that we’re trying to 
“hire expertise”, that both understands our universe and brings in 
some level of external subject matter experience and expertise, which is 
good.  But then we, (for we == leadership, at least) treat them like 
staff, not community.

I have (many) more thoughts on that theme, but will stop there, for now, 
and see what people think.

Leslie.

On 1 Aug 2019, at 17:04, Stephen Farrell wrote:

> Hiya,
>
> I have some feedback as an individual member of the
> community...
>
> On 15/07/2019 15:25, Sarah B wrote:
>> Hello, Attached is the RSE SOW intended for the upcoming RFP. You'll
>> find it very much inline with the previous SOW we sent out as part of
>> the RFP during the last iteration of this process. The RSOC is
>> requesting community feedback, and would like to run a 4 week
>> feedback period. That period starts today, July 15, and ends August
>> 15, 2019. Please direct your feedback to the RSOC directly.
>
> Since we did ask after the plenary to use this list, I'll
> send to here...
>
> If the hiring/search process starts now, I think there ought
> be some mention that the community are highly likely to be
> modifying rfc6635 in the next two years. My read of all the
> mails is that it seems to be an almost universally held opinion
> that some changes to 6635 are needed and timely, e.g. taking
> out the bit that pretends the RSE is somehow day-to-day
> "responsible" for the operation of the RPC. Of course there
> are very different opinions as to what changes to make but
> in any case I think all potential new RSEs should be told
> this up front.
>
> I'm honestly not sure myself if going ahead now and trying to
> find a new RSE for 2020-2022 and maybe more is a good or bad
> plan. I can see arguments for waiting 'till we're done with
> a 6635bis, for going ahead and involving a new RSE in 6635bis
> discussion and for trying to find someone to be acting RSE
> for a year or so while the 6635bis discussion happens. I'm
> also not clear that there's a community consensus on that
> question.
>
> (It'd be great if more people explicitly said which option
> they think ought be taken here for this question that needs
> an answer within a couple of weeks. IIUC the default will be
> to run the process as per 6635 as that's the only reasonable
> default I can see in the absence of consensus for something
> else.)
>
> If I were forced to choose between one of the three options
> from the para 2 above this, I think I'd very weakly go for
> trying to get a new RSE now who is willing to be involved
> in the 6635bis work. (My initial preference was for an
> acting RSE but very very few of the sensible people I chatted
> to about this in Montreal seemed to like that.)
>
> Other than that, reflecting on some of the other mails, my
> personal feedback to RSOC is:
>
> - please do considering a search committee made up of people
> that you hope will be acceptable to those with all shades of
> opinion as to the RSE position and the current situation (if
> they exist and are gullible enough to say yes to you;-)
>
> - as previously stated in the threads about RSE-as-employee,
> please do not restrict yourself to searching for a new RSE
> from locations with some specific (e.g. US-style) employment
> law - finding the best person and not trying to pick based
> on a preferred contractual arrangement is what I hope you do
>
> - perhaps consider adding something to the statement of work
> (or whatever you publicise) to the effect that the RFC series
> has been on the go for 50 years and we'd like it to continue
> for some decades more (so long as interesting material keeps
> turning up to publish) and that such a long term focus is
> part of the RSE role in 6635 and is extremely likely to be
> part of the role in future too
>
> - unless you're going for the acting RSE approach, please do
> not encourage applications from members of the IETF community
> as I think we don't want an RFC author for the RSE role but
> rather a series editor and those are IMO quite different things
> (there may be a couple of RFC authors who could be a good RSE,
> but I'd bet there are many more who'd wrongly-think that they
> could be a good RSE, so it'd be good to not have to deal with
> those folks if you can think of a nice way to discourage them:-)
>
> Cheers,
> S.
>
>
>
>
>>
>> Kind regards, Sarah Banks, Chair on behalf of the RSOC
>>
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 2 Aug 2019 16:55:46 +0100

Hiya,

>> rather a series editor and those are IMO quite different things

So I think the rest of that bullet is important to keep with the
first part you quote above:

"(there may be a couple of RFC authors who could be a good RSE,
but I'd bet there are many more who'd wrongly-think that they
could be a good RSE, so it'd be good to not have to deal with
those folks if you can think of a nice way to discourage them:-)"

> Reynolds.  All were IETF community members.

Sure.

> less luminary than it used to be.

No idea. I wasn't about 'till about mid-'90's and like most
IETFers didn't care at all about any of this until much more
recently. That said, I think I'd bet it was always true that
the community included quite a few people who'd wrongly-think
they could be a good RSE and very few who would be.

> But, ISTM that part of the larger problem is that we’re trying to “hire
> expertise”, that both understands our universe and brings in some level
> of external subject matter experience and expertise, which is good.  But
> then we, (for we == leadership, at least) treat them like staff, not
> community.

I don't believe it's accurate to say that "leadership" (if
you mean every IAB/IESG/LLC-board member) "treat them like
staff." I do agree that that's a perception that's out there
that seems to me to be based on a real divergence of opinion
in the community (and not just "leadership") as to how the
RSE role (and maybe other roles) ought be defined.

So while it's a bit self-serving for me to say it, it may
be that thinking of the RSE situation as being nothing more
than a leadership problem may be mistaken. (Even if I'm
right there, it of course remains entirely understandable
and even correct to beat-up on leadership in such cases:-)

Cheers,
S.

---

From: "Leslie Daigle" <[email-masked]>
Date: Fri, 02 Aug 2019 12:09:13 -0400

Hi,

> those folks if you can think of a nice way to discourage them:-)"

I understood your point (and largely agree with it :^) ) but I 
deliberately removed it in my quote because I felt it was a distraction 
from the main thing:  your starting statement that the next RSE would 
not be a community member.

>> “hire

Definitely “and other roles”, but that’s a subject for a different 
list.

Leadership is specifically singled out because that’s who’s making 
the implementation decisions that are making the reality more like 
“staff” than “community”.

It may or may not be reflected more broadly throughout the community:   
ISTM that the real question here is to figure that out, and get 
community consensus on which way we want to go, because there are 
significant consequences either way.

Leslie.

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 2 Aug 2019 18:03:19 +0100

Hiya,

> It may or may not be reflected more broadly throughout the community:  

IMO this is not a situation where only I* people differ
in opinion, nor one where all I* people are of one mind.

IOW, I feel pretty sure that there are diverse opinions
on the RSE role in the community when you omit those
currently doing some I* stuff. And that seems to be
reflected within the set of people currently on I* too.

As I think understand those arguments I reckon they
could maybe be roughly characterised as falling into
two buckets. Bucket#1 has arguments along the lines
that there now exist lots of ways to publish things
so the RFC series (and associated roles) no longer
need to be setup as they were 20 or 30 years ago.
Bucket#2 might be roughly described as those who
think there's an inherent value in the RFC series
and it's longevity and that changes to that need to
be done with extreme care and attention to the past
as well as the present and future.

Personally, I think there are valid arguments in
both buckets, but I'd find myself more in tune with
the arguments in bucket#2 I figure.

All that said, I am very unsure of the relative numbers
of IETF participants who basically don't care (a majority
I'd bet when it comes to any of this organisational stuff),
or who might be usefully described as fitting into buckets
#1 or #2.

And of course, I might also be plain wrong in how I
think about the arguments here.

> significant consequences either way.

Yep. I agree with you there. It's not that clear how
one might determine (rough) consensus on some of these
issues though, until we get to e.g. a draft of 6635bis
that we can run through a normal enough process.

Cheers,
S.

---

From: Michael StJohns <[email-masked]>
Date: Fri, 2 Aug 2019 13:26:57 -0400

On 8/2/2019 11:30 AM, Leslie Daigle wrote:
>
>
> Replying to just one point in this, as I am still trying to chew 
> through the larger problem:
>

Jon/Bob/Joyce preceded the community, and were a big influence on how 
the community came to be formed.  As such, they were somewhat immune to 
what the community would write down about the RFC series "must"s.  Then 
there's the "inventing the job" thing that Jon and Bob and Joyce did, 
and the further refinement of "publisher" not "RFC Author" that Heather 
did.

None of these three were typical RFC authors - most of what they were 
credited as authors for (according to the RFC Editor search function) 
were related to their other jobs (IANA, RFC Editor). Bob was probably 
the closest to a typical RFC author with his interest in diffserv, rsvp 
and related protocols.

> less luminary than it used to be.

There is some of that, but it's probably more that the skillsets don't 
match up.   With the one exception of Ole J (and of course excluding the 
RSE and ISE), I'm not sure anyone currently involved in the IETF as an 
RFC author has series editing/publishing experience. I would expect that 
a few have book or special publication editing experience, but I'm not 
sure how well those might translate.

> some level of external subject matter experience and expertise, which 
> is good.  But then we, (for we == leadership, at least) treat them 
> like staff, not community.

I think we need to prioritize expertise over knowledge of our universe.  
I'm pretty sure (worked example == Heather) that we anyone we choose for 
the role that understands publishing can eventually be made to 
understand publishing RFCs.

Later, Mike

>
> I have (many) more thoughts on that theme, but will stop there, for 
> now, and see what people think.
>
> Leslie.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 3 Aug 2019 10:34:23 +1200

Isn't the point that the RSE *might* be a community member and/or RFC
author, but *must* be knowledgeable and experienced in technical
publishing?

Regards
   Brian