Subject: [rfc-i] DATE CHANGE: RFC Editor Model - Virtual Interim Meeting Announcement and Invitation

From: Heather Flanagan <[email-masked]>
Date: Wed, 4 Sep 2019 12:30:09 -0700

** Based on feedback that I’ve hit a major international holiday on 30 September, I’ve moved that meeting slot to 1 October 2019 **

Hello,

The RFC Series has come to a crossroads where questions must be answered regarding how the Series should be managed, the role of the RFC Series Editor, and the oversight of the RFC Editor function. The RFC Editor publishes RFCs for the IETF, the IRTF, the IAB, and the Independent Submissions stream. Those RFCs are referred to by other Standards Development Organizations (SDOs), by organizations and governments in their procurement processes, by academics, and more. Decisions on the future of the RFC Editor and the RFC Series needs to include input from both the producers and the consumers of RFCs.

I am reaching out to different groups and organizations so that they may be a part of figuring out how to answer those questions. It is worth noting that I am not trying to get to a final answer on what the future of the RFC Editor and the RFC Series should be; I’m trying to reach consensus on who should be making those decisions.  So, with that in mind, this is an invitation to attend one of three virtual interim meetings, and/or the face-to-face meeting (with remote participation supported) at IETF 106 in Singapore. 

This is not an IETF or IRTF activity, but we are holding this discussion under the IETF and IRTF policies described in the Note Well (https://www.ietf.org/about/note-well/ <https://www.ietf.org/about/note-well/>).  This is to ensure consistent and well-understood policies, particularly relating to appropriate behavior, privacy, etc.  To the extent that topics of discussion might comprise input to IETF or IRTF and involve regular participants in each, this ensures that these discussions are covered under the rules of those bodies.

The virtual meetings will be held in various time-zone sensitive windows to enable as much participation as possible:

Friday, 13 September 2019 at 16:00 UTC
Monday, 30 September 2019 at 13:00 UTC
Friday, 18 October 2019 at 02:00 UTC

The WebEx information, a copy of the agenda [1], and (eventually) all future proceedings are on the RSE wiki: https://www.rfc-editor.org/rse/wiki/doku.php?id=interim <https://www.rfc-editor.org/rse/wiki/doku.php?id=interim>

Required reading list: 
https://www.rfc-editor.org/info/rfc4844 <https://www.rfc-editor.org/info/rfc4844>
https://www.rfc-editor.org/info/rfc6635 <https://www.rfc-editor.org/info/rfc6635>
https://datatracker.ietf.org/doc/draft-carpenter-request-for-comments/ <https://datatracker.ietf.org/doc/draft-carpenter-request-for-comments/>
https://datatracker.ietf.org/doc/draft-iab-fiftyyears/ <https://datatracker.ietf.org/doc/draft-iab-fiftyyears/>
https://www.ietf.org/about/note-well/ <https://www.ietf.org/about/note-well/>

This announcement and invitation is being extended to:
* IETF, IRTF, IAB, and Independent Submission authors and participants via various mailing lists, including the rfc-interest, ietf-announce, and wgchairs mailing lists
* Regional NOGs
* IAB liaison contacts (see https://www.ietf.org/about/liaisons/ <https://www.ietf.org/about/liaisons/>)
* ISOC chapter heads
* REFEDS

Email-based discussion on this topic should happen on the rfc-interest mailing list (https://www.rfc-editor.org/mailman/listinfo/rfc-interest <https://www.rfc-editor.org/mailman/listinfo/rfc-interest>).

Additional participants are welcome; feel free to forward to anyone you think would be interested and willing to contribute to the discussion. 

Thank you for your time,
Heather Flanagan
RFC Series Editor

—

[1] Agenda

Administrivia
Meeting will be recorded
Note Well (https://www.ietf.org/about/note-well/ <https://www.ietf.org/about/note-well/>)

Acknowledging possible models
The RFC Editor as a wholly independent entity
The RFC Editor as an IAB/RSOC managed function
The RFC Editor as an IETF LLC managed function

Identifying how to handle next steps:
Who manages the community discussion?
Who needs to be invited to the table?
Who calls consensus?

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Sep 2019 13:54:49 +1200

Hi,

I won't be able to attend either of the first two interim meetings, so excuse me for getting a word in first.

>  2. Acknowledging possible models
> 

I think those models are not entirely separate; there could be more overlap than appears at first sight. The kind of model that I believe would be robust for the future is along the following lines:

- state and guarantee the editorial independence of the RFC Series and the Series Editor. This is something we failed to do in the IAB Charter 19 years ago. Whether this deserves a legal framework (e.g. "The RFC Editor Foundation") is open to discussion.

- retain the notion that there is community monitoring (I hesitate to use the word "oversight", because I believe that it's got us into trouble twice, with both the IAOC and the RSOC).

- retain the IETF/IAB linkage as the way of exercising that monitoring. Rename and respecify the RSOC accordingly.

- use the IETF LLC to manage the measurable functions of the production and publication processes. And, presumably, as the funding agency for the unmeasurable functions of the series editor (monitored as above).

I don't think this would be a radical change; more of a rebalancing to make things work the way we thought they worked.

One other thought for now. If the IETF really believed that an independent RFC Series is not needed for the IETF's output, it would be trivial enough: when a draft is approved by the IESG, all we'd need to do is rename draft-ietf-sillywg-sillyprotocol-15 as final-ietf-sillywg-sillyprotocol and post it to the tracker.

Regards
   Brian Carpenter

On 05-Sep-19 07:30, Heather Flanagan wrote:
> This is not an IETF or IRTF activity, but we are holding this discussion under the IETF and IRTF policies described in the Note Well (https://www.ietf.org/about/note-well/).  This is to ensure consistent and well-understood policies, particularly relating to appropriate behavior, privacy, etc.  To the extent that topics of discussion might comprise input to IETF or IRTF and involve regular participants in each, this ensures that these discussions are covered under the rules of those bodies.
> 
> https://www.rfc-editor.org/info/rfc4844
> https://www.rfc-editor.org/info/rfc6635
> https://datatracker.ietf.org/doc/draft-carpenter-request-for-comments/
> https://datatracker.ietf.org/doc/draft-iab-fiftyyears/
> https://www.ietf.org/about/note-well/
> 
> * IAB liaison contacts (see https://www.ietf.org/about/liaisons/)
> * ISOC chapter heads
> * REFEDS
> 
> Email-based discussion on this topic should happen on the rfc-interest mailing list (https://www.rfc-editor.org/mailman/listinfo/rfc-interest).
> 
>   * Meeting will be recorded
>   * Note Well (https://www.ietf.org/about/note-well/)
> 
> 
>   * The RFC Editor as a wholly independent entity
>   * The RFC Editor as an IAB/RSOC managed function
>   * The RFC Editor as an IETF LLC managed function
> 
> 
>   * Who manages the community discussion?
>   * Who needs to be invited to the table?
>   * Who calls consensus?
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
>

---

From: Heather Flanagan <[email-masked]>
Date: Fri, 13 Sep 2019 12:36:54 -0700

Hi Brian,

> On Sep 10, 2019, at 6:54 PM, Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi,
> 

The possible models are noted purely to give us a sense of scale, of what kind of issues will the body that calls consensus need to deal with. The goal of these interim calls is not to iterate on that list of possible models in any way. 

So, yes, you are making good points. Hold that thought. :-)

-Heather

>> The WebEx information, a copy of the agenda [1], and (eventually) all future proceedings are on the RSE wiki: https://www.rfc-editor.org/rse/wiki/doku.php?id=interim <https://www.rfc-editor.org/rse/wiki/doku.php?id=interim> <https://www.rfc-editor.org/rse/wiki/doku.php?id=interim <https://www.rfc-editor.org/rse/wiki/doku.php?id=interim>>
>> 
>> Required reading list: 
>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>> https://www.rfc-editor.org/mailman/listinfo/rfc-interest <https://www.rfc-editor.org/mailman/listinfo/rfc-interest>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/ietf-announce <https://www.ietf.org/mailman/listinfo/ietf-announce>
>> 
> 
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest <https://www.rfc-editor.org/mailman/listinfo/rfc-interest>