Subject: [rfc-i] RFC 8661 in AUTH48, was: [xml2rfc-dev] [v3] Please help review v3 files

From: Julian Reschke <[email-masked]>
Date: Wed, 18 Sep 2019 06:32:13 +0200

On 03.08.2019 14:51, Julian Reschke wrote:
> ... >
>> ... >> The contributors section in both documents looks terrible in HTML.
> Probably because there is no defined way to add contributors in a way
> that renders in a manner consistent with authors in text formats, so the
> authors choose to use <pre>/<artwork> for that section.  We need to fix
> that somehow.
>>
>> Right - that was the only way we could get the info to display similar
>> to Authors’ Addresses.
>> We will discuss this.
>
> Please discuss here:
> <https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/81>
> ...

FWIW, RFC 8661 (in AUTH48) has that problem.

Would be good to resolve it in some way before publication.

Best regards, Julian
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Heather Flanagan <[email-masked]>
Date: Wed, 18 Sep 2019 13:09:17 -0700

> On Sep 17, 2019, at 9:32 PM, Julian Reschke <[email-masked]> wrote:
> 

HI Julian, et al.,

The RFC Editor discussed this internally; we recognize it as a problem for more than just RFC-to-be 8661. That said, for now we’re going to use a work around, as the implementing of a new way of handling the role of “contributor” is outside the existing scope of work. 

The plan for now is touse <artwork> element. Yes, it will look differently than Authors' Addresses in the HTML and PDF outputs. It is not ideal.

The future solution (TBD) may have us creating the role “contributor” and having that signal specific rendering details within the Contributor section. 

This isn’t a showstopper for going live with v3.

-Heather

---

From: Julian Reschke <[email-masked]>
Date: Wed, 18 Sep 2019 22:22:28 +0200

> The RFC Editor discussed this internally; we recognize it as a problem for more than just RFC-to-be 8661. That said, for now we’re going to use a work around, as the implementing of a new way of ha…

Well, the issue has been known for several years now, so declaring it
out-of-scope is a bit weird. Note that this is a regression from v2,
where line breaks could be forced inside regular text, so at least no
abuse of <artwork> was needed.

> The future solution (TBD) may have us creating the role “contributor” and having that signal specific rendering details within the Contributor section.

As discussed in the ticket
(<https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/81>),
adding a new role will not work, as:

- existing tools will treat contributors as authors, which they are not
- it does not address the RFC style guide suggestion to allow mixing
prose with contact information.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Wed, 18 Sep 2019 22:59:17 +0200

On 18.09.2019 22:22, Julian Reschke wrote:
>> The RFC Editor discussed this internally; we recognize it as a problem
>> for more than just RFC-to-be 8661. That said, for now we’re going to
>> use a work around, as the implementing of a new way of handling the
>> role of “contributor” is outside the existing scope of work.
>

16 years, apparently:
<https://mailarchive.ietf.org/arch/msg/xml2rfc/V6eiR3kzg3svDwJRPnh4st4K-Zs>.

Best regards, Julian

---

From: S Moonesamy <[email-masked]>
Date: Thu, 19 Sep 2019 02:35:08 -0700

Hello,
At 01:22 PM 18-09-2019, Julian Reschke wrote:
>>The RFC Editor discussed this internally; we recognize it as a 
>>problem for more than just RFC-to-be 8661. That said, for now we're 
>>going to use a work around, as the implementing of a new way of 
>>handling the role of 'contributor' is outside the existing scope of work.
>

Given that this is a known problem and it is not that new, why is 
outside the existing scope of work?

Regards,
S. Moonesamy