Subject: [rfc-i] First v3 RFC is published - RFC 8651 on Dynamic Link Exchange Protocol (DLEP) Control-Plane-Based Pause Extension

From: Heather Flanagan <[email-masked]>
Date: Mon, 7 Oct 2019 13:00:25 -0700

Wow, everyone. We did it!

Thank you all for years and years of effort in getting us to this point. RFC 8651 is now the first RFC to be published in the v3 format.

As those of you on the xml2rfc list know, there are still heated discussions underway about some aspects of the XML vocabulary. Getting the -bis documents out to capture the reality of the v3 format is critically important. That is in the top 3 priorities for me as I wrap up my time as RSE (the other two are operational transition items and the RFC Model process discussion).

I particularly want to thank the RPC staff. They have worked incredibly hard to fill the roles of expert copyeditors, quality assurance engineers, and key stakeholders throughout the seven years (and counting) of the RFC format project. This is an amazing team. Thank you.

Heather Flanagan, RSE

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: RFC 8651 on Dynamic Link Exchange Protocol (DLEP) Control-Plane-Based Pause Extension
> Date: October 7, 2019 at 12:58:52 PM PDT
> To: [email-masked], [email-masked]
> Cc: [email-masked], [email-masked], [email-masked]
> 
> A new Request for Comments is now available in online RFC libraries.
> 
> 
>        RFC 8651
> 
>        Title:      Dynamic Link Exchange Protocol (DLEP) 
>                    Control-Plane-Based Pause Extension 
>        Author:     B. Cheng, 
>                    D. Wiggins,
>                    L. Berger, Ed.
>        Status:     Standards Track
>        Stream:     IETF
>        Date:       October 2019
>        Mailbox:    [email-masked], 
>                    [email-masked], 
>                    [email-masked]
>        Pages:      12
>        Updates/Obsoletes/SeeAlso:   None
> 
>        I-D Tag:    draft-ietf-manet-dlep-pause-extension-08.txt
> 
>        URL:        https://www.rfc-editor.org/info/rfc8651
> 
>        DOI:        10.17487/RFC8651
> 
> This document defines an extension to the Dynamic Link Exchange
> Protocol (DLEP) that enables a modem to use DLEP messages to pause
> and resume data traffic coming from its peer router.
> 
> This document is a product of the Mobile Ad-hoc Networks Working Group of the IETF.
> 
> This is now a Proposed Standard.
> 
> STANDARDS TRACK: This document specifies an Internet Standards Track
> protocol for the Internet community, and requests discussion and suggestions
> for improvements.  Please refer to the current edition of the Official
> Internet Protocol Standards (https://www.rfc-editor.org/standards) for the 
> standardization state and status of this protocol.  Distribution of this 
> memo is unlimited.
> 
> This announcement is sent to the IETF-Announce and rfc-dist lists.
> To subscribe or unsubscribe, see
>  https://www.ietf.org/mailman/listinfo/ietf-announce
>  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
> 
> For searching the RFC series, see https://www.rfc-editor.org/search
> For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
> 
> Requests for special distribution should be addressed to either the
> author of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for
> unlimited distribution.
> 
> 
> The RFC Editor Team
> Association Management Solutions, LLC
> 
> 

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 7 Oct 2019 16:10:25 -0400

Heather,

Congratulations!

And a request ... probably not for you, but for the tools team (added to
the to: list). The Datatracker has a pointer to the htmlized version from
the tools site, but not the HTML version from the rfc-editor site ... can
that be added?

Thanks,
Andy

On Mon, Oct 7, 2019 at 4:00 PM Heather Flanagan <[email-masked]> wrote:

> Thank you all for years and years of effort in getting us to this point.
> RFC 8651 is now the first RFC to be published in the v3 format.
>
> As those of you on the xml2rfc list know, there are still heated
> discussions underway about some aspects of the XML vocabulary. Getting the
> -bis documents out to capture the reality of the v3 format is critically
> important. That is in the top 3 priorities for me as I wrap up my time as
> RSE (the other two are operational transition items and the RFC Model
> process discussion).
>
> I particularly want to thank the RPC staff. They have worked incredibly
> hard to fill the roles of expert copyeditors, quality assurance engineers,
> and key stakeholders throughout the seven years (and counting) of the RFC
> format project. This is an amazing team. Thank you.
>
> Heather Flanagan, RSE
>
> Begin forwarded message:
>
> *From: [email-masked]
> *Subject: **RFC 8651 on Dynamic Link Exchange Protocol (DLEP)
> Control-Plane-Based Pause Extension*
> *Date: *October 7, 2019 at 12:58:52 PM PDT
> *To: [email-masked], [email-masked]
> *Cc: [email-masked], [email-masked],
> [email-masked]
>

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 7 Oct 2019 13:13:00 -0700

(Trimming the recipient list a bit)

I think that’s a great idea (though as you noted, outside of my purview)!

-Heather

> On Oct 7, 2019, at 1:10 PM, Andrew G. Malis <[email-masked]> wrote:
> 
> Heather,
> 
> Congratulations!
> 
> And a request ... probably not for you, but for the tools team (added to the to: list). The Datatracker has a pointer to the htmlized version from the tools site, but not the HTML version from the rfc-editor site ... can that be added?
> 
> Thanks,
> Andy
> 
> 
> On Mon, Oct 7, 2019 at 4:00 PM Heather Flanagan <[email-masked] <mailto:[email-masked]>> wrote:
>> From: [email-masked] <mailto:[email-masked]>
>> To: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>> Cc: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>> 
>>        Mailbox:    [email-masked] <mailto:[email-masked]>, 
>>                    [email-masked] <mailto:[email-masked]>, 
>>                    [email-masked] <mailto:[email-masked]>
>>        Pages:      12
>>        URL:        https://www.rfc-editor.org/info/rfc8651 <https://www.rfc-editor.org/info/rfc8651>
>> 
>>        DOI:        10.17487/RFC8651
>> 
>> Internet Protocol Standards (https://www.rfc-editor.org/standards <https://www.rfc-editor.org/standards>) for the 
>>  https://www.ietf.org/mailman/listinfo/ietf-announce <https://www.ietf.org/mailman/listinfo/ietf-announce>
>>  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist <https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist>
>> 
>> For searching the RFC series, see https://www.rfc-editor.org/search <https://www.rfc-editor.org/search>
>> For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk <https://www.rfc-editor.org/retrieve/bulk>
>> 
>> author of the RFC in question, or to [email-masked] <mailto:[email-masked]>.  Unless
> [email-masked] <mailto:[email-masked]>
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest <https://www.rfc-editor.org/mailman/listinfo/rfc-interest>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 7 Oct 2019 22:58:44 +0200

On 07.10.2019 22:00, Heather Flanagan wrote:
> discussions underway about some aspects of the XML vocabulary. Getting
> the -bis documents out to capture the reality of the v3 format is
> critically important. That is in the top 3 priorities for me as I wrap
> up my time as RSE (the other two are operational transition items and
> the RFC Model process discussion).
>
> hard to fill the roles of expert copyeditors, quality assurance
> engineers, and key stakeholders throughout the seven years (and
> counting) of the RFC format project. This is an amazing team. Thank you.
>
> Heather Flanagan, RSE
> ...

So, as far as I can tell, <https://www.rfc-editor.org/rfc/rfc8651.xml> -
which is supposed to be the canonical format - does not conform to the
V3 grammar (neither the one from RFC 7991, nor what's in the unpublished
RFC 7991bis):

> C:\projects\xml2rfc\rfc8651.xml:93:96: error: attribute "bare" not allowed here; expected attribute "anchor", "empty", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:93:96: error: attribute "indent" not allowed here; expected attribute "anchor", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:95:150: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:95:250: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:96:104: error: attribute "bare" not allowed here; expected attribute "anchor", "empty", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:96:104: error: attribute "indent" not allowed here; expected attribute "anchor", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:98:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:98:256: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:103:150: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:103:287: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:106:150: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:106:266: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:107:104: error: attribute "bare" not allowed here; expected attribute "anchor", "empty", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:107:104: error: attribute "indent" not allowed here; expected attribute "anchor", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:109:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:109:270: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:110:112: error: attribute "bare" not allowed here; expected attribute "anchor", "empty", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:110:112: error: attribute "indent" not allowed here; expected attribute "anchor", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:112:174: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:112:306: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:117:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:117:248: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:120:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:120:252: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:125:150: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:125:272: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:128:150: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:128:264: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:129:104: error: attribute "bare" not allowed here; expected attribute "anchor", "empty", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:129:104: error: attribute "indent" not allowed here; expected attribute "anchor", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:131:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:131:278: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:134:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:134:270: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:137:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:137:302: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:142:150: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:142:246: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:143:104: error: attribute "bare" not allowed here; expected attribute "anchor", "empty", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:143:104: error: attribute "indent" not allowed here; expected attribute "anchor", "pn", "spacing", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:145:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:145:278: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:148:162: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:148:282: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:153:155: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:153:258: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:156:155: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:156:263: error: attribute "sectionFormat" not allowed here; expected attribute "pageno", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:166:144: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:179:88: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:182:139: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:184:139: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:187:163: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:188:124: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:200:134: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:201:138: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:209:90: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:209:176: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:221:134: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:224:152: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:288:96: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:347:196: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "format", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:347:196: error: attribute "section" not allowed here; expected attribute "derivedContent", "format", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:347:196: error: attribute "derivedLink" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:431:92: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:468:113: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:507:96: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:534:102: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:563:134: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:565:134: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:575:114: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:581:139: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:593:88: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:607:127: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:608:120: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:633:127: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:634:120: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:667:118: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:668:110: error: attribute "sectionFormat" not allowed here; expected attribute "derivedContent", "pageno", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:711:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:711:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:726:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:726:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:741:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:741:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:770:197: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:770:197: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:794:199: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "target", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:794:199: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:815:151: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:815:151: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:825:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:825:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:848:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:848:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:877:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:877:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:903:128: error: attribute "quoteTitle" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:903:128: error: attribute "derivedAnchor" not allowed here; expected attribute "quote-title", "xml:base" or "xml:lang"
> C:\projects\xml2rfc\rfc8651.xml:937:70: error: element "author" not allowed here; expected the element end-tag or element "artset", "artwork", "aside", "blockquote", "dl", "figure", "iref", "ol", "section", "sourcecode", "t", "table", "texttable" or "ul"
> C:\projects\xml2rfc\rfc8651.xml:951:72: error: element "author" not allowed here; expected the element end-tag or element "artset", "artwork", "aside", "blockquote", "dl", "figure", "iref", "ol", "section", "sourcecode", "t", "table", "texttable" or "ul"
> C:\projects\xml2rfc\rfc8651.xml:965:82: error: element "author" not allowed here; expected the element end-tag or element "artset", "artwork", "aside", "blockquote", "dl", "figure", "iref", "ol", "section", "sourcecode", "t", "table", "texttable" or "ul"
> C:\projects\xml2rfc\rfc8651.xml:106:266: error: IDREF "name-extension-data-items" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:120:252: error: IDREF "name-restart" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:153:258: error: IDREF "name-acknowledgments" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:103:287: error: IDREF "name-extension-usage-and-identif" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:109:270: error: IDREF "name-queue-parameters" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:131:278: error: IDREF "name-extension-type-value" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:145:162: error: IDREF "section-6.1" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:148:162: error: IDREF "section-6.2" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:134:270: error: IDREF "name-data-item-values" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:128:264: error: IDREF "name-iana-considerations" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:125:272: error: IDREF "name-security-considerations" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:137:302: error: IDREF "name-queue-parameter-sub-data-ite" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:106:150: error: IDREF "section-3" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:103:150: error: IDREF "section-2" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:95:150: error: IDREF "section-1" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:142:150: error: IDREF "section-6" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:128:150: error: IDREF "section-5" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:125:150: error: IDREF "section-4" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:148:282: error: IDREF "name-informative-references" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:156:155: error: IDREF "section-appendix.b" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:153:155: error: IDREF "section-appendix.a" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:117:248: error: IDREF "name-pause" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:120:162: error: IDREF "section-3.3" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:131:162: error: IDREF "section-5.1" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:134:162: error: IDREF "section-5.2" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:137:162: error: IDREF "section-5.3" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:95:250: error: IDREF "name-introduction" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:112:174: error: IDREF "section-3.1.1" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:156:263: error: IDREF "name-authors-addresses" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:112:306: error: IDREF "name-queue-parameter-sub-data-it" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:142:246: error: IDREF "name-references" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:145:278: error: IDREF "name-normative-references" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:98:162: error: IDREF "section-1.1" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:98:256: error: IDREF "name-key-words" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:109:162: error: IDREF "section-3.1" without matching ID
> C:\projects\xml2rfc\rfc8651.xml:117:162: error: IDREF "section-3.2" without matching ID

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 7 Oct 2019 23:06:01 +0200

On 07.10.2019 22:58, Julian Reschke wrote:
>> Thank you all for years and years of effort in getting us to this
>> point. RFC 8651 is now the first RFC to be published in the v3 format.
>>
>> I particularly want to thank the RPC staff. They have worked
>> incredibly hard to fill the roles of expert copyeditors, quality
>> assurance engineers, and key stakeholders throughout the seven years
>> (and counting) of the RFC format project. This is an amazing team.
>> Thank you.
>>
>> Heather Flanagan, RSE
>> ...
>

Also, running the XML through an alternative processor (rfc2629.xslt)
yields:

> ERROR: user-supplied boilerplate differs from auto-generated boilerplate (inserting auto-generated) (at line 6)

...which is no surprise as the generated TOC is contained in the
<boilerplate> element, where it has no reason to be.

I understand that the V3 format is work-in-progress, but whatever the
state is, there should be at least one version of the format's grammar
that the published XML conforms to.

Best regards, Julian

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 7 Oct 2019 16:37:48 -0400

This is awesome. And the HTML version is very easy to read. Nice job. And direct section links! Perfect!

Tom

> On Oct 7, 2019, at 4:13 PM, Heather Flanagan <[email-masked]> wrote:
> 
>> On Oct 7, 2019, at 1:10 PM, Andrew G. Malis <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Heather,
>> 
>> Congratulations!
>> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Martin J. Dürst <[email-masked]>
Date: Mon, 7 Oct 2019 23:45:15 +0000

[reducing cc to RFC-interest, but feel free to re-broaden again]

Congratulations to everybody involved! I'm of course looking forward to 
the first RFC with non-ASCII characters.

And a small (but I guess important) nit: At 
https://www.rfc-editor.org/info/rfc8651, I'd put the HTML icon before 
the TXT icon, because now HTML is the "main" version.

Regards,   Martin.

---

From: Martin J. Dürst <[email-masked]>
Date: Mon, 7 Oct 2019 23:47:12 +0000

Also, for the "Cite this RFC:", BibTeX would be nice to have. I'd be 
willing to help with it.

Regards,    Martin.

On 2019/10/08 08:45, Martin J. Dürst wrote:
> .

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 7 Oct 2019 16:47:18 -0700

> On Oct 7, 2019, at 4:45 PM, Martin J. Dürst <[email-masked]> wrote:
> 

That seems like a sane suggestion; I’ll discuss it with the RPC!

Thanks,
Heather

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 7 Oct 2019 18:21:15 -0700

(Shifting to just rfc-interest and probably the very interested parties on the RSOC/IAB)

> On Oct 7, 2019, at 2:06 PM, Julian Reschke <[email-masked]> wrote:
> 

Hi Julian,

Are you asking for an RNG file that’s publicly available, or a -bis doc that’s up to date? I’m still working on the latter, as you’ve noted, and for the former we (the RFC Editor) is looking at what’s here as the latest: https://svn.tools.ietf.org/svn/tools/xml2rfc/trunk/cli/xml2rfc/data/v3.rnc

I know that’s not entirely satisfactory--there are changes that have not been noted anywhere except the implementation draft, the xml2rfc release notes, and various email discussions —but that’s where it stands for now. 

-Heather

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 8 Oct 2019 02:47:43 +0000

From: rfc-interest <[email-masked]> on behalf of Heather Flanagan <[email-masked]>
Date: Monday, October 7, 2019 at 4:00 PM
To: IETF discussion list <[email-masked]>, RFC Interest <[email-masked]>
Cc: RSOC <[email-masked]>, Internet Architecture Board <[email-masked]>
Subject: [rfc-i] First v3 RFC is published - RFC 8651 on Dynamic Link Exchange Protocol (DLEP) Control-Plane-Based Pause Extension

Heather Flanagan, RSE

Yippee!!

---

From: Julian Reschke <[email-masked]>
Date: Tue, 8 Oct 2019 06:02:43 +0200

On 08.10.2019 03:21, Heather Flanagan wrote:
>> On Oct 7, 2019, at 2:06 PM, Julian Reschke <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
> Are you asking for an RNG file that’s publicly available, or a -bis doc
> that’s up to date? I’m still working on the latter, as you’ve noted, and
> for the former we (the RFC Editor) is looking at what’s here as the
> latest:
> https://svn.tools.ietf.org/svn/tools/xml2rfc/trunk/cli/xml2rfc/data/v3.rnc
>
> I know that’s not entirely satisfactory--there are changes that have not
> been noted anywhere except the implementation draft, the xml2rfc release
> notes, and various email discussions —but that’s where it stands for now.
>
> -Heather

I'm actually looking for both.

I checked
https://svn.tools.ietf.org/svn/tools/xml2rfc/trunk/cli/xml2rfc/data/v3.rnc,
and indeed the published XML validates with it, but that's because it
contains a change that never has been discussed before and which also is
not documented anywhere (as far as I can tell). That in turn was added
in order to workaround something which is a leak of an implementation
detail (the preptool step inserting the TOC), wihch in turn, isn't
documented either.

Best regards, Julian