Subject: Re: [rfc-i] [IAB] New proposal/New SOW comment period

From: John C Klensin <[email-masked]>
Date: Thu, 03 Oct 2019 15:28:25 -0400

Christian,

I just noticed that I had never responded to your note below.
It deserves an answer, particularly because I think you have
identified a key reason why various of us keep talking past each
other.

Briefly and I hope correctly interpreting your comments, many of
us believe the RFC Series is an Internet Community resource and
publication series and that, when ISOC and the IETF took on
responsibility for it in several stages from the early 1990s
through 2007, it was doing so as, to use Jon Postel's language
form quite a different document, a trustee for that larger
community.  It is obviously reasonable to question that role and
its ongoing appropriateness and to assert that, e.g., the IESG
should have control over what is published.  I can certainly
remember discussions of that issue in 1994.  We had them again
leading up to the publication of RFCs 4844 through 4846 in 2007,
and several times in between and subsequently.  I think it is
safe to say that the community has never been in complete
agreement since the RFC Editor Function was separately and
directly funded by the US Government and probably not even
before then.  I do not, however, see that discussion as "some
people believe one thing and others believe something else" or
"whether the RSOC (and, to some extent, the IAB) agrees with my
understanding of the role and function of the RFC Series".  From
my point of view, the community was asked that question as part
of the "RFC++" discussion of somewhat over a year ago and there
was a fairly clear answer of "not just about the IETF" (both in
terms of the series and what things were called).  If we
disagree about that conclusion, then we have another problem.
But, even if you (and others) believe the outcome of the July
2018 discussions was unclear with regard to the function of the
RFC Series, I think we end up with two issues:

(1) Where the RFC Editor Function is concerned, are the RSOC and
IAB responsible for fairly interpreting community consensus
(even if only EITF community consensus) and following it, or can
they reasonably go off in other directions without any
accountability to the community?

(2) Given that the RFC++ effort was an attempt to redefine the
RFC Editor Function at least with regard to how documents are
named and that it clearly did not get [even] IETF community
consensus, is it reasonable to use Heather's decision to step
down at the end of the year (whether that decision came as a
surprise or was deliberately or accidentally induced) as an
excuse or mechanism for opening the question of the role of the
RFC Editor Function again in such a short time?   And, if it is,
should that question be posed in a balanced way and asked openly
and specifically rather than partially hidden in the plans for
replacing Heather (whether temporarily or permanent, etc.).

FWIW, there are many other questions about the RFC Editor
Function and the RFC Series about which assumptions have been
made for many years but that sensible people can argue are
obsolete.  One that has been raised repeatedly (and that the
RFC++ effort certainly touched on) was whether Independent
Submissions are still necessary and appropriate given all of the
other ways by which information that comes out of the IETF can
be published.   Another is whether the whole idea of archival
documents is necessary any more.  Recent threads on the
rfc-interest list lead me to believe that there are several
members of the community who believe the answer to the latter
question is "no" or perhaps that the IETF model for
authoritative clarifications to standards-track documents is in
need of reopening and reconsideration.

best,
   john

--On Friday, September 13, 2019 11:00 -0700 Christian Huitema
<[email-masked]> wrote:

> On 9/13/2019 7:44 AM, John C Klensin wrote:
> 
>> The difficulty, which several people tried to get a
>> focus on (before IETF 105, at the plenary, and thereafter),
>> was the question of whether the RSOC (and, to some extent,
>> the IAB) understood (generally and consistent with community
>> understanding) the role and function of the RFC Series, the
>> relationship of the RSE to that function, the appropriate
>> interpretation of "oversight", some important management and
>> procurement differences between hiring and management of
>> high-level professional and, procurement of
>> easily-substitutable commodity items.
> 
> John,
> 
> The way you phrase it, there is an eminent understanding of
> the role and function of the RFC series and the RSE that
> everybody should agree on, and you suspect the IAB does not.
> That why you use the word "understood" in the quoted text. I
> think that vocabulary presumes the outcome of the ongoing
> discussion. For example, you and several others including Mike
> and Brian hold it as obvious that "the RFC series is bigger
> than the IETF". That was certainly true in 1981, but I am sure
> there are people who don't believe that in 2019 -- and those
> people are indeed part of "the community".
> 
> You may believe that you have a superior understanding, but
> the correct phrasing would be "the question of whether the
> RSOC (and, to some extent, the IAB) agrees with my
> understanding of the role and function of the RFC Series".

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 3 Oct 2019 21:13:05 +0100

Hi John,

A question and a comment below.

On 03/10/2019 20:28, John C Klensin wrote:
> community.  

On the "larger community" (than IETF/IRTF) aspect, do we have
any definition of how that community might be characterised?

Personally, I can easily see including RFC readers in that,
(otherwise why'd we bother make 'em?) but beyond that, I don't
know what else may be meant. Can you (or someone) clarify?

> It is obviously reasonable to question that role and

Again, speaking personally, I do see two rough positions that
people in the IETF seem to have, and ISTM that divergence is
also reflected in the subset of us currently in IETF leadership
positions. One position might roughly revolve around ideas
that we ought cherish the independence of the RSE and the
longevity of the series, another might be said to revolve around
ways that we should change the series to better reflect
today's reality. (I don't mean that to be in any way a precise
characterisation and once one tried to be precise there
would of course be more than two different positions.) My
take is that both positions seem sincerely held and each has
some merit. (Though I admit I'd be more inclined to cherishing
than changing, as my own starting point.)

In any case, I do think we ought have a community discussion
now about that, given that Heather is (regretfully) moving on
and given the changes to 6635 that seem obvious (to me at
least) now we have the LLC setup.

Cheers,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 4 Oct 2019 09:24:35 +1300

Hi Stephen,
> know what else may be meant. Can you (or someone) clarify?

Not in a few words, but may I point to
https://tools.ietf.org/html/draft-carpenter-request-for-comments ?
The most relevant text is:

   The reasonable conclusion from the above is that none of the I*
   organisations (IETF Trust, IETF LLC, IETF, IESG, IAB or ISOC) can
   claim exclusivity of ownership or control over the RFC series.  It is
   community property and must operate on behalf of the community as a
   whole.

   A first important consequence is that major decisions about the
   future of the RFC Series must be taken by a consensus of a very broad
   community.  That doesn't mean the IETF or the IAB.  It means the IETF
   and IAB, plus the IRTF, plus many other people who have contributed
   to, or made use of, the RFC Series over the last fifty years.  How to
   reach out to this community is in itself a big question.

   A second important consequence is that the position of RFC Series
   Editor answers to the community as a whole, not narrowly to the IAB.
   In particular the RFC Series Editor has considerable independence (in
   addition to the obvious independence of the Independent Series
   Editor).
 
> today's reality. 

I'd rather say "change the IETF standards process to better reflect
today's reality, including how that process interacts with the RFC
series." IMHO it would be a serious mistake to try to fix the IETF's
process only by fiddling with the RFC series.

> (I don't mean that to be in any way a precise

Indeed. 

   Brian

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 3 Oct 2019 21:40:17 +0100

(Changing the subject, hope that's ok)

Hi Brian,

> https://tools.ietf.org/html/draft-carpenter-request-for-comments ?

Sure. I recall reading that before.

>    community property and must operate on behalf of the community as a

I'm not sure that considering this in terms of who owns or
controls what is our best bet TBH, even though that is partly
in contention I guess. It may be easier to first roughly
define what is meant by a "larger community" (though I may
be wrong about that as I often am;-).

>    reach out to this community is in itself a big question.

Do you think that's a different set of people than "RFC
readers"? If so, how?

I guess one could extend it to people affected by the RFC
series, but then you're up to 7.7 billion and counting
which doesn't seem right really.

FWIW, I'm not seeing much in the middle that could be
usefully characterised, although I'm sure there are many
programmers out there who don't read RFCs but who work on
code that includes implementations of RFCs.

Cheers,
S.

PS: Your riff on my rough description of positions below
seems pretty reasonable but not that related to the specific
question above.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 4 Oct 2019 11:40:40 +1300

> (Changing the subject, hope that's ok)

More than OK, thanks.

> be wrong about that as I often am;-).

I agree.
 
> Do you think that's a different set of people than "RFC

As you hint below, implementors may in effect be part of the 
RFC user community even if they don't actually read the text.
And other such as lobbyists and politicians in some cases.
And consumer advocates. So the boundary is bound to be fuzzy.
I don't think there's any point in trying to define it precisely;
we just have to recognise that it's not just "us" for any
reasonable definition of "us", so we have a broad responsibility.

   Brian

---

From: John C Klensin <[email-masked]>
Date: Thu, 03 Oct 2019 19:22:36 -0400

Stephen,

> (Changing the subject, hope that's ok)

Probably overdue although I wanted my note to reflect the
subject line Christian used.  So thanks.

General comment: I think Brian's I-D is a very important
contribution to what I increasingly see as the key discussion.
I think (at least) the three of us agree that discussion is due
or overdue (except insofar as we see the core issues as having
been settled in July 2018).  From my personal standpoint,
whatever the IAB or RSOC decide to do to be sure there isn't a
break in the RFC Editor Function on Heather's departure is very
nearly irrelevant except insofar as those decisions foreclose or
preempt options for the future of the RFC Series.
Unfortunately, I see a very real risk of such foreclosure or
preemption occurring, whether by accident or intentionally.

>...
>>    The reasonable conclusion from the above is that none of
>>    the I* organisations (IETF Trust, IETF LLC, IETF, IESG,
>>    IAB or ISOC) can claim exclusivity of ownership or control
>>    over the RFC series.  It is community property and must
>>    operate on behalf of the community as a whole.
> 

I would suggest that it implies not only "readers of RFCs" (your
categorization later in your note) but everyone who is dependent
on them.  To the extent to which we want to be even partially as
an engineering body rather than a recorder of common industry
practices (a long note I wrote about that some time ago, but was
assured that no one had read, might be relevant here) that means
publication, not only of documents that describe the IETF's
conclusions but documents that explain why the IETF might be
wrong under some circumstances and what should be done instead.
It includes procurement people who want to be sure that whatever
they buy conforms to some standard.  That implies that the
standard has to be clear and stable but not that they will ever
read it (if things don't work and they call in the lawyers, it
may imply that the latter, and experts they hire, would need to
read it carefully).  That, in turn, raises some issues about
what "the standard" for a particular topic or protocol really
is, which segues into the Newtrk work that the IESG at the time
blew off but the underlying issues are as significant now as
ever.   

>From my point of view, very few of those issues are actually
separable from each other and, as Brian points out, it "would be
a serious mistake to try to fix the IETF's process only by
fiddling with the RFC series".  I'd actually go a bit further
and suggest that it is hard to think clearly about the RFC
Editor Function without understanding what the IETF --and those
who are, or should be, dependent on its work-- actually need and
want.  If, for example, the IETF were to go significantly in the
direction of turning technical specifications into living
documents, then a different publication model might be needed
(it may be helpful to remember that Newtrk never anticipated
ISDs or other summary documents being part if the RFC Series and
subject to its constraints.  On the other hand, if the IETF were
to move in the direction of 5 year review cycles and completely
replacing earlier documents, that would also force large changes
in the relationship between IETF technical specs and the RFC
Series.

> which doesn't seem right really.

See above.  I think that, wrt the RFC Series and the RFC Editor
function, it would help a lot if the IETF and IAB assumed the
role of trustees for that broader community, thought carefully
about what that would mean, shared those thoughts as widely as
possible, and opened them for discussion.

>...

best,
   john

---

From: Christian Huitema <[email-masked]>
Date: Fri, 4 Oct 2019 00:51:15 -0700

John,

Your note deserves a longer reply, but I can start with a brief answer.

Starting from your last point, I do believe that the Independent Stream
and its Editor provide an important function in the standard process,
both for checks and balance, so that independent contributions can be
published in the RFC series without endorsement or agreement from IETF
Working Groups or the IESG, and for providing an avenue for publication
of specification created outside of the IETF. I have all reasons to
believe that this process is working quite well, and no desire to change
that. The principles of RFC 1796 are still relevant.

I also believe that the RFC series is today pretty much centered on the
IETF. Over 80% of the publications are in the IETF stream, 15% in the
Independent stream, with IRTF and IAB sharing the reminder. But then,
these last three streams are in practice just as focused on the IETF as
the IETF stream itself. The overwhelming majority of the document
authors also participate in the IETF, contribute to WG, write drafts,
etc. The document themselves are generally part of the IETF discussion,
even if they are research pieces or independent publication. These
observations make me extremely skeptical about the supposed Internet
Community that would contribute to the RFC series independently of the
IETF. In practice, I don't see any evidence that such an independent
Internet Community exists today.

I have heard Brian Carpenter's argument that if there is not an
authorship community, there is a readership community. That leaves me
skeptical. Clearly, authors and publishers should care about their
readership, and I wish we had better ways to assess the impact of our
publications. But passive readership does not create a community, no
more than me reading ITU publications makes me part of the ITU
community. What creates a community is engagement, contributions and
sharing. I see that happening in the IETF and the IRTF. I wish more
people would participate, but in practice this means increased openness
of the IETF, recruiting existing communities and open source projects, etc.

The RFC series are part of our history and our tradition. Our tradition
is based on solid principles, such as open standards, openly documented,
easy to access, easy to read, well archived. Our tradition also gives us
the strong "RFC" brand, which we would be silly to jeopardize with some
kind of "new Coke" effort. Heather has done a lot of work to modernize
the format, the reference tools and the archival tools without breaking
too much from that tradition. That's great.

At the same time, there is a tension between the tradition and the need
to serve and recruit a wider community. Our document production time is
counted in years, and that does not help convincing open source projects
to work with us. Our documents are cast for eternity, errors included,
which does not help the part the part of the readership who wants to
implement standards. Implementing our standards involves a treasure hunt
to find how many RFC have to be read before understanding the whole
picture. And that's before we even consider the potential of confusion
between standards, experiments, independent efforts, and drafts. The
IETF community will need to solve that over time. I assume that this
will imply some sharing of the work between the RFC Editor and the
"superstructure" of the IETF, and I wait to see the discussion happening
in the ad hoc working group. And yes, of course the discussion process
should be open and fair.

-- Christian Huitema

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 4 Oct 2019 10:31:49 +0100

Hiya,

Answers to Brian, John, and Christian (from the other
thread) below...

> reasonable definition of "us", so we have a broad responsibility.

I think I disagree about the level of fuzziness that's ok here.
If we extend to all 7.7 billion people then there's no way in
the world anyone could really consult the non-IETF bits of the
community. So I think I'd argue that a direct connection to the
RFC series (e.g. being a reader) is needed if we're to get a
common understanding of this bigger community.

Yes, that'd omit some who implement from stackexchange but that
might be good enough. Personally, I have absolutely no problem
not including lobbyists in our description of that community. (But
note that this need not be exclusionary - all that lobbyist has
to do is read an RFC to get back in:-)

On 04/10/2019 00:22, John C Klensin wrote:
> I would suggest that it implies not only "readers of RFCs"
> (your categorization later in your note) but everyone who
> is dependent on them.

But that is basically the entire planet, right? (So same point
as I made above seems to me to apply.) But if I'm wrong, can
you help me understand (e.g. via examples) who you think is in,
and not in, the community as you envisage it?

On 04/10/2019 08:51, Christian Huitema wrote:
> sharing.

I guess I disagree with you there Christian - ISTM that
at the very least, people who read RFCs and write related
code that is part of many network stacks, but who do not
engage with the IETF or RFC editor at all, do deserve more
consideration than you imply. I can see arguments for a
bigger set of people deserving consideration but omitting
the above example set seems just broken to me.

Cheers,
S.

---

From: Christian Huitema <[email-masked]>
Date: Fri, 4 Oct 2019 11:21:51 -0700

> the above example set seems just broken to me.

Sure, but if they don't somehow communicate, how do you know they are there?

And if they do communicate, the question is "with whom"? Where do they
send the message saying that they are trying to implement protocol FOO
but they don't get what section 3.1.5 of RFC XXXX really means?
Slashdot? Stack overflow? Some Reddit group? Actually, it would be very
nice if the IETF had a documented feedback channel for such exchanges.
That would be a nice way to grow the community.

-- Christian Huitema

---

From: Leif Johansson <[email-masked]>
Date: Fri, 4 Oct 2019 13:28:08 -0700

Skickat från min iPhone

> 4 okt. 2019 kl. 11:21 skrev Christian Huitema <[email-masked]>:
> 
> 
> And if they do communicate, the question is "with whom"? Where do they send the message saying that they are trying to implement protocol FOO but they don't get what section 3.1.5 of RFC XXXX really means? Slashdot? Stack overflow? Some Reddit group? Actually, it would be very nice if the IETF had a documented feedback channel for such exchanges. That would be a nice way to grow the community.
> 
> -- Christian Huitema
> 
All of the above probably. Contrary to popular opinion the IETF is not the center of the universe. 

There are good sw engineers out there who (#pearlclutch) couldn’t give a penny about what the IETF believe is proper procedure for communicating feedback on whatever.

Cheers Leif

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 4 Oct 2019 22:17:01 +0100

Hiya,

On 04/10/2019 19:21, Christian Huitema wrote:
> Sure, 

As in: you agree that particular set of people do deserve
consideration in the upcoming discussion? If so, I think
that's correct.

But, that implies we should also be thinking if there are
other sets of folks (adding up <<7.7 billion:-) who similarly
deserve consideration.

> but if they don't somehow communicate, how do you know they are there?

For the set I mentioned? Do you really doubt they're there?
I do not.

> And if they do communicate, the question is "with whom"? 

I don't think that's a question we need address at all. That's
just their business.

> Where do they
> Slashdot? Stack overflow? Some Reddit group? 

Yes. stackexchange etc. mostly at present it seems. It'd
once have been things like Dr. Dobbs magazine and/or
comp.<various> via usenet I guess.

> Actually, it would be very

We did discuss exactly that (a stackexchange <something>) at
the IAB retreat - not for IETF process-wonkery like this, but
for protocols that are widely used like HTTP. I think someone
there was gonna look into it but can't recall if anything's
been done since. I can totally such a channel working for HTTP
or maybe DNS, but I'd guess not for this discussion. Might be
worth a try regardless though, even if it didn't work for this
discussion, we'd learn HOWTO.

I do however have a glib answer for how we could try communicate
with people who read some RFCs but who don't otherwise get at all
involved... we write an RFC. Maybe one describing the upcoming
discussion and try see if promoting that in various places gets
any feedback. So there may be a case for writing charter-like
text for the upcoming discussion in an RFC (I guess that'd be
an IAB-stream RFC if we did it).

For other subsets of people, other mechanisms will I guess be
needed, hence me wondering if it'd be good to try characterise
better who might really be in that "bigger" community. We seem
to have identified at least one set of people already so maybe
it'll not be too hard to find more sets or agree we've found
enough.

Cheers,
S.

---

From: Randy Bush <[email-masked]>
Date: Fri, 04 Oct 2019 14:38:30 -0700

> reasonable definition of "us", so we have a broad responsibility.

and we should have the honesty and the humility not to put words in
the mouths of those neither present nor having the floor to speak for
themselves.

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 5 Oct 2019 11:07:27 +1300

> And if they do communicate, the question is "with whom"? Where do they send the message saying that they are trying to implement protocol FOO but they don't get what section 3.1.5 of RFC XXXX reall…

Yes, but it isn't just the IETF. It's all the streams, so the dispatcher for generic queries will have to be (at least externally) the RFC Editor, I think.

On the underlying point - the fuzziness of the community boundary - I really don't believe in magic, or that the community we should worry about is 7.7 billion people. But we would be deluding ourselves to think that we can count the members of the community; we can't even count the members of the IETF. So we really have to accept, IMHO, that there is an open-ended public service responsibility here, not just a responsibility to a well-defined closed community. And if an obscure network operator in Northern Elbonia has a comment to make on an RFC from 1969 tagged in the index as "(Status: UNKNOWN)", that is automatically part of the community discourse, even though we don't know which stream that RFC belongs to.

   Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 5 Oct 2019 06:38:28 +0200

On 2019-10-05 00:07, Brian E Carpenter wrote:
>> And if they do communicate, the question is "with whom"? Where do
>> they send the message saying that they are trying to implement
>> protocol FOO but they don't get what section 3.1.5 of RFC XXXX
>> really means? Slashdot? Stack overflow? Some Reddit group?
>> Actually, it would be very nice if the IETF had a documented
>> feedback channel for such exchanges. That would be a nice way to
>> grow the community.
> 
> Yes, but it isn't just the IETF. It's all the streams, so the
> dispatcher for generic queries will have to be (at least externally)
> the RFC Editor, I think.
> 
> On the underlying point - the fuzziness of the community boundary - I
> really don't believe in magic, or that the community we should worry
> about is 7.7 billion people. But we would be deluding ourselves to
> think that we can count the members of the community; we can't even
> count the members of the IETF. So we really have to accept, IMHO,
> that there is an open-ended public service responsibility here, not
> just a responsibility to a well-defined closed community.

I agree, and it's an important point.

	Henrik

> And if an
> obscure network operator in Northern Elbonia has a comment to make on
> an RFC from 1969 tagged in the index as "(Status: UNKNOWN)", that is
> automatically part of the community discourse, even though we don't
> know which stream that RFC belongs to.
> 
> Brian

---

From: John C Klensin <[email-masked]>
Date: Sat, 05 Oct 2019 04:02:22 -0400

--On Saturday, October 5, 2019 11:07 +1300 Brian E Carpenter
<[email-masked]> wrote:

> On the underlying point - the fuzziness of the community
> boundary - I really don't believe in magic, or that the
> community we should worry about is 7.7 billion people. But we
> would be deluding ourselves to think that we can count the
> members of the community; we can't even count the members of
> the IETF. So we really have to accept, IMHO, that there is an
> open-ended public service responsibility here, not just a
> responsibility to a well-defined closed community. And if an
> obscure network operator in Northern Elbonia has a comment to
> make on an RFC from 1969 tagged in the index as "(Status:
> UNKNOWN)", that is automatically part of the community
> discourse, even though we don't know which stream that RFC
> belongs to.

I think this is key although I look at it a bit differently.
Nothing I've said implied that we should be seeking consensus
of, much less speaking for, several billion people (nor trying
to enumerate them).   I don't think we should even be trying to
determine consensus among ISOC members or ISOC chapters even
though we presumably could get them enumerated if we asked
nicely.   At the same time, we know they are out there.  We can
identify many of the communities and at least crudely describe
their needs.  We should not presume we can identify all possible
communities or get the description of any one of them and their
needs exactly right.   We don't even make that presumption about
the community of active IETF participants and that is one reason
we talk only about "rough consensus" and not "strong consensus"
or "broad consensus".  To those communities who are part of the
global Internet community and whom we can identify, we owe a
real, good-faith, effort to try to make educated guesses at
their needs and to take what Brian calls an open-ended public
service responsibility and what I described earlier as acting as
trustees for that broader community.  We also have some
obligation to keep looking for and identifying those smaller
communities and clusters, rather than, in the extreme case,
either no one we cannot precisely identify or no one who is not
an active IETF participant, actually counts.

best,
   john

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 5 Oct 2019 12:20:41 +0100

Hiya,

On 05/10/2019 09:02, John C Klensin wrote:
> to enumerate them).

That's not how I read what you and Brian wrote TBH. I did
and still do think that both of you are saying that anyone
affected by the Internet should somehow "count" (in the
future of the RSE discussion) and ISTM that that does end
up setting up someone to grandiosely claim to be speaking
for the entire planet. (I hope none of us really want to
try do that;-) Again, I'd love to be corrected but that's
how I've read your and Brian's mails on this so far.

ISTM that damages the argument that there's more than the
IETF involved - if we can't characterise (characterise, not
"count") the "who else" in some sensible manner then we do
kinda end up where Christian seemed to be starting from.

And just to be clear, I at least have said nothing about
calling consensus for any such grouping. I think we'd be
jumping too far ahead in worrying about that right now TBH.
I'd first like to know the kinds (not numbers, kinds) of
people involved and then worry abut how they might be
consulted.

Cheers,
S.

PS: "ISOC chapters" (and I guess ISOC members if there are
some uninvolved in the IETF) is another totally credible set
of people that ought be considered. The HOWTO for consulting
them also seems easy enough which is good.

> I don't think we should even be trying to

---

From: S Moonesamy <[email-masked]>
Date: Sat, 05 Oct 2019 12:14:21 -0700

Hi Stephen,
>kinda end up where Christian seemed to be starting from.

That's a good point.

I went through some documents, e.g. RFC 6635 and the discussions 
which happened many years ago.  There is the following in the RFC: 
"to better serve the communities that produce and depend on the RFC 
Series".  I gather that the usage of the word "communities"  is 
intentional, i.e. it means that there is more than one community.

Is the IRTF a subset of the IETF?  If that was the case, they can 
folded into one community.  One side-effect of such a decision is 
that it constrains (future) decisions of the IRTF about its 
identity.  We could hand-wave that question and deal with it when it 
becomes a problem.  As I look back, I would say that this is why the 
IETF ended up with its inconsistent stories.

I assume that the IAB is aware that there are other organizations 
which rely on documents published through the Series.  In my opinion, 
some of those organization might not agree to be seated under the 
IETF umbrella.

There was a comment [1] from Mr Johansson.  There are a few persons 
on the ietf@ mailing list who are ex-IAB members.  I have no doubt 
that they would understand what the comment means.

Regards,
S. Moonesamy

1. https://mailarchive.ietf.org/arch/msg/ietf/3lVQg1IX1HGjgT-ogevbLPHqyyc

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 6 Oct 2019 09:05:29 +1300

Hi Stephen,

> how I've read your and Brian's mails on this so far.

Let me try to answer this by example. Who do you think is in the
community to which RFC7258 (BCP188) is relevant? Or RFC1984,
for that matter. These may be outliers, but that doesn't take
them out of scope.

> kinda end up where Christian seemed to be starting from.

The IRTF is easily identified. The various operator groups and
the RIRs and their customers/members. ISOC and its chapters.
The SDOs that we have formal or informal relationships with.
All product developers and open source developers who implement
RFCs. Government regulators (think cryptography, privacy, network
neutrality). The courts, when IPR issues come up. I don't think
it's at all hard to cite large groups that are affected. What's
hard is knowing when to stop.
 
> calling consensus for any such grouping.

No, indeed not. Calling for comments is easy enough, but calling for
consensus isn't plausible. But I don't think that's what John and I
are saying. 

Regards
   Brian

> I think we'd be

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 5 Oct 2019 23:24:55 +0100

Hiya,

> Hi Stephen,
...>
> for that matter. These may be outliers, but that doesn't take

Heh, using my own argument against me, eh:-) That's fair
though. Both are largely but not entirely written for IETF
participants. So yes, 7258 was written also explicitly
considering how other readers might perceive the text And
it wasn't just the editors/authors doing that, many of the
(very many!) comments on the draft considered that aspect.
I didn't check back but don't however recall any major
change made for only that specific reason, it was more a
case of re-wording, mostly for clarity or to avoid specific
potential misunderstandings. I guess the same was true for
1984. The relevant "other readers" are pretty much covered
by your list below, maybe with the addition of tech journos.

> neutrality). 

The above is a good list, thanks. And I can envisage ways one
might try look for feedback from those kinds of people. (Doing
so may fail, but it's doable.)

> The courts, when IPR issues come up. 

I think I'd argue to not go that far on the basis that any
court action involving an RFC likely already involves someone
from the earlier list.

So I guess the question is whether or not people starting from
Christian's position find that a convincing list or not. I do
think it is myself. Christian, what do you think? (Others with
a similar position should feel free to answer too.)

Cheers,
S.

> I don't think

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 6 Oct 2019 11:37:36 +1300

One quick addendum: researchers and educators. I know people
personally who cite RFCs for research & teaching purposes, but
don't participate at all in I*TF activities.

Regards
   Brian

---

From: Christian Huitema <[email-masked]>
Date: Sat, 5 Oct 2019 17:25:54 -0700

> a similar position should feel free to answer too.)

I think that the list above is a plausible definition of the
"readership" of the RFC series. We have feedback channels with many of
those, and it would be nice to get more. On the other hand, I do not
believe that this defines a "community", and I certainly can't see that
as the basis for any serious accountability mechanism.

-- Christian Huitema

---

From: Colin Perkins <[email-masked]>
Date: Sun, 6 Oct 2019 22:06:09 +0100

> On 5 Oct 2019, at 20:14, S Moonesamy <[email-masked]> wrote:
> I went through some documents, e.g. RFC 6635 and the discussions which happened many years ago.  There is the following in the RFC: "to better serve the communities that produce and depend on the RFC Series".  I gather that the usage of the word "communities"  is intentional, i.e. it means that there is more than one community.
> 
> Is the IRTF a subset of the IETF?  If that was the case, they can folded into one community.  One side-effect of such a decision is that it constrains (future) decisions of the IRTF about its identity.  We could hand-wave that question and deal with it when it becomes a problem.  As I look back, I would say that this is why the IETF ended up with its inconsistent stories.

The IRTF is not a subset of the IETF, although the participants have significant overlap. The RFC Editor and IAB have been careful to involve the IRTF in this discussion.

> I assume that the IAB is aware that there are other organizations which rely on documents published through the Series.  In my opinion, some of those organization might not agree to be seated under the IETF umbrella.

I’ve certainly not seen any suggestion to 'seat the IRTF under the IETF umbrella' from the IAB.

Colin

> There was a comment [1] from Mr Johansson.  There are a few persons on the ietf@ mailing list who are ex-IAB members.  I have no doubt that they would understand what the comment means.
> 
> Regards,
> S. Moonesamy
> 

-- 
Colin Perkins
https://csperkins.org/