Subject: [rfc-i] Fwd: New Version Notification for draft-flanagan-rseme-00.txt

From: Heather Flanagan <[email-masked]>
Date: Thu, 24 Oct 2019 14:48:41 -0700

Hola a todos!

I’ve posted a -00 draft for the RSEME BoF (Tuesday, 19 November @ 08:45-09:30 Singapore Time). This is a proposal based on the information I heard during the virtual meetings (and many thanks, again, to those who participated). Discussion is welcome; if there is enough constructive input that seems to have general agreement, I’ll be happy to try and get in an -01 before the Nov 4 cut-off for I-Ds.

Thanks!
Heather

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-flanagan-rseme-00.txt
> Date: October 24, 2019 at 2:47:02 PM PDT
> To: "Heather Flanagan" <[email-masked]>
> 
> 
> A new version of I-D, draft-flanagan-rseme-00.txt
> has been successfully submitted by Heather Flanagan and posted to the
> IETF repository.
> 
> Name:		draft-flanagan-rseme
> Revision:	00
> Title:		RFC Series Model Process
> Document date:	2019-10-24
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/internet-drafts/draft-flanagan-rseme-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-flanagan-rseme/
> Htmlized:       https://tools.ietf.org/html/draft-flanagan-rseme-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-flanagan-rseme
> 
> 
> Abstract:
>   This draft offers a proposal to form a new IAB program called the RFC
>   Editor Future Development Program.  This proposal is based on the
>   discussions held during three virtual meetings in September and
>   October 2019, and requests a new program, open to all, that will
>   drive consensus around any changes to the RFC Editor model through
>   extensive community engagement and outreach to a broad set of
>   stakeholder communities.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Melinda Shore <[email-masked]>
Date: Thu, 24 Oct 2019 20:11:20 -0800

On 10/24/19 1:48 PM, Heather Flanagan wrote:
> I’ve posted a -00 draft for the RSEME BoF (Tuesday, 19 November @
> 08:45-09:30 Singapore Time). This is a proposal based on the information
> I heard during the virtual meetings (and many thanks, again, to those
> who participated). Discussion is welcome; if there is enough
> constructive input that seems to have general agreement, I’ll be happy
> to try and get in an -01 before the Nov 4 cut-off for I-Ds.

Thanks for getting this out so quickly, and for what
looks like a comprehensive and well-structured summary
of the discussion so far.

I have to admit that it never occurred to me to do this
as an IAB program and I find it a really appealing idea,
with the caveat that some new processes are going to have
to be defined.  For example, the proposal doesn't mention
how the program would reach decisions (by rough consensus,
I assume?) or how it would be handled if things went badly
(accountability, chair/editor replacement if necessary, etc.).
As things currently stand, IAB programs are chaired by
IAB members, but that's not defined anywhere so it's
an open question AFAIC.  Similarly, to my knowledge we've
never had a completely open IAB program, either, as there's
been an expectation that it would be a small, focused (fsvo)
group with domain expertise.  So, I think some process
questions would need to be settled in advance to protect
the group against process-based DoS attacks (not that that
would ever happen at the IETF), etc.

I also think this is an opportunity to try some innovation
around longer-term efforts, so I'd be curious to hear additional
proposals.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Oct 2019 11:36:30 +0100

Hey Melinda,

You make some good points:

> For example, the proposal doesn't mention
> I assume?)

I would hope that a program can self-organise (like NomCom, for example). 
But the fact of that self-organisation could usefully be written down.

> how it would be handled if things went badly

That is a biggy! And even how you would measure "going badly".
I think we normally allow an IAB program to be appointed by and removed by the IAB (in the knowledge that the IAB can be appointed/removed by the community), and that together with reporting from the program to the IAB should be enough.

> an open question AFAIC. 

Yes. I am pretty sure that some programs have been chaired by non-IAB people in the past. 
That actually sounds like a good use of resources because (presumably) the IAB are already doing stuff.
Being present should be enough without needing to chair as well.

> Similarly, to my knowledge we've

Very agree.
That has been handled in the past by asking for volunteers at formation, and somewhat controlling the numbers.
I would be concerned if we got into a strict "IAB appoints" situation because we want to avoid the IAB only appointing (by accident or design) people with a particular outlook.

Best,
Adrian

---

From: Heather Flanagan <[email-masked]>
Date: Fri, 25 Oct 2019 06:14:03 -0700

> On Oct 24, 2019, at 9:11 PM, Melinda Shore <[email-masked]> wrote:
> 

FWIW, not all IAB programs are chaired by IAB members. I point to the RSOC as the current example of that. As to the openness of IAB programs, I don’t think there’s anything that says they can’t be; I did not see any requirements about that one way or the other on https://www.iab.org/activities/programs/ or in RFC 2850. 

> around longer-term efforts, so I'd be curious to hear additional

Suggestions are more than welcome!

-Heather

---

From: Heather Flanagan <[email-masked]>
Date: Fri, 25 Oct 2019 06:27:21 -0700

> On Oct 25, 2019, at 3:36 AM, Adrian Farrel <[email-masked]> wrote:
> 
> Hey Melinda,
> 

I do like the idea of suggesting they model their activities and behavior along the lines of an IETF working group, including validating consensus on the list, sticking tot he standards of behavior in the IETF Note Well, and following the guidance in RFC 7282, "On Consensus and Humming in the IETF”. I expect people would naturally trend that way, whether it’s written down or not. 

> I think we normally allow an IAB program to be appointed by and removed by the IAB (in the knowledge that the IAB can be appointed/removed by the community), and that together with reporting from t…

Well, in my mind, “going badly” means “unable to reach consensus and descending into unprofessional behavior”.

> I would be concerned if we got into a strict "IAB appoints" situation because we want to avoid the IAB only appointing (by accident or design) people with a particular outlook.

Any reason that the IAB can’t call for volunteers, and then ask for input from the community on the candidates? That’s what they did for the RSOC, so there is precedent.

-Heather

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 25 Oct 2019 14:33:55 +0100

Hiya,

On 24/10/2019 22:48, Heather Flanagan wrote:
> 08:45-09:30 Singapore Time). This is a proposal based on the
> information I heard during the virtual meetings (and many thanks,
> again, to those who participated). Discussion is welcome; if there is
> enough constructive input that seems to have general agreement, I’ll
> be happy to try and get in an -01 before the Nov 4 cut-off for I-Ds.

Good stuff. If we had consensus on something like that approach
I think that'd be good.

While the text in the draft is fine as it says "may choose," I
figure it could be a bad plan to try do any work via design teams
in the short term.

ISTM that at present the IETF has sets of participants with (at
least) two general positions that seem fairly diametrically opposed.
In that kind of situation my guess is there'd be a real fear of a
design team being stacked (whether by accident or design) in one
direction or another, and that fear might lead to lots of wrangling.

I'm not sure if much can be done about that other than to depend
on the wisdom of the chairs as to when to try use a design team,
but I just wanted to check that the plan was not: "start work on
Monday, name design teams on Tuesday, do nothing while awaiting
design team output..."

Cheers,
S.

> 
> Thanks! Heather
> 
>> Begin forwarded message:
>> 
>> From: [email-masked] Subject: New Version Notification
>> for draft-flanagan-rseme-00.txt Date: October 24, 2019 at 2:47:02
>> PM PDT To: "Heather Flanagan" <[email-masked]>
>> 
>> 
>> A new version of I-D, draft-flanagan-rseme-00.txt has been
>> successfully submitted by Heather Flanagan and posted to the IETF
>> repository.
>> 
>> Name:		draft-flanagan-rseme Revision:	00 Title:		RFC Series Model
>> Process Document date:	2019-10-24 Group:		Individual Submission 
>> Pages:		6 URL:
>> https://www.ietf.org/internet-drafts/draft-flanagan-rseme-00.txt 
>> Status:
>> https://datatracker.ietf.org/doc/draft-flanagan-rseme/ Htmlized:
>> https://tools.ietf.org/html/draft-flanagan-rseme-00 Htmlized:
>> https://datatracker.ietf.org/doc/html/draft-flanagan-rseme
>> 
>> 
>> Abstract: This draft offers a proposal to form a new IAB program
>> called the RFC Editor Future Development Program.  This proposal is
>> based on the discussions held during three virtual meetings in
>> September and October 2019, and requests a new program, open to
>> all, that will drive consensus around any changes to the RFC Editor
>> model through extensive community engagement and outreach to a
>> broad set of stakeholder communities.
>> 
>> 
>> 
>> 
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at
>> tools.ietf.org.
>> 
>> The IETF Secretariat
>> 
> 
>

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 24 Oct 2019 18:54:41 -0700

Hi Heather,

I think you did a great job summarizing the  meetings (i unfortunately
missed the third) and laying out a clear path forward to a path forward.
I'm certainly glad the community seemed to coalesce around a common
acceptable direction. I encourage everyone uncomfortable with any aspects
of this plan to voice their opinions. Whatever path we end up on, we need
to take input from as many voices as possible.

Cheers,
Wes

---

From: Heather Flanagan <[email-masked]>
Date: Fri, 25 Oct 2019 07:26:30 -0700

> On Oct 25, 2019, at 6:33 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

That certainly wasn’t in my head - I just wanted to make sure that the option was out there, given there are likely to be several areas of that may well need focused attention. First, the whole group has to figure out the details (milestones, goals, requirements, etc) of what they’re going to tackle, and in what order. Then they can possibly use design teams to run some of those things in parallel. 

> direction or another, and that fear might lead to lots of wrangling.

If it was an easy thing, we wouldn’t be here in the first place. :-)

> design team output…"

I hope not!

-Heather

> <0x5AB2FAF17B172BEA.asc>

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 30 Oct 2019 07:39:56 -0500

Hi Heather, IAB,

I realize I missed the window to comment on this before the -01 was published, so feel free to disregard what I say below.

I think the line "Past IAB or IETF chairs would likely be good choices,” describing candidates to chair the program, is ill-advised. It reinforces what I think is a perilous notion that old-timers are best suited to do tasks in the community because they have been doing similar tasks for a long time. I realize there are caveats in the sentence, but to the extent that having it in there then creates some onus on the IAB to explain itself if it does not choose past chairs to chair this program, I think it would be better to leave this out. It is already mentioned elsewhere in the document that one participant suggested that past chairs be central to this process, which seems sufficient to document the fact that someone thought this was a good idea.

Best,
Alissa

> On Oct 24, 2019, at 4:48 PM, Heather Flanagan <[email-masked]> wrote:
> 
> Hola a todos!
> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: "Heather Flanagan" <[email-masked] <mailto:[email-masked]>>
>> 
>> 
>> URL:            https://www.ietf.org/internet-drafts/draft-flanagan-rseme-00.txt <https://www.ietf.org/internet-drafts/draft-flanagan-rseme-00.txt>
>> Status:         https://datatracker.ietf.org/doc/draft-flanagan-rseme/ <https://datatracker.ietf.org/doc/draft-flanagan-rseme/>
>> Htmlized:       https://tools.ietf.org/html/draft-flanagan-rseme-00 <https://tools.ietf.org/html/draft-flanagan-rseme-00>
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-flanagan-rseme <https://datatracker.ietf.org/doc/html/draft-flanagan-rseme>
>> 
>> 
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> The IETF Secretariat
>> 
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 30 Oct 2019 15:48:37 +0200

Hi Heather,

I’ve read the -01 and feel that it is a reasonable way forward. I only attended one of the meetings, but the document seems to reflect the discussion accurately. I do agree with Alissa’s point though :-)

Thanks for the work for running these discussions and writing this up!

Jari

---

From: Christian Huitema <[email-masked]>
Date: Wed, 30 Oct 2019 11:29:36 -0700

On 10/30/2019 5:39 AM, Alissa Cooper wrote:
> Hi Heather, IAB,
>
> I realize I missed the window to comment on this before the -01 was
> published, so feel free to disregard what I say below.
>
> I think the line "Past IAB or IETF chairs would likely be good
> choices,” describing candidates to chair the program, is ill-advised.
> It reinforces what I think is a perilous notion that old-timers are
> best suited to do tasks in the community because they have been doing
> similar tasks for a long time. I realize there are caveats in the
> sentence, but to the extent that having it in there then creates some
> onus on the IAB to explain itself if it does not choose past chairs to
> chair this program, I think it would be better to leave this out. It
> is already mentioned elsewhere in the document that one participant
> suggested that past chairs be central to this process, which seems
> sufficient to document the fact that someone thought this was a good idea.

I agree with Alissa there. I notice that someone proposed that in the
minutes of the 3rd conference call. Minuting that proposal is fine, but
endorsing it is something entirely different.

-- Christian Huitema

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 30 Oct 2019 11:41:53 -0700

I also agree with this, and would also like to note that for *chair* of the
program we actually want someone who is good at making sure multiple
perspectives are heard and helps bring things to consensus more than
someone with a lot of institutional knowledge. Some of those people are
certainly former I* Chairs, but a number of people who we often call on for
this kind of duty are notand some of them are comparatively recent IETF
participants.

-Ekr

---

From: Jari Arkko <[email-masked]>
Date: Wed, 30 Oct 2019 20:49:41 +0200

Due to some off-list comments (thanks!), I realise that I wanted to clarify the comment that I made about past chairs in the text. I specifically would like to suggest a change in the text of the document. But I did not want to state an opinion about who is or is not suitable or capable for the task. 

The change that I’d suggest is:

OLD:
Past IAB or IETF chairs would likely be good choices.
NEW:
(deleted)

Rationale: What people you want leading an effort is always a consideration, a complex one, with many variables. I just don’t want us to put any particular set of people in a special role, either in positive or negative fashion.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 31 Oct 2019 10:28:47 +1300

> Rationale: What people you want leading an effort is always a consideration, a complex one, with many variables. I just don’t want us to put any particular set of people in a special role, either i…

Speaking as someone who was on the third call where this point came up, and who would qualify, my immediate reaction was that I didn't really want that sticky label on me anyway ;-). However, there is an underlying point: we do want people with a wider view than just the current incumbents in I* and RFC* roles. Past I* chairs are in that category, so they are fair examples.

   Brian