Subject: Re: [rfc-i] rfcXXXX.json

From: Alice Russo <[email-masked]>
Date: Fri, 18 Oct 2019 09:51:12 -0700

Julian,

Thanks for your close review; apologies for my delayed reply. We will work on fixing those issues (i.e., remove array on each record; consistent use of an empty array for multivalue fields).

The use of zero-padded filenames was a mistake, and they were removed and replaced shortly after we received your mail (e.g., rfc0093.json was replaced by rfc93.json).

The errata-related suggestion is noted; presumably https://www.rfc-editor.org/errata.json does not meet the need?

Thanks,
Alice

> On Sep 25, 2019, at 12:57 AM, Julian Reschke <[email-masked]> wrote:
> 
> On 25.09.2019 06:18, Julian Reschke wrote:
>> ...
>>> Julian,
>>> They are available for use and fairly stable after an update that was
>>> completed today. And, we may continue to iron things out. Feedback
>>> welcome.
>>> ...
>> 
>> Thanks so far. Will have a look.
>> ...
> 
> OK, had a look, and did a test implementation in the JS used by
> rfc2629.xslt (which currently goes to tools.ietf.org for that kind of
> information).
> 
> I'm currently looking at <https://www.rfc-editor.org/rfc/rfc2617.json>
> as example.
> 
> Question: why is the data coming back as JSON array? It currently
> contains one object, but what would it mean if it contains zero, or more
> than one?
> 
> Question: I note that apparently a four-digit RFC number is expected in
> the URL. That probably should be documented (with a plan for RFC >=
> 10000 of course).
> 
> Bug: when the RFC is not updated by anything, the "updated_by" member
> comes back as array with *one* item, and that item is *null*. Easy to
> work around, but should be fixed to return an empty array instead. The
> same issue probably applies to other multi-valued fields.
> 
> Suggestion: later on, it would be great not to only get the errata URL,
> but also some basic information (individual errata IDs with status and
> section numbers, if available).
> 
> Best regards, Julian
> 

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Ronald Tse <[email-masked]>
Date: Sat, 19 Oct 2019 11:33:42 +0000

Hi Alice,

Would it also be possible to provide structured data for the remaining fields to make the JSON structure on par with the RFC BibXML entries?

Taking the same example given by Julian, the RFC 2617 BibXML entry:
https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.2617.xml

Contains structured data for authorship, e.g.:
<author initials="J." surname="Franks" fullname="J. Franks">
<organization/>
</author>

Publication date:
<date year="1999" month="June”/>

And series info:
<seriesInfo name="RFC" value="2617”/>

As part of the community that utilizes RFC bibliographic information we really appreciate the existence of an easily accessible JSON endpoint!

Kind regards,
Ron

_____________________________________

Ronald Tse
Ribose Inc.

On Oct 18, 2019, at 6:51 PM, Alice Russo <[email-masked]<mailto:[email-masked]>> wrote:

Julian,

Thanks,
Alice

---

From: Alice Russo <[email-masked]>
Date: Tue, 22 Oct 2019 12:35:42 -0700

Ron,

Thanks for sending; we will take your suggestions into consideration when improving these files.

Thanks,
Alice

> On Oct 19, 2019, at 4:33 AM, Ronald Tse <[email-masked]> wrote:
> 
> Hi Alice,
> 
>> On Oct 18, 2019, at 6:51 PM, Alice Russo <[email-masked]> wrote:
>> 
>> Julian,
>>

---

From: Ronald Tse <[email-masked]>
Date: Wed, 23 Oct 2019 17:40:53 +0000

Really appreciate it Alice!

Ronald Tse
Ribose Inc.

On Oct 23, 2019, at 3:35 AM, Alice Russo <[email-masked]<mailto:[email-masked]>> wrote:

Ron,

Thanks,
Alice

On Oct 19, 2019, at 4:33 AM, Ronald Tse <[email-masked]<mailto:[email-masked]>> wrote:

Hi Alice,

Publication date:

And series info:

Kind regards,
Ron

Ronald Tse
Ribose Inc.

Julian,

Thanks,
Alice