Subject: [rfc-i] a benign use case for XML for RFCs

From: Michael Richardson <[email-masked]>
Date: Wed, 16 Oct 2019 19:06:19 +0200

I wanted a reference for a term which I knew was widely used and referenced.
I found an RFC that used it, and since I'm lazy and untutored in the ways of
bibliographic references, I just used Richard's git repo so that I could copy
and paste a *good* reference in xml.
If I'd had to have done a round trip with rfc-editor, then I'd have just
improvised something, which the RPC would have then had to fix later on.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 16 Oct 2019 13:13:42 -0400

> improvised something, which the RPC would have then had to fix later on.

Did you compare the text to the published RFC to ensure it matched?

Best regards,
Kathleen

-- 

Best regards,
Kathleen

---

From: Julian Reschke <[email-masked]>
Date: Wed, 16 Oct 2019 19:58:54 +0200

On 16.10.2019 19:13, Kathleen Moriarty wrote:
>
>
> On Wed, Oct 16, 2019 at 1:05 PM Michael Richardson
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
> ...

Unless I'm missing something, this was just about borrowing a specific
<reference> element. It had nothing to do with re-creating the whole
document.

Best regards, Julian

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Oct 2019 14:21:51 -0400

> <reference> element. It had nothing to do with re-creating the whole

FWIW, I think it’s fine to use these XML files as long as they’re labeled appropriately.  The problem comes in when someone downloads these XML files without understanding that they do not correspond to the RFC, and then uses them as if they were authoritative.  So the use you are talking about makes perfect sense, but not if the file is called RFC4242.xml, and not if it contains markup that says “this is RFC4242.”

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 16 Oct 2019 16:01:48 -0400

On Wed, Oct 16, 2019 at 3:54 PM Michael Richardson <[email-masked]> wrote:

> Kathleen Moriarty <[email-masked]> wrote:
>     >> I found an RFC that used it, and since I'm lazy and untutored in
> the ways
>     >> of
>     >> bibliographic references, I just used Richard's git repo so that I
> could
>     >> copy
> Yes, I did.
> Cool, I think that's an understandable concern for the RFC production
center/editor to have if it does not happen.

-- 

Best regards,
Kathleen

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Oct 2019 17:07:39 -0400

On Oct 16, 2019, at 5:00 PM, Michael Richardson <[email-masked]> wrote:
> I agree. The file name should be draft-ietf-foo-bar-last-before-rfcXXXX.xml.

No, it shouldn’t contain the RFC number at all.   If it does, people will misinterpret that.

---

From: Julian Reschke <[email-masked]>
Date: Wed, 16 Oct 2019 23:16:33 +0200

On 16.10.2019 23:07, Ted Lemon wrote:
> On Oct 16, 2019, at 5:00 PM, Michael Richardson <[email-masked]
> <mailto:[email-masked]>> wrote:
>> I agree. The file name should be
>> draft-ietf-foo-bar-last-before-rfcXXXX.xml.
>

A bigger concern is the actual content. Right now, when fed into
xml2rfc, it will create something that claims to be RFCxxxx.

Fixing this would require changing the metadata on the <rfc> element.

Best regards, Julian

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 Oct 2019 21:55:40 +0200

Yes, I did.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 Oct 2019 23:00:41 +0200

>> <reference> element. It had nothing to do with re-creating the whole

True, but of course, the RFC-editor could have fixed the entry in some
significant way.

Ted Lemon <[email-masked]> wrote:
    > FWIW, I think it’s fine to use these XML files as long as they’re
    > labeled appropriately.  The problem comes in when someone downloads
    > these XML files without understanding that they do not correspond to
    > the RFC, and then uses them as if they were authoritative.  So the use
    > you are talking about makes perfect sense, but not if the file is
    > called RFC4242.xml, and not if it contains markup that says “this is
    > RFC4242.”

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 Oct 2019 23:59:25 +0200

> No, it shouldn’t contain the RFC number at all.   If it does, people will misinterpret that.

yeah, I thought about that too.
It becomes a bit difficult to find the document unless you know it's history,
but I guess one can ask the datatracker.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Oct 2019 18:03:15 -0400

> but I guess one can ask the datatracker.

Yes, I think anybody who doesn’t know to ask the datatracker is not a good candidate for receiving the document.  :)

---

From: Michael Richardson <[email-masked]>
Date: Thu, 17 Oct 2019 09:52:41 +0200

> Yes, I think anybody who doesn’t know to ask the datatracker is not a
    > good candidate for receiving the document.  :)

That seems like a good "you must be this tall"

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 17 Oct 2019 10:59:38 +0200

> Fixing this would require changing the metadata on the <rfc> element.

Actually, I’d put a command line option into xml2rfc that specifies “now make the real thing”; then the input text does not have to change.

Grüße, Carsten