Subject: Re: [rfc-i] [art] New RFCs text formatting

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 1 Dec 2019 14:51:57 +0100

Hi Brian,

On 2019-12-01 01:59, Brian E Carpenter wrote:
> On 01-Dec-19 12:55, Keith Moore wrote:
> ...
>> I think it would also be "interesting" if the preferred source for RFCs 
>> became a site other than rfc-editor.org.    (Which, for all I know, 
>> might already be the case.)
> (Switching lists, intentionally)
> 
> I pretty much always use https://tools.ietf.org/html/rfcXXXX and so do many other people. However, right now there's a consistency problem:
> 
> https://tools.ietf.org/html/rfc/rfc3056
> https://www.rfc-editor.org/rfc/rfc3056.html
> 
> are roughly the same, but
> 
> https://tools.ietf.org/html/rfc8651
> https://www.rfc-editor.org/rfc/rfc8651.html
> 
> are very different.

Yes, right.

> Is there a plan to fix that inconsistency?

I didn't have any explicit plans, but fixing that should be fairly
straightforward.  The biggest question is really what the majority
of users will be expecting.  The Principle of Least Astonishment
would seem to be applicable.

Best regards,

	Henrik

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 1 Dec 2019 14:59:36 +0100

On Dec 1, 2019, at 14:51, Henrik Levkowetz <[email-masked]> wrote:
> 
> Principle of Least Astonishment

https://tools.ietf.org/html/rfcxxx has been a way to access the htmlized paginated plaintext version for quite a while now; creating something similar for v3 (maybe with links that aren’t guessed, but generated from real information) would fulfill the POLA for me.  

Of course, getting the RFC-editor HTML version from tools.ietf.org, where that exists, would also be useful, but not under that URL (and maybe with the htmlized version as a fallback).

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 1 Dec 2019 16:04:14 +0100

Hi Carsten, Brian,

On 2019-12-01 14:59, Carsten Bormann wrote:
> https://tools.ietf.org/html/rfcxxx has been a way to access the
> htmlized paginated plaintext version for quite a while now; creating
> something similar for v3 (maybe with links that aren’t guessed, but
> generated from real information) would fulfill the POLA for me.

Yes.  Unfortunately, this requires a new xml2rfc formatter which generates
HTML directly, like the current HTML formatter, but does line-breaking
and indentation like the current TXT formatter.  Neither can trivially be
extended to do that.

Not that I haven't thought about it, but it will require quite a bit of
work.

> Of course, getting the RFC-editor HTML version from tools.ietf.org,
> where that exists, would also be useful, but not under that URL (and
> maybe with the htmlized version as a fallback).

For now, I've made a trivial tweak to the htmlizer; there's a new line
under the top menu providing a link to the RFC-Editor's HTML:

Best regards,

	Henrik

---

From: John C Klensin <[email-masked]>
Date: Sun, 01 Dec 2019 18:06:48 -0500

Rich,

What is missing is a page-image format (I personally don't care
if it is restricted to ASCII or uses UTF-8 coding or not, but
believe the latter would be better and easier to achieve with
xml2rfc v3) with headers, footers, and pagination compatible
with what we have been using/ living with for the last 40-odd
years.

IETF list added back in because, IMO, part of what got us to the
point where we are having this discussion now rather than
three-plus years ago was that a number of discussions and
decisions occurred on the rfc-interest list without adequate
information, warning, and serious attempts to get informed
consensus among those who use and work with RFCs rather than
just those willing to endure sometimes very detailed discussions
on that list including, occasionally, the tone and
aggressiveness of some of them.

That short enough?
   john

--On Sunday, December 1, 2019 03:10 +0000 "Salz, Rich"
<[email-masked]> wrote:

> The holiday season is upcoming, the new-format cutover is very
> recent, and we just had an IETF meeting.
> 
> Maybe cut folks a little slack and just briefly (!!!) point
> out what is missing?
> 
> Ietf moved to bcc; rfc-interest added.

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 1 Dec 2019 23:23:03 +0000

>    That short enough?

Modulo the second paragraph :)  sure.

---

From: Keith Moore <[email-masked]>
Date: Sat, 30 Nov 2019 20:13:36 -0500

> Is there a plan to fix that inconsistency?

Not just that, but I happened to run across what purported to be one of 
the HTTP RFCs on a web site claiming to be that of the HTTP WG, and its 
presentation was different still.

It's possible that having multiple possible presentations of RFCs is 
more of a feature than a bug, but it does bring some problems with it.

FWIW, I vastly prefer the HTML on tools.ietf.org though it could 
certainly use improvement.   I find the HTML on rfc-editor.org much more 
difficult to read.

Keith

---

From: Keith Moore <[email-masked]>
Date: Sun, 1 Dec 2019 10:54:37 -0500

Sent from my iPhone

> On Dec 1, 2019, at 8:59 AM, Carsten Bormann <[email-masked]> wrote:
> 

+1

> Of course, getting the RFC-editor HTML version from tools.ietf.org, where that exists, would also be useful, but not under that URL (and maybe with the htmlized version as a fallback).

If the rfc editor improves readability of their html versions, maybe.    But I would not want to see the current RFC editor HTML replace the existing HTMLized versions on the tools site.

Keith