Subject: [rfc-i] Representing Unicode in a draft

From: Mario Loffredo <[email-masked]>
Date: Fri, 17 Jan 2020 15:21:14 +0100

Dear,

how can I represent Unicode characters in a draft written in XML?

I put them natively into an artwork/CDATA element but the PDF generated 
by xml2rfc includes the corresponding code point values.

I donwloaded RFC7997.xml that represents Unicode strings in the same way 
and converted it into PDF by xml2rfc v3 but the result is similar.

Is xml2rfc unable to convert Unicode characters or am I doing something 
wrong?

Best regards,

Mario

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jan 2020 18:35:25 +0100

Hi Mario,

> how can I represent Unicode characters in a draft written in XML?

It depends on what you want to express.  Depending on the use case, the
answer may be one of:

 - use the <u/> element
 - place them in <artwork/>
 - it cannot currently be done.

More on the options:

  https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html#name-how-do-i-insert-non-ascii-c
  https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-10#appendix-A.1

> by xml2rfc includes the corresponding code point values.

It sounds as if this should have worked; could you send me the xml file
that gave this result, please?

Regards,

	Henrik (xml2rfc maintainer)