Subject: [rfc-i] Archival format to rfc-interest and the IAB

From: Sarah Banks <[email-masked]>
Date: Thu, 13 Feb 2020 11:10:21 -0800

Hello IAB and RFC-interest community,

	The RSOC has been following discussion of the issues encountered in deploying the v3 RFC format. These issues have necessitated several changes to the format as bugs and ambiguities are found. While we believe that this is necessary, we have a concern that the incremental nature of these changes will result in will result in RFCs published in more than one XML format over time, as the adjustments are made.

	The Temporary RFC Series Project Manager is currently investigating how many of the already-executed as well as anticipated changes might result in backwards-incompatible changes to the format, to get a better sense of scale. 

	It could be that having multiple such formats in the corpus of RFCs will be an acceptable outcome; or, a decision could be made to re-publish the affected "interim format" RFCs in the final v3 format. We don't believe it's necessary to make that decision now, but we're sharing this information with the broader community for discussion.

Thanks,
Sarah
For the RSOC

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 13 Feb 2020 14:17:44 -0500

Sarah,

Just my 2 cents. If we ever want to have a hope of being able to rerun
archived XML v3 RFCs through the processor, all interim v3 RFCs should be
checked once the final v3 vocabulary is determined and the corresponding
tools are available. This can be done perhaps just by rerunning them and
comparing the new result against the original result. If they're the same,
then no updates are needed. If they do differ, then the archived XML should
be corrected.

Cheers,
Andy

On Thu, Feb 13, 2020 at 2:10 PM Sarah Banks <[email-masked]> wrote:

>         The RSOC has been following discussion of the issues encountered
> in deploying the v3 RFC format. These issues have necessitated several
> changes to the format as bugs and ambiguities are found. While we believe
> that this is necessary, we have a concern that the incremental nature of
> these changes will result in will result in RFCs published in more than one
> XML format over time, as the adjustments are made.
>
>         The Temporary RFC Series Project Manager is currently
> investigating how many of the already-executed as well as anticipated
> changes might result in backwards-incompatible changes to the format, to
> get a better sense of scale.
>
>         It could be that having multiple such formats in the corpus of
> RFCs will be an acceptable outcome; or, a decision could be made to
> re-publish the affected "interim format" RFCs in the final v3 format. We
> don't believe it's necessary to make that decision now, but we're sharing
> this information with the broader community for discussion.
>
> Thanks,
> Sarah
> For the RSOC
>
>

---

From: "John R. Levine" <[email-masked]>
Date: 13 Feb 2020 14:31:00 -0500

> then no updates are needed. If they do differ, then the archived XML should

There are definitely changes to the XML grammar, and I agree that if the 
XML is supposed to be archival, we should make the XML agree with the 
final spec.

This won't change the text and I don't think it's likely to change the 
appearance significantly, e.g., the page breaks in some output formats 
might change, but they're not normative.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 14 Feb 2020 09:14:19 +1300

Sarah,

This is not about the technical aspect of your message.

Can you clarify why this is RSOC business? I don't understand where it fits in https://tools.ietf.org/html/rfc6635#section-3.1. I would have expected any proposals to come from the (acting) RSE.

Regards
   Brian Carpenter

---

From: Sarah Banks <[email-masked]>
Date: Wed, 19 Feb 2020 15:58:11 -0800

Hi Brian,
   It’s coming from the RSOC because we do not currently have an RSE. We currently do not have an acting RSE. We have a person in situ doing his finest to hold down tactical items while the community figures out the RSE business. Because this item felt like it couldn’t be simply shelved until there is an RSE the RSOC, including the temp PM, decided to share this note in the spirit of transparency. It’s not a new discussion in the RSOC, simply a byproduct of the desire to share info. 

Thanks
Sarah

> On Feb 13, 2020, at 12:14 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Sarah,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Feb 2020 12:34:08 +1300

I'm sorry, Sarah, I am simply incapable of understanding where this fits into "oversight". If it's anybody's problem operationally, it's John Levine's; and if there is a strategic concern it presumably belongs to the IETF Trust, which owns the IPR and therefore needs to be concerned about the long-term integrity of documents.

Regards
   Brian Carpenter

---

From: Ted Hardie <[email-masked]>
Date: Thu, 20 Feb 2020 16:44:53 -0800

On Thu, Feb 20, 2020 at 3:34 PM Brian E Carpenter <
[email-masked]> wrote:

> I'm sorry, Sarah, I am simply incapable of understanding where this fits
> into "oversight".

Please re-review the initial message, especially this bit:

It could be that having multiple such formats in the corpus of RFCs will be
> an acceptable outcome; or, a decision could be made to re-publish the
> affected "interim format" RFCs in the final v3 format. We don't believe
> it's necessary to make that decision now, but we're sharing this
> information with the broader community for discussion.
>

The RSOC is not making a decision here, it is ensuring that the community
knows the topic needs discussion.

> If it's anybody's problem operationally, it's John Levine's; and if there
> is a strategic concern it presumably belongs to the IETF Trust, which owns
> the IPR and therefore needs to be concerned about the long-term integrity
> of documents.
>

The IAB has published the format documents historically, not the trust.
This is a question ultimately about the formats in the RFC series, not the
IPR conditions under which they are licensed.

best regards,

Ted Hardie

> >    It’s coming from the RSOC because we do not currently have an RSE. We
> currently do not have an acting RSE. We have a person in situ doing his
> finest to hold down tactical items while the community figures out the RSE
> business. Because this item felt like it couldn’t be simply shelved until
> there is an RSE the RSOC, including the temp PM, decided to share this note
> in the spirit of transparency. It’s not a new discussion in the RSOC,
> simply a byproduct of the desire to share info.
> >
> > Thanks
> > Sarah
> >
> >> Can you clarify why this is RSOC business? I don't understand where it
> fits in https://tools.ietf.org/html/rfc6635#section-3.1. I would have
> expected any proposals to come from the (acting) RSE.
> >>
> >> Regards
> >>   Brian Carpenter
> >>
> >>>    The RSOC has been following discussion of the issues encountered in
> deploying the v3 RFC format. These issues have necessitated several changes
> to the format as bugs and ambiguities are found. While we believe that this
> is necessary, we have a concern that the incremental nature of these
> changes will result in will result in RFCs published in more than one XML
> format over time, as the adjustments are made.
> >>>
> >>>    The Temporary RFC Series Project Manager is currently investigating
> how many of the already-executed as well as anticipated changes might
> result in backwards-incompatible changes to the format, to get a better
> sense of scale.
> >>>
> >>>    It could be that having multiple such formats in the corpus of RFCs
> will be an acceptable outcome; or, a decision could be made to re-publish
> the affected "interim format" RFCs in the final v3 format. We don't believe
> it's necessary to make that decision now, but we're sharing this
> information with the broader community for discussion.
> >>>
> >>> Thanks,
> >>> Sarah
> >>> For the RSOC
> >>>
> >>>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 20 Feb 2020 17:51:10 -0700

On 2/20/20 5:44 PM, Ted Hardie wrote:

> This is a question ultimately about the formats in the RFC series, not
> the IPR conditions under which they are licensed. 

Yes. Specifically, a concern that we could end up with documents in
multiple (de-facto) formats.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Feb 2020 17:50:23 +1300

> multiple (de-facto) formats.

I'm fully aware of that. I assume that the acting RSE is fully aware of that.
I was asking a different question.

   Brian

---

From: "John R. Levine" <[email-masked]>
Date: 21 Feb 2020 08:40:55 -0800

>> multiple (de-facto) formats.

Right, with the question being whether to go back and fix the coding (not 
the text) or explicitly decide to live with it.

It's not totally clear to me who makes the final decision here.  IAB? 
IETF consensus?

Regards,