Subject: [rfc-i] xi:include in published RFC XMLs

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Feb 2020 20:32:52 +0100

Am I confused or are xi:include a no-no in published RFC XML files?

I would have expected these to be expanded in

https://www.rfc-editor.org/authors/rfc8742.xml

but then this is not the real final XML file.

As is, I can’t really AUTH48-check the references for correctness (the files at xml2rfc.ietf.org can change at any time).

Grüße, Carsten

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Tue, 18 Feb 2020 20:48:16 +0100

> but then this is not the real final XML file.

Right. That's not the published one.

> As is, I can’t really AUTH48-check the references for correctness (the files at xml2rfc.ietf.org can change at any time).

Correct. I believe AUTH48 needs a check on the canonical-XML-to-be (at
the end).

Best regards, Julian

---

From: Alice Russo <[email-masked]>
Date: Tue, 18 Feb 2020 16:54:46 -0800

Greetings,

As Julian wrote, files in the "authors/" directory are not published files.

The preptool is run before the XML file is published. We are taking into consideration your suggestion that the authors (in general) should have the opportunity to review the prepped XML file during AUTH48 state.

As we wrote to you in the relevant AUTH48 thread, in the case of this specific document, the prepped XML file and the not prepped XML file are available for your review. 

Thank you.
RFC Editor/ar

> On Feb 18, 2020, at 11:48 AM, Julian Reschke <[email-masked]> wrote:
>