Subject: Re: [rfc-i] acknowledging reviewers name in RFCs

From: Michael Richardson <[email-masked]>
Date: Thu, 16 Apr 2020 19:04:18 -0400

I found this in my outbox from nearly a year ago while looking for something
else.

There was some strong support that if we were going to Acknowledge reviews
and other activities, that we should do it in a semantically meaningful XML
way.

There was a mix of views about criteria for who should be acknowledged.
At this point, I'd like to leave it to authors to decide, and perhaps some
WGs might decide to experiment with guidelines.

In order to get there, it seems that we need to add semantic XML, and I don't
know what the process would be do that.

I understand that we have outstanding mismatches between our specifications
and our tools already.
Is there an issue tracker that I should use to lodge this "feature request"?
Should I just send a patch?

Michael Richardson <[email-masked]> wrote:
    > Benjamin's email to tools-discuss about how to find who did a review
    > reminded me of some things that I'd like to have in published RFCs.
    > I believe that it will help with getting more volunteers into our process if
    > we more publically and formally acknowledge others.

    > I'd like to have a standard way to show who did:
    > 1) WG chair and AD stick-handling of a document.
    > 2) Document Shepherd
    > 3) Area reviews, and detailed individual reviews

    > While many authors put many of these things into Acknowledgements, it's not
    > in a standard format, and it's not easily pulled out in the XML.
    > (Such as by Jari's scripts)

    > I know that overall RFC version 3 format is done, and I'll go do some
    > homework as I suspect that all the pieces to do this in the XML is there, we
    > just have to do it.

    > But, before offering a specific solution, I'd like to find out how we would
    > get consensus that this is a correct thing to do.  Yes, I can write an
    > Internet Draft, but it wouldn't be longer than the above email, and I'm not
    > sure who would approve if not the IESG/GenAD.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "John Levine" <[email-masked]>
Date: 16 Apr 2020 19:17:07 -0400

>know what the process would be do that.

You can add it as an issue here.  No promises.

https://github.com/i-rse/rfc-issues/issues

R's,
John
-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 17 Apr 2020 03:19:18 +0200

> know what the process would be do that.

Color me skeptical.

Today, I can write acknowledgements sections such as

Adam Ant provided the initial idea that led to this specification and kept us on track using extensive reviews during its entire development.  Bernd dasBrot helped improve the editorial quality of the definitions immensely.  Charlie Cat provided a framework to review and validate the examples.  Dino Dog found a missing semicolon on page 46.

How do I translate this to XML?

If the intention is to make this accessible to bibliometrics ("Eamon Egg co-authored 46 RFCs cited in 374 other RFCs and reviewed 147 RFCs”), then we have two problems:

(1) RFCs which were published before this was done, don’t count,
(2) we’d have trouble finding anyone who cared about these bibliometrics enough to make use of them in any meaningful way.

Not sure this is worth the effort.

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Sat, 18 Apr 2020 08:42:53 -0700

> On Apr 16, 2020, at 6:19 PM, Carsten Bormann <[email-masked]> wrote:
> 

Likewise.

Bob

---

From: Christian Huitema <[email-masked]>
Date: Sat, 18 Apr 2020 12:43:12 -0700

>> Not sure this is worth the effort.

What Carsten and Bob said. Plus, consider that one of the pressing
problem today is to finally finalize the xml2rfc V3 format. If we want
that to finally happen, the last thing we want is adding new features.

-- Christian Huitema

---

From: Julian Reschke <[email-masked]>
Date: Sat, 18 Apr 2020 22:19:55 +0200

On 18.04.2020 21:43, Christian Huitema wrote:
> ...
> ...

Indeed.

What we need is people participating in the spec revisions. (Hint:
https://github.com/rfc-format).

Best regards, Julian

---

From: Sarah Banks <[email-masked]>
Date: Mon, 20 Apr 2020 16:00:19 -0700

I'll pile on with a big +1. We are trying to burn down the issues in getting the v3 format work out. I'd prefer to hold the line on adding new features, particularly one like this, which doesn't seem to fall into the "necessary at this time" category. 

Thanks,
Sarah

> On Apr 18, 2020, at 1:19 PM, Julian Reschke <[email-masked]> wrote:
>