Subject: [rfc-i] Informational...

From: Michael StJohns <[email-masked]>
Date: Tue, 9 Jun 2020 15:24:06 -0400

Hi -

I was looking at a document that's currently on last call for the third 
time in the transport area with a proposed status of "Informational".   
After reading it, I was wondering why it was being published by the 
Transport area, as opposed to being an architectural discussion by the 
IAB or even as a product of the IRTF?  In any event, it got me thinking 
about the Informational category of documents and wondering what would 
happen if we added a sub-header or sub-category for documents published 
under this banner - here's a strawman list:

IAB Architectural Note - applied to IAB consensus documents
IAB Policy Note -  ditto
IESG Policy Note - applied to IESG consensus documents
Community Policy Note - applied to community consensus documents 
wherever originated
Technical Cross Publication - previously published documents where the 
IETF will not gain change control
IRTF Pure Research
IRTF Applied Research
IETF Path Not Taken (applied to documents that weren't accepted as WG 
items, but might have been  viable alternatives ISE or Area Director 
sponsored)
Individual Technical Proposal or Opinion
Individual Policy Proposal or Opinion
Individual Architectural Proposal or Opinion
Individual Other
(IAB/IESG/IRTF/IETF) Workshop Report
Business Report
Other; Uncategorized.

The Informational group is the least homogeneous of any of the 
publication categories, and possible the one least understood by the 
non-IETF crowd as to its role.  Perhaps providing some sub-text might 
improve things slightly.

This is a discussion topic - not so much a baked proposal.

Enjoy - Mike

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 9 Jun 2020 18:17:00 -0400

Mike,

You left off what's probably the most common category, an IETF WG consensus
document that doesn't contain protocol conformance language (e.g.
architecture, framework, overall requirements, etc.), thus is not on the
standards track.

Cheers,
Andy

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 11 Jun 2020 10:00:58 -0700

Michael StJohns <[email-masked]> writes:

> I was looking at a document that's currently on last call for the
> third time in the transport area with a proposed status of
> "Informational".

Do you think this sort of list would fall nicely into the larger picture
of tagging/organization discussions that seem to be floating around a
lot at the same time?
-- 
Wes Hardaker
USC/ISI
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Michael StJohns <[email-masked]>
Date: Thu, 11 Jun 2020 13:14:46 -0400

On 6/9/2020 6:17 PM, Andrew G. Malis wrote:
> Mike,
>
> You left off what's probably the most common category, an IETF WG 
> consensus document that doesn't contain protocol conformance language 
> (e.g. architecture, framework, overall requirements, etc.), thus is 
> not on the standards track.

What - not "Other; Uncategorized"?

Seriously though - I agree.   I'm wondering if there might be 2-4 
categories we could agree on to break these down.  Or maybe just one?

Working Group Explanatory Material?

>
> Cheers,
> Andy
>
>
> On Tue, Jun 9, 2020 at 3:24 PM Michael StJohns <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi -
>
>     third
>     [email-masked] <mailto:[email-masked]>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 11 Jun 2020 15:08:06 -0400

Mike,

That sounds good, or, if you want to be more wordy, "any RFC published by
an IETF Working Group that is not a standards-track or Experimental
specification."

Cheers,
Andy

On Thu, Jun 11, 2020 at 1:14 PM Michael StJohns <[email-masked]>
wrote:

> consensus document that doesn't contain protocol conformance language (e.g.

---

From: Michael StJohns <[email-masked]>
Date: Thu, 11 Jun 2020 16:01:51 -0400

On 6/11/2020 3:08 PM, Andrew G. Malis wrote:
> Mike,
>
> That sounds good, or, if you want to be more wordy, "any RFC published 
> by an IETF Working Group that is not a standards-track or Experimental 
> specification."
>
I was looking for a short item that could be part of an RFC header and 
ideally usable as a filter term for searching.

Later, Mike

> Cheers,
> Andy
>
>
> On Thu, Jun 11, 2020 at 1:14 PM Michael StJohns 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>>     consensus document that doesn't contain protocol conformance
>>     language (e.g. architecture, framework, overall requirements,
>>     etc.), thus is not on the standards track.
>
>>     On Tue, Jun 9, 2020 at 3:24 PM Michael StJohns
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         Hi -
>>

---

From: Michael StJohns <[email-masked]>
Date: Thu, 11 Jun 2020 16:04:33 -0400

> of tagging/organization discussions that seem to be floating around a

I do think it would fit in.   The question is how nicely given firmly 
held positions!

It's sort of why I sent the note and made sure it was on this mailing 
list rather than rfced-future.   In any event, it may be a way to 
provide the sub-text necessary without having to have a wholesale change 
in the flavor of the RFC series.

Later, Mike