Subject: [rfc-i] Libxml for W3C docs

From: Cullen Jennings <[email-masked]>
Date: Mon, 17 Aug 2020 16:44:05 -0600

I’m not sure who I should notify about this so pointers appreciated … 

When I download the W3C bibxml entries pointed at from the page at https://xml2rfc.tools.ietf.org/, it does not seem to be missing  recent entries. 

https://xml2rfc.tools.ietf.org/public/rfc/bibxml-w3c/?C=M;O=D

Anyone happen to know how this is generated of who deal with the care and feeding of it. 

Thanks, Cullen 

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 18 Aug 2020 00:02:10 +0000

Hey Cullen.

I presume you mean "it is MISSING recent entries"?

That software dates back a LONG time, and has been pretty solid. (It's written in everyone's favorite language, TCL.) However, the w3c updates and some of the other updates appear to have stopped working about a year ago.

However, it was a breakage that didn't generate any error messages.

What I THINK is happening is TCL is NOT FOLLOWING the HTTP => HTTPS redirects that a lot of sites have implemented in the past couple years. The timing seems right.

What I don't know for sure is if TCL will be able to deal with the HTTPS URLs. I'll monitor what happens the next time the script runs.

	Tony

On 8/17/20, 6:44 PM, "rfc-interest on behalf of Cullen Jennings" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks, Cullen

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 17 Aug 2020 21:28:48 -0600

> On Aug 17, 2020, at 6:02 PM, HANSEN, TONY L <[email-masked]> wrote:
> 
> Hey Cullen.
> 
> I presume you mean "it is MISSING recent entries”?

ahhgg - yes, i meant that - sorry and thank you for taking it the right way

> What I don't know for sure is if TCL will be able to deal with the HTTPS URLs. I'll monitor what happens the next time the script runs.

Thank you kindly.