Subject: Re: [rfc-i] [Tools-discuss] <contact/>: asciiFullname should be latinFullname

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Oct 2020 17:39:48 +0200

Hi Henrik,

I was trying to respond to Julian here.

> On 2020-10-07, at 17:01, Henrik Levkowetz <[email-masked]> wrote:
> 
> As for what 7991 is really talking about, interpreting 'ASCII' as
> “accessible to a reader familiar with the Latin writing system”, rather
> than strictly ASCII, I'll leave that interpretation as yours.  That's not
> the understanding I got from 7991.

Me neither, in particular with the example in the companion 7997 that gave an ASCII-only “identifier” (cleverly avoiding the transliteration/transcription dilemma) for a Latin name.  However, it seems to me that it simply didn’t occur to the people involved in the process that led to RFC 799x that transliterations tend to use beyond-ASCII characters (or they considered pure-ASCIIness more important).

> I indicated earlier that I thought expanding the use use of Latin to
> the case you raised was reasonable, but it seems that response wasn't
> enough for you, so now I have no idea of how to respond.

No, I totally agree with your response.  I just tried to answer Julian’s question.

So we do need a bit of a variance here from RFC 7991.  We could do that the same way all the other variances have been handled (such as introducing the <contact/> element that didn't exist in RFC 7991 either).  Or we could somehow convince ourselves this is suddenly a major change (e.g., because the attributes are called “ascii”something they really should stay ASCII-only).  I don’t think it is, but if I could post to the rfc-interest list, I would love to hear whether people there agree, too.

Grüße, Carsten

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 7 Oct 2020 18:02:41 +0200

Hi Carsten,

On 2020-10-07 17:39, Carsten Bormann wrote:
> Me neither, in particular with the example in the companion 7997 that
> gave an ASCII-only “identifier” (cleverly avoiding the
> transliteration/transcription dilemma) for a Latin name. However, it
> seems to me that it simply didn’t occur to the people involved in the
> process that led to RFC 799x that transliterations tend to use
> beyond-ASCII characters (or they considered pure-ASCIIness more
> important).
> 
>> I indicated earlier that I thought expanding the use use of Latin 
>> to the case you raised was reasonable, but it seems that response
>> wasn't enough for you, so now I have no idea of how to respond.
> 

Ah, ok.  Good then.

> So we do need a bit of a variance here from RFC 7991. We could do
> that the same way all the other variances have been handled (such as
> introducing the <contact/> element that didn't exist in RFC 7991
> either).

I think the decision to permit Latin script for names applies here.  I
don't see this as a new decision, but a matter of applying an already
settled question consistently.

Best regards,

	Henrik

> Or we could somehow convince ourselves this is suddenly a
> major change (e.g., because the attributes are called
> “ascii”something they really should stay ASCII-only). I don’t think
> it is, but if I could post to the rfc-interest list, I would love to
> hear whether people there agree, too.
> 
> Grüße, Carsten
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Oct 2020 18:19:18 +0200

> settled question consistently.

+1

Grüße, Carsten