Subject: [rfc-i] Tables as paragraphs

From: Carsten Bormann <[email-masked]>
Date: Tue, 10 Nov 2020 14:53:41 +0100

https://github.com/cabo/kramdown-rfc2629/issues/82

In short, RFCXMLv2 allowed the use of artwork and texttable in the flow of a section, without generating captions(*), by leaving out anchor and title.

For RFCXMLv3, it seems that functionality was lost for tables (it still works for artwork).

It needs to be reinstated.

Grüße, Carsten

(*) Historically, captions really were invented for floats, which we don’t have, as we don’t have pages.  Captions are still useful for larger items (tables or artwork), so they can be referenced from outside and so a title can be placed.
But for tables that really form part of the flow of text, a caption is jarring (as it obviously is, e.g., for programming language examples that are part of the flow of text.  So there is no place for a caption here.

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Tue, 10 Nov 2020 15:50:12 +0100

Am 10.11.2020 um 14:53 schrieb Carsten Bormann:
> ...

Indeed: I raised this as
<https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/14> in
February 2017.

> It needs to be reinstated.

Agreed.

> But for tables that really form part of the flow of text, a caption is jarring (as it obviously is, e.g., for programming language examples that are part of the flow of text.  So there is no place…

+1

Best regard, Julian