Subject: [rfc-i] Script to generate RFC reference including abstract?

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 24 Jan 2021 12:03:41 -0500

Just to save myself a bit of work if this already exists ....

Have any of you written a script when, given a list of RFC numbers, will
generate an xml2rfc-ish reference and pull out the abstract for each RFC?
Something like, when given "8660", will produce:

   [RFC8660]  Bashandy, A., Ed., Filsfils, C., Ed., Previdi, S.,
              Decraene, B., Litkowski, S., and R. Shakir, "Segment
              Routing with the MPLS Data Plane", RFC 8660,
              DOI 10.17487/RFC8660, December 2019,
              <https://www.rfc-editor.org/info/rfc8660>.

   Segment Routing (SR) leverages the source-routing paradigm.  A node
   steers a packet through a controlled set of instructions, called
   segments, by prepending the packet with an SR header.  In the MPLS
   data plane, the SR header is instantiated through a label stack.
   This document specifies the forwarding behavior to allow
   instantiating SR over the MPLS data plane (SR-MPLS).

Thanks,
Andy
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "StJohns, Michael" <[email-masked]>
Date: Sun, 24 Jan 2021 14:21:01 -0500

Maybe try this?
http://web-harvest.sourceforge.net/manual.php

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 25 Jan 2021 08:07:32 -0500

Martin,

Thanks, that's an awesome use of curl, which I've used before for other
purposes.

And I had forgotten that the bibxml includes the abstracts.

Cheers,
Andy

On Mon, Jan 25, 2021 at 1:59 AM Martin Thomson <[email-masked]> wrote:

> To get the reference:
> curl -sSf
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.8446.xml
>
> To get just the abstract:
> curl -sSf
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.8446.xml |
> \
>   xmllint --xpath '//abstract/t/text()' /dev/stdin
>
> On Mon, Jan 25, 2021, at 04:03, Andrew G. Malis wrote:
> > Have any of you written a script when, given a list of RFC numbers,
> > will generate an xml2rfc-ish reference and pull out the abstract for
> > each RFC? Something like, when given "8660", will produce:
> >
> > xml2rfc-dev mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/xml2rfc-dev
> >
>
> xml2rfc-dev mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc-dev
>