Subject: [rfc-i] whose on first

From: Randy Bush <[email-masked]>
Date: Fri, 19 Feb 2021 14:13:48 -0800

now that henrik too has been driven off, are there folk still fixing
issues, such as bibxml?  or do we keep rolling our own?

      <reference anchor='I-D.spaghetti-sidrops-rpki-rsc'>
	<front>
	  <title>RPKI Signed Checklists</title>
	  <author initials='J' surname='Snijders' fullname='Job Snijders'>
	    <organization>Fastly</organization>
	  </author>
          <date month='February' year='2021' />
        </front>
	<seriesInfo name='Internet-Draft' value='draft-spaghetti-sidrops-rpki-rsc-02' />
	<format type='TXT' target='http://www.ietf.org/internet-drafts/draft-spaghetti-sidrops-rpki-rsc-02.txt' />
      </reference>

randy
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 19 Feb 2021 23:29:11 +0100

On 2021-02-19, at 23:13, Randy Bush <[email-masked]> wrote:
> 
> are there folk still fixing

I don’t understand the current situation any more than you, but Henrik did leave us this gem:

$ curl https://datatracker.ietf.org/doc/bibxml3/draft-spaghetti-sidrops-rpki-rsc/xml

<?xml version="1.0" encoding="UTF-8"?>
<reference anchor="I-D.spaghetti-sidrops-rpki-rsc">
   <front>
      <title>RPKI Signed Checklists</title>
      <author fullname="Job Snijders">
	 <organization>Fastly</organization>
      </author>
      <date month="February" day="11" year="2021" />
      <abstract>
	 <t>   This document defines a Cryptographic Message Syntax (CMS) profile
   for a general purpose listing of checksums (a &#39;checklist&#39;), for use
   with the Resource Public Key Infrastructure (RPKI).  The objective is
   to allow an attestation, in the form of a listing of one or more
   checksums of arbitrary digital objects (files), to be signed &quot;with
   resources&quot;, and for validation to provide a means to confirm a
   specific Internet Resource Holder produced the signed checklist.  The
   profile is intended to provide for the signing of a checksum listing
   with an arbitrary set of Internet Number Resources.

	 </t>
      </abstract>
   </front>
   <seriesInfo name="Internet-Draft" value="draft-spaghetti-sidrops-rpki-rsc-02" />
   <format type="TXT" target="https://www.ietf.org/internet-drafts/draft-spaghetti-sidrops-rpki-rsc-02.txt" />
</reference>

(The value of /reference/format/@target in this is, er, suboptimal; Martin Thomson has pointed out [1] that you can delete the whole <format target=…> thing and xml2rfc will insert something sensible instead, which you can further control via xml2rfc options.  kramdown-rfc environment variable for that: KRAMDOWN_NO_TARGETS)

Grüße, Carsten

[1]: https://github.com/cabo/kramdown-rfc2629/pulls?q=is%3Apr+is%3Aclosed

---

From: "Randy Bush" <[email-masked]>
Date: Fri, 19 Feb 2021 14:32:13 -0800

hi carsten,

my rsync does not get it

ryuu.rg.net:/Users/randy> ls refs/id/bibxml3/*spaghetti*
refs/id/bibxml3/reference.I-D.draft-spaghetti-sidrops-rpki-manifest-validation-00.xml
refs/id/bibxml3/reference.I-D.draft-spaghetti-sidrops-rpki-manifest-validation-01.xml
refs/id/bibxml3/reference.I-D.draft-spaghetti-sidrops-rpki-vrp-yang-00.xml
refs/id/bibxml3/reference.I-D.spaghetti-sidrops-rpki-manifest-validation.xml
refs/id/bibxml3/reference.I-D.spaghetti-sidrops-rpki-vrp-yang.xml

randy

---
[email-masked]
`gpg --locate-external-keys --auto-key-locate wkd [email-masked]`
signatures are back, thanks to dmarc header mangling

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 19 Feb 2021 23:36:08 +0100

> my rsync does not get it

I don’t think we can rsync bibxml from the datatracker yet.
Might be interesting to pull something together that does the equivalent over HTTP so one can then rsync from that…  But the datatracker is not very fast, so this might overload it.

Grüße, Carsten

---

From: "Randy Bush" <[email-masked]>
Date: Fri, 19 Feb 2021 14:39:08 -0800

> Might be interesting to pull something together that does the 
> equivalent over HTTP so one can then rsync from that…  But the 
> datatracker is not very fast, so this might overload it.

this is my nightly rsync

```
#!/bin/sh
RSY="/usr/bin/rsync -vaHx --delete"
$RSY rfc-editor.org::rfcs-text-only $HOME/rfcs
$RSY ietf.org::internet-drafts $HOME/ids
# old + new, though i really want only old
$RSY rsync.tools.ietf.org::tools.id $HOME/ids.old
# for xml2rfc
$RSY xml2rfc.tools.ietf.org::xml2rfc.bibxml/bibxml $HOME/refs/rfc
$RSY xml2rfc.tools.ietf.org::xml2rfc.bibxml/bibxml3 $HOME/refs/id
```

i am quite open to improving it

randy

---
[email-masked]
signatures are back thanks to dmarc header mangling

---

From: Randy Bush <[email-masked]>
Date: Sat, 20 Feb 2021 12:54:00 -0800

> My privileges on the machine where bibxml is hosted were also cut off,
> so I have not been able to debug or fix what is going on there.

effing brilliant.  as an old friend once told me

    When there is rot somewhere in the middle of the organization, that
    part can be sawed off and regrown.  When it is at the top, it
    descends.  A middle manager may be able to block it for a while; but
    eventually they break and the rot keeps descending.
      -- paraphrased from Tom DeMarco

if senior software engineers of the quality of the tools crew are
actually fungible, then why can $dayjob not fill two open reqs?

randy

---
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Tue, 23 Feb 2021 08:59:30 +1300

> On 21/02/2021, at 9:54 AM, Randy Bush <[email-masked]> wrote:
> 

Just so that we are clear, the machine that Tony has lost privileges on is under the sole control of Henrik and privileges were lost because it died irreparably.  The service has since been moved to another machine controlled exclusively by Henrik and so all decisions regarding privileges are made by him.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Randy Bush <[email-masked]>
Date: Mon, 22 Feb 2021 13:27:31 -0800

> Just so that we are clear, the machine that Tony has lost privileges
> on is under the sole control of Henrik and privileges were lost
> because it died irreparably.  The service has since been moved to
> another machine controlled exclusively by Henrik and so all decisions
> regarding privileges are made by him.

i can unhappily report that i have become aware of this.  and more of
the sad chain of events leading us here than i might like to be.  and
yes, of course henrik had his role to play.  and he comes from the
passive aggressive swedish culture to which i am somewhat allergic.

as the list of departing senior professionals continues to grow, all
from similar causes, it just might not be entirely their fault.

best wishes on the senior software engineers are fungible experiment.

randy

---
[email-masked]