Subject: [rfc-i] Mailing lists overlap - merge them ?

From: Roger Price <[email-masked]>
Date: Sun, 7 Feb 2021 21:16:08 +0100 (CET)

On Wed Feb 3 19:32:42 PST 2021, IETF Executive Director wrote:

> In October-November 2020 the IETF Administration LLC ran a survey of I-D 
> authors on the formats and tools that they use. ...

> I recommend that any discussion on this subject takes place on either 
> rfc-interest at rfc-editor.org or tools-discuss at ietf.org as appropriate.

This survey is very interesting, but the regular double posting shows
that the two mailing lists overlap too much.  I suggest merging them.

Roger
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 8 Feb 2021 10:26:21 +1300

> that the two mailing lists overlap too much.  I suggest merging them.

Bad idea. This topic does indeed interest both lists, but rfc-interest
covers much, much more than tools-discuss (and is not an IETF list, in fact). Also, tools-discuss covers more that document prep tools.

   Brian

---

From: Roger Price <[email-masked]>
Date: Mon, 8 Feb 2021 10:36:45 +0100 (CET)

On Mon, 8 Feb 2021, Brian E Carpenter wrote:

> Bad idea. This topic does indeed interest both lists, but rfc-interest covers 
> much, much more than tools-discuss (and is not an IETF list, in fact). Also, 
> tools-discuss covers more that document prep tools.

OK. But it would be interesting to know the overlap of the readership.  20% or 
80% ?

About rfc-interest says: "...Topics appropriate to this list may include 
formatting, tools, style, content, and indexing aspects of the RFC series...."

About Tools-discuss says: "A list for announcement and discussion of IETF 
related tools"

That looks like tools overlap to me.  If the lists are not to be merged, 
then they are to be clearly separated.  Roger

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Feb 2021 13:19:06 +0100

On 2021-02-08, at 10:36, Roger Price <[email-masked]> wrote:
> 
> If the lists are not to be merged, then they are to be clearly separated. 

      +----------------------+
      |                      |
      |  rfc-interest        |
      |                      |
      |          +-----------+----------------+
      |          |           |                |
      |          |           |  tools-discuss |
      |          |           |                |
      |   +------+-----------+-------+        |
      |   |      |           |       |        |
      |   |      |           |       |        |
      |   |      |           |       |        |
      +---+------+-----------+       |        |
          |      |                   |        |
          |      |                   |        |
          |      |                   |        |
          |      +-------------------+--------+
          |                          |
          |   xml2rfc, xml2rfc-dev   |
          |                          |
          +--------------------------+

Exercise for the reader:  Please disentangle!

(Figure stolen from RFC 8989 and adapted.)

Grüße, Carsten

---

From: Roger Price <[email-masked]>
Date: Mon, 8 Feb 2021 16:57:20 +0100 (CET)

On Mon, 8 Feb 2021, Carsten Bormann wrote:

>      +-----------------------+
>      |                       |
>      |   rfc-interest        |
>      |                       |
>      |                       |
>      |                       |
>      |                       |
>      |        ...............|..
>      |        : tools-discuss| :
>      |  ,------------------, | :
>      |  |     :            | | :
>      |  |     :            | | :
>      |  |     :            | | :
>      +--+------------------+-+ :
>         |     :            |   :
>         |     :            |   :
>         |     -------------|----
>         |  xml2rfc,        |
>         |  xml2rfc-dev     |
>         '------------------'
>
>

If the truth were known, I suspect that the diagram would show that the
tools-discuss readership is almost entirely covered by rfc-interest and xml2rfc.

rfc-interest already excludes the IETF standards process and general IETF 
organizational issues.  If it also sent the technicians to xml2rfc for technical 
questions, then tools-discuss could be retired, and there would be little need 
for double posting.

Roger

(Figure stolen from Carsten and adapted.)

---

From: Jay Daley <[email-masked]>
Date: Tue, 9 Feb 2021 11:16:22 +1300

Roger

> On 8/02/2021, at 10:36 PM, Roger Price <[email-masked]> wrote:
> 
>> Bad idea. This topic does indeed interest both lists, but rfc-interest covers much, much more than tools-discuss (and is not an IETF list, in fact). Also, tools-discuss covers more that document prep tools.
> 
> OK. But it would be interesting to know the overlap of the readership.  20% or 80% ?

I’m happy to get that data for you.  

Jay

> 
> About rfc-interest says: "...Topics appropriate to this list may include formatting, tools, style, content, and indexing aspects of the RFC series...."
> 
> About Tools-discuss says: "A list for announcement and discussion of IETF related tools"
> 
> That looks like tools overlap to me.  If the lists are not to be merged, then they are to be clearly separated.  Roger

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Feb 2021 10:11:06 +1100

Hi Roger,

I suspect that there's still a need for tools-discuss, because there are other tools.

However, it'd be *great* if we were more rigorous about moving discussions to the appropriate venue. In particular, if I care about the XMLv3 format but not about the xml2rfc tool (which is *one* implementation of it), I should be able to subscribe only to the rfc-interest list to see relevant discussion. 

Cheers,

> On 9 Feb 2021, at 2:57 am, Roger Price <[email-masked]> wrote:
> 
> rfc-interest already excludes the IETF standards process and general IETF organizational issues.  If it also sent the technicians to xml2rfc for technical questions, then tools-discuss could be retired, and there would be little need for double posting.
> 
> Roger
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 8 Feb 2021 16:39:35 -0700

> However, it'd be *great* if we were more rigorous about moving discussions to the appropriate venue. In particular, if I care about the XMLv3 format but not about the xml2rfc tool (which is *one* i…

+1

Peter

---

From: Loa Andersson <[email-masked]>
Date: Tue, 9 Feb 2021 15:41:17 +0800

All,

I'm subscribed tp tjhe rfc-i list onöy, if list are merged I will get a 
couple of extra mails each week, and as of now I don't see any benefit 
from this.

However, if merging solves a real problem, then I'm not going to argue 
against merging. But as I remember we had good reasons to make two list.

/Loa

On 08/02/2021 17:36, Roger Price wrote:
>> covers much, much more than tools-discuss (and is not an IETF list, in 
>> fact). Also, tools-discuss covers more that document prep tools.
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest