Subject: Re: [rfc-i] [Rfc-markdown] 1.3.34: map most codeblock classes to <sourcecode> instead of <artwork>

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Feb 2021 01:38:19 +0100

>> Sorry, my intent here is probably better visible in the current editor’s version:
>> 
>> https://cabo.github.io/mtct/draft-bormann-core-media-content-type-format.html <https://cabo.github.io/mtct/draft-bormann-core-media-content-type-format.html>
> 
> I’m not sure I understand - do you mean that you want it indented to show that you are quoting the ABNF or do mean that you want a different alignment.  I ask because I can’t see a different alignment.

I was essentially trying to separate the ABNF quoted for reference from the ABNF that is part of this specification.
As you can see, this doesn’t work very well in the HTML (better for figure 1, where it is obvious this is centred, than for figure 4).
The distinction is much easier to see in the plaintext, where aside/blockquote get much stronger visual support.

So this may not be the perfect example, but it was a case where I was trying to center source code.

My criticism of the current grammar is that there are lots of arbitrary differences between different contexts in which things can be used, and these arbitrary differences seem to be driven by the combination of (1) a desire to enforce a weird perception of “good style” with (2) a lack of imagination.  Much less of this would probably have happened if the grammar had been properly factorized.  The grammar style to repeat everything everywhere seems to suggest one should endlessly tweak any single one of the clones so they are all subtly different, leading to the current jungle.

CCing rfc-interest, because this is a problem not with, but for writing IETF documents in markdown.

Grüße, Carsten

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Feb 2021 07:14:05 +0100

Am 22.02.2021 um 01:38 schrieb Carsten Bormann:
> ...
> My criticism of the current grammar is that there are lots of arbitrary
> differences between different contexts in which things can be used, and
> these arbitrary differences seem to be driven by the combination of (1)
> a desire to enforce a weird perception of “good style” with (2) a lack
> of imagination.  Much less of this would probably have happened if the
> grammar had been properly factorized.  The grammar style to repeat
> everything everywhere seems to suggest one should endlessly tweak any
> single one of the clones so they are all subtly different, leading to
> the current jungle.
> ...

The grammar in RFC 7991 is using this style because it was inherited
from RFC 7749.

RFC 7749 uses this style because of me :-). It actually was the simplest
thing to do after automatic version from the old DTD. Furthermore, it
simplified coming up with the tooling which auto-generated large parts
of 7749 and 7791 from the actual grammar.

And no, the intention was not "endless tweaking". What happened (as I
said multiple times) is that RFC 7991 was published as a "snapshot" for
tools development, to be revised once implementation feedback came in.
That should have happened about three years ago.

Refactoring the grammar would indeed be interesting. I'm not concinved
though that the result will be better, as we might run into different
kinds of edge cases.

Best regards, Julian