Subject: Re: [rfc-i] [Tools-discuss] Recommendation 9 from Results and analysis of the survey of I-D authors on formats and tools

From: "John R Levine" <[email-masked]>
Date: 6 Feb 2021 21:41:53 -0500

In article <18192.1612647870@localhost> you write:
>   I think that getting all this right in whatever markdown format would
>   take several iteration of tool improvements, and we have only just
>   gotten to XMLv3.

I completely agree, so I hope people keep working on tools. We can declare 
success if the tools get to the point that people could write and edit 
drafts all the way to RFC publication without anyone having to peek at the 
XML versions. (We can call that the MS Word standard.) I realize how very 
far we are from that point,

>   XMLv3 gets this all 'right' now, but I think that we aren't even close
>   to 100% submission as XML.

Speaking of tools that need work, we're still getting more submissions in 
XMLv2 than XMLv3.  While the RPC can mechanically convert v2 to v3, the 
semantics aren't identical and it leads to needless extra work to figure 
out what something was actually supposed to say or mean.

R's,
John
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 7 Feb 2021 04:20:08 +0100

On 2021-02-07, at 03:41, John R Levine <[email-masked]> wrote:
> 
> Speaking of tools that need work, we're still getting more submissions in XMLv2 than XMLv3.  

There might be use for some nagging at the submission site, e.g.

To get nicer HTML output from the submission service, prepare your input using
xml2rfc --v2v3 to convert v2 XML to v3, or 
kdrfc -3c to generate v3 XML from kramdown-rfc source.

(Much of the "v2 XML" probably no longer is, as people have started to embed v3 features into that — just like kramdown-rfc does.  I think we could have a flag day, after which all “v2" input is converted to “v3” during submission.)

Grüße, Carsten

---

From: "John R Levine" <[email-masked]>
Date: 6 Feb 2021 23:15:03 -0500

> There might be use for some nagging at the submission site, e.g.

Good point, we are working on that, and also on the very old and ugly 
xml2rfc web page.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Michael Richardson <[email-masked]>
Date: Sat, 06 Feb 2021 23:33:01 -0500

> kdrfc -3c to generate v3 XML from kramdown-rfc source.

So, kramdown now does native v3 XML output?
I don't have to upgrade it anymore?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 7 Feb 2021 05:42:02 +0100

> So, kramdown now does native v3 XML output?

I don’t think trying to do that would be a useful thing to put into kramdown-rfc proper.
There is exactly one document that knows what v3 is, and that is the source code of xml2rfc.
So it seems more natural to actually use xml2rfc to generate the v3.
(The downside is that I don’t get to fix any bugs in that converter quickly, but so far I have found only one.)

> I don't have to upgrade it anymore?

“You” don’t have to do that, `kdrfc -3c` calls xml2rfc ––v2v3 for you :-)
(Which leaves a draft-foo-bar.v2v3.xml in v3 format lying around, ready for submission.)

Grüße, Carsten