Subject: Re: [rfc-i] I need your "good" RFCs

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 12 Feb 2021 08:57:42 -0500

Wes,

If "interoperable implementations" is an indicator, then it's hard to beat
RFC 826, which must have many many thousands, if not millions, of
independent implementations by now.

Cheers,
Andy

On Thu, Feb 11, 2021 at 5:03 PM Michael Thomas <[email-masked]> wrote:

>
> On 2/11/21 1:51 PM, Wes Hardaker wrote:
> > Good folks,
> >
> > I'm looking for people's favorite RFCs with respect to readability and
> > understand-ability.  Do you have ones that have always impressed you as
> > your favorites as how RFCs should be written to make their protocol/etc
> > easily understood?  If so, send a note my way (ideally using this
> > subject line).  I don't necessarily think you need to do a reply-all.
> >
> > [And yes, I recognize that this is a subjective ask, and everyone will
> > have a different opinion as to "what is readable" and "what is
> > understandable".  That's ok -- I'm asking for opinions and not facts].
> >
> Even though it's a bit self-serving, I think DKIM (rfc 4871) was pretty
> clear as it managed to get dozens of interoperable implementations. The
> ability to get interoperability without back knowledge or trawling the
> working group mailing list is a good sign that they are well written.
> Back in the day, IP and TCP RFC's were very easy to understand.
>
> Mike
>
>
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 12 Feb 2021 09:38:31 -0800

"Andrew G. Malis" <[email-masked]> writes:

> If "interoperable implementations" is an indicator, then it's hard to beat RFC
> 826, which must have many many thousands, if not millions, of independent
> implementations by now.

Ha, that's a very good point!  Thank you.

I assume that must mean it's readable and understandable then too.
-- 
Wes Hardaker
USC/ISI

---

From: "Martin Thomson" <[email-masked]>
Date: Sat, 13 Feb 2021 07:31:50 +1100

> I assume that must mean it's readable and understandable then too.

Not a safe assumption. A simple protocol, which this is, often does not get implemented on the basis of its specification.

(Not saying that RFC 826 is bad. I am not familiar with it enough to say.)

---

From: Robert Sparks <[email-masked]>
Date: Fri, 12 Feb 2021 16:56:49 -0600

> Not a safe assumption. A simple protocol, which this is, often does not get implemented on the basis of its specification.

Happens with complicated protocols too. Implementation by watching 
wireshark and making guesses is a thing in the wild. But that can be 
enough to become fully conformant if the protocol is simple.

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 17 Feb 2021 06:41:46 -0800

> enough to become fully conformant if the protocol is simple.

Yes, I have to say there is one very widely used protocol (I won't throw
stones here) that comes from an RFC set that I absolutely hate reading.
-- 
Wes Hardaker
USC/ISI
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest