Subject: Re: [rfc-i] Citing drafts

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Feb 2021 17:46:41 +0000

Moved from rfc-interest (BCC) to tools-discuss.

>    My pet hate is that I have to scroll to the bottom before I can tell the 
    system that I want the lot.

(Are hates what peeves become when fully grown? :)
 
One the one hand, I get it.  I find it annoying too.  On the other hand, you're presumably already down at the bottom of the page at the time you see it. On the third hand, it's annoying to have to tweak the link if you already started sharing it. On the fourth hand, it could be an easy change.

When would you want to get the full document?  When you click on a document from the WG page?  (e.g., https://datatracker.ietf.org/wg/acme/documents/ )

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 02 Mar 2021 15:44:46 +1100

> When would you want to get the full document?  When you click on a document from the WG page?  (e.g., https://datatracker.ietf.org/wg/acme/documents/ )

Plus one zillion to this.  I NEVER want just the top of the document, unsearchable, unscrollable.  If I open a document, I want to see the whole document.  Even the biggest RFC is really not that much data top ship across the network or render.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: tom petch <[email-masked]>
Date: Tue, 2 Mar 2021 10:13:18 +0000

> Plus one zillion to this.  I NEVER want just the top of the document, unsearchable, unscrollable.  If I open a document, I want to see the whole document.  Even the biggest RFC is really not that m…

When all I want is the document, then I want the full document and the 
simplest, cleanest, fastest etc way to get it is from the ftp: server, 
which presents me with one line per every current I-D, title, date, 
size, all I need to know before I download it.

But often, when following a reference to a document, then context 
matters.  I want that meta-data before I go further.  If the I-D is in 
the RFC Editor queue, then there is no point in noting the spelling 
mistakes.  Almost all of the meta-data is relevant at some point; AD 
watching, Last Call, early YANG Doctor review requested, IESG Ballot, 
Shepherd write-up available, history of versions pre- and post- WG 
adoption and so on, all may colour what I am going to do and I need that 
data before I start on an I-D.

This is of course in the course of reviewing the work of other authors, 
peer review, but that is of course what makes the IETF different, that 
all are invited to review, to improve the quality of the IETF's output 
and having that meta-data is a  key part of that.

Tom Petch