Subject: Re: [rfc-i] [Tools-discuss] what metric replaces page-count?

From: "John R Levine" <[email-masked]>
Date: 12 Apr 2021 21:54:40 -0400

It appears that Michael Richardson  <[email-masked]> said:
>John Levine's "but IDs still have page count" helps me not at all when
>comparing two RFCs.  It this a document I can read over a coffee break, or do
>I need to lock-myself in the wifi-free tree-house all afternoon?

The file size should give you a pretty good hint.

I suppose we could publish mechanically generated word counts for some definition of "word".

R's,
John
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Tue, 13 Apr 2021 08:52:27 +0200

> I suppose we could publish mechanically generated word counts for some

Yep. The only question is how to treat the contents of <artwork> and
<sourcecode>.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 13 Apr 2021 09:02:41 +0200

> Yep. The only question is how to treat the contents of <artwork> and

For most source code languages, there is a relatively well-established notion of what “lines of code” (LOC) are.  Of course, this doesn’t mix that well with “words”.

There also is a question how the discontinuity between pre-8650 and 8650+ RFCs can be addressed; a common metric would be useful.
58 lines * 69 columns (assuming standard indent) ≈ 4000 characters max per page (minus ≈ 100 characters lost per paragraph break and around 200 per section start) meshes somewhat with counting characters in text and with counting LoC in code.

Grüße, Carsten