Subject: [rfc-i] html versions of existing RFCs

From: Michael Richardson <[email-masked]>
Date: Sat, 29 May 2021 17:53:49 -0400

As the HTML was never authoritative, and the XML has been authoritative for
awhile, even when it was v2 XML, will the RFC editor consider using the newer
xml2rfc (with --v2v3 maybe) on existing RFCs, so that the HTML link for older
(but not ancient) RFCs (e.g. 8366) will be the HTML rendering, rather than
the HTML-sized txt?

for instance:
    https://www.rfc-editor.org/rfc/rfc8366.html

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "John Levine" <[email-masked]>
Date: 29 May 2021 19:36:33 -0400

It appears that Michael Richardson  <[email-masked]> said:
>awhile, even when it was v2 XML, ...

No, the XML only became authoritative when we switched to v3.

> will the RFC editor consider using the newer >xml2rfc (with --v2v3 maybe) on existing RFCs, so that the HTML link for older
>(but not ancient) RFCs (e.g. 8366) will be the HTML rendering, rather than the HTML-sized txt?

I gather that in a lot of RFCs created using v2 there were tweaks to
the text after rendering. While the rendered HTML would certainly be
more attractive, it wouldn't always be correct.

R's,
John