Subject: [rfc-i] <artwork/> vs <sourcecode/> - this is a change request

From: Brian E Carpenter <[email-masked]>
Date: Sat, 29 May 2021 17:19:54 +1200

Hi,

XML2RFCv3 allows us to label chunks of source code to distinguish them from normal figures. That's fine and makes it clear where the IETF Trust's <CODE BEGINS> should be used.

However, a side effect of that in the grammar is that <artwork> can no longer carry attributes like type="cddl". That is a problem if <artwork> is used for short code illustrations in the text, but they should not be flagged as <sourcecode> because they are just illustrations, not complete chunks of code.

Why does this matter? Because even these illustrations need to be valid, and that means that checking tools need to be able to identify them.

This problem came up during AUTH48 for RFC8990, and caused quite some extra work.

The change request is to allow <artwork type="cddl"> etc. It's sent to this list because it isn't a bug report, but a request to update the grammar.

Regards
   Brian

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 29 May 2021 07:51:06 +0200

Hi Brian,

let me add:
The grammar is fine with any text string on artwork’s type attribute.

However,
https://xml2rfc.tools.ietf.org/xml2rfc-doc.html#name-type-attribute-4
innovates by giving the type attribute different semantics than before (and different from sourcecode’s type attribute).
Even some of the types defined in 7991 now seem to be deprecated.

The whole thing seems to confuse not just us, see for instance:
https://github.com/cabo/kramdown-rfc2629/pull/125

I do believe we need some guidance *now* how to proceed with artwork and sourcecode; these occur in the majority of RFCs and not using them consistently reduces the utility of the XML access.

The markdown form of authoring lends itself to have one kine of codeblock with one type parameter.
The distinction between artwork and sourcecode is entirely artificial; kramdown-rfc currently guesses that any of the type values
      ARTWORK_TYPES = %w(ascii-art binary-art call-flow hex-dump svg)
as well as code blocks with an “artwork-align” attribute are artwork, anything else is sourcecode.
This is not really tenable, with the guess list potentially changing all the time.

Grüße, Carsten

> On 29. May 2021, at 07:19, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
>

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 29 May 2021 15:56:16 +1000

There's an open issue for this, but I forget where the repo is. It'd be really nice if the RFC Editor web site were updated with this sort of info...

> On 29 May 2021, at 3:51 pm, Carsten Bormann <[email-masked]> wrote:
> 
> Hi Brian,
> 
> let me add:

--
Mark Nottingham   https://www.mnot.net/

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 29 May 2021 08:03:08 +0200

On 29. May 2021, at 07:56, Mark Nottingham <[email-masked]> wrote:
> 
> There's an open issue for this, but I forget where the repo is.

Found it:
https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/195

Grüße, Carsten