Subject: [rfc-i] Is v3 ready?

From: Steve Slevinski <[email-masked]>
Date: Sun, 27 Jun 2021 09:24:56 -0500

Hi RFC Interest,

It’s time to update my I-D again.
I let it sit for 18 months.

I was hoping to switch to v3, but I’m running into errors.
The conversion from v2 to v3 still breaks tables by adding <td></tr>.
Easy find and replace.

The xml2frc tool is complaining about <seriesInfo> being used in <front>.
Looking through the specification, this should be allowed.

I wanted to use the new SVG and Unicode possibilities.

Is there an example v3 XML document I can use as a starting point?

Thanks,
-Steve
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 Jun 2021 16:54:29 +0200

> The conversion from v2 to v3 still breaks tables by adding <td></tr>.

If that's reproducable: open a ticket at
<https://trac.ietf.org/trac/xml2rfc>.

> Looking through the specification, this should be allowed.

The use of seriesInfo in the new place (front) is unfinished. My
recommendation is to stick what v2 uses for now.

> Is there an example v3 XML document I can use as a starting point?

All over the place. For all recent RFCs, you can just look at their XML
(but make sure to run "xml2rfc --unprep" before looking...).

Best regards, Julian

---

From: Steve Slevinski <[email-masked]>
Date: Sun, 27 Jun 2021 10:09:10 -0500

> On Jun 27, 2021, at 9:54 AM, Julian Reschke <[email-masked]> wrote:
> 

I tried the conversion today.
I don’t have permission to open a ticket.

Converting this text will reproduce the error.

          <texttable align='left' style='all' anchor='table_other_codes'>
            <ttcol>Description</ttcol>
            <ttcol>FSW Characters</ttcol>
            <ttcol>SWU Characters</ttcol>

            <c>Sequence Marker</c>
            <c>A</c>
            <c>U+1D800</c>

            <c>Signbox Markers</c>
            <c>B, L, M, R</c>
            <c>U+1D801 to U+1D804</c>

            <c>Numbers</c>
            <c>250 to 749</c>
            <c>U+1D80C to U+1D9FF</c>
            
            <c>Symbols</c>
            <c>S10000 to S38b07</c>
            <c>U+40001 to U+4F428</c>
            
          </texttable>

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 Jun 2021 17:16:56 +0200

>              <c>U+40001 to U+4F428</c>

Converts to:

         <thead>
           <tr>
             <th>Description</th>
             <th>FSW Characters</th>
             <th>SWU Characters</th>
           </tr>
         </thead>
         <tbody>
           <tr>
             <td>Sequence Marker</td>
             <td>A</td>
             <td>U+1D800</td>
           </tr>
           <tr>
             <td>Signbox Markers</td>
             <td>B, L, M, R</td>
             <td>U+1D801 to U+1D804</td>
           </tr>
           <tr>
             <td>Numbers</td>
             <td>250 to 749</td>
             <td>U+1D80C to U+1D9FF</td>
           </tr>
           <tr>
             <td>Symbols</td>
             <td>S10000 to S38b07</td>
             <td>U+40001 to U+4F428</td>
           </tr>
         </tbody>
       </table>

over here...

Best regards, Julian

---

From: Steve Slevinski <[email-masked]>
Date: Sun, 27 Jun 2021 10:29:25 -0500

My apologies.

On page https://xml2rfc.tools.ietf.org/experimental.html <https://xml2rfc.tools.ietf.org/experimental.html> I didn’t see the convert v2 to v3 option in the top section.

I used the old prototype at the bottom of the page.

-Steve

> On Jun 27, 2021, at 10:16 AM, Julian Reschke <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Jun 2021 17:31:01 +0200

> Converts to:

Ha.

      <table align="left" anchor="table_other_codes">
        <thead>
          <tr>
            <th align="left">Description</th>
            <th align="left">FSW Characters</th>
            <th align="left">SWU Characters</th>
          </tr>
        </thead>
        <tbody>
          <tr>
            <td align="left">Sequence Marker</td>
            <td align="left">A</td>
            <td align="left">U+1D800</td>
          </tr>
          <tr>
            <td align="left">Signbox Markers</td>
            <td align="left">B, L, M, R</td>
            <td align="left">U+1D801 to U+1D804</td>
          </tr>
          <tr>
            <td align="left">Numbers</td>
            <td align="left">250 to 749</td>
            <td align="left">U+1D80C to U+1D9FF</td>
          </tr>
          <tr>
            <td align="left">Symbols</td>
            <td align="left">S10000 to S38b07</td>
            <td align="left">U+40001 to U+4F428</td>
          </tr>
        </tbody>
      </table>

Why are we getting three different outputs here?

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 Jun 2021 17:56:00 +0200

> Why are we getting three different outputs here?

1) Let's make sure we all use the same input. A minimal complete example
would be good.

2) Then let's compare xm2rfc versions and command lines...

Best regards, Julian

PS: FWIW, unless I'm missing something your output only has the @align
defaults added, right?

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 Jun 2021 17:57:41 +0200

Am 27.06.2021 um 17:29 schrieb Steve Slevinski:
> My apologies.
>
> On page https://xml2rfc.tools.ietf.org/experimental.html
> <https://xml2rfc.tools.ietf.org/experimental.html> I didn’t see the
> convert v2 to v3 option in the top section.
>

Ah.

Install the current version (3.9.1) of xml2rfc ("pip install xml2rfc"),
then run it with the "--v2v3" command line option.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Jun 2021 18:00:32 +0200

> PS: FWIW, unless I'm missing something your output only has the @align

Yes, and I am surprised that is different from your output.

I used xml2rfc 3.8.0.

3.9.1 gives:

Which I think is the same.

Grüße, Carsten

---

From: Steve Slevinski <[email-masked]>
Date: Sun, 27 Jun 2021 11:42:18 -0500

Thanks Julian,

The online version is 3.9.0.
It is working great.

I am able to add Unicode and SVG to my Internet Draft.
Awesome!

The HTML output is very nice.
I have a custom font that I need to load.
By adding the following to the HTML, everyone is able to see the characters as intended.
It works for people who have the font installed and those who don’t.

/* fonts */
@font-face {
  font-family: "SuttonSignWritingOneD";
  src: 
    local('SuttonSignWritingOneD'),
    url('https://unpkg.com/@sutton-signwriting/[email-masked]/font/SuttonSignWritingOneD.ttf') format('truetype');
}
.unicode {
  font-family: SuttonSignWritingOneD;
}
Thanks for the great work,
-Steve

> On Jun 27, 2021, at 10:57 AM, Julian Reschke <[email-masked]> wrote:
>

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 Jun 2021 19:57:02 +0200

Am 27.06.2021 um 18:42 schrieb Steve Slevinski:
 > ...

Out of curiosity: why do you need a custom font? This *will* be a
problem upon publication...

Best regards, Julian

---

From: "StJohns, Michael" <[email-masked]>
Date: Sun, 27 Jun 2021 14:05:35 -0400

My guess is that this will explain why.

https://slevinski.github.io/SuttonSignWriting/

AIRC - it’s possible to embed fonts in the document?   As XML I mean?

Mike

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 Jun 2021 20:09:55 +0200

Am 27.06.2021 um 20:05 schrieb StJohns, Michael:
> <https://slevinski.github.io/SuttonSignWriting/>

I see :-)

> AIRC - it’s possible to embed fonts in the document?   As XML I mean?

You could embed the source code of the font in some way; but having the
font used for display is something the format does not support.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 27 Jun 2021 20:16:01 +0200

Rendering those fonts into SVG should work fine. 

Sent from mobile, sorry for terse

> On 27. Jun 2021, at 20:10, Julian Reschke <[email-masked]> wrote:
>

---

From: Steve Slevinski <[email-masked]>
Date: Sun, 27 Jun 2021 13:19:50 -0500

> problem upon publication...

Hi Julian,

I plan to add the extra HTML to the version I post on my website.

I understand that the official publication won’t have the extra style.

-Steve

---

From: Jay Daley <[email-masked]>
Date: Mon, 28 Jun 2021 09:34:07 +1200

Hi Steve

To answer the question in your subject line - yes it is ready, but more needs to be done to make it easier to use, including a new web service to replace xml2rfc.tools.ietf.org, for which we have an RFP out[1], better author documentation and a single place to find template, tools etc.  These problems were all identified in the survey we did last year of I-D authors and the recommendations [2] are being worked through.

Please continue to send feedback - it’s very helpful for this work.

Jay

[1]  https://www.ietf.org/media/documents/Author_tools_web_services_re-implementation_RFP.pdf
[2]  https://www.ietf.org/blog/results-and-analysis-of-the-survey-of-i-d-authors-on-formats-and-tools/

> On 28/06/2021, at 2:24 AM, Steve Slevinski <[email-masked]> wrote:
> 
> Hi RFC Interest,
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 28 Jun 2021 09:45:47 +1200

> I used the old prototype at the bottom of the page.

We've been discussing (well, ranting) about the delapidated state of that 
page over on th tools-discuss list, but there is a plan to update it.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 28 Jun 2021 09:48:34 +1200

> I am able to add Unicode and SVG to my Internet Draft.

Glad to hear it. But for the wider public, be aware that SVG generated with your favourite drawing package is unlikely to pass the Tiny SVG check out of the box. Experience suggests that very simple things drawn with a very simple tool like dia have the best chance of passing.

    Brian

---

From: Steve Slevinski <[email-masked]>
Date: Sun, 27 Jun 2021 17:00:21 -0500

> On Jun 27, 2021, at 4:48 PM, Brian E Carpenter <[email-masked]> wrote:
> 

Hi Brian,

My SVG is created from scratch by my tools.
To pass validation, I had to delete the metadata tag and remove the “fill” attribute from the <rect> and <path> tags.
These details are allowed by Tiny SVG1.2, but not allowed by the RFC SVG subset of RFC 7996.

Overall, good error messages, good references, and a very easy fix.

-Steve

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 28 Jun 2021 14:30:49 +1200

Steve,

The other thing you might want to do, if and only if you have a 'viewbox' 
element in the <svg/> statement, is to remove the associated 'width' and 'height' elements if present. They prevent proper scaling of figures within a browser window.

Regards
   Brian Carpenter

On 28-Jun-21 10:00, Steve Slevinski wrote:
>> Glad to hear it. But for the wider public, be aware that SVG generated 
with your favourite drawing package is unlikely to pass the Tiny SVG check out of the box. Experience suggests that very simple things drawn with a very simple tool like dia have the best chance of passing.

---

From: Alice Russo <[email-masked]>
Date: Mon, 28 Jun 2021 15:17:34 -0700

Steve,

> (but make sure to run "xml2rfc --unprep" before looking...).

This page links to RFCs that make use of some specific v3 features:
https://www.rfc-editor.org/rse/wiki/doku.php?id=v3_feature_usage

As an alternative to --unprep, the "not prepped" v3 XML files are available here:
https://www.rfc-editor.org/rfc/prerelease/

Alice Russo
RFC Production Center