Subject: [rfc-i] When is a new version of xml2rfc used by the submission tool?

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 24 Sep 2021 07:14:20 -0700

Hi,

When a new version of xml2rfc released, is it immediately used by the submission tool, or is there is a delay?  If it is the latter, how do I know which version will be used when submitting?

This is related to the double-quote with <tt>.  If the submission tool uses 3.10.0, then I need to add the double-quotes manually before submitting, and I do not want to have to submit twice if I guessed wrong.

Thanks.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Sep 2021 16:51:11 +0200

Note that the rfcxml fork will also be visible with a delay by people using various canned collections of tools, including Martin Thomson’s I-d-template. 

Sent from mobile, sorry for terse

> On 24. Sep 2021, at 16:14, Marc Petit-Huguenin <[email-masked]> wrote:
> 
> Hi,
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 24 Sep 2021 10:17:27 -0500

Normally, the datatracker would pick up a new version of xml2rfc at its 
next release, which I expect to be next week.

I can patch this in today though to help limit the window of having to 
guess.

RjS

On 9/24/21 9:51 AM, Carsten Bormann wrote:
> Note that the rfcxml fork will also be visible with a delay by people 
> using various canned collections of tools, including Martin Thomson’s 
> I-d-template.
>
>> When a new version of xml2rfc released, is it immediately used by the 
>> submission tool, or is there is a delay?  If it is the latter, how do 
>> I know which version will be used when submitting?
>>
>> This is related to the double-quote with <tt>.  If the submission 
>> tool uses 3.10.0, then I need to add the double-quotes manually 
>> before submitting, and I do not want to have to submit twice if I 
>> guessed wrong.
>>
>> Thanks.
>>
>> -- 
>> Marc Petit-Huguenin

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 24 Sep 2021 08:33:11 -0700

On 9/24/21 8:17 AM, Robert Sparks wrote:
> Normally, the datatracker would pick up a new version of xml2rfc at its next release, which I expect to be next week.
> 
> I can patch this in today though to help limit the window of having to guess.

I would prefer a deterministic way to find the xml2rfc version, for scripting purposes.  If the datatracker always picks the latest version of xml2rfc at each release, then I can use https://datatracker.ietf.org/api/version to infer the correct version.

Alternatively if there is the possibility of out of release updates, the xml2rfc version could be added to https://datatracker.ietf.org/api/version.

I checked https://datatracker.ietf.org/release/ and I do not see the xml2rfc upgrades in there, so using that and https://datatracker.ietf.org/api/version to find the current version of xml2rfc won't work.

---

From: Robert Sparks <[email-masked]>
Date: Fri, 24 Sep 2021 14:14:15 -0500

I have done this - the datatracker is now running 3.10.0

On 9/24/21 10:17 AM, Robert Sparks wrote:
>
> Normally, the datatracker would pick up a new version of xml2rfc at 
> its next release, which I expect to be next week.
>
>>> When a new version of xml2rfc released, is it immediately used by 
>>> the submission tool, or is there is a delay?  If it is the latter, 
>>> how do I know which version will be used when submitting?
>>>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 24 Sep 2021 14:20:00 -0500

Hi Marc - I captured this suggestion at 
https://trac.ietf.org/trac/ietfdb/ticket/3415

RjS

On 9/24/21 10:33 AM, Marc Petit-Huguenin wrote:
> I would prefer a deterministic way to find the xml2rfc version, for 
> scripting purposes.  If the datatracker always picks the latest 
> version of xml2rfc at each release, then I can use 
> https://datatracker.ietf.org/api/version to infer the correct version.
>
> Alternatively if there is the possibility of out of release updates, 
> the xml2rfc version could be added to 
> https://datatracker.ietf.org/api/version.
>
> I checked https://datatracker.ietf.org/release/ and I do not see the 
> xml2rfc upgrades in there, so using that and 
> https://datatracker.ietf.org/api/version to find the current version 
> of xml2rfc won't work.
>
>>
>> RjS
>>
>>> Note that the rfcxml fork will also be visible with a delay by 
>>> people using various canned collections of tools, including Martin 
>>> Thomson’s I-d-template.
>>>

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 24 Sep 2021 12:27:27 -0700

Hi Robert,

Thank you for the ticket and the update of the datatracker.

On 9/24/21 12:20 PM, Robert Sparks wrote:
> Hi Marc - I captured this suggestion at https://trac.ietf.org/trac/ietfdb/ticket/3415
> 
> RjS
>

---

From: "Martin Thomson" <[email-masked]>
Date: Sat, 25 Sep 2021 09:07:52 +1000

> using various canned collections of tools, including Martin Thomson’s 

For the record, update builds run twice a month, when my code changes (not often lately), and when someone asks (open an issue, just like someone did last night).

The version of major tools is printed in logs.

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 24 Sep 2021 19:35:53 -0400

Where is the official online version? Is it still at:

https://xml2rfc.tools.ietf.org

	Thanks,
	Paul

---

From: Jay Daley <[email-masked]>
Date: Mon, 27 Sep 2021 10:25:31 +1300

> On 25/09/2021, at 11:35 AM, Paul Kyzivat <[email-masked]> wrote:
> 

Yes, that’s the official version.  There is a new version in development and the notes on that from the last tools call are:

	• Preview version is available at https://author-tools.ietf.org/
	• API documentation: https://author-tools.ietf.org/doc/
	• Author Tools API github project: https://github.com/ietf-tools/ietf-at
	• Author Tools UI github project: https://github.com/ietf-tools/ietf-at-ui

Limitations on preview version:
	• Basic conversions from XML (v2/v3), text, kramdown-rfc2629 to XML v3, text, HTML, PDF formats.
	• Limited visibility of errors and warnings.
	• Does not support API keys.
	• Runs on a development box, might not work properly and could go down at any time.

Upcoming work:
	• Add support for API keys via Datatracker.
	• Improvements on default settings.
	• Release to wider community.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Mon, 27 Sep 2021 09:49:57 -0500

As the notes indicate, the author-tools implementation is going through 
rapid transition, and while we're very close for everyone to start 
trying to use it, there will be times over the next couple of days where 
it will be unavailable, or even not working correctly, as the 
implementation proceeds.

Feel free to try it out, but until we send a "ready" signal, expect 
there to be bumps.

RjS