Subject: [rfc-i] Machine-readable documents at Hackathon 112

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 29 Oct 2021 05:39:14 -0700

Stephen, Colin, and I would like to invite you to participate in the online IETF 112 Hackathon on our umbrella project of "Machine-readable documents and their tools":

https://trac.ietf.org/trac/ietf/meeting/wiki/112hackathon#MachineReadable

If you have done some work on that subject that you would like to present or discuss, or if you have opinions on that topic, or simply are curious about how machine-readable documents can make the Internet work better, and what tools are available to produce and use these documents, please join us.  Stephen and I will be presenting our work with shorts live presentations at scheduled times during the week:

https://trac.ietf.org/trac/ietf/meeting/wiki/112hackathon/teamschedule

Feel free to add your project to either or both Wiki pages.

The Hackathon itself is free to attend and open to everyone:

https://www.ietf.org/how/runningcode/hackathons/112-hackathon/

We are looking forward to meet you there.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 29 Oct 2021 09:32:58 -0700

Hi Leonard,

PDF files are used for IETF standards, but only as non-canonical representations.  That said, be able to translate the machine-readable parts from the canonical format into a PDF that is also machine-readable is interesting.  Is there a publicly available specification of the PDF format that enables that kind of things?

Thanks.

On 10/29/21 06:58, Leonard Rosenthol wrote:
> Marc – this very interesting, though seems to focus on a different definition of “document” than what I normally work with.
> 
> I’ve been working for a decade or more on evolving PDF to serve not only as a solution for human consumption of information but also for machines.  The results of this work have led to solutions used in various international and national standards for production of such content – a good example is the eInvoicing standards of Germany and France.
> 
> If this seems like something that fits what you envision, I am happy to present my work on the technologies and their adoption in open standards.
> 
> Leonard
> Senior Principal Architect, PDF & Content Authenticity  |  Adobe  |  p. 408.536.2433  |  c. 215.808.4978  |  [email-masked]<mailto:[email-masked]>
> 
> 
> From: rfc-interest <[email-masked]> on behalf of Marc Petit-Huguenin <[email-masked]>
> Date: Friday, October 29, 2021 at 8:41 AM
> To: rfc-interest <[email-masked]>
> Cc: Colin Perkins <[email-masked]>
> Subject: [rfc-i] Machine-readable documents at Hackathon 112
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fietf%2Fmeeting%2Fwiki%2F112hackathon%23MachineReadable&amp;data=04%7C01%7Clrosenth%40adobe.com%7C67f2306ac3144360073008d99ad923d3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711080638740114%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=kC%2FRKWzrQgQhT0XzchPxey33kRyruRWkT6og3%2BTtlLw%3D&amp;reserved=0
> 
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fietf%2Fmeeting%2Fwiki%2F112hackathon%2Fteamschedule&amp;data=04%7C01%7Clrosenth%40adobe.com%7C67f2306ac3144360073008d99ad923d3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711080638740114%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=ar6QYdkLGa0kV816mfqzk%2BAuiT9hOY0KeTtcId57eSw%3D&amp;reserved=0
> 
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fhow%2Frunningcode%2Fhackathons%2F112-hackathon%2F&amp;data=04%7C01%7Clrosenth%40adobe.com%7C67f2306ac3144360073008d99ad923d3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711080638740114%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=cI0ngoZQMUx8gcnfuQ23kd2pi3F4qlZJ2REYmg9WPQQ%3D&amp;reserved=0
>

---

From: Leonard Rosenthol <[email-masked]>
Date: Sat, 30 Oct 2021 23:41:55 +0000

The current ISO standard – 32000-2:2020 – has all the necessary functionality.   Most of it was present in 32000-1:2008, but some nice additions were made in 2.0.

Leonard

From: Marc Petit-Huguenin <[email-masked]>
Date: Friday, October 29, 2021 at 12:33 PM
To: Leonard Rosenthol <[email-masked]>, rfc-interest <[email-masked]>
Cc: Colin Perkins <[email-masked]>
Subject: Re: [rfc-i] Machine-readable documents at Hackathon 112
Hi Leonard,

Thanks.

On 10/29/21 06:58, Leonard Rosenthol wrote:
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fietf%2Fmeeting%2Fwiki%2F112hackathon%23MachineReadable&amp;data=04%7C01%7Clrosenth%40adobe.com%7C75142930ad9141b8d9e108d99af9c744%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711219878234958%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=xScn34Ib5Mr3YFepCujHGuBboc966kZkxK4cZTJNb%2Bk%3D&amp;reserved=0
>
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fietf%2Fmeeting%2Fwiki%2F112hackathon%2Fteamschedule&amp;data=04%7C01%7Clrosenth%40adobe.com%7C75142930ad9141b8d9e108d99af9c744%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711219878234958%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=onFFRwAxK02Pu%2FNtTBHgl%2BEsuzBwBwdtWv%2FADcqDucw%3D&amp;reserved=0
>
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fhow%2Frunningcode%2Fhackathons%2F112-hackathon%2F&amp;data=04%7C01%7Clrosenth%40adobe.com%7C75142930ad9141b8d9e108d99af9c744%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711219878244916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=43FcMmnbDfagErbtZIQsCIxGTmyoXxQ1OFW9ZJikc80%3D&amp;reserved=0
>

--
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmarc.petit-huguenin.org%2F&amp;data=04%7C01%7Clrosenth%40adobe.com%7C75142930ad9141b8d9e108d99af9c744%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711219878244916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=4Y2QqeindzuHffV1yyFgR4gIPK1qkOWMK70vedp5Wos%3D&amp;reserved=0
Profile: https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fpetithug&amp;data=04%7C01%7Clrosenth%40adobe.com%7C75142930ad9141b8d9e108d99af9c744%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C637711219878244916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=JHTDvE9uBjzBdthQLN5rkyjxFAHXvVuffuzCjMwCTKc%3D&amp;reserved=0
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 31 Oct 2021 05:16:48 -0700

Hi Leonard,

I looked at was publicly available on the Internet about the features in 32000-2:2020 (e.g. https://www.loc.gov/preservation/digital/formats/fdd/fdd000474.shtml) but I am not sure how any of theses relate to machine-readable documents.  In the context of this Hackathon my understanding of "machine-readable documents" are documents, namely RFCs, from which parts can be extracted and processed by tools to assist the "user" of that RFC into accomplishing some task.  Examples of these tasks could be to implement a protocol, verify conformance to a protocol, derive APIs, etc...  Stephen and Colin's draft[1] is a perfect example of that (my work is on the other side of machine-readable documents, i.e. how to ensure that machine-readable documents are correct in the first place).

Anyway you should join us to discuss that, particularly during the time slots marked "Packet Formats", in which Stephen will present a way to make RFC's Packet Headers machine-readable.

Thanks.

[1] https://datatracker.ietf.org/doc/html/draft-mcquistin-augmented-ascii-diagrams

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 31 Oct 2021 14:35:54 -0700

Apparently I cannot get over not understanding something, so I got a copy of 32000-2:2020 and of Factur-X 1.0.05.  My understanding is that since PDF 2.0 and PDF/A-3 it is possible to embed files in a PDF.  xml2rfc (the tool) already generates PDF/A-3u files so that would be just a matter of extracting the sourcecode and maybe artset elements from the canonical file and embed them in the PDF output.  Or even embed the whole canonical file.

Then tools like https://github.com/glasgow-ipl/ips-protodesc-code could be modified to directly extract the data from the PDF file.

---

From: "John Levine" <[email-masked]>
Date: 31 Oct 2021 18:09:10 -0400

It appears that Marc Petit-Huguenin <[email-masked]> said:
>Apparently I cannot get over not understanding something, so I got a copy of 32000-2:2020 and of Factur-X 1.0.05.  My understanding is that since PDF 2.0 and
>PDF/A-3 it is possible to embed files in a PDF.  xml2rfc (the tool) already generates PDF/A-3u files so that would be just a matter of extracting the
>sourcecode and maybe artset elements from the canonical file and embed them in the PDF output.  Or even embed the whole canonical file.

The PDF versions of RFCs that we publish have the entire XML source
file embedded in them. After we run xml2rfc to create the PDF, we use
a commercial tool from Callas Software to turn it into PDF/A and embed
the XML file.

If you open the PDF in a recent version of Acrobat Reader, there
should be a button you can push to extract the XML. It's the same XML
as the separate XML file so if you want to do something with the XML,
you might as well start with the XML.

R's,
John

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 31 Oct 2021 15:33:17 -0700

> a commercial tool from Callas Software to turn it into PDF/A and embed

Aah!  I did look at the PDF produced by xml2rfc, which is why I did not see the embedded file.

FTR evince also permits to extract the xml file (Side Pane button on top left, then Attachments button on bottom).

> you might as well start with the XML.

Yes, but having multiple ways to do things is how technology can serve us instead of the other way around.