Subject: [rfc-i] ascii= attributes in RFCXMLv3

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Feb 2022 21:29:04 +0100

Lucas Pardue asked me about beyond-ASCII support in kramdown-rfc.

Part of this is that there is about a dozen elements in RFCXML that have an ascii= attribute.
I wondered what these do, so I wrote:

    <author initials="C." surname="Bormann" fullname="Carsten Bormann">
      <organization showOnFrontPage="true" ascii="ignoredunicorn">🦄</organization>
      <address>
        <postal>
          <street ascii="ignoredtoyota1">トヨタ自動車株式会社</street> <street ascii="ignoredtoyota2">トヨタ</street>
        </postal>
        <email>[email-masked]</email>
      </address>
    </author>

None of this is visible in xml2rfc’s rendering in either TXT or HTML.

Generally, fields that are not visible will not be checked in proofreading, so I think this is a dangerous state we are in.

Should these attributes be deprecated?  What were they intended for?

Grüße, Carsten

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Alice Russo <[email-masked]>
Date: Tue, 1 Feb 2022 17:14:59 -0800

Hi Carsten,

From https://authors.ietf.org/non-ascii-characters-in-rfcxml :

> author and contact's postal address using <street>, <city>, <region>, <city>, <country> and * <email> elements. Each of these elements has an ascii attribute to hold the ASCII equivalent, which will also appear in the output format.

In practice:
https://www.rfc-editor.org/rfc/rfc9094.html#name-authors-addresses

From testing why the example below didn't work, it seems that the trigger for getting the "Additional contact information:" portion to appear in Authors' Addresses is to supply a non-ASCII fullname. 

Here are files with your example (using the template from [1] as a starting point):
https://www.rfc-editor.org/v3test/sample2.html
https://www.rfc-editor.org/v3test/sample2.pdf
https://www.rfc-editor.org/v3test/sample2.txt
https://www.rfc-editor.org/v3test/sample2.xml (source)

As for why the organization's ASCII equivalent doesn't appear in the output, perhaps it's tripping on the emoji. It works as expected if changed to フ.

Thanks,
Alice

[1] https://authors.ietf.org/en/templates-and-schemas

> On Feb 1, 2022, at 12:29 PM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Feb 2022 07:27:03 +0100

Hi Alice,

> From testing why the example below didn't work, it seems that the trigger for getting the "Additional contact information:" portion to appear in Authors' Addresses is to supply a non-ASCII fullname…

Great detective work!

Of course it is conceivable that an author has a Latin name (so doesn’t need a “asciiFullname”) and lives in a non-Latin country and/or works for a non-Latin employer with a non-Latin address, so I’d count this as an xml2rfc bug.

> As for why the organization's ASCII equivalent doesn't appear in the output, perhaps it's tripping on the emoji. It works as expected if changed to フ.

Which would then be another xml2rfc bug.

(I simply hadn’t implemented the fullname/surname/initials complication yet, otherwise I wouldn’t have stumbled about the first issue in testing…)

Thank you!

Grüße, Carsten