Subject: [rfc-i] Markdown template for draft?

From: Paul Kyzivat <[email-masked]>
Date: Tue, 1 Feb 2022 10:30:56 -0500

I have very limited experience with markdown. (I have recently used it 
for meeting agendas.)

I'm interested in trying it out for a new draft. Are there any markdown 
templates for drafts that I can use as a starting point?

Also, is there a good web based tool I can use for rendering the markdown?

	Thanks,
	Paul

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Feb 2022 15:47:20 +0000

Look at authors.ietf.org and authors-tools.ietf.org

Both are still evolving and aren't "done" but should help you get on your way.

If you decide to use github, it's hard to get better than Martin's i-d-template stuff which is at https://github.com/martinthomson/i-d-template

---

From: Robert Sparks <[email-masked]>
Date: Tue, 1 Feb 2022 10:06:54 -0600

> If you decide to use github, it's hard to get better than Martin's i-d-template stuff which is at https://github.com/martinthomson/i-d-template
Paul - I strongly recommend spending the time to get started with 
Martin's above template repository - it will make things much easier for 
you in the long run.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Feb 2022 17:36:37 +0100

I think we are having a hard time with the word template here.

(1) Some of us are talking about an example input document (XML, markdown), an “I-D template”.

(2) Some of us are talking about Martin Thomson’s I-D-template setup for a GitHub repository that automates a lot of the GitHub operations of an I-D repository.  (This includes a few (1).)

(3) Some of us are talking about https://github.com/martinthomson/internet-draft-template — a GitHub “template repository” that you can use to create an instance of (2).

Like Robert, I would strongly recommend using (3) to get a (2) and use one of the (1) templates in (2) to start your work (Note that (2) is agnostic between RFCXML, kramdown-rfc, and mmark).  This gives you a great basis to collaborate with your co-authors and the WG about your draft.

If you don’t care about the collaboration aspect as much, you can use one of the (1) templates in (2) to start your local instance of a draft.  I would recommend installing xml2rfc and kramdown-rfc (which comes with kdwatch!) locally for all normal processing.  The tools at authors-tools.ietf.org can be used in a pinch (and it may be easier to use idnits, rfcdiff etc. from there than installing them locally as well).

Grüße, Carsten

> On 2022-02-01, at 17:06, Robert Sparks <[email-masked]> wrote:
> 
> 
> Paul - I strongly recommend spending the time to get started with Martin's above template repository - it will make things much easier for you in the long run.
>> 
>>

---

From: Miek Gieben <[email-masked]>
Date: Wed, 2 Feb 2022 08:02:58 +0100

[ Quoting <[email-masked]> in "[rfc-i] Markdown template for draft..." ]
>I'm interested in trying it out for a new draft. Are there any
>markdown templates for drafts that I can use as a starting point?

See here for example RFCs in mmark markdown:

https://github.com/mmarkdown/mmark/tree/master/rfc

/Miek

--
Miek Gieben

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Feb 2022 23:04:24 +0100

> (1) Some of us are talking about an example input document (XML, markdown), an “I-D template”.

I put in a couple example documents that work as starting points into:

https://github.com/cabo/kramdown-rfc2629/tree/master/examples

These are based on the XML examples on authors.ietf.org, specifically those linked from https://authors.ietf.org/en/templates-and-schemas

The bare example,

https://raw.githubusercontent.com/cabo/kramdown-rfc2629/master/examples/draft-rfcxml-general-template-bare-00.xml-edited.md

…is sweet, short and not very useful (about the shortest that doesn’t get refused by xml2rfc; it doesn’t even have a docname).

The other one,

https://raw.githubusercontent.com/cabo/kramdown-rfc2629/master/examples/draft-rfcxml-general-template-standard-00.xml-edited.md

…is an example that you should be able to start from — delete what you don’t need, and refer to the example if you do need it later.

(Authors.ietf.org also has a Cadillac XML example; I haven’t got around to converting this to markdown yet and adding a few of the things that can make kramdown-rfc so useful — one of these days...)

You may also like Martin Thomson’s example:

https://raw.githubusercontent.com/martinthomson/i-d-template/main/example/draft-todo-yourname-protocol.md

Further suggestions are welcome!

Grüße, Carsten

---

From: Jay Daley <[email-masked]>
Date: Thu, 3 Feb 2022 12:01:29 +1300

Thank you.

> On 3/02/2022, at 11:04 AM, Carsten Bormann <[email-masked]> wrote:
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]