Subject: Re: [rfc-i] More about RFC10k

From: Carsten Bormann <[email-masked]>
Date: Fri, 29 Apr 2022 00:38:43 +0200

Does anyone have a recent projection for when RFC10K is going to hit?

(I could do that myself, of course, but if people have done that more seriously I’d like to know.)

Grüße, Carsten

> On 2016-04-05, at 05:25, HANSEN, TONY L <[email-masked]> wrote:
> 
> By current estimates, we should be there in 4-6 years. Hopefully at that time Steve can write a new RFC that "Updates RFC 1000".
> 
> 
> 
> On 4/4/16, 10:46 PM, "rfc-interest on behalf of Brian E Carpenter" <[email-masked] on behalf of [email-masked]> wrote:
> 
>> I just came across this quote from Steve Crocker in RFC 1000:
>> 
>>>   Where will it end?  The network has the exceeded all estimates of its
>>>   growth.  It has been transformed, extended, cloned, renamed and
>>>   reimplemented.  I doubt if there is a single computer still on the
>>>   network that was on it in 1971.  But the RFCs march on.  Maybe I'll
>>>   write a few words for RFC 10,000.
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest
> 

_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 29 Apr 2022 00:45:23 +0200

> Does anyone have a recent projection for when RFC10K is going to hit?

(An update of https://arkko.com/tools/rfcstats/pubdistr.html would be a nice shortcut to an estimate.)

Grüße, Carsten

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 28 Apr 2022 23:50:44 +0000

Ack. When I wrote the message from 2015 that Carsten replied to, we were averaging >300 RFCs per year. However, the last four years have slowed down drastically:

278 RFCs in 2000.
193 RFCs in 2001.
219 RFCs in 2002.
234 RFCs in 2003.
281 RFCs in 2004.
327 RFCs in 2005.
459 RFCs in 2006.
320 RFCs in 2007.
289 RFCs in 2008.
285 RFCs in 2009.
364 RFCs in 2010.
390 RFCs in 2011.
337 RFCs in 2012.
276 RFCs in 2013.
326 RFCs in 2014.
300 RFCs in 2015.
310 RFCs in 2016.
263 RFCs in 2017.
209 RFCs in 2018.
179 RFCs in 2019.
127 RFCs in 2020.

Jari's page doesn't have 2021 in it, but rfc index indicates that there were 240.

Since the highest number is currently 9236, that leaves us ~750 to go. If we continue at the average of the past three years (179+127+240)/3 = ~180/year, that gives us about another four years before we hit 10k, or sometime in or after 2025.

	Tony

On 4/28/2022, 6:45 PM, "rfc-interest on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    Grüße, Carsten