Subject: [rfc-i] Lamenting clusters...

From: Carsten Bormann <[email-masked]>
Date: Wed, 18 May 2022 17:34:15 +0200

From a recent mail exchange (*):

“Teaches me not even to have an informative reference to a spec that informatively references another spec that normatively references a not-yet-published spec.”

Just lamenting, no action required.
(Still, maybe we are holding this wrong.)

Grüße, Carsten

(*) RFC-to-be numbers for all the specs can be supplied upon request.

_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Michael Richardson <[email-masked]>
Date: Wed, 18 May 2022 16:53:43 -0400

Carsten Bormann <[email-masked]> wrote:
    > “Teaches me not even to have an informative reference to a spec that
    > informatively references another spec that normatively references a
    > not-yet-published spec.”

Does doing this result in being in cluster with that spec?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 18 May 2022 19:47:53 -0400

I think Informative references are normally to drafts and do not cause a
hold up until the draft is published as an RFC.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 19 May 2022 05:47:14 +0200

On 19. May 2022, at 01:47, Donald Eastlake <[email-masked]> wrote:
> 
> I think Informative references are normally to drafts and do not cause a hold up until the draft is published as an RFC.

That is the theory.

The practice appears to be that the RFC editor tries to achieve a “clean” state for RFCs that are published simultaneously, so even informative references point to the RFC version of a document.
That is of course a good thing when it can be achieved without too much collateral damage; it is definitely less confusing to have all the specs that make up one cluster reference each other by the RFC number.
But it creates informal dependencies that are hard to sleuth out from the outside.
It would be quite useful to be able to look at a cluster and see where the delay actually is.

What’s not so transparent is the definition of “simultaneous”.

What I would like to see is a form of “conditional reference” in the approved document:  An instruction for the RFC-editor to put in an informative reference if it does not cause a significant delay (either because it can stay a reference to the draft or because the simultaneous publishing actually is reasonably simultaneous without causing grave delays).

Grüße, Carsten

(My mental image of the RFC clustering process is that of the video game “Katamari Damacy” [1].
Sorry if that is only useful for those who have played that game...)

[1]: https://en.wikipedia.org/wiki/Katamari_Damacy

> On Wed, May 18, 2022 at 4:53 PM Michael Richardson <[email-masked]> wrote:
>

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 19 May 2022 15:20:31 -0700

Hi Carsten,

The RFC Editor will not delay publication of an RFC for an informative reference unless it is requested by the relevant AUTH48 parties (e.g., authors, ADs). 

We update the references to point to RFCs if we think the I-Ds will likely be published around the same time (e.g., the documents are entering AUTH48 together or the referenced document has already entered AUTH48).  However, the informative reference will be reverted to refer to the I-D and published without delay unless someone requests otherwise.  

Please specify the documents you’re referring to so we can review.  

Thanks,
RFC Editor/sg 

> On May 18, 2022, at 8:47 PM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 19 May 2022 13:37:22 -0700

> I think Informative references are normally to drafts

hmmm.  my, likely bad, habits are
  - no normative to drafts except when expecting a cluster, then
  - normative to things you MUST know to understand/implement
  - informative to things you might find interesting/helpful

i suspect that a wise head, such as sob, has written this up some time.

rndy