Subject: [rfc-i] Referencing I-Ds

From: Krzysztof Szarkowicz <[email-masked]>
Date: Wed, 25 May 2022 21:32:40 +0200

Hello,

I am trying to reference following I-Ds in my draft:

I-D.draft-ietf-teas-ietf-network-slices
I-D.draft-ietf-teas-ietf-network-slice-nbi-yang

However, at http://xml.resource.org/public/rfc/bibxml3 <http://xml.resource.org/public/rfc/bibxml3> I don’t see these drafts. I see only:

I-D.draft-ietf-teas-ietf-network-slice-definition-00.xml

How can I reference above mentioned drafts?

Thank you,
Krzysztof Szarkowicz

_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 26 May 2022 18:54:01 +0200

> I-D.draft-ietf-teas-ietf-network-slice-nbi-yang

Try

I-D.ietf-teas-ietf-network-slices
I-D.ietf-teas-ietf-network-slice-nbi-yang

(Without draft-.)

The names with draft are for specific revisions, the ones without are for the series.

(I didn’t test this, but generally it works.)

Grüße, Carsten

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Thu, 26 May 2022 18:56:45 +0200

Thank you.

Indeed. In the mean time I figured it out.

Grüße,
Krzysztof

> On 2022 -May-26, at 18:54, Carsten Bormann <[email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 26 May 2022 10:27:37 -0700

As an aside, is there a reason we don't allow you to do
I-D.draft-ietf-<blah>? I've certainly made that mistake plenty of times and
it seems like it would save trouble to allow both forms.

-Ekr

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Thu, 26 May 2022 20:13:55 +0200

Not all drafts are available in form I-D.draft-ietf-<blah> in http://xml.resource.org/public/rfc/bibxml3 <http://xml.resource.org/public/rfc/bibxml3>.

//Krzysztof

> On 2022 -May-26, at 19:27, Eric Rescorla <[email-masked]> wrote:
> 
> As an aside, is there a reason we don't allow you to do I-D.draft-ietf-<blah>? I've certainly made that mistake plenty of times and it seems like it would save trouble to allow both forms.
> 
> -Ekr
> 
> 
> On Thu, May 26, 2022 at 9:54 AM Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
> On 25. May 2022, at 21:32, Krzysztof Szarkowicz <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> [email-masked] <mailto:[email-masked]>
> https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest <https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 26 May 2022 11:54:11 -0700

On Thu, May 26, 2022 at 11:14 AM Krzysztof Szarkowicz <[email-masked]>
wrote:

> Not all drafts are available in form I-D.draft-ietf-<blah> in
> http://xml.resource.org/public/rfc/bibxml3.
>

I don't understand your point. What I am saying is that the tools could
accept I-D.ietf-<blah> but if
you enter I-D.draft-ietf-<blah> and there isn't any draft named
draft-draft-ietf-<blah> we assume
you meant I-D.ietf-<blah>

-Ekr

---

From: Robert Sparks <[email-masked]>
Date: Thu, 26 May 2022 14:49:52 -0500

So, this is puddle of deep pain, at least for me.

the datatracker will let you do either right now, at the cost of having 
some places where there is ambiguity around whether the end of the 
string you provide is a version or not, at which point things can break. 
Made up example: "draft-foo-bar-802-11" (is that version 11 of that 
draft, or is it asking for something like "draft-foo-bar-802-11-04").

the services at xml2rfc.tools.ietf.org for bibxml3 to date have dealt 
with this by saying that if the string starts out with the 'draft-' 
prefix, it's always a specific version - that is, any -nn at the end of 
the string means version nn, and if the string starts out with anything 
other than 'draft-', then whatever the rest of the string is, it's part 
of the draft name proper - no version can be specified at the end of it.

The new bib.ietf.org service will initially do what 
xml2rfc.tools.ietf.org does with those names (but we had an argument 
about it).

RjS

On 5/26/22 1:54 PM, Eric Rescorla wrote:
>
>
> On Thu, May 26, 2022 at 11:14 AM Krzysztof Szarkowicz 
> <[email-masked]> wrote:
>
> I don't understand your point. What I am saying is that the tools 
> could accept I-D.ietf-<blah> but if
>>     I-D.draft-ietf-<blah>? I've certainly made that mistake plenty of
>>     times and it seems like it would save trouble to allow both forms.
>>
>>     -Ekr
>>
>>

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Thu, 26 May 2022 22:04:23 +0200

Eric,

This is the list from http://xml.resource.org/public/rfc/bibxml3/ <http://xml.resource.org/public/rfc/bibxml3/>

reference.I-D.draft-ietf-teas-gmpls-signaling-smp-04.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-gmpls-signaling-smp-04.xml>	08-Sep-2020 00:00	1.6K	 
	reference.I-D.draft-ietf-teas-gmpls-signaling-smp-05.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-gmpls-signaling-smp-05.xml>	22-Apr-2021 17:20	1.5K	 
	reference.I-D.draft-ietf-teas-ietf-network-slice-definition-00.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-ietf-network-slice-definition-00.xml>	25-Jan-2021 00:00	1.4K	 
	reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-00.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-00.xml>	08-Dec-2014 00:00	2.3K	 
	reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-01.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-01.xml>	06-Feb-2015 00:00	2.3K	 
	reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-02.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-02.xml>	08-Mar-2015 00:00	2.3K	 
	reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-03.xml <https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-interconnected-te-info-exchange-03.xml>	15-Oct-2015 00:00	2.3K

I can swear, following reference was not working previously (as per above list):

        <xi:include href="http://xml.resource.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-ietf-network-slices.xml”/ <http://xml.resource.org/public/rfc/bibxml3/reference.I-D.draft-ietf-teas-ietf-network-slices.xml%E2%80%9D/>>

But now, it works, as you say.

Might be, there was some temporary issue only.

//Krzysztof

> On 2022 -May-26, at 20:54, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
> On Thu, May 26, 2022 at 11:14 AM Krzysztof Szarkowicz <[email-masked] <mailto:[email-masked]>> wrote:
> I don't understand your point. What I am saying is that the tools could accept I-D.ietf-<blah> but if
> you enter I-D.draft-ietf-<blah> and there isn't any draft named draft-draft-ietf-<blah> we assume
>> On 2022 -May-26, at 19:27, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
>>