Subject: Re: [rfc-i] More about RFC10k

From: Jean Mahoney <[email-masked]>
Date: Tue, 3 May 2022 17:28:01 -0500

Hi all,

Annual stats can be found here: https://www.rfc-editor.org/rfcs-per-year/

Note that in 2020 there were 209 RFCs published. Recalculating the 
average going back five years [1] and using the (fairly close) estimate 
that 750 numbers have not yet been assigned, RFC 10K could happen in 
about 3.4 years.

Best regards,

Jean

[1]  Five years is an arbitrary cutoff for the average and gives the 
following: (263+208+180+209+240)/5 = ~220/year.

On 4/28/22 6:50 PM, HANSEN, TONY L wrote:
> Ack. When I wrote the message from 2015 that Carsten replied to, we were averaging >300 RFCs per year. However, the last four years have slowed down drastically:
>
> 278 RFCs in 2000.
> 193 RFCs in 2001.
> 219 RFCs in 2002.
> 234 RFCs in 2003.
> 281 RFCs in 2004.
> 327 RFCs in 2005.
> 459 RFCs in 2006.
> 320 RFCs in 2007.
> 289 RFCs in 2008.
> 285 RFCs in 2009.
> 364 RFCs in 2010.
> 390 RFCs in 2011.
> 337 RFCs in 2012.
> 276 RFCs in 2013.
> 326 RFCs in 2014.
> 300 RFCs in 2015.
> 310 RFCs in 2016.
> 263 RFCs in 2017.
> 209 RFCs in 2018.
> 179 RFCs in 2019.
> 127 RFCs in 2020.
>
> Jari's page doesn't have 2021 in it, but rfc index indicates that there were 240.
>
> Since the highest number is currently 9236, that leaves us ~750 to go. If we continue at the average of the past three years (179+127+240)/3 = ~180/year, that gives us about another four years before we hit 10k, or sometime in or after 2025.
>
> 	Tony
>
> On 4/28/2022, 6:45 PM, "rfc-interest on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:
>
>      On 2022-04-29, at 00:38, Carsten Bormann <[email-masked]> wrote:
>      >
>      > Does anyone have a recent projection for when RFC10K is going to hit?
>
>      (An update of https://arkko.com/tools/rfcstats/pubdistr.html would be a nice shortcut to an estimate.)
>
>      Grüße, Carsten
>
>
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 4 May 2022 00:47:42 +0200

> Annual stats can be found here: https://www.rfc-editor.org/rfcs-per-year/

Hi Jean,

I wonder if there is a similar graph for documents reaching EDIT state.
(Numbers are allocated some time between reaching EDIT state and publication.)

But I think 2025, possibly second half, is now a pretty solid prediction.

Thanks!

Grüße, Carsten

---

From: Jean Mahoney <[email-masked]>
Date: Tue, 3 May 2022 21:07:28 -0500

Hi Carsten,

> (Numbers are allocated some time between reaching EDIT state and publication.)

There's not a similar graph for docs in EDIT. Closest perhaps is this 
graph of the number of pages in EDIT/RFC EDITOR/AUTH48/AUTH48-DONE for 
the last two years:

https://www.rfc-editor.org/wp-content/uploads/2022RPCQbars.png

Notes: Peak number of pages in the queue coincides with C238 moving into 
AUTH48 in Summer 2020 and the minimum number of pages shows when C238 
was published. Previous snapshots of this graph can be found in the 
reports to the IETF <https://www.rfc-editor.org/report-summary/ietf/>.

Best regards,

Jean