Subject: [rfc-i] Inserting SVG graphics into an IETF draft

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Tue, 24 May 2022 16:01:33 +0000

Greetings all

After much material review and head scratching, I have an intentionally open-ended question to ask.

Please find attached a sample Kramdown draft and related SVG graphic.  This SVG displays corrected on all of the 12 or so viewers I have tried.

How do I incorporate this SVG into the RFC draft?

Cheers

_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Jay Daley <[email-masked]>
Date: Tue, 24 May 2022 17:13:47 +0100

Hi Paul

> On 24 May 2022, at 17:01, Paul Duffy (paduffy) <paduffy=[email-masked]> wrote:
> 
> Greetings all
>  

See the documentation at https://authors.ietf.org/en/diagrams

kind regards
Jay

>  
> Cheers
>  
>  
>  
> <AliceAndBob.md>_______________________________________________

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Tue, 24 May 2022 16:21:22 +0000

Thanks Jay, but I've already been there.

The SVG generated by my production tool is not accepted by the IETF validators (despite the fact it is fine with any other SVG viewer I have tried).

-----Original Message-----
From: Jay Daley <[email-masked]> 
Sent: Tuesday, May 24, 2022 12:14 PM
To: Paul Duffy (paduffy) <[email-masked]>
Cc: RFC Interest <[email-masked]>
Subject: Re: [rfc-i] Inserting SVG graphics into an IETF draft

Hi Paul

kind regards
Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 24 May 2022 18:29:10 +0200

We are shackled by RFC7996. 

See https://github.com/cabo/kramdown-rfc/wiki/SVG for tools that are directly supported by kramdown-rfc. If you tell me your tool, I might add support. 

Sent from mobile, sorry for terse

> On 24. May 2022, at 18:21, Paul Duffy (paduffy) <paduffy=[email-masked]> wrote:
>

---

From: "John Levine" <[email-masked]>
Date: 24 May 2022 12:57:54 -0400

It appears that Carsten Bormann  <[email-masked]> said:
>-=-=-=-=-=-
>-=-=-=-=-=-

Right -- in retrospect it was a mistake to try to define the list of permitted elements
rather than listing the criteria for what it can contain, e.g., only black and white,
no animation.

R's,
John

---

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Tue, 24 May 2022 17:01:23 +0000

Thanks Carsten

I believe I have two issues I’m struggling with …

  *   The SVG generated from my tooling does not adhere to 7996.  For whatever reasons, IETF is now out-of-step with the rest of the SVG ecosystem.  But I have a vendor willing to work with us.
  *   If my SVG does adhere to 7996, how specifically is that incorporated into my kramdown draft?  There are hundreds of files in the link you provided.    Is there a specific example available?

Cheers

From: rfc-interest <[email-masked]> On Behalf Of Carsten Bormann
Sent: Tuesday, May 24, 2022 12:29 PM
To: Paul Duffy (paduffy) <paduffy=[email-masked]>
Cc: Jay Daley <[email-masked]>; RFC Interest <[email-masked]>
Subject: Re: [rfc-i] Inserting SVG graphics into an IETF draft

On 24. May 2022, at 18:21, Paul Duffy (paduffy) <paduffy=[email-masked]<mailto:paduffy=[email-masked]>> wrote:

---

From: Alice Russo <[email-masked]>
Date: Tue, 24 May 2022 10:02:35 -0700

Hi Paul,

I ran your file through svgcheck [1] w/ the -r repair option, edited the output in Dia bc it had removed all the text, ran svgcheck -r again to get a file for which it says 'File conforms to SVG requirements.' Here's the file in case it's useful:
https://www.rfc-editor.org/v3test/AliceBobSample_alt.svg

Alice 

[1] https://github.com/ietf-tools/RfcEditor/tree/master/svgcheck

> On May 24, 2022, at 9:21 AM, Paul Duffy (paduffy) <paduffy=[email-masked]> wrote:
>

---

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Tue, 24 May 2022 17:13:24 +0000

Must use svgcheck from the command line, or will SVG 1.2 Tiny Checker and Converter work (https://xml2rfc.tools.ietf.org/experimental)?

-----Original Message-----
From: Alice Russo <[email-masked]> 
Sent: Tuesday, May 24, 2022 1:03 PM
To: Paul Duffy (paduffy) <[email-masked]>
Cc: Jay Daley <[email-masked]>; RFC Interest <[email-masked]>
Subject: Re: [rfc-i] Inserting SVG graphics into an IETF draft

Hi Paul,

Alice

---

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Tue, 24 May 2022 17:42:35 +0000

Here's the result from the web tool ... it does not generate a result that could be edited / viewed ...

Unable to Validate File

Parsing file INPUT
../../../../..INPUT:5: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:8: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:11: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:14: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:17: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:20: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:23: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:26: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:29: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:32: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:35: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:38: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:41: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:44: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:47: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:50: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:53: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:56: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:59: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:62: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:65: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:68: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:71: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:74: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:77: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:80: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:83: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:86: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:89: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:92: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:95: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:98: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:101: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:104: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:107: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:110: The element 'symbol' is not allowed as a child of 'g'
../../../../..INPUT:116: Style property 'fill' promoted to attribute
../../../../..INPUT:116: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:116: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:126: Style property 'fill' promoted to attribute
../../../../..INPUT:126: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:126: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:126: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:126: Style property 'stroke' promoted to attribute
../../../../..INPUT:126: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:126: Style property 'stroke-miterlimit' removed
../../../../..INPUT:126: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:127: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:127: Style property 'fill' promoted to attribute
../../../../..INPUT:127: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:127: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:127: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:127: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:127: Style property 'stroke' promoted to attribute
../../../../..INPUT:127: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:127: Style property 'stroke-miterlimit' removed
../../../../..INPUT:127: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:127: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:128: Style property 'fill' promoted to attribute
../../../../..INPUT:128: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:128: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:135: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:135: Style property 'fill' promoted to attribute
../../../../..INPUT:135: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:135: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:135: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:135: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:135: Style property 'stroke' promoted to attribute
../../../../..INPUT:135: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:135: Style property 'stroke-miterlimit' removed
../../../../..INPUT:135: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:135: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:136: Style property 'fill' promoted to attribute
../../../../..INPUT:136: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:136: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:143: Style property 'fill' promoted to attribute
../../../../..INPUT:143: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:143: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:143: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:143: Style property 'stroke' promoted to attribute
../../../../..INPUT:143: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:143: Style property 'stroke-miterlimit' removed
../../../../..INPUT:143: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:144: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:144: Style property 'fill' promoted to attribute
../../../../..INPUT:144: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:144: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:144: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:144: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:144: Style property 'stroke' promoted to attribute
../../../../..INPUT:144: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:144: Style property 'stroke-miterlimit' removed
../../../../..INPUT:144: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:144: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:145: Style property 'fill' promoted to attribute
../../../../..INPUT:145: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:145: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:150: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:150: Style property 'fill' promoted to attribute
../../../../..INPUT:150: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:150: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:150: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:150: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:150: Style property 'stroke' promoted to attribute
../../../../..INPUT:150: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:150: Style property 'stroke-miterlimit' removed
../../../../..INPUT:150: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:150: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:151: Style property 'fill' promoted to attribute
../../../../..INPUT:151: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:151: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:156: Style property 'stroke' promoted to attribute
../../../../..INPUT:156: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:156: Style property 'fill' promoted to attribute
../../../../..INPUT:156: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:156: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:157: Style property 'fill' promoted to attribute
../../../../..INPUT:157: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:157: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:181: Style property 'fill' promoted to attribute
../../../../..INPUT:181: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:181: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:181: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:181: Style property 'stroke' promoted to attribute
../../../../..INPUT:181: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:181: Style property 'stroke-miterlimit' removed
../../../../..INPUT:181: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:182: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:182: Style property 'fill' promoted to attribute
../../../../..INPUT:182: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:182: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:182: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:182: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:182: Style property 'stroke' promoted to attribute
../../../../..INPUT:182: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:182: Style property 'stroke-miterlimit' removed
../../../../..INPUT:182: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:182: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:183: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:183: Style property 'fill' promoted to attribute
../../../../..INPUT:183: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:183: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:183: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:183: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:183: Style property 'stroke' promoted to attribute
../../../../..INPUT:183: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:183: Style property 'stroke-miterlimit' removed
../../../../..INPUT:183: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:183: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:184: Style property 'fill' promoted to attribute
../../../../..INPUT:184: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:184: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:184: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:184: Style property 'stroke' promoted to attribute
../../../../..INPUT:184: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:184: Style property 'stroke-miterlimit' removed
../../../../..INPUT:184: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:185: Style property 'fill' promoted to attribute
../../../../..INPUT:185: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:185: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:206: Style property 'stroke' promoted to attribute
../../../../..INPUT:206: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:206: Style property 'fill' promoted to attribute
../../../../..INPUT:206: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:206: The attribute 'fill' does not allow the value 'rgb(100%,100%,100%)', replaced with 'black'
../../../../..INPUT:207: Style property 'fill' promoted to attribute
../../../../..INPUT:207: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:207: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:232: Style property 'fill' promoted to attribute
../../../../..INPUT:232: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:232: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:232: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:232: Style property 'stroke' promoted to attribute
../../../../..INPUT:232: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:232: Style property 'stroke-miterlimit' removed
../../../../..INPUT:232: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:233: Style property 'fill-rule' promoted to attribute
../../../../..INPUT:233: Style property 'fill' promoted to attribute
../../../../..INPUT:233: Style property 'fill-opacity' promoted to attribute
../../../../..INPUT:233: Style property 'stroke-width' promoted to attribute
../../../../..INPUT:233: Style property 'stroke-linecap' promoted to attribute
../../../../..INPUT:233: Style property 'stroke-linejoin' promoted to attribute
../../../../..INPUT:233: Style property 'stroke' promoted to attribute
../../../../..INPUT:233: Style property 'stroke-opacity' promoted to attribute
../../../../..INPUT:233: Style property 'stroke-miterlimit' removed
../../../../..INPUT:233: The attribute 'fill' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
../../../../..INPUT:233: The attribute 'stroke' does not allow the value 'rgb(0%,0%,0%)', replaced with 'black'
ERROR: File does not conform to SVG requirements

-----Original Message-----
From: Alice Russo <[email-masked]> 
Sent: Tuesday, May 24, 2022 1:03 PM
To: Paul Duffy (paduffy) <[email-masked]>
Cc: Jay Daley <[email-masked]>; RFC Interest <[email-masked]>
Subject: Re: [rfc-i] Inserting SVG graphics into an IETF draft

Hi Paul,

Alice

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 May 2022 11:11:08 +1200

In my experience, dia is just about the only tool that gets close to meeting RFC7996 requirements. Whatever tool Paul used generates constructs that RFC7996 disallows, and svgcheck therefore removes.

Even Alice's version doesn't scale properly. My personal fixup tool produced the attached from Alice's, which does allow scaling.

Major surgery is needed rather than fixup tools.

Regards
    Brian

On 25-May-22 05:02, Alice Russo wrote:
> .

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 25 May 2022 10:16:11 +1000

I still draw ASCII art.  It seems like you could do the same for this example.

aasvg [1] produces acceptable SVG from ASCII art that is guaranteed to be acceptable to svgcheck and RFC 7996 [2].  Example: https://httpwg.org/http2-spec/draft-ietf-httpbis-http2bis.html#figure-2

[1] https://github.com/martinthomson/aasvg
[2] With default options and one caveat: it puts width and height attributes on the <svg> element, which xml2rfc doesn't like.  But xml2rfc is wrong to complain.

On Wed, May 25, 2022, at 09:11, Brian E Carpenter wrote:
> In my experience, dia is just about the only tool that gets close to 
> meeting RFC7996 requirements. Whatever tool Paul used generates 
> constructs that RFC7996 disallows, and svgcheck therefore removes.
>
> Even Alice's version doesn't scale properly. My personal fixup tool 
> produced the attached from Alice's, which does allow scaling.
>
> Attachments:
> * AB_alt_fixed.svg

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 May 2022 15:44:10 +1200

> [2] With default options and one caveat: it puts width and height attributes on the <svg> element, which xml2rfc doesn't like.  But xml2rfc is wrong to complain.

It's the width and height attributes that break automatic scaling, so I believe the complaint is justified. If a viewbox element is present, the width and height elements can simply be deleted. That's one of the things my fixup tool does.

    Brian

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 25 May 2022 16:29:11 +1000

On Wed, May 25, 2022, at 13:44, Brian E Carpenter wrote:
> It's the width and height attributes that break automatic scaling, so I 
> believe the complaint is justified. If a viewbox element is present, 
> the width and height elements can simply be deleted. That's one of the 
> things my fixup tool does.

This has some pretty dire consequences for how the image is rendered.  If I have a narrow image, it gets scaled up dramatically.  

I considered fixing this by padding out the viewbox to some predetermined size, but the inconsistency in renderings still makes it impossible to produce HTML (and PDF) output with any sort of predictable size.

There are vast differences in line length between renderings (the default styling >> my preferred styling), there is no predictability in how images end up scaled if you allow them to resize to the width of the column.

In other words, I think that automatic scaling is not a desirable feature.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 May 2022 08:32:18 +0200

> In other words, I think that automatic scaling is not a desirable feature.

My experience is similar.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 May 2022 08:33:08 +0200

My experience is similar.
Compounded by some surprising differences in HTML and PDF rendering.

Grüße, Carsten

---

From: Eliot Lear <[email-masked]>
Date: Wed, 25 May 2022 08:38:31 +0200

Given the seeming uniformity of opinion that things are broken, is there 
a similar consensus as to what Good looks like, and has someone written 
that up?

Eliot

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 25 May 2022 17:09:37 +1000

> a similar consensus as to what Good looks like, and has someone written 

I suspect that this is low on a very long list of things awaiting the right moment to strike.

---

From: Brian Carpenter <[email-masked]>
Date: Wed, 25 May 2022 19:48:24 +1200

Well, I disagree. If we want RFCs to be viewable on a large variety of
devices and screen sizes, IMHO figures need to scale.

Do you see problems with the figures in RFC8989?

Regards,
    Brian Carpenter
    (via tiny screen & keyboard)

---

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Wed, 25 May 2022 13:10:27 +0000

Hi Martin

I offered the Alex/Bob example as simply that ... a simple example.  A starting point to focus this discussion.

The actual diagrams I have coming are far more complex.

Cheers

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 26 May 2022 11:03:43 +1200

I think we don't even have a clear understanding of who is in charge.

Off topic, but my draft list of topics for the future RSWG includes:

(8) Format evolution.

The policy question is to decide who is in charge of format
evolution. Who debates and who decides? The technical
details (e.g. XML2RFC fixes, SVG usability) don't belong
in the RSWG, so where do they belong?

Regards
    Brian