Subject: [rfc-i] Handling of large code sections ...

From: "Paul Duffy \(paduffy\)" <paduffy=[email-masked]>
Date: Wed, 25 May 2022 21:14:43 +0000

Folks

Is it acceptable for a draft to externally reference large sections of code (say, parked in Github) versus inlining into the draft?  The latter makes for easy access and input into the code's respective tool chain, versus messy cut/paste of the former.

Cheers
_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Michael StJohns <[email-masked]>
Date: Wed, 25 May 2022 17:20:57 -0400

On 5/25/2022 5:14 PM, Paul Duffy (paduffy) wrote:
>
> Folks
>
> Is it acceptable for a draft to externally reference large sections of 
> code (say, parked in Github) versus inlining into the draft?  The 
> latter makes for easy access and input into the code’s respective tool 
> chain, versus messy cut/paste of the former.
>
> Cheers
>
>

I would venture to guess that none of the current RFC editor tools would 
support such a model.   And I'm not sure that you really want to force 
readers (or editors) off in that direction. A reference to the code is 
fine. A "live" reference, especially one you'd expect the readers to 
click through seems more than a bit problematic.

Later, Mike

---

From: "John Levine" <[email-masked]>
Date: 25 May 2022 21:11:11 -0400

It appears that Paul Duffy (paduffy) <[email-masked]> said:
>-=-=-=-=-=-
>-=-=-=-=-=-
>
>Folks
>
>Is it acceptable for a draft to externally reference large sections of code (say, parked in Github) versus
>inlining into the draft?  The latter makes for easy access and input into the code's respective tool chain,
>versus messy cut/paste of the former.

Maybe.  We do allow <xi:include href=blah> to import external files, but there's no way to refer
to part of an external file.

R's,
John

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 26 May 2022 10:18:54 -0400

> to part of an external file.

IIUC this would be inlined when the document is converted to an RFC. So 
it isn't a permanent solution.

	Thanks,
	Paul

---

From: "John R. Levine" <[email-masked]>
Date: 26 May 2022 10:33:19 -0400

>> Maybe.  We do allow <xi:include href=blah> to import external files, but 
>> there's no way to refer to part of an external file.
>
> IIUC this would be inlined when the document is converted to an RFC. So it 
> isn't a permanent solution.

If you want your RFC to point to an external resource that is not part 
of the document, we call that a reference.

RFCs are archival and there is no way we would publish an RFC whose 
rendering depended on another web page that might or might not still exist 
several years from now.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly