Subject: [rfc-i] Multi-level bulleted list

From: Krzysztof Szarkowicz <[email-masked]>
Date: Fri, 3 Jun 2022 19:08:03 +0200

Hello,

I see some drafts use multi-level bulleted lists. For example https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-bgp-pic-18 <https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-bgp-pic-18>, in Section 5.2:

   o  Let's take a look at the flattened pathlist used by the prefix
      "VPN-IP2", The pathlist associated with the prefix "VPN-IP2" has
      three entries.

       o The first and second entry have index "0". This is because
         both entries correspond to ePE2. Thus when hashing performed
         by the forwarding engine results in using first or the second
         entry in the pathlist, the forwarding engine will pick the
         correct VPN label "VPN-L22", which is the label advertised by
         ePE2 for the prefix "VPN-IP2".

       o The third entry has the index "1". This is because the third
         entry corresponds to ePE3. Thus when the hashing is performed
         by the forwarding engine results in using the third entry in
         the flattened pathlist, the forwarding engine will pick the
         correct VPN label "VPN-L32", which is the label advertised by
         "ePE3" for the prefix "VPN-IP2”.

I couldn’t figure out, how to create such lists with version 3 XML template.

Do you have some example (for version 3 XML template)?

Thank you,
Krzysztof

_______________________________________________
rfc-interest mailing list
[email-masked]
https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Jean Mahoney <[email-masked]>
Date: Fri, 3 Jun 2022 12:37:15 -0500

Krysztof,

To create a nested list like the one below, use the following construction:

<ul>
   <li>
     <t>Let's take a look at...</t>
     <ul>
       <li>The first and second entry...</li>
       <li>The third entry...</li>
     </ul>
   </li>
   <li>Some other stuff I added to this example...</li>
</ul>

which will create the following output:

    *  Let's take a look at...

       -  The first and second entry...

       -  The third entry...

    *  Some other stuff I added to this example...

The key is to use <t/> around the text that is outside the nested list.

More information on nested lists can be found here:

https://authors.ietf.org/en/lists-in-rfcxml

Best regards,

Jean

On 6/3/22 12:08 PM, Krzysztof Szarkowicz wrote:
> Hello,
>
> I see some drafts use multi-level bulleted lists. For example 
> https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-bgp-pic-18, in 
> Section 5.2:
>
>

---

From: Jean Mahoney <[email-masked]>
Date: Fri, 3 Jun 2022 12:38:45 -0500

Apologies, Krzysztof, for misspelling your name!

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Fri, 3 Jun 2022 19:44:43 +0200

Jean,

It works.

Thanks a lot!

Krzysztof

> On 2022 -Jun-03, at 19:38, Jean Mahoney <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> https://authors.ietf.org/en/lists-in-rfcxml <https://authors.ietf.org/en/lists-in-rfcxml>
>> 
>> Best regards,
>> 
>> Jean
>> 
>> 
>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest <https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest>
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest <https://mailman.rfc-editor.org/mailman/listinfo/rfc-interest>