Subject: Re: [Rfc-markdown] Initial mmark spec

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 05 Jan 2015 06:29:05 -0700

Hi Miek,

I have plans use markdown to write I-Ds, but not as standalone documents, so I need to be able to write my own parser.  mmark seems to be a good start, so my question is where could I find the ABNF (or equivalent) for it?

Thanks.

On 12/31/2014 11:16 AM, Miek Gieben wrote:
> Hello,
> 
> Mmark (https://github.com/miekg/mmark) is shaping up as a nice (and fast) markdown parser,
> there is still work to be done, but I wanted to post an initial document detailing the syntax. It borrows syntax from all over the place and I'm the only
> one developing it, so feedback is welcome.
> 
> Below is the XML2 output after processing with XML2RFC of the `mmark2rfc.md`
> document which you can find in the github repository.
> 

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Miek Gieben <[email-masked]>
Date: Mon, 5 Jan 2015 13:50:13 +0000

[ Quoting <[email-masked]> in "Re: [Rfc-markdown] Initial mmark sp..." ]
>Hi Miek,
>
>I have plans use markdown to write I-Ds, but not as standalone documents, so I
>need to be able to write my own parser.  mmark seems to be a good start, so my
>question is where could I find the ABNF (or equivalent) for it?

There is no grammar for markdown...https://news.ycombinator.com/item?id=8267039

The nearest to a grammar that I know of is the PEG grammar
(http://en.wikipedia.org/wiki/Parsing_expression_grammar), which has this old
spec: https://github.com/jgm/peg-markdown

I'm not completely clear on why you need to write your own parser?

/Miek

--
Miek Gieben

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 05 Jan 2015 07:08:54 -0700

> There is no grammar for markdown...https://news.ycombinator.com/item?id=8267039

This is sad.

> I'm not completely clear on why you need to write your own parser?

The processing of the markdown needs to be integrated in my own development tools, that are written in Java.

Thanks.