Subject: [Rfc-markdown] Submissions rejected because of postal glitch

From: Carsten Bormann <[email-masked]>
Date: Tue, 3 Nov 2020 08:57:03 +0100

No, it’s not about USPS being destroyed deliberately, this time:

Error: Unable to validate the XML document: INPUT
INPUT: Line 44: Element postal content does not follow the DTD, expecting (street+ , (city | region | code | country)*), got (city code country )

Locally, xml2rfc has no problem processing this document, but the submission failed anyway.
Apparently, the validator employed in the submission tool insists on there being a street (and that not being empty!?) in a postal element.

Has anybody else ran into this inconsistency?

Grüße, Carsten

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 3 Nov 2020 19:52:50 +1100

Yes. 

Sent from my iPhone

> On 3 Nov 2020, at 6:57 pm, Carsten Bormann <[email-masked]> wrote:
> 
> _______________________________________________
> Rfc-markdown mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rfc-markdown

---

From: Julian Reschke <[email-masked]>
Date: Tue, 3 Nov 2020 13:33:24 +0100

> Has anybody else ran into this inconsistency?

<street> is indeed mandatory in v2; the workaround is to submit an empty
element (see
<https://github.com/reschke/xml2rfc/commit/7e9d2b7fe1333608400e6a2bf7c9a5cf144a7c36>).

In v3 documents, this should not be necessary.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 3 Nov 2020 13:56:50 +0100

> <https://github.com/reschke/xml2rfc/commit/7e9d2b7fe1333608400e6a2bf7c9a5cf144a7c36>).

The problem appears to be that this is not visible in local processing.
Will look at this in more detail later…

Grüße, Carsten