Subject: [Rfc-markdown] Prevent double space after initial?

From: Lars Eggert <[email-masked]>
Date: Mon, 1 Nov 2021 12:21:08 +0200

Hi,

is there a way to prevent a double space being inserted in the ASCII rendering of an name containing an initial, e.g., make

	W. Richard ("Rich") Stevens

render as above instead of

	W.  Richard ("Rich") Stevens
          ^^
Thanks,
Lars

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 1 Nov 2021 11:43:26 +0100

On 2021-11-01, at 11:21, Lars Eggert <[email-masked]> wrote:
> Signed PGP part

(In the TXT, presumably — sentence spacing doesn’t survive HTML.)

If this is text you have input, you can replace the space after the dot with a non-breaking space (*).  
Can’t make an example for the input, because my mail composer swallows non-breaking spaces and replaces them with plain spaces, but the result looks like this:

With SP
With NBSP

No, I don’t know why xml2rfc doesn’t apply the usual rules for keyboarding sentence ends for sentence spacing.
(Probably because enough people hate sentence spacing that any energy for a fix dissipated.)

Grüße, Carsten

(*) Depending on whether you want to keep allowing a line break here (which I would consider wrong, but tastes vary), you alternatively can insert a zero-width space U+200B right after the dot.  That actually survives Apple mail:

W. Richard ("Rich") Stevens
➔
W.​ Richard ("Rich") Stevens

Maybe I should insert these automatically after dots followed by exactly one single space(**)?  The RFC editor will hate me… :-)

(**) These otherwise don’t occur in the “new line for new sentence” keyboarding style.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 1 Nov 2021 11:59:16 +0100

Am 01.11.2021 um 11:43 schrieb Carsten Bormann:
> ...

And, consequently, all that code should be removed.

Putting workarounds into the XML source to address issues in the TXT
output certainly is not a good idea.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 1 Nov 2021 12:24:01 +0100

> output certainly is not a good idea.

Wrong mailing list.

Over in Rfc-interest I would note that we are slowly coming to terms with the fact that RFCXML needs to be able to generate multiple output formats.
(The dominant ideology during development of RFCXMLv3 was that HTML is replacing all other formats, so we don’t have to care.)

This means that we want the semantic information that is needed to generate these formats (or perform other processing, such as validating the code) to be available in the XML form.

Whether sentence detection is such semantic information can be debated.
I certainly learned that this was important when I started to use computers for text processing in the 1970s.
(I since have learned to suppress the reflex to keyboard \& after each non-period dot…)

The root cause for the specific problem that Lars had is of course our addiction to initials, which has other problems as well [1].

Back to the purpose of the mailing list:
Markdown was mostly designed to generate HTML, and since HTML by design can’t do anything useful with sentence detection, markdown has no support for it.
So support for anything that an author wants to do here is going to be an afterthought.

Grüße, Carsten

[1]: https://www.kalzumeus.com/2010/06/17/falsehoods-programmers-believe-about-names/