Subject: [Rfc-markdown] document internal refrences in markdown

From: Loa Andersson <[email-masked]>
Date: Sat, 19 Feb 2022 00:42:44 +0800

Folks,

I'm new to markdown. Find it quite easy to use, but have a question on 
internal references.

Let us assume that I have a section header:

1.1 Requirement Language

I want a reference pointing so I add to the header in the markdown

¤¤ Requirement Language {#REQ-lang}

and everywhere where I put {{REQ-lang}} this will be expanded to 
"Section 1.1"

Let us assume that I'd want it to be expanded to "Section 1.1 
Requirement Language" instead. Is there a way of doing that?

/Loa
-- 
Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 18 Feb 2022 18:30:11 +0100

> On 2022-02-18, at 17:42, Loa Andersson <[email-masked]> wrote:
> 
> Folks,
> 
> I'm new to markdown. Find it quite easy to use, but have a question on internal references.
> 
> and everywhere where I put {{REQ-lang}} this will be expanded to "Section 1.1"
> 
> Let us assume that I'd want it to be expanded to "Section 1.1 Requirement Language" instead. Is there a way of doing that?

Yes, but you need to repeat yourself a bit (*):

{{REQ-LANG}}{{<<REQ-LANG}}

➔ https://github.com/cabo/kramdown-rfc2629/wiki/Syntax#-syntax-links
(at the end)

Grüße, Carsten

(*) I think kramdown-rfc needs a macro processor — we aren’t fully Turing equivalent yet!…

(**) Do these ¤¤ actually work for you?