Subject: Re: [Rfc-markdown] [rfc-i] Markdown template for draft?

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Feb 2022 23:04:24 +0100

On 2022-02-01, at 17:36, Carsten Bormann <[email-masked]> wrote:
> 
> I think we are having a hard time with the word template here.
> 
> (1) Some of us are talking about an example input document (XML, markdown), an “I-D template”.

I put in a couple example documents that work as starting points into:

https://github.com/cabo/kramdown-rfc2629/tree/master/examples

These are based on the XML examples on authors.ietf.org, specifically those linked from https://authors.ietf.org/en/templates-and-schemas

The bare example,

https://raw.githubusercontent.com/cabo/kramdown-rfc2629/master/examples/draft-rfcxml-general-template-bare-00.xml-edited.md

…is sweet, short and not very useful (about the shortest that doesn’t get refused by xml2rfc; it doesn’t even have a docname).

The other one,

https://raw.githubusercontent.com/cabo/kramdown-rfc2629/master/examples/draft-rfcxml-general-template-standard-00.xml-edited.md

…is an example that you should be able to start from — delete what you don’t need, and refer to the example if you do need it later.

(Authors.ietf.org also has a Cadillac XML example; I haven’t got around to converting this to markdown yet and adding a few of the things that can make kramdown-rfc so useful — one of these days...)

You may also like Martin Thomson’s example:

https://raw.githubusercontent.com/martinthomson/i-d-template/main/example/draft-todo-yourname-protocol.md

Further suggestions are welcome!

Grüße, Carsten

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 03 Feb 2022 09:43:47 +1100

I recently decided to play Internet-Draft golf: https://raw.githubusercontent.com/martinthomson/empty-draft/main/draft-mt-empty.md

Not sure if that is as helpful as those other links, but it demonstrates how easy it is to use markdown.

On Thu, Feb 3, 2022, at 09:04, Carsten Bormann wrote:
> These are based on the XML examples on authors.ietf.org, specifically 
> those linked from https://authors.ietf.org/en/templates-and-schemas
>
> The bare example,
>
> …is sweet, short and not very useful (about the shortest that doesn’t 
> get refused by xml2rfc; it doesn’t even have a docname).
>
> The other one,
>
> …is an example that you should be able to start from — delete what you 
> don’t need, and refer to the example if you do need it later.
>
> (Authors.ietf.org also has a Cadillac XML example; I haven’t got around 
> to converting this to markdown yet and adding a few of the things that 
> can make kramdown-rfc so useful — one of these days...)
>
> _______________________________________________
> Rfc-markdown mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rfc-markdown

---

From: Jay Daley <[email-masked]>
Date: Thu, 3 Feb 2022 12:01:29 +1300

Thank you.

> On 3/02/2022, at 11:04 AM, Carsten Bormann <[email-masked]> wrote:
> 
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Thu, 3 Feb 2022 09:35:34 +0200

Hi,

> Not sure if that is as helpful as those other links, but it demonstrates how easy it is to use markdown.

this is nice, thanks.

It might be slightly less minimal and somewhat more useful if you also added the bits that generated the RFC2119 boilerplate and maybe gave an example about how to reference a draft and an RFC.

Lars