Subject: [Rfced-future] On approval bodies and EKR's text: QUESTIONS for you

From: Eliot Lear <[email-masked]>
Date: Fri, 5 Feb 2021 21:14:00 +0100

Hi everyone,

First, the chairs want to again thank Eric for bringing some text to the discussion.  From our perspective, there is a lot on which we may agree, and we would like to test consensus on some of the points, knowing that discussion is ongoing on other aspects.

Do people agree that the stream managers are part of the approval body?
Do people agree that process proposals flow from the WG to the approval body?
Do people agree that the grounds for rejection of a proposal include damage to a stream?
Do people agree that any objections must be returned to the WG for discussion?
Do people agree that if the WG still wants to press forward, two objections would still halt approval?
Do people agree that damage to a stream would include long term strategic damage to the series?

Not on this list is whether the RSx is part of the approval body.  To summarize where we are there, one group of people believe that it is important for the RSx to be a voting member, either because that person would represent those not otherwise represented (and yes, we’ve had some back and forth about that), while another group of people feel strongly that the RSx not be a voting member. The chairs believe this is a good topic for our upcoming meeting.

What is important: proponents of each position (and perhaps there are many different positions) should be prepared to present the principles that they are arguing for.  For each person arguing a particular position, we ask that you also be prepared to identify what accommodations or model changes would accommodate you if you couldn’t get your first choice.  We’ve some of this, and we are hoping to see more, so that people can find common ground.

Brian and Eliot

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 5 Feb 2021 21:40:45 -0000

Hi Brian and Eliot.

Thanks for this.

Yes, but… 😊

Your list is nicely phrased as things I can agree with, but they are not limiting statements. So,

> Do people agree that the stream managers are part of the approval body?

I agree, but I’d be interested to know who else is there, and whether those others can also object.

> Do people agree that process proposals flow from the WG to the approval body?

I agree, and I suspect you mean to say that proposals originating in the approval body (I think they are capable of original thought) must flow into the WG.

> Do people agree that the grounds for rejection of a proposal include damage to a stream?

Certainly that is one of the reasons. I wonder what other grounds are considered.

> Do people agree that any objections must be returned to the WG for discussion?

I think that one is unavoidable in that the WG will discuss what the WG discusses. But maybe, the objection must be clearly set out and the objector must make themselves available to discuss the objection.

> Do people agree that if the WG still wants to press forward, two objections would still halt approval?

I agree that two objections would halt approval. But I also think that one objection would halt approval. It would not be acceptable, in my opinion, for the WG and the approval body to shut down the IAB stream against the opinion of the manager of the IAB stream (nominally the chair of the IAB).

> Do people agree that damage to a stream would include long term strategic damage to the series?

I agree. I think that many other things might be uncovered as damage to a stream. I am not sure that citing an example that is pretty much the most significant damage to a stream is a useful thing to do. It might be better to qualify the grounds for objection as “significant damage to the stream” although that, too, is a subjective thing so would be better accompanied by examples of non-grounds for objection.

This could be compared to the IESG’s Discuss criteria list [1] that is mainly a list of reasons why not to enter a Discuss, and [2] that is a fuller list of why and why not to Discuss, but it must be remembered that those references did not exist ab initio, they were developed over time and with experience of what is and is not reasonable. I caution against trying to define our list of reasons to object and not object with any precision before we have running code.

Cheers,

Adrian

[1] https://www.ietf.org/standards/process/iesg-ballots/

[2] https://www.ietf.org/about/groups/iesg/statements/iesg-discuss-criteria/

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 7 Feb 2021 09:36:34 +1300

On 06-Feb-21 09:14, Eliot Lear wrote:
> Hi everyone,
> 
> First, the chairs want to again thank Eric for bringing some text to the discussion.  From our perspective, there is a lot on which we may agree, and we would like to test consensus on *some* of the points, knowing that discussion is ongoing on other aspects.
> 
>   * Do people agree that the stream managers are part of the approval body?

Yes

>   * Do people agree that process proposals flow from the WG to the approval body?

Yes

>   * Do people agree that the grounds for rejection of a proposal include damage to a stream?

Yes

>   * Do people agree that any objections must be returned to the WG for discussion?

Yes

>   * Do people agree that if the WG still wants to press forward, two objections would still halt approval?

No. I think we should require consensus, rather than defining voting rules. We're talking about a rather small group - consensus is not an unreasonable goal.

Suppose the vote was 4:1 in favour of scrapping the normative/informative distinction. Do we want the IETF Stream to be overruled on this?

>   * Do people agree that damage to a stream would include long term strategic damage to the series?

Why ask that? The bullet above does not state that damage to a stream is the *only* ground for objection. Certainly, damage to the series as a whole must be a ground for objection, but that isn't what you are asking.

   Brian C

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 7 Feb 2021 16:41:04 -0800

On Fri, Feb 5, 2021 at 12:14 PM Eliot Lear <lear=[email-masked]>
wrote:

> Hi everyone,
>
> First, the chairs want to again thank Eric for bringing some text to the
> discussion.  From our perspective, there is a lot on which we may agree,
> and we would like to test consensus on *some* of the points, knowing that
> discussion is ongoing on other aspects.
>
>
>    - Do people agree that the stream managers are part of the approval
>    body?
>
> Yes, probably.

>
>    - Do people agree that process proposals flow from the WG to the
>    approval body?
>
> Yes.

>
>    - Do people agree that the grounds for rejection of a proposal include
>    damage to a stream?
>
> Yes.

>
>    - Do people agree that any objections must be returned to the WG for
>    discussion?
>
> Yes.

>
>    - Do people agree that if the WG still wants to press forward, two
>    objections would still halt approval?
>
> No, I don't think we're there yet, given that we don't understand the
composition of the body.

>    - Do people agree that damage to a stream would include long term
>    strategic damage to the series?
>
> I'm not sure. That seems like a very speculative kind of harm. What I had
in mind here was "this would make it impossible for me to operate my stream
in the short term". I believe we should be deferring as much as possible to
the community process on bigger picture issues.

-Ekr

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 7 Feb 2021 16:50:09 -0800

On Sat, Feb 6, 2021 at 12:36 PM Brian E Carpenter <
[email-masked]> wrote:

> Why ask that? The bullet above does not state that damage to a stream is
> the *only* ground for objection. Certainly, damage to the series as a whole
> must be a ground for objection, but that isn't what you are asking.
>

Well, obviously people don't need to agree but the intent of my proposal
was to sharply limit the grounds on which the approval body could object to
documents.

Taking a step back from the details one could imagine people on these
bodies as having two roles:

- Representing their equities (i.e., what is good for their streams)
- Representing their own views of what's good for the series regardless of
whether it affected their streams.

I believe that we should attempt to limit the role of the approval body as
much as possible to the former category. The reason for this is that the WG
has inherent community legitimacy, whereas the stream managers does not
(primarily because of how they are selected but also because of the
interests they represent). I don't see any particular reason why the
opinion of the stream managers should override the opinion of the WG on
matters that don't directly threaten their streams.

I suspect that this is another example of an issue where we actually have
disagreement about principles, and hence a good topic for the live
discussion.

-Ekr

---

From: Michael StJohns <[email-masked]>
Date: Sun, 7 Feb 2021 19:51:23 -0500

On 2/5/2021 3:14 PM, Eliot Lear wrote:
> Hi everyone,
>
> First, the chairs want to again thank Eric for bringing some text to 
> the discussion.  From our perspective, there is a lot on which we may 
> agree, and we would like to test consensus on *some* of the points, 
> knowing that discussion is ongoing on other aspects.
>
Yes
>   * Do people agree that process proposals flow from the WG to the
Yes, but not exclusively.  The approval body should be able to originate 
documents (some model as IAB and IESG streams).  I also think that there 
may be non-WG submissions  (e.g. similar to AD sponsored) that may be 
appropriate to be approved in the editorial stream.  E.g. informative 
documents that apply to general publication issues.
>     include damage to a stream?
I think we actually just need to leave the approval body to figure out 
what gets rejected.   I think this is one only one of the grounds. 
Others include quality, relevance and community need (not just WG 
consensus).
>   * Do people agree that any objections must be returned to the WG for
I don't know what that actually does.   Rejected documents (not 
originating in the approval body) that don't get approved are in the 
state that all non approved documents end up in and the WG or authors 
can take whatever actions they want including revising and 
resubmitting.  I'd say instead that rejections from the approval body 
need a cover letter of some sort similar to how feedback works in the 
other streams and leave it at that.

>     objections would still halt approval?
The approval body approves.  Failure to approve is not an objection, its 
a rejection - those words mean different things.   I don't have any 
problem with the WG or authors doing the try try again thing - but I'd 
hope the WG chairs would recognize futility when they see it.
Yes.
>
> Not on this list is whether the RSx is part of the approval body.  To 
> summarize where we are there, one group of people believe that it is 
> important for the RSx to be a voting member, either because that 
> person would represent those not otherwise represented (and yes, we’ve 
> had some back and forth about that), while another group of people 
> feel strongly that the RSx not be a voting member. The chairs believe 
> this is a good topic for our upcoming meeting.

The RSE/A is going to get some sort of veto with respect to anything 
within their contractual responsibilities - e.g. if a document purports 
to tell the RSE/A *how* to do something, and that something implicates 
the RSE/A's duties to provide [insert legalese here], the RSE will be 
perfectly within their rights to say "interesting document, but I'm not 
doing that".  That's just a fact.  A "bad" document that gets approved 
over the RSE's objections may  end up with an argument between the RSE 
and the LLC, or with the RSE terminating their contract or other actions.

>
> What is important: proponents of each position (and perhaps there are 
> many different positions) should be prepared to present the principles 
> that they are arguing for.  For each person arguing a particular 
> position, we ask that you also be prepared to identify what 
> accommodations or model changes would accommodate you if you couldn’t 
> get your first choice.  We’ve some of this, and we are hoping to see 
> more, so that people can find common ground.
>

Later, Mike

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 7 Feb 2021 20:00:25 -0500

Hmmm.   This seems to have an assumption that the WG is inherently 
presumed to be correct.

As far as I know, even the IETF technical process does not have that 
assumption.  If IESG members raise legitimate technical technical 
issues, the WG is required to address them.  And ADs are not restricted 
to their own area to raise such issues.

Yours,
Joel

On 2/7/2021 7:50 PM, Eric Rescorla wrote:
> 
> 
> On Sat, Feb 6, 2021 at 12:36 PM Brian E Carpenter 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Why ask that? The bullet above does not state that damage to a
>     stream is the *only* ground for objection. Certainly, damage to the
>     series as a whole must be a ground for objection, but that isn't
>     what you are asking.
> 
> 
> was to sharply limit the grounds on which the approval body could object 
> to documents.
> 
> - Representing their own views of what's good for the series regardless 
> of whether it affected their streams.
> 
> I believe that we should attempt to limit the role of the approval body 
> as much as possible to the former category. The reason for this is that 
> the WG has inherent community legitimacy, whereas the stream managers 
> does not (primarily because of how they are selected but also because of 
> the interests they represent). I don't see any particular reason why the 
> I suspect that this is another example of an issue where we actually 
> have disagreement about principles, and hence a good topic for the live 
> discussion.
> 
> -Ekr
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 7 Feb 2021 17:25:21 -0800

> Hmmm.   This seems to have an assumption that the WG is inherently

As I said earlier, I don't think it's "presumed to be correct", but rather
"is the most legitimate representative of the community". We don't have an
oracle of what's correct or not, so at the end of the day, someone/some
group has to decide. I believe in this case that authority is best vested
in the WG.

> to their own area to raise such issues.

Right. I do not think that structure is serving us particularly well on the
IESG and I think it will serve even less well here, given the proposed
constitution of this body.

-Ekr

---

From: Joel Halpern Direct <[email-masked]>
Date: Sun, 7 Feb 2021 22:36:36 -0500

You refer to "the proposed constitution of the body" in your response 
below.  I presume that refers to the constitution of teh approval body.
I believe I have stated that in my view the concern is the fact that, 
like the IETF, there is no control on (or means to ensure participation 
from needed parties) in the constitution of the working group.  Given 
the flakiness I have seen from working groups that really did (in most 
regards) know what they are doing, I am concerned if we do not create 
some form of insurance / ensurance.

Yes, this is basically teh same reason that I have objected to 
streamlining proposals in the past that would have removed most of the 
IESG's grounds for objecting to IETF documents.  I suspect this is an 
area where we have very basic disagreements.

Yours,
Joel

On 2/7/2021 8:25 PM, Eric Rescorla wrote:
> 
> 
> On Sun, Feb 7, 2021 at 5:00 PM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> As I said earlier, I don't think it's "presumed to be correct", but 
> rather "is the most legitimate representative of the community". We 
> don't have an oracle of what's correct or not, so at the end of the day, 
> someone/some group has to decide. I believe in this case that authority 
> is best vested in the WG.
> 
> 
> Right. I do not think that structure is serving us particularly well on 
> the IESG and I think it will serve even less well here, given the 
> proposed constitution of this body.
> 
> -Ekr
> 
> 
>     Yours,
>     Joel
> 
>      > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >      >   * Do people agree that damage to a stream would include long
>      >     term strategic damage to the series?
>      >

---

From: Eliot Lear <[email-masked]>
Date: Mon, 8 Feb 2021 08:53:33 +0100

Hi Adrian,

Just one clarification.

> On 5 Feb 2021, at 22:40, Adrian Farrel <[email-masked]> wrote:
> 
> Your list is nicely phrased as things I can agree with, but they are not limiting statements.
> 

Nor need they be.  Our goal is simply to understand where there is agreement and where there is more work to be done.

Eliot

---

From: Ted Lemon <[email-masked]>
Date: Mon, 8 Feb 2021 07:58:23 -0500

Historically this has been the IETF as a whole, with the AD calling consensus. Why do you want to change that?

> On Feb 8, 2021, at 02:53, Eliot Lear <lear=[email-masked]> wrote:
> 
> Hi Adrian,
> 
> Just one clarification.
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Feb 2021 17:55:50 +1100

> On 6 Feb 2021, at 7:14 am, Eliot Lear <lear=[email-masked]> wrote:
> 
> Hi everyone,
> 
> 	• Do people agree that the stream managers are part of the approval body?

Yes.

> 	• Do people agree that process proposals flow from the WG to the approval body?

Yes. If the approval body wants to originate a document, I'd expect them to introduce it in the WG early in its lifetime.

> 	• Do people agree that the grounds for rejection of a proposal include damage to a stream?

Yes.

> 	• Do people agree that any objections must be returned to the WG for discussion?

Yes.

> 	• Do people agree that if the WG still wants to press forward, two objections would still halt approval?

Not sure, we need to understand the composition of the approval body.

> 	• Do people agree that damage to a stream would include long term strategic damage to the series?

That seems... fuzzy. Examples?

--
Mark Nottingham   https://www.mnot.net/

---

From: Eliot Lear <[email-masked]>
Date: Tue, 9 Feb 2021 11:41:57 +0100

Hi Mark,

> That seems... fuzzy. Examples?

The example I gave earlier applies: what if the WG decides to approve a format that blind people can’t read?  Another example would be the WG approving a format change that would put archival value at risk (let’s say, HTML over EBCDIC, tarred up and compressed with an algorithm that people might have stopped using long ago, back in 2030).  A third example would be to destabilize the referential nature of the series.

The key point is that any harm would not be immediate, but rather the change would, in the opinion of TBD # streams, risk the long term viability of the series.

Eliot

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 9 Feb 2021 05:40:35 -0800

On Tue, Feb 9, 2021 at 2:42 AM Eliot Lear <lear=[email-masked]>
wrote:

> The example I gave earlier applies: what if the WG decides to approve a
> format that blind people can’t read?

I think this example is quite clarifying, so I'm going to stop here. While
the question of whether a particular format is accessible requires
specialized expertise, the question of how accessible to make things is a
policy question of the kind we ordinarily leave to WGs. Why would (for
instance) the ISE have particular insight into this matter or particular
legitimacy to object?

-Ekr

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Feb 2021 13:53:35 -0000

Well, clearly, the ISE (or any Stream Manager, so we erm, don’t risk getting personal?) might have personal experience and insight. But that is entirely distinct from the legitimacy to object.

But who *does* object, and why?

Consider if the WG is not aware that their proposals will have the negative impact. Should someone on the approval group have the ability to say “Hold on, wait. Take this back and consider what you are doing.” This is, frankly, the equivalent of a Discuss in the IETF Stream. 

Of course, if the WG decides as a matter of policy to make the change in the full knowledge of what they are doing, then that might be fine. I would like to see that sort of thing backed up by text that says “We know the effect of what we are doing, and this is why we’re doing it.” Who goes back to the WG and says “You must/should include this.” That’s somewhere between a Discuss and a Comment on the IETF Stream.

The answer to “who” for both of these paragraphs could be “no need to do this because it will be handled by normal discussion in the WG” but we know from the technical work that this doesn’t always happen. We know that the final review cycle adds value and catches issues, and we have process for handling that.

So (back to the issue at hand) if the Stream Managers cannot raise this type of “Discuss” off their own bat or because of advice received, then someone else needs to be able to do it.

Cheers,

Adrian

From: Rfced-future <[email-masked]> On Behalf Of Eric Rescorla
Sent: 09 February 2021 13:41
To: Eliot Lear <lear=[email-masked]>
Cc: [email-masked]; Mark Nottingham <[email-masked]>; Brian Rosen <[email-masked]>
Subject: Re: [Rfced-future] On approval bodies and EKR's text: QUESTIONS for you

On Tue, Feb 9, 2021 at 2:42 AM Eliot Lear <lear=[email-masked] <mailto:[email-masked]> > wrote:

Hi Mark,

> That seems... fuzzy. Examples?

The example I gave earlier applies: what if the WG decides to approve a format that blind people can’t read?

I think this example is quite clarifying, so I'm going to stop here. While the question of whether a particular format is accessible requires specialized expertise, the question of how accessible to make things is a policy question of the kind we ordinarily leave to WGs. Why would (for instance) the ISE have particular insight into this matter or particular legitimacy to object?

-Ekr

---

From: Sarah Banks <[email-masked]>
Date: Tue, 9 Feb 2021 09:10:58 -0800

Hi,
   Inline.

<snip>
> I think this example is quite clarifying, so I'm going to stop here. While the question of whether a particular format is accessible requires specialized expertise, the question of how accessible t…

Because the ISE might happen to have that experience from other work experiences. However, I would expect the RSE would have the purview here to raise this issue, and/or object accordingly. One of the benefits here would be that while the WG is generally focused on what the WG cares about (and less about the larger issues of the RFC Series, longevity, archival issues, etc), that HAS been in the wheelhouse of the RSE. Further, having a group of folks who can provide reasonable input or feedback on the issues is seems prudent. The ISE in your example might not have direct experience with the issue of "approving a format blind people can't read", but when the RSE raises an objection and outlines the why, I'd expect stream managers to understand the argument for (or against).

Thanks,
Sarah

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Feb 2021 08:34:15 +1300

Yes. But what strikes me in ekr's line of argument, and also in mnot's comment elsewhere:

>> As such, I remain unconvinced that the RFC Series is a special case that needs extraordinary processes or powers for a designated expert.

is very bluntly an implication that "we" (for some value of "we" that seems to mainly comprise protocol engineers) know better than an experienced technical publisher about non-protocol-engineering aspects of technical publishing.

We don't.

   Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 9 Feb 2021 13:51:16 -0700

[ no hats ]

> is very bluntly an implication that "we" (for some value of "we" that seems to mainly comprise protocol engineers) know better than an experienced technical publisher about non-protocol-engineering…

I would like to continue tugging at this thread in the interest of
collective clarity.

What I'm trying to understand is the mental model that people on this
list have of what "technical publishing" means in our context, and what
"aspects of technical publishing" are most relevant to our needs.

As I said here the other day, one perspective is that *mostly* what's
happening in the RFC series is that we protocol engineers are publishing
documentation for other technical folks (programmers, operators,
technically-minded product managers and regulators, etc.).

To my mind, in several respects this feels different from the kind of
technical publishing involved in, say, physics or medicine journals,
scholarly books, aircraft maintenance manuals, and professional
magazines. Indeed, it seems much more similar to the ongoing series of
technical proposals and documents produced in communities centered on,
say, programming languages like Python [1] or Rust [2] - some of which
are even called RFCs (and none of which involve contributions, as far as
I know, from an "experienced technical publisher"). I realize that this
very pragmatic perspective might seem to relegate the RFC series to mere
documentation, but I don't see it as "mere" in any way - look at what
we've built since April 7, 1969.

So consider this to be one end of the spectrum or a very minimal
specification for what we do. If we add more features to the spec, what
further "aspects of technical publishing" need to be added?

Peter

[1] https://www.python.org/dev/peps/

[2] https://github.com/rust-lang/rfcs

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Feb 2021 12:41:44 +1300

Peter,

>  If we add more features to the spec, what

If I knew that, I'd be an expert in technical publishing. That's why (IMHO) we need one, and profited greatly from having one for a number of years.

We've collectively developed quite a strong dose of hubris, IMNSHO, and we don't know what we don't know.

Regards
   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Feb 2021 10:52:06 +1100

> is very bluntly an implication that "we" (for some value of "we" that seems to mainly comprise protocol engineers) know better than an experienced technical publisher about non-protocol-engineering…

And that implies that your perspective is that this person always "know[s] better" than the community, on every issue that they care to have an opinion about. 

It also implies that the community is so obstinate as to ignore that person's well-supported and informed arguments in WG discussion, ignore the objections they make when a decision is made, and that the appeals process is so weak that that person is overruled throughout its application. It also implies that the folks on this thread who seem to want to unconditionally support this person would also be ignored and overruled throughout that process.

Is there any example to date of an RFC Editor needing to exercise these powers against this straw-man pig-headed community?

Even with expert help that has extraordinary powers, there is no guarantee that the right decisions will be made. What are you *really* engineering for here?

Cheers,

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 9 Feb 2021 15:54:44 -0800

On Tue, Feb 9, 2021 at 11:34 AM Brian E Carpenter <
[email-masked]> wrote:

> >> As such, I remain unconvinced that the RFC Series is a special case
> that needs extraordinary processes or powers for a designated expert.
>
> is very bluntly an implication that "we" (for some value of "we" that
> seems to mainly comprise protocol engineers) know better than an
> experienced technical publisher about non-protocol-engineering aspects of
> technical publishing.
>
> We don't.
>

Well, that's not what I'm saying, at least. What I'm saying is that we (in
this case the prospective members of the WG) are the group with the
legitimacy to make decisions. That doesn't mean not consulting experts, but
it means that the final decision making ought to rest with the community.
This doesn't seem to me to be a particularly unusual notion. Here are two
examples:

- The IETF LLC engages a lawyer to advise it on legal matters, but
ultimately makes the decisions with the lawyers advice (I think I have
given this example before).
- It's quite common in political systems to have departments staffed by
career civil servants who have subject matter expertise but to ultimately
accountable (typically headed) to political appointees who may or may not
have subject matter expertise.

My position is that it's the job of the community to take in expert
input/advice, including, but not limited to that of the RSE/A, and balance
it against other factors and ultimately come to a decision.

-Ekr

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 9 Feb 2021 19:04:48 -0500

Mark, your quesiton of whether an RSE has needed to exercise such 
authority seems oddly formed since the very different operating 
structure probably renders the question historically meaningless.

On the other hand, we do have evidence of cases where it took a forceful 
AD to get a working group to do the right things technically.  Given 
that we have seen this in areas where we have real expertise, I find 
myself concluding that such need is more likely in a situation where the 
WG participants have less expertise.

Yours,
Joel

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Feb 2021 11:10:55 +1100

> On 10 Feb 2021, at 11:04 am, Joel M. Halpern <[email-masked]> wrote:
> 
> Mark, your quesiton of whether an RSE has needed to exercise such authority seems oddly formed since the very different operating structure probably renders the question historically meaningless.

I was asking if there's a basis in history for granting an RSA/E special powers. We've had a person with those broad powers for a fair chunk of time (in various specific forms); I think it's relevant to ask if they've been used. 

> On the other hand, we do have evidence of cases where it took a forceful AD to get a working group to do the right things technically.  Given that we have seen this in areas where we have real expertise, I find myself concluding that such need is more likely in a situation where the WG participants have less expertise.

That may be, and I'm not necessarily against this person having *any* special consideration/weight in the process. However, if they have such powers, there should be corresponding constraints on them -- just as there are for an AD. And it needs to be more than 'the LLC decides whether to renew the contract' -- that's too indirect.

Cheers,

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 9 Feb 2021 20:02:20 -0500

I think the analogy with the LLC's lawyer may well be misleading.  If 
the LLC ignores the lawyer's advice when he is right, there are external 
forces which are likely to make the issue rather material.
The forces at work in the RFC process are far more indirect.  Hence the 
pressures on the WG to listen to the RSE are very different from the 
pressures on the LLC to listen to the lawyer.  (The fact that we went 
further and put another lawyer on the LLC board itself can be argued to 
further this point.)

Yours,
Joel

On 2/9/2021 6:54 PM, Eric Rescorla wrote:
> 
> 
> On Tue, Feb 9, 2021 at 11:34 AM Brian E Carpenter 
>      >> As such, I remain unconvinced that the RFC Series is a special
>     case that needs extraordinary processes or powers for a designated
>     expert.
> 
>     is very bluntly an implication that "we" (for some value of "we"
>     that seems to mainly comprise protocol engineers) know better than
>     an experienced technical publisher about non-protocol-engineering
>     aspects of technical publishing.
> 
>     We don't.
> 
> 
> Well, that's not what I'm saying, at least. What I'm saying is that we 
> (in this case the prospective members of the WG) are the group with the 
> legitimacy to make decisions. That doesn't mean not consulting experts, 
> but it means that the final decision making ought to rest with the 
> community. This doesn't seem to me to be a particularly unusual notion. 
> Here are two examples:
> 
> career civil servants who have subject matter expertise but to 
> ultimately accountable (typically headed) to political appointees who 
> may or may not have subject matter expertise.
> 
> input/advice, including, but not limited to that of the RSE/A, and 
> balance it against other factors and ultimately come to a decision.
> 
> -Ekr
> 
> 
> 
>         Brian
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Feb 2021 14:28:31 +1300

On 10-Feb-21 12:54, Eric Rescorla wrote:
> 
> 
> On Tue, Feb 9, 2021 at 11:34 AM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Well, that's not what I'm saying, at least. What I'm saying is that we (in this case the prospective members of the WG) are the group with the legitimacy to make decisions. That doesn't mean not consulting experts, but it means that the final decision making ought to rest with the community. This doesn't seem to me to be a particularly unusual notion. Here are two examples:
> 
> - The IETF LLC engages a lawyer to advise it on legal matters, but ultimately makes the decisions with the lawyers advice (I think I have given this example before).
> - It's quite common in political systems to have departments staffed by career civil servants who have subject matter expertise but to ultimately accountable (typically headed) to political appointees who may or may not have subject matter expertise.
> 
> My position is that it's the job of the community to take in expert input/advice, including, but not limited to that of the RSE/A, and balance it against other factors and ultimately come to a decision.

Yes, I find it hard to disagree with that position. I think what are really talking about is the sanity-check level, where in the IETF we have quite a superstructure today: the formal review teams, the IETF Last Call process, and the IESG review and DISCUSS process, which both you and I have been part of in the past. What we're talking about is the equivalent
superstructure for the RFC series' own documents, and specifically how the "lawyer-equivalent" role fits into that. I'm uncomfortable that the expert's last chance to raise objections is (in effect) at the WG Last Call stage. In the IESG analogy, there is further expert review during the approval process. I care about that, not so much about voting rules.

   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Feb 2021 12:33:52 +1100

> On 10 Feb 2021, at 12:28 pm, Brian E Carpenter <[email-masked]> wrote:
> 
> I'm uncomfortable that the expert's last chance to raise objections is (in effect) at the WG Last Call stage. In the IESG analogy, there is further expert review during the approval process. I care about that, not so much about voting rules.

I'd be very supportive of a notion that the expert's input gets highlighted in all post-WG stages. I'd been assuming that it would be included in their deliberations as a matter of course (as would all objections / feedback), but calling it out seems appropriate, especially since we're paying for that advice.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Feb 2021 15:00:55 +1300

> I was asking if there's a basis in history for granting an RSA/E special powers. We've had a person with those broad powers for a fair chunk of time (in various specific forms); I think it's releva…

Since the clear split between the RSE and ISE functions, things have been a bit different and much clearer, I think. Before that split, the RSE (in the person of Jon Postel or Bob Braden) certainly took publish/don't publish decisions for non-IETF drafts, and published the style guide autonomously (or with a nominal OK from the IAB). Since the split, as far as I know, only the ISE has made publish/don't publish decisions, and the RSE plus the production team have updated the style guide, taken decisions about archival, and so on. I think it's fair to say that the style guide has never been a consensus document. That doesn't mean there was no consultation, but the decisions were autonomous.

Another example: the RFC Series ISSN was obtained in 2008. That was essentially a decision between the then RSE and the IETF Trust (copyright holder for the RFC Series), in consultation with the then Editorial Board. There was advance notification to the IETF list,  and a few days of discussion, but it certainly wasn't a community consensus.
(Thread starting at https://mailarchive.ietf.org/arch/msg/ietf/PF0dHtc5KK_hqyXkrzxM755s9MI/)

In the new regime we're discussing here, I assume the decision would have been taken by the WG and approved (or not) by the approval body. The opinion of a publishing expert would be an important part of the process.

   Brian