Subject: [Rfced-future] Issues with draft-saintandre-rfced-model raised in discussion with the RPC

From: Jay Daley <[email-masked]>
Date: Thu, 6 May 2021 12:39:23 +1200

I discussed draft-saintandre-rfced-model with the RPC and we identified the following issues, which I have added to GitHub:

Issue #56:  The RSWG/RSAB process is clear for larger projects but the RPC also need a path for discussion and agreement on smaller things that do not require a consensus process.  Previously the RPC would discuss and agree these with the RSE, with the RSE taking the decision on what meets the threshold for taking to the community.  How are those agreed now and who decides what does and does not need community consensus/engagement?

Issue #57:  The RPC has a wide set of projects to deliver with limited resources and decisions have to be made on priorities.  Previously this was negotiated between the RSE and RPC with the RSE having an understanding of community priorities.  How are the priorities set now?

Issue #58:  Will the RPC be able to continue to make smaller updates to the online portion of the style guide and various lists as they do now?

Issue #59:  It’s not clear who mediates disputes between the RPC and Authors?

Issue #60:  Disputes between the RPC and authors sometimes need escalating and in the proposed process the stream manager appears to be the escalation point.  However, if the dispute is about something that affects all the streams, such as RFC style/policies, then it appears that this has to be escalated to the RSAB.  Is that correct and will the RSAB be able to respond in a timely manner?

Issue #61:  Traditionally, the RSE has acted as the eyes and ears of the RPC, sharing insight and feedback about what they’re hearing from the community.  There are multiple times when the RSE brought community requirements to the RPC that the RPC were unaware of.  Is the RPC now required to do that directly or is that the responsibility of the RSWG/RSAB or do we assume that any requirements that are not brought to the RSWG are to be left unmet?

Issues #62:  It is not clear who would communicate decisions about RPC projects/priorities to the community.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 6 May 2021 16:18:39 +1200

Thanks for that, a very useful dose of reality IMHO.

Personally I'd write most of these into the role description for the RSAE. Three specific comments in line below:

On 06-May-21 12:39, Jay Daley wrote:
> I discussed draft-saintandre-rfced-model with the RPC and we identified 
the following issues, which I have added to GitHub:
> 
> 
> Issue #56:  The RSWG/RSAB process is clear for larger projects but the RPC also need a path for discussion and agreement on smaller things that do not require a consensus process.  Previously the RPC would discuss and 
agree these with the RSE, with the RSE taking the decision on what meets the threshold for taking to the community.  How are those agreed now and who decides what does and does not need community consensus/engagement?
> Issue #57:  The RPC has a wide set of projects to deliver with limited resources and decisions have to be made on priorities.  Previously this was negotiated between the RSE and RPC with the RSE ha…

I think the decision path has to be the RSWG/RSAB, but this is a typical area where I'd expect the RSAE to make proactive proposals and facilitate 
the discussion. (Reasoning: priorities within limited resources really do 
need to reflect what the community wants.)
 
> Issue #58:  Will the RPC be able to continue to make smaller updates to 
the online portion of the style guide and various lists as they do now?

I certainly hope that the answer is yes.
 
> Issue #60:  Disputes between the RPC and authors sometimes need escalating and in the proposed process the stream manager appears to be the escalation point.  However, if the dispute is about somet…

This is another area where I'd expect the RSAE to be proactive and facilitate discussion.

  Brian C

---

From: Eliot Lear <[email-masked]>
Date: Thu, 6 May 2021 09:53:13 +0200

Jay,

Thank you for these contributions.  May I ask that people discuss them in individual threads so as to make it easier for us to track progress?

Eliot

> On 6 May 2021, at 02:39, Jay Daley <[email-masked]> wrote:
> 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 9 May 2021 12:14:47 -0600

Hi Jay, thanks for identifying these issues with the RPC. Where needed
I'll start new threads (as Eliot already did for 56).

> Issue #59:  It’s not clear who mediates disputes between the RPC and Authors?

It seems to me that this might depend somewhat on the stream. In my
experience, within the IETF stream this mediation role is often played
by a document shepherd, WG chair, or Area Director. As I understand it,
in the Independent stream the ISE could play this role. Etc.

I suppose it might also depend on the nature of the dispute. Perhaps our
RPC friends could describe the common dispute types and how they're
resolved now (and have been resolved in the past) so that we can reason
about this issue with greater clarity.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 9 May 2021 12:29:51 -0600

> Issue #60:  Disputes between the RPC and authors sometimes need escalating and in the proposed process the stream manager appears to be the escalation point.  However, if the dispute is about somet…

Here again it would be good to understand broadly what kinds of disputes
we envision. My sense is that whereas deeper policy issues would likely
need to be taken up in the WG, for smaller issues that need a timely
resolution the RSAB would be the best initial escalation point because
all streams are represented there; however, after the issue is raised
with the RSAB it seems to me that the RSAB could ask one or more of the
RSAB members (which could be the RSA/E) to investigate and suggest a
resolution.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 9 May 2021 12:33:03 -0600

> Issue #58:  Will the RPC be able to continue to make smaller updates to the online portion of the style guide and various lists as they do now?

I see no reason why not!

(Here again, the RPC might want to have some kind of ad-hoc advisory
team, perhaps including the RSA/E, to help guide such decisions.)

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 9 May 2021 13:03:11 -0600

Issues 57, 60, and 61 seem to be closely related...

> Issues #62:  It is not clear who would communicate decisions about RPC projects/priorities to the community.

My understanding from the discussions so far is that we've envisioned
the RFC Series WG as the venue for formulating policies, not for
specifying the goals and scope of particular projects or setting
priorities among such projects. Thus this cluster of issues raises
important questions.

I see a few things here...

First, senior contributors or managers within the RPC might need to
become more involved in community discussions so that they can better
understand community priorities. Naturally, if this is a change from
current practice, the RPC will want to include such activities in its
scope of work with the LLC.

Second, as I mentioned in a recent message the RPC might to work with a
small advisory group (formed from people who are also heavily involved
in community discussions) so that it can confer on proposals for solving
larger open issues (e.g., before sharing such proposals with the broader
community). Such a group could, of course, also include the RSA/E. Or
the RPC could just work directly with the RSA/E in such matters.

Third, since ongoing operation of RFC publication is envisioned to be
handled under arrangements between the LLC and the RPC, I would think
that some matters of projects and priorities would be subject to, say,
statements of work for particular projects that would be proposed by the
RPC and approved by the LLC.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 May 2021 12:34:31 +1200

On 10-May-21 07:03, Peter Saint-Andre wrote:
>> Issue #57:  The RPC has a wide set of projects to deliver with limited 
resources and decisions have to be made on priorities.  Previously this was negotiated between the RSE and RPC with the RSE having an understanding of community priorities.  How are the priorities set now?
> RPC and approved by the LLC.

Alternatively, we could nudge the RSA/E role a bit closer to the old
RSE role, and define that the RPC relies on the RSA/E as the intermediary
for all these points.

     Brian

---

From: Eric Rescorla <[email-masked]>
Date: Sun, 9 May 2021 19:01:56 -0700

On Sun, May 9, 2021 at 11:30 AM Peter Saint-Andre <[email-masked]>
wrote:

> > Issue #60:  Disputes between the RPC and authors sometimes need
> escalating and in the proposed process the stream manager appears to be the
> escalation point.  However, if the dispute is about something that affects
> all the streams, such as RFC style/policies, then it appears that this has
> to be escalated to the RSAB.  Is that correct and will the RSAB be able to
> respond in a timely manner?
>

I'd also like to understand what kind of disputes are envisioned here. Like
what's the last one that couldn't be,handled by the stream manager.