Subject: [Rfced-future] Appeals, etc.

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 May 2021 13:32:57 -0700

Hi folks,

Please feel free to tell me if we closed on this and I missed it, but
I don't think we've quite figured out how to handle complaints about
process failures in either the RSAB or the RSWG. In the IETF, as we
all know, you can appeal to the AD or the IESG, and the IAB if you
don't like the answer for the IESG.

I think I'm persuaded by the argument from Joel and (I think) MT that
the recourse for the RSAB is to complain to the stream management
bodies (i.e., the IESG and IAB) and have the representatives replaced,
rather than have a formal appeal. However, I think we need some
mechanism for dealing with process failures in the RSWG. This is
somewhat complicated by the proposed chair structure where the
two chairs are appointed by different groups. However, if we take
Lars's proposal for the IETF Chair and the IAB, then I think the
IAB should be the appeal body (this is consistent with other suggestions
for them having ultimate responsibity). This also works well b/c
the IETF Chair is on the IAB.

-Ekr

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 May 2021 09:16:58 +1200

> the IETF Chair is on the IAB.

I agree (and I've said this on a couple of threads already). Given
the precedent in the IETF appeals structure, and remembering where
our money comes from, I think we should also ask the ISOC Board to
be the final appeal stop, with the same scope as for the IETF case.
Cut, paste and patch from
https://www.rfc-editor.org/rfc/rfc2026.html#section-6.5.3 

   Brian

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 May 2021 14:30:50 -0700

> https://www.rfc-editor.org/rfc/rfc2026.html#section-6.5.3

I concur.

-Ekr

   Brian
>
> --
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 12 May 2021 09:18:00 +0200

Just so that your humble co-chair understands what is being proposed, I think I am understanding several points:

1.  The recourse to a bad RSAB decision is not a formal appeal but argue to constituent bodies to replace their members.
2.  The co-chairs for the RFCWG should be appointed by the IAB and the IETF Chair (respectively).
3.  Appeals of chair decisions go to the IAB, and then to ISOC per 2026 6.5.3.

If this is the proposal, are there people who disagree with it?

Eliot

> On 11 May 2021, at 23:30, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Tue, May 11, 2021 at 2:17 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> https://www.rfc-editor.org/rfc/rfc2026.html#section-6.5.3 <https://www.rfc-editor.org/rfc/rfc2026.html#section-6.5.3>
> 
> I concur.
> 
> -Ekr
> 
>    Brian
> 
> --
> [email-masked] <mailto:[email-masked]>
> https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
> --

---

From: Martin J. Dürst <[email-masked]>
Date: Wed, 12 May 2021 17:10:30 +0900

Hello Eliot,

> 1.  The recourse to a bad RSAB decision is not a formal appeal but argue to constituent bodies to replace their members.

That was not my understanding, and I hope it wasn't Brian's. The 
recourse to an "average" bad RSAB decision should be an appeal, similar 
to e.g. a bad decision by an IETF WG chair or an AD,...

As a recourse to an extraordinarily bad RSAB decision, and some 
potential other happenings (i.e. not RSAB only), i.e. something that 
exposes deep structural problems, such as the happenings that led to the 
current redesign process, the IAB should take the lead and see what 
needs doing. (of course we hope that our current work will reduce the 
chances of such a need)

To replace the members of the RSAB may not be easy, as many of them 
participate ex officio.

Regards,   Martin.

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 13 May 2021 09:54:06 +1200

>> 1.  The recourse to a bad RSAB decision is not a formal appeal but argue to constituent bodies to replace their members.

s/recourse/first recourse/ surely? The *final* recourse is definitely an appeal.

   Brian

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 13 May 2021 08:28:58 +1000

> to e.g. a bad decision by an IETF WG chair or an AD,...

I think that the word we use here (appeal or not) is not as important as the process.

My understanding was that the proposed response to a (believed) bad RSAB decision was to ask the appointing bod(y/ies) to discipline the individual(s) involved and request that they either change their position or be replaced.  That is not *strictly* an appeal in the sense we understand, but it would have many of the same characteristics.
 
> To replace the members of the RSAB may not be easy, as many of them 

This is true of ISE and (maybe) the IRTF chair, but they each have their own replacement path if it comes to that.  The others would be replaceable should it come to that.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 13 May 2021 12:04:34 +0100

I agree with Martin (put up more flags!).

For those who are NomCom appointed, they are "replaceable" through NomCom, recallable, and appealable for their actions.

For those who are appointed in other ways, requests can be made to discipline/replace them. Since the requests will be to NomCom appointed people, failure to act will be appealable, etc.

A

---

From: Michael StJohns <[email-masked]>
Date: Thu, 13 May 2021 13:43:22 -0400

Tagging here because this is the last in the chain so far:

Let's say the RSWG says YES (for some document), and the RSAB says NO, 
the RSWG (actually it has to be a person, not the RSWG) appeals to the 
IAB and the IAB says YES. Can the RSAB now appeal to the ISOC board? 
They are not just the deciders, but unlike the IESG, they have an actual 
interest in the proceedings.  If they can't appeal, why not?

Let's drop the IAB from the chain.  It makes little sense to have them 
there especially given that directly or indirectly they are responsible 
for 3 of the 4 ex officio members which I would think would lead to all 
manner of conflicts of interest and a need for at least some recusals.

Later, Mike

> For those who are appointed in other ways, requests can be made to discipline/replace them. Since the requests will be to NomCom appointed people, failure to act will be appealable, etc.

I don't believe that failure to remove someone (or for that matter the 
act of appointing someone) comes under the list of appealable actions.  
If it had, I would have probably opened an appeal against the IAB for 
not removing the RSOC a while back. Just saying.   As I said elsewhere, 
you can appeal the process, not the result.  If the process is followed, 
but you don't like the result, then ....    In any event, I think this 
would be a Bad Idea (tm).

Yes, you can recall someone - but if the IAB declines to remove you, the 
IRTF chair for not replacing the IRTF stream manager or its own member, 
do you recall the entire body?

*sigh*

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 13 May 2021 12:43:59 -0700

> IAB and the IAB says YES. Can the RSAB now appeal to the ISOC board?

Well, we should probably first establish how appeals work. For instance, can
the IAB approve a document or can they just send it back to the RSAB for
reconsideration with some instruction about following the process? As an
analogy, the IAB cannot approve documents on appeal.

> manner of conflicts of interest and a need for at least some recusals.

I don't think this is the right answer. The most likely case (as now) is
that
they have 1/4 members on the IAB (the IESG Chair), so this seems manageable,
especially as the alternative is having the ISOC board handle first level
appeals,
which seems not amazing given how far detached they are from the main
work of the RFC Series.

-Ekr

Later, Mike
> > For those who are NomCom appointed, they are "replaceable" through
> NomCom, recallable, and appealable for their actions.
> >
> > For those who are appointed in other ways, requests can be made to
> discipline/replace them. Since the requests will be to NomCom appointed
> people, failure to act will be appealable, etc.
>
> > My understanding was that the proposed response to a (believed) bad RSAB
> decision was to ask the appointing bod(y/ies) to discipline the
> individual(s) involved and request that they either change their position
> or be replaced.  That is not *strictly* an appeal in the sense we
> understand, but it would have many of the same characteristics.
> >
> > This is true of ISE and (maybe) the IRTF chair, but they each have their
> own replacement path if it comes to that.  The others would be replaceable
> should it come to that.
> >
>
> --

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 14 May 2021 08:39:51 +1200

On 14-May-21 07:43, Eric Rescorla wrote:
> 
> 
> On Thu, May 13, 2021 at 10:43 AM Michael StJohns <[email-masked] <mailto:[email-masked]>> wrote:
> 
> I don't think this is the right answer. The most likely case (as now) is that
> especially as the alternative is having the ISOC board handle first level appeals,

I agree with Ekr. The IAB is big enough that a few recusals don't matter. 
Also,
I regard it as highly likely that the ISOC Board will agree to be the court of
final resort but rather unlikely that they would agree to be the primary
court.

   Brian

>     > For those who are appointed in other ways, requests can be made to discipline/replace them. Since the requests will be to NomCom appointed 
>     > From: Rfced-future <[email-masked] <mailto:[email-masked]>> On Behalf Of Martin Thomson
>     > Sent: 12 May 2021 23:29
>     > To: [email-masked] <mailto:[email-masked]>

---

From: John C Klensin <[email-masked]>
Date: Thu, 13 May 2021 17:44:25 -0400

--On Friday, May 14, 2021 08:39 +1200 Brian E Carpenter
<[email-masked]> wrote:

>> I don't think this is the right answer. The most likely case
>> (as now) is that they have 1/4 members on the IAB (the IESG
>> Chair), so this seems manageable, especially as the
>> alternative is having the ISOC board handle first level
>> appeals, which seems not amazing given how far detached they
>> are from the main work of the RFC Series.
> 
> I agree with Ekr. The IAB is big enough that a few recusals
> don't matter.  Also,
> I regard it as highly likely that the ISOC Board will agree to
> be the court of final resort but rather unlikely that they
> would agree to be the primary court.

In addition, the idea of the ISOC Board as the final step in an
appeals process arose at a time when ISOC and the IETF were very
tightly bound today, when ISOC's man goal and function was
providing a legal home for the IETF (and, btw, the IETF was far
less into making rules to try to cover every detail).  As the
two bodies have evolved along different paths over the years,
that has become less true: ISOC has many functions and
activities that do not involve the IETF (or just barely do) and,
with the establishment of the LLC, at least one reason for the
direct connection no longer exists.

The ISOC BoT has been successful as the final appeal point (and
then under only one condition) because we have never, to my
knowledge, actually asked them to exercise that authority.
Given that appeals to them are allowed only when there are
claims the procedures --not an individual decision consistent
with those procedures-- and that, at least as I read RFC 2026
(again, we have no actual experience), they can rewrite the
procedures themselves if they conclude they insufficient to
protect openness and fairness, I think I can safely predict
that, should there be such an appeal tomorrow and was followed
by a finding of unfairness and either a procedural rewrite or a
demand for one, there would be a meltdown on a scale that would
make the one that brought this Program into being loot like a
minor aberration.

Probably it is safe to make them the point of final appeal if we
are relying on the experience of the last quarter century and
assume that they will never be called upon.   But, if we assume
appeals in this case, appeals that might include more
substance-specific issues rather than ones of whether procedures
match broader principles, then we are expanding the risk that
they would be called upon.  Be careful what you wish for.

best,
    john

---

From: Michael StJohns <[email-masked]>
Date: Fri, 14 May 2021 13:47:30 -0400

On 5/13/2021 3:43 PM, Eric Rescorla wrote:
>
>
> On Thu, May 13, 2021 at 10:43 AM Michael StJohns 
> <[email-masked] <mailto:[email-masked]>> wrote:
>

Following that thread, we should stop talking about who and work on what 
might be appealed before getting back to who.  I'm not actually sure 
there is any reason to have an appeal chain for that matter.

> which seems not amazing given how far detached they are from the main

See above, and previous notes in this chain.  Specifically, the 
discussion point that the appointing body bring a "misbehaving RSAB 
member" to heel as a first step before an appeal.  AIRC, appointments 
and replacements are a whole-IAB activity, which I would think might 
then be in conflict with being an impartial decider for whatever appeal 
follows.

So - if the IAB is in the appeal chain, then that's the only lever it 
should have on a particular decision, not both being in the appeals 
chain and able to twiddle with the RSAB members.

Mike

>     > For those who are NomCom appointed, they are "replaceable"
>     through NomCom, recallable, and appealable for their actions.
>     >
>     > For those who are appointed in other ways, requests can be made
>     to discipline/replace them. Since the requests will be to NomCom
>     appointed people, failure to act will be appealable, etc.
>
>     > From: Rfced-future <[email-masked]
>     <mailto:[email-masked]>> On Behalf Of Martin Thomson
>     > Sent: 12 May 2021 23:29
>     > My understanding was that the proposed response to a (believed)
>     bad RSAB decision was to ask the appointing bod(y/ies) to
>     discipline the individual(s) involved and request that they either
>     change their position or be replaced.  That is not *strictly* an
>     appeal in the sense we understand, but it would have many of the
>     same characteristics.
>     >
>     > This is true of ISE and (maybe) the IRTF chair, but they each
>     have their own replacement path if it comes to that.  The others
>     would be replaceable should it come to that.
>     >
>
>     -- 
>     <https://www.iab.org/mailman/listinfo/rfced-future>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 15 May 2021 16:28:52 +1200

On 15-May-21 05:47, Michael StJohns wrote:
> Following that thread, we should stop talking about who and work on what might be appealed before getting back to who.  I'm not actually sure there is any reason to have an appeal chain for that matter.

I'm sure we need checks and balances, and we have running code proof that 
the recall mechanism is very hard to trigger and is definitely not for everyday disputes. So it seems to me a given that we need an appeal mechanism that is much easier to use than a recall, even without knowing what the typical dispute might be about.

IMHO we have text at https://datatracker.ietf.org/doc/html/rfc2026#section-6.5 that our document editor can adapt; it describes what sort of issues might arise at WG level, IESG level (~= RSAB level) and above. I think the analogy is quite strong.

   Brian

> See above, and previous notes in this chain.  Specifically, the discussion point that the appointing body bring a "misbehaving RSAB member" 
to heel as a first step before an appeal.  AIRC, appointments and replacements are a whole-IAB activity, which I would think might then be in 
conflict with being an impartial decider for whatever appeal follows.
> 
> So - if the IAB is in the appeal chain, then that's the only lever it should have on a particular decision, not both being in the appeals chain and able to twiddle with the RSAB members.
> 
> Mike
> 
>>
>> -Ekr
>>
>>     Later, Mike
>>
>>
>>     > My understanding was that the proposed response to a (believed) bad RSAB decision was to ask the appointing bod(y/ies) to discipline the individual(s) involved and request that they either change their position 
or be replaced.  That is not *strictly* an appeal in the sense we understand, but it would have many of the same characteristics.