Subject: [Rfced-future] Suggestions for "RSEA Ongoing Performance Evaluation"

From: Jay Daley <[email-masked]>
Date: Wed, 5 May 2021 09:24:47 +1200

I’ve reviewed 6.2 "RSEA Ongoing Performance Evaluation" of draft-saintandre-rfced-model and I wonder if it is possible for a draft recommendation from the IETF Executive Director to be presented to the RSAB, excluding the RSEA, and an official view of the RSAB to be included in the final recommendation to the LLC Board?

My concern here is that community feedback, while often of high quality, may potentially be biased or incomplete and the RSAB is probably best placed to take a view on that.

Also, I think it would be useful to note why this recommendation has to go to the LLC Board rather than just being handled by the IETF Executive Director, otherwise this document may inadvertently set a precedent for other contracts.

Finally, I assume the feedback, summary of feedback and the recommendation are confidential?  If not then that should be clearly stated.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 5 May 2021 20:56:25 +1200

> My concern here is that community feedback, while often of high quality, may potentially be biased or incomplete and the RSAB is probably best placed to take a view on that.

That's true. There's always a risk of a prominent individual being blamed 
for issues outside their control, or for one noisy complainant being taken more seriously than a majority of satisfied customers. The ED and the RSAB are likely to have a more balanced perception.

> Also, I think it would be useful to note why this recommendation has to 
go to the LLC Board rather than just being handled by the IETF Executive Director, otherwise this document may inadvertently set a precedent for other contracts.
> 
> Finally, I assume the feedback, summary of feedback and the recommendation are confidential?  

I certainly hope so. But it might all be discoverable in case of dispute, 
so needs to conform to appropriate HR practice. 

   Brian

> If not then that should be clearly stated.
> 
> Jay
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 5 May 2021 11:27:51 +0200

Issue 55 for all of this.

> On 4 May 2021, at 23:24, Jay Daley <[email-masked]> wrote:
> 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 9 May 2021 13:09:52 -0600

Hi Jay,

On 5/4/21 3:24 PM, Jay Daley wrote:
> I’ve reviewed 6.2 "RSEA Ongoing Performance Evaluation" of draft-saintandre-rfced-model 

Once again, that was very drafty text. Nothing set in stone there.

> and I wonder if it is possible for a draft recommendation from the IETF Executive Director to be presented to the RSAB, excluding the RSEA, and an official view of the RSAB to be included in the final recommendation to the LLC Board?
> 

That seems reasonable.

> Also, I think it would be useful to note why this recommendation has to go to the LLC Board rather than just being handled by the IETF Executive Director, otherwise this document may inadvertently…

What is the LLC's preference? I agree that we don't want to set the
wrong kind of precedent here. Having the ED handle the recommendation
seems fine to me.

> Finally, I assume the feedback, summary of feedback and the recommendation are confidential?  If not then that should be clearly stated.

Agreed.

Peter

---

From: Jay Daley <[email-masked]>
Date: Mon, 10 May 2021 08:17:30 +1200

> On 10/05/2021, at 7:09 AM, Peter Saint-Andre <[email-masked]> wrote:
> 
> Hi Jay,
> 

Let me know if you want suggested text.

> wrong kind of precedent here. Having the ED handle the recommendation

I will check in with the LLC Board.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]