Subject: [Rfced-future] Issue 56: Process for RPC work not requiring consensus

From: Eliot Lear <[email-masked]>
Date: Thu, 6 May 2021 10:12:51 +0200

Hi there,

> Issue #56:  The RSWG/RSAB process is clear for larger projects but the RPC also need a path for discussion and agreement on smaller things that do not require a consensus process.  Previously the RPC would discuss and agree these with the RSE, with the RSE taking the decision on what meets the threshold for taking to the community.  How are those agreed now and who decides what does and does not need community consensus/engagement?

With regard to this issue, as well as 57, 58, and 59, these seem to articulate a point that was raised in Issue 23 (“What is strategic?”).  What I propose to do is to close 23 in favor of us using your pragmatic issues.

But we should maintain the context of thinking around that issue.  I believe the intent of the WG at this point was for the overarching policy and procedure to be set by the RFGWG, but for the implementation of that policy to rest entirely with the RPC.  While the RPC should be free and even be encouraged to consult the RS[EA], the decision is with the RPC.  It is not a negotiation.  This is my understanding of the group view, based on previous discussions.  While I don’t believe we’ve discussed this explicitly, it seems reasonable for the RPC to periodically report on those activities to the RFCWG.

There will occasionally be ambiguities.  Here, I believe the group’s view is one of “better to ask forgiveness than permission” in those circumstances.  That is- the RPC is empowered to act, but then should report the ambiguity to the RFCWG, as the RFCWG process is expected to be rather laborious.  Again, consultation with the RS[EA] encouraged.

Is my understanding of people’s views here off?  I believe the text in draft-saintandre-rfced-model is consistent with this position, but could do with a tad more elaboration along these lines.

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 6 May 2021 08:36:14 -0400

As I understand our discussion, what you describe below about the RPC 
just taking care of things is what some people had proposed or expected. 
  Others (including myself) were quite concerned about the change in 
role of the RPC, and wondered if that was a good idea, and whether it 
would work for the RPC.  From the questions they are asking, they have 
their doubts.

Yours,
Joel

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 9 May 2021 12:07:32 -0600

> There will occasionally be ambiguities.  Here, I believe the group’s view is one of “better to ask forgiveness than permission” in those circumstances.  That is- the RPC is empowered to act, but th…

In his reply to this message, Joel raises a concern about a change in
the RPC's role. It would be good for Sandy perhaps to provide her
perspective, but my recent experience working through open issues
related to v3 of the XML vocabulary in collaboration with Sandy and
Alice is that they often find it helpful to confer with someone (or a
small team) regarding issues that crop up. These aren't large policy
issues of the kind that we've envisioned working through in the RFCWG,
but they benefit from informed and focused discussion. However, it's not
clear to me whether the RFC Editor Model needs to define a formal
structure for such discussions, since I think they could be defined by
the RPC in an ad-hoc way (e.g., through an informal technical or
editorial advisory team).

> Is my understanding of people’s views here off?  I believe the text in draft-saintandre-rfced-model is consistent with this position, but could do with a tad more elaboration along these lines.

I wouldn't put much stock in the current text. :-) My intent is to
update that document once we've reached something close to consensus via
discussion on this list.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 May 2021 12:28:03 +1200

On 10-May-21 06:07, Peter Saint-Andre wrote:
>> There will occasionally be ambiguities.  Here, I believe the group’s view is one of “better to ask forgiveness than permission” in those circumstances.  That is- the RPC is empowered to act, but 
then should report the ambiguity to the RFCWG, as the RFCWG process is expected to be rather laborious.  Again, consultation with the RS[EA] encouraged.
> editorial advisory team).

I think the RPC is effectively asking "Who do we talk to when we can't
decide on our own?" and to me the obvious answer is "The RSA/E". Do we
need to say more?

    Brian

>> Is my understanding of people’s views here off?  I believe the 
text in draft-saintandre-rfced-model is consistent with this position, but could do with a tad more elaboration along these lines.

---

From: Jay Daley <[email-masked]>
Date: Mon, 10 May 2021 15:01:41 +1200

> decide on our own?" and to me the obvious answer is "The RSA/E". Do we

No that’s answering their question orthogonally.  Under the current model, the RSE has authority to decide what requires community consultation and what doesn’t, which gives us a clean split between decider (RSE) and implementer (RPC). The answer is about who decides that now and if that is to be the RPC then it should be made clear.  If any guidelines are to be provided then the priority should be principles to use when determining where to draw the line rather than who to consult with.

Jay

-- 
Jay Daley
IETF Executive Director

> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 May 2021 17:23:26 +1200

On 10-May-21 15:01, Jay Daley wrote:
>>>>> Issue #56:  The RSWG/RSAB process is clear for larger projects but the RPC also need a path for discussion and agreement on smaller things that do not require a consensus process.  Previously the RPC would discuss 
and agree these with the RSE, with the RSE taking the decision on what meets the threshold for taking to the community.  How are those agreed now and who decides what does and does not need community consensus/engagement?
>>>> But we should maintain the context of thinking around that issue.  I 
believe the intent of the WG at this point was for the overarching policy 
and procedure to be set by the RFGWG, but for the implementation of that policy to rest entirely with the RPC.  While the RPC should be free and even be encouraged to consult the RS[EA], the decision is with the RPC.  It is not a negotiation.  This is my understanding of the group view, based on previous discussions.  While I don’t believe we’ve discussed this explicitly, it seems reasonable for the RPC to periodically 

>> report on those activities to the RFCWG.
>>>>
>> then should report the ambiguity to the RFCWG, as the RFCWG process is 
expected to be rather laborious.  Again, consultation with the RS[EA] encouraged.
> No that’s answering their question orthogonally.  Under the current model, the RSE has authority to decide what requires community consultation and what doesn’t, which gives us a clean split betwee…

I see. Personally I would be happy that the RPC makes such decisions
(after consulting with the RSA/E) as long as there is a way to
challenge it (which might just mean raising an issue in the RSWG).

     Brian