Subject: [Rfced-future] Issue 6: Streams have content control

From: Eliot Lear <[email-masked]>
Date: Tue, 18 May 2021 10:44:31 +0200

Last summer we had agreed that this was to be the case.  However, Martin raised the following point as part of issue housecleaning on this:

> Streams can have editorial policies of their own as long as they aren't in conflict with those of the series.
> 
> That's different than what I understand by content control, which is deciding what is published.  Which I think we all agree remains, provided that the content that a stream decides to publish is not in conflict with editorial policies of the series as a whole.
> 
> I will note that the series itself has very loose editorial policies.  It doesn't even choose between British and American English.  Tightening those would be possible through the process we are designing.  The terminology debate is probably not where I would start, but it is one possible option.  Whatever the change though, the potential for conflict between stream and series policies is a good example of a valid reason that the RSAB might reject what the RSWG produces.

First, do people agree with Martin on this?  It’s a bit more nuanced than what we had previously agreed.

This begs two questions:

What are the definitive editorial policies today?  Are we thinking https://www.rfc-editor.org/styleguide/? <https://www.rfc-editor.org/styleguide/?>
Are we saying that the RPC makes the final call on whether a document is consistent with whatever policies are in place?

Thanks,

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 18 May 2021 09:09:02 -0400

I don't know quite what to make of Martin's argument.  If I understand 
it properly, I disagree with the conclusion that the case described 
would be a good potential reason for the RSAB to reject a document from 
the RSWG.  If the community decides that all documents shall use British 
spelling, then it seems that all documents MUST use British spelling.  I 
do not see how this could be seen as significant harm to the series or 
any given stream.  (Even if I think it would be a bad choice for the 
RSWG to make.)

Yours,
Joel

On 5/18/2021 4:44 AM, Eliot Lear wrote:
> Last summer we had agreed that this was to be the case.  However, Martin 
> raised the following point as part of issue housecleaning on this:
> 
>> Streams can have editorial policies of their own as long as they 
>> aren't in conflict with those of the series.
>>
>> That's different than what I understand by content control, which is 
>> deciding what is published.  Which I think we all agree remains, 
>> provided that the content that a stream decides to publish is not in 
>> conflict with editorial policies of the series as a whole.
>>
>> I will note that the series itself has very loose editorial policies. 
>>  It doesn't even choose between British and American English. 
>>  Tightening those would be possible through the process we are 
>> designing.  The terminology debate is probably not where I would 
>> start, but it is one possible option.  Whatever the change though, the 
>> potential for conflict between stream and series policies is a good 
>> example of a valid reason that the RSAB might reject what the RSWG 
>> produces.
> 
>   * What are the definitive editorial policies today?  Are we thinking
>     https://www.rfc-editor.org/styleguide/?
>     <https://www.rfc-editor.org/styleguide/?>
>   * Are we saying that the RPC makes the final call on whether a
>     document is consistent with whatever policies are in place?
> 
> 
> Thanks,
> 
> Eliot
>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 18 May 2021 15:21:18 +0200

Joel,

Good points made.  Please see below:

> On 18 May 2021, at 15:09, Joel M. Halpern <[email-masked]> wrote:
> 
> I don't know quite what to make of Martin's argument.  If I understand it properly, I disagree with the conclusion that the case described would be a good potential reason for the RSAB to reject a document from the RSWG.  If the community decides that all documents shall use British spelling, then it seems that all documents MUST use British spelling.  I do not see how this could be seen as significant harm to the series or any given stream.  (Even if I think it would be a bad choice for the RSWG to make.)

I think we are changing issues (I love how these things bleed into each other), but let’s run with the idea that indeed members of the RSAB decide that they interpret that their streams are adversely impacted.  Who gets to tell them differently?  Is that appealable or not?

Combing back to this issue, what we have here is a case where at the moment, the RSAB and the RFCWG are not in the work flow at the moment.  It is the RPC and the representative of the stream manager (like an AD in the case of the IETF).  Who gets that final say?  Previously we had said that it was the stream manager.  Do we want to consider a change to that?

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 18 May 2021 09:25:47 -0400

Not sure about all you comments below.
But on "final say" stream mnaagers have final say when there is no 
policy established.  Otherwise, they have as much say as the policy 
allows.  Usually, we write the policies to give the streams some wiggle 
room, on the sensible theory that writing strict rules causes bad 
failure cases.

Under current setups, if policy and stream clash, the RSE talks with the 
stream head.  It is unclear who would have that conversation from the 
RPC side under the new procedure.  Some folks seem to assume it will be 
the individual RPC editor.  Which seems an awkward dynamic.

Yours,
Joel

On 5/18/2021 9:21 AM, Eliot Lear wrote:
>> On 18 May 2021, at 15:09, Joel M. Halpern <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> would be a good potential reason for the RSAB to reject a document 
>> from the RSWG.  If the community decides that all documents shall use 
>> British spelling, then it seems that all documents MUST use British 
>> spelling.  I do not see how this could be seen as significant harm to 
>> the series or any given stream.  (Even if I think it would be a bad 
>> choice for the RSWG to make.)
> 
> 
> I think we are changing issues (I love how these things bleed into each 
> other), but let’s run with the idea that indeed members of the RSAB 
> decide that they interpret that their streams are adversely impacted. 
>   Who gets to tell them differently?  Is that appealable or not?
> 
> Combing back to this issue, what we have here is a case where at the 
> moment, the RSAB and the RFCWG are not in the work flow at the moment. 
>   It is the RPC and the representative of the stream manager (like an AD 
> in the case of the IETF).  Who gets that final say?  Previously we had 
> said that it was the stream manager.  Do we want to consider a change to 
> that?
> 
> Eliot
>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 18 May 2021 20:52:38 +0200

Just a clarification: this was Martin Thomson.

> On 18 May 2021, at 10:44, Eliot Lear <lear=[email-masked]> wrote:
> 
> Signed PGP part

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 May 2021 09:52:34 +1200

On 18-May-21 20:44, Eliot Lear wrote:
>> That's different than what I understand by content control, which is deciding what is published.  Which I think we all agree remains, provided that the content that a stream decides to publish is not in conflict 
with editorial policies of the series as a whole.
>   * What are the definitive editorial policies today?  Are we thinking https://www.rfc-editor.org/styleguide/? <https://www.rfc-editor.org/styleguide/?>

Yes, with the final arbiter being the RFC Series Editor.

>   * Are we saying that the RPC makes the final call on whether a document is consistent with whatever policies are in place?

They know very well today that negotiation with the stream manager is a must, but if we don't have an RFC Series Editor then any answer other than 
"yes" is unreasonable and amounts to micro-management by committee.

Our WG/RSAB mechanism sets policy. The RPC implements policy, and negotiates with stream managers when necessary. Anything else seems unworkable.

   Brian

---

From: Christian Huitema <[email-masked]>
Date: Tue, 18 May 2021 12:42:54 -1000

On 5/18/2021 11:52 AM, Brian E Carpenter wrote:

>> This begs two questions:
>>
>>    * What are the definitive editorial policies today?  Are we thinkinghttps://www.rfc-editor.org/styleguide/?<https://www.rfc-editor.org/styleguide/?>

I agree with Brian. I can't imagine firing the RSWG/RSAB mechanism each 
time there is a minor dispute between author and RPC.

-- Christian Huitema

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 19 May 2021 09:23:34 +1000

On Wed, May 19, 2021, at 08:42, Christian Huitema wrote:
> Our WG/RSAB mechanism sets policy. The RPC implements policy, and 
> negotiates with stream managers when necessary. Anything else seems 
> unworkable. 

This is exactly right.

If you want an analogue for the broader point, think of the way in which government departments execute on legislative direction.  Laws set out the important constraints: goals and what must and must not be done, but they don't -- and can't -- proscribe down to the level of day-to-day operations.  Instead, they give those who execute those instructions the power to get that work done.

I would expect no different here.  There might be some high-level rules like "only the IETF stream publishes on standards track".  On the other hand, the rules regarding commas and hyphens might be deferred to the RPC with something like "the RPC maintains a style guide that is regularly updated that documents what grammatical conventions are followed in documents, ..."

I think that the point about disputes is particularly relevant and probably needs dedicated text.  I agree with both Brian and Christian here: as authors engage with the RPC under the auspices of the stream, the stream managers are the point at which disputes between author and RPC are resolved.  The RSWG and RSAB might be a higher authority, but the way to escalate is to initiate discussion about high-level strategy in the RSWG.  Going to the RSWG should not affect the specific document that might be the source of contention though -- if something changes it will likely take long enough that it only affects future work.

(Joel was right to pick up on the problem in my original example; I struggled to find an example of conflict, but obviously failed.)

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 20 May 2021 15:55:13 -0600

> If you want an analogue for the broader point, think of the way in which government departments execute on legislative direction.  Laws set out the important constraints: goals and what must and mu…

I generally agree. However, many forms of government include not only a
legislative branch (RSWG/RSAB) and an executive branch (RPC (+LLC?)),
but also a judicial branch, for which the equivalent is unclear under v3
of the RFC Editor Model (whereas it was clear in v2).

> I think that the point about disputes is particularly relevant and probably needs dedicated text.  I agree with both Brian and Christian here: as authors engage with the RPC under the auspices of the stream, the stream managers are the point at which disputes between author and RPC are resolved. 

In practice, disputes (in the IETF stream) can be resolved at other
points: by a document shepherd, a WG chair, or an Area Director. But
yes, the stream manager is the ultimate point of resolution.

> The RSWG and RSAB might be a higher authority, but the way to escalate is to initiate discussion about high-level strategy in the RSWG.  

Nit: I prefer to think of RSWG/RSAB as the place to define high-level
policy, not necessarily strategy.

It seems there is something of a hierarchy here:

1. High-level policies for the RFC Series as a whole are defined by the
RSWG/RSAB.

2. Stream-specific policies are defined by the respective stream
managers. (These could be seen as "mid-level" policies, I suppose.)

3. Low-level policies (e.g., the styleguide) are defined by the RPC.

Note that in this context I'm limiting my comments to "content control"
broadly defined. So that roles are clear to RSWG participants, RSAB
members, stream managers, and RPC team members, I think we need to gain
greater clarity about the policy remit of the RSWG, but I'll pursue that
topic in a separate thread.

> Going to the RSWG should not affect the specific document that might be the source of contention though -- if something changes it will likely take long enough that it only affects future work.

Likely so.

I propose the following new text:

###

Resolution of Disagreements between Authors and the RPC

During the process of editorial preparation and publication,
disagreements can arise between the authors of an RFC-to-be and the RPC.
In the main, such disagreements are handled quickly through direct
consultation between the parties; however, on occasion it is necessary
for a document shepherd, working group chair or research group chair, or
IETF Area Director to help reach agreement. In extremis (or where such
mediating individuals are not involved, as with the Independent Stream),
the relevant stream manager should intercede to achieve a resolution.

###

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 May 2021 11:50:25 +1200

On 21-May-21 09:55, Peter Saint-Andre wrote:
...
> the relevant stream manager should intercede to achieve a resolution.

Works for me.

   Brian C

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 21 May 2021 10:12:50 +1000

> > the relevant stream manager should intercede to achieve a resolution.

Same.  Thanks Peter.

---

From: "John Levine" <[email-masked]>
Date: 23 May 2021 18:23:43 -0400

>the individual RPC editor.  Which seems an awkward dynamic.

That wouldn't work.  The editors follow the policy that we have
in the style guide and that the streams set.  If there's a disagreement
about whether something follows the policy or what the policy says,
that goes to RPC management and the RSE (or at this point it would be me.)

This needs to be a fairly narrow path so we can ensure that the resolution
doesn't break things.