Subject: Re: [Rfced-future] Issue 38: Delegates for RSAB members

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 9 Jul 2021 11:41:27 -0600

My apologies for the delayed response. I'm working in batch mode. :-)

Updated proposed text:

The IAB and IESG delegates must be selected by the Nominating
Committee {{RFC3777}} to their respective bodies (i.e., they
must not be liaison or ex-officio members). These delegates shall
serve for one-year renewable terms. If it becomes necessary to
replace such a delegate for any reason, then for the sake of continuity
the IAB or IESG should name a new delegate to complete the term.

Further comments below.

On 6/29/21 7:28 AM, Adrian Farrel wrote:
> I agree with Ekr about replacing for any reason.
> 
>  
> 
> I don’t oppose any of these delegation rules, I just find them odd.
> 
>  
> 
> The delegating body remains completely responsible for the actions of
> the delegate, so:
> 
>   * Why does it matter where the delegate is drawn from?

AIUI the idea is that IAB and IESG delegates need to be selected by the
Nominating Committee so that:

(1) they are not liaison or ex-officio members, which would be strange
(the IAB chair could be the IESG delegate!)

(2) normal recall processes can be applied if necessary

>   * Why set specific term limits in this document (surely that is up to
>     the delegating body)?

In practice I doubt that it makes much difference, but I suppose terms
could be 2 years instead of 1.

>   * Why can the IRTF chair and ISE also delegate?

Perhaps because then the "reporting" lines become unclear.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 10 Jul 2021 16:41:22 +1200

> The IAB and IESG delegates must be selected by the Nominating

s/be/have been/  for clarity.

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 11 Jul 2021 14:30:41 +0100

I *still* don't object to this, but (just so you know) you haven't convinced me this isn't odd.

When, in the course of my life in general, I delegate some task, I delegate to someone I think is capable of carrying the task. Yet I remain completely responsible for their performance. If they screw up in any way, then I am responsible: of course, I might remove them from their delegated role, but more importantly I should be held responsible for their actions and for the act of delegating to them.

I don't see, in view of this, why it is a requirement that the Head of the IETF Stream can only delegate to another AD. 

Cheers,
Adrian

-----Original Message-----
From: Peter Saint-Andre <[email-masked]> 
Sent: 09 July 2021 18:41
To: [email-masked]; 'Eric Rescorla' <[email-masked]>; 'Eliot Lear' <[email-masked]>
Cc: [email-masked]
Subject: Re: [Rfced-future] Issue 38: Delegates for RSAB members

Updated proposed text:

Further comments below.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 12 Jul 2021 18:08:02 -0600

> I *still* don't object to this, but (just so you know) you haven't convinced me this isn't odd.

It's my job here to (try to) capture the sense of the discussions and,
once we have it, rough consensus. AIUI, the argument is that whoever is
on the RSAB needs to be chosen more directly by the community than a
random appointee might be. I am not completely sure that this makes a
great difference in the end because a random appointee can be recalled
just as easily as an AD, or perhaps more so. In this specific case, we
might ask the IESG if they have a preference.

Peter

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 13 Jul 2021 09:58:30 +0100

> once we have it, rough consensus.

Sure, sure. Not directly blaming you for the (non)sense of the discussion 😊

> AIUI, the argument is that whoever is
> random appointee might be.

Well, erm, "random" might be prejudicial in this discussion since, I believe no suggestion of randomness was made. I think the question is whether the stream head is able to make a free choice of delegate or must be confined to a specific pool.

As I read the suggestion:
- The head of the IETF stream may delegate to another AD
- The head of the IAB stream may delegate to another NomCom-appointed IAB member
- The heads of the IRTF and IS streams may not delegate

I don't understand these constraints.

Compare with a recent email calling for an IETF Delegate to the ICANN 2022 Nominating Committee [1]. There is no requirement that that volunteer (appointed by the IAB) should be drawn from the IAB. Yet the IAB is clearly responsible for their actions.

> I am not completely sure that this makes a great difference in the end
> because a random appointee can be recalled just as easily as an AD, or
> perhaps more so. In this specific case, we might ask the IESG if they have
> a preference.

Certainly, asking the IESG (and the IAB) would give us another data point.

But did I miss someone giving the reason behind the suggestion to constrain the delegation pool?

Cheers,
Adrian

[1] https://mailarchive.ietf.org/arch/msg/ietf-announce/o-q6AfhJmXAqulmuR-As4alE_wM/

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 13 Jul 2021 15:40:56 +0200

I think it would be important for the appointee to be a member of the IESG or IAB respectively, mainly so that person knows what’s going on there. Similarly I think it would be hard for the IRTF chair or ISE to delegate to someone how is not involved in the processes there. However, the IRTF chair does involve the IRSG members more than it used to be the case, so leaving a bit of slack in the formulation to give them a choice in future is probably a good thing.

> On 13. Jul 2021, at 02:08, Peter Saint-Andre <[email-masked]> wrote:
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 14 Jul 2021 16:37:40 +1000

> On 29 Jun 2021, at 3:54 pm, Eliot Lear <[email-masked]> wrote:
> 
>> The IAB and IESG delegates shall serve for one year renewable terms.  Should a delegate become unavailable, the appointing body MAY replace that individual to complete the term.

This text bothers me. Why are we defining how these bodies are represented in *this* document -- shouldn't they choose their own procedures for doing so? 

Practically speaking, there are going to be times when it's a pain for a representative to be replaced on a top-down schedule, rather than at the convenience of the appointing body. Also, it raises questions about whether there's proper transfer of institutional knowledge.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Colin Perkins <[email-masked]>
Date: Wed, 14 Jul 2021 19:13:31 +0100

I tend to agree – it doesn’t seem unreasonable for the IRTF chair to have the option of delegating to an IRSG member. 

Colin

> On 13 Jul 2021, at 14:40, Mirja Kuehlewind <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Eliot Lear <[email-masked]>
Date: Wed, 14 Jul 2021 21:21:51 +0200

> I tend to agree – it doesn’t seem unreasonable for the IRTF chair to have the option of delegating to an IRSG member.

What would it mean to hold that person accountable?  Who gets to do that?

Eliot

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 14 Jul 2021 20:27:01 +0100

I'm close to wondering what the point of contributing to this conversation is.

You hold a delegate responsible by calling on the person who delegated to act, and when they fail you remove the person who delegated.

This is what it means to delegate.

A

-----Original Message-----
From: Eliot Lear <[email-masked]> 
Sent: 14 July 2021 20:22
To: Colin Perkins <[email-masked]>; Mirja Kuehlewind <[email-masked]>
Cc: [email-masked]; Adrian Farrel <[email-masked]>; Eric Rescorla <[email-masked]>; Peter Saint-Andre <[email-masked]>
Subject: Re: [Rfced-future] Issue 38: Delegates for RSAB members

Eliot

---

From: Colin Perkins <[email-masked]>
Date: Wed, 14 Jul 2021 20:34:37 +0100

Exactly.
Colin

> On 14 Jul 2021, at 20:27, Adrian Farrel <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 14 Jul 2021 13:03:22 -0700

This matches my expectation as well.

-Ekr

On Wed, Jul 14, 2021 at 12:34 PM Colin Perkins <[email-masked]> wrote:

> > You hold a delegate responsible by calling on the person who delegated
> to act, and when they fail you remove the person who delegated.
> >
> > Cc: [email-masked]; Adrian Farrel <[email-masked]>; Eric
> Rescorla <[email-masked]>; Peter Saint-Andre <[email-masked]>
> >> I tend to agree – it doesn’t seem unreasonable for the IRTF chair to
> have the option of delegating to an IRSG member.
> >

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Jul 2021 08:59:26 +1200

Also we have various precedents for (e.g.) the IAB appointing someone to an external committee (e.g. the gazillion committees that ICANN seems to have), by a process of the IAB's own choosing. So why don't we just say that (apart from fixed maximum terms) it's for the appointing body to determine its own appointment process, including delegation?

Regards
   Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Jul 2021 14:21:01 -0600

> Also we have various precedents for (e.g.) the IAB appointing someone to an external committee (e.g. the gazillion committees that ICANN seems to have), by a process of the IAB's own choosing. So w…

Without my editor hat on, that seems reasonable. If someone has a
concern with process followed by the appointing body, they can take it
up there.

Peter

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 28 Jul 2021 21:32:22 +0100

Hi,

I'm pleased to see the direction this thread is possibly headed. It is
consistent with my understanding of what delegation should mean.

A

-----Original Message-----
From: Rfced-future <[email-masked]> On Behalf Of Peter
Saint-Andre
Sent: 28 July 2021 21:21
To: Brian E Carpenter <[email-masked]>; [email-masked]
Subject: Re: [Rfced-future] Issue 38: Delegates for RSAB members

On 7/14/21 2:59 PM, Brian E Carpenter wrote:
> Also we have various precedents for (e.g.) the IAB appointing someone to
an external committee (e.g. the gazillion committees that ICANN seems to
have), by a process of the IAB's own choosing. So why don't we just say that
(apart from fixed maximum terms) it's for the appointing body to determine
its own appointment process, including delegation?

Peter