Subject: [Rfced-future] Issue #73 Who is responsible for creating new streams?

From: Eliot Lear <[email-masked]>
Date: Mon, 12 Jul 2021 11:46:58 +0200

Hi there,

I opened this issue, and while it is related to who sits on the RSAB, 
it's a little different.  The question is really this: what is the 
process to create / delete editorial streams?  Does it go through the 
IETF process?  Does it go to the IAB?  Does it go through th RSWG/RSAB 
process?

Peter asks this question: is it beyond the remit of *this* group to 
decide that?  My gut says that this is not this group's decision but 
perhaps an IAB decision or IETF decision or something in between.  To 
say otherwise would seem the tail wagging the dog.  Unless people 
disagree with this logic, I'll close the issue.  Please comment by the 26th.

This having been said, I do think this may be an issue for Brian's 2850 
update doc, since the IAB has previously held authority to manage that 
process.

Eliot

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 12 Jul 2021 18:59:42 +0100

Hi,

I’m struggling with this one a bit.

Sadly, I think this is not the small question that it might appear from your email. To me it is essential to the definition of the “RFC Series” to define what streams exist.

I think there are two classes of stream:

a.	Those that the IETF would like to exist
b.	Those that exist outwith the IETF

In class a) we have all of the current streams (IETF, IAB, IRTF, IS) and they are defined and controlled by existing RFCs. To remove one, to merge two, or to create another would be acts of IETF consensus (in one way or another). 

In class b) we could envision another SDO or forum that works on Internet specifications coming to the RSE and asking to be published as RFCs. I can see the IETF having a strong opinion on this, and I can see “the decision-maker” taking those opinions very seriously, but I can’t see why that would be the IETF’s decision or the IAB’s decision. The crunch here is “What is the RFC Series?” and I think we have been dodging this question despite it being fundamental to how we got here, today.

Now I realise that Peter’s question is a meta-question. Not “what should be the process?” but “who gets to decide what the process is?” Nevertheless, the question is so fundamental to what the RFC Series is and what the responsibilities of the various actors are, that I think we have to look at it to uncover the implications. Otherwise we are simply making a decision by hiding from the question.

Cheers,

Adrian

From: Rfced-future <[email-masked]> On Behalf Of Eliot Lear
Sent: 12 July 2021 10:47
To: [email-masked]
Subject: [Rfced-future] Issue #73 Who is responsible for creating new streams?

Hi there,

I opened this issue, and while it is related to who sits on the RSAB, it's a little different.  The question is really this: what is the process to create / delete editorial streams?  Does it go through the IETF process?  Does it go to the IAB?  Does it go through th RSWG/RSAB process?

Peter asks this question: is it beyond the remit of this group to decide that?  My gut says that this is not this group's decision but perhaps an IAB decision or IETF decision or something in between.  To say otherwise would seem the tail wagging the dog.  Unless people disagree with this logic, I'll close the issue.  Please comment by the 26th.

This having been said, I do think this may be an issue for Brian's 2850 update doc, since the IAB has previously held authority to manage that process.

Eliot

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 12 Jul 2021 18:04:33 +0000

RFC’s should not exist outside of the IETF or its designees.

---

From: Eliot Lear <[email-masked]>
Date: Mon, 12 Jul 2021 20:11:54 +0200

Hi Rich,

> RFC’s should not exist outside of the IETF or its designees.
This is a bit too terse.  After all, the IAB, IRTF, and ISE streams all 
exist outside of the IETF today. But maybe you mean that the IETF should 
have a say about new streams.

One could invert this question:

Who has the authority to close down a stream?  If today it is the IAB, 
then who is it tomorrow?  One  answer is: the IAB.  Another answer might 
be the IETF.

Adrian wrote:

> The crunch here is “What is the RFC Series?” and I think we have been 
> dodging this question despite it being fundamental to how we got here, 
> today.

Beyond its editorial process and output definition, do we even get to 
say more?

Eliot

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 12 Jul 2021 18:16:45 +0000

> This is a bit too terse.  After all, the IAB, IRTF, and ISE streams all exist outside of the IETF today.

I said “or its designees” which I intended to cover your example. It could be interesting for an historian to find out what orgs existed at the time those streams were created but more than I want to do. ;)

Perhaps we say “not covered as an IETF activities as defined by the LLC” After all, I would expect the LLC trademark protection would prevent that from happening.

If some random SDO wants to publish an RFC, go ahead.  Just not here.

---

From: Michael StJohns <[email-masked]>
Date: Mon, 12 Jul 2021 14:26:02 -0400

Hi Eliot -

On 7/12/2021 2:11 PM, Eliot Lear wrote:
> This is a bit too terse.  After all, the IAB, IRTF, and ISE streams 
> all exist outside of the IETF today. But maybe you mean that the IETF 
> should have a say about new streams.
>
> then who is it tomorrow?  One  answer is: the IAB. Another answer 
> might be the IETF.
>
The third leg of this is - who pays for new streams?   There is a cost 
per RFC that is borne by the LLC (and additional indirect support from 
the ISOC).  If some SDO came to us, said they'd contribute, had a set of 
documents that were not anathema to the Internet, and was willing to 
follow the RFC series editorial guidelines, I'd probably have a quick 
chat with the ISOC and IAB (as our outwardly facing organization), and 
the LLC with respect to any financial considerations and then put it to 
the RSAB's vote to add the stream if recommended by those three groups.

For deleting a stream, the stream owner (if they've gotten out of the 
publication business or no longer want to bear the costs), the RSAB if 
the stream has become moribund (abandoned), the LLC if they're behind in 
their contributions, and the RSAB, ISOC and IAB collectively if the 
relationship with the stream owner has diverged from our interests.

>> dodging this question despite it being fundamental to how we got 
>> here, today.
>
If I tell you I'm giving you an elephant, and you've never seen such a 
thing, and you have to provide for its care and feeding, wouldn't I be 
remiss if I didn't provide you with said requirements?   That's not a 
great analogy, because and elephant is a physical object with well known 
properties, whereas the RFC series is an implemented idea or ideal.  But 
this is all about the care and feeding of the series so...

I think we're doing too much of "I'll know it when I see it" here and my 
view of what the RFC series is and others views of what the RFC series 
is diverge widely.   At some point what the RFC series is and where it's 
headed needs to be considered and the document that Peter is authoring 
is much weaker for not having that front and center.

Later, mike

---

From: Michael StJohns <[email-masked]>
Date: Mon, 12 Jul 2021 14:27:10 -0400

On 7/12/2021 2:16 PM, Salz, Rich wrote:
> all exist outside of the IETF today.
>
> I said “or its designees” which I intended to cover your example. It 
> could be interesting for an historian to find out what orgs existed at 
> the time those streams were created but more than I want to do. ;)
>
Streams are a recent invention.  The answer is pretty much all of them 
existed at the times streams were created.

> Perhaps we say “not covered as an IETF activities as defined by the 
> LLC” After all, I would expect the LLC trademark protection would 
> prevent that from happening.
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 12 Jul 2021 18:03:30 -0600

> headed needs to be considered and the document that Peter is authoring

Correction: I'm just editing.

> is much weaker for not having that front and center.

We could pull in some text from RFC 4844.

Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 12 Jul 2021 18:16:29 -0600

On 7/12/21 11:59 AM, Adrian Farrel wrote:
> Sadly, I think this is not the small question that it might appear from
> your email. To me it is essential to the definition of the “RFC Series”
> to define what streams exist.
> 
>  
> 
>  1. Those that the IETF would like to exist
>  2. Those that exist outwith the IETF
> 
>  
> 
> In class a) we have all of the current streams (IETF, IAB, IRTF, IS) and
> they are defined and controlled by existing RFCs. To remove one, to
> merge two, or to create another would be acts of IETF consensus (in one
> way or another).
> 
>  
> 
> In class b) we could envision another SDO or forum that works on
> Internet specifications coming to the RSE and asking to be published as
> RFCs. I can see the IETF having a strong opinion on this, and I can see
> “the decision-maker” taking those opinions very seriously, but I can’t
> see why that would be the IETF’s decision or the IAB’s decision. The
> crunch here is “What is the RFC Series?” and I think we have been

I don't disagree.

> Now I realise that Peter’s question is a meta-question. 

Actually I was just replying in thread. :-)

> Not “what should
> be the process?” but “who gets to decide what the process is?”
> Nevertheless, the question is so fundamental to what the RFC Series is
> and what the responsibilities of the various actors are, that I think we
> have to look at it to uncover the implications. Otherwise we are simply
> making a decision by hiding from the question.

After I posted in this issue / thread, while working on our I-D I
realized that this document needs to specify what the process is. How we
bootstrap the authority to specify that is another question...

Peter

---

From: Nevil Brownlee <[email-masked]>
Date: Tue, 13 Jul 2021 12:22:03 +1200

Hi Adrian et al:
A little bit of history of "new streams."  Back about 2012 Heather was
approached by another organisation asking "could you publish our
documents (as RFCs)"?
That caused a fairly long discussion by the IAB and IESG of the day;
the outcome was "no, you're likely to have very few documents, submit
those to the Independent Stream (via the RSE)".
That still seems sensible to me, this group could just ignore it, or
maybe say something like "if a new stream is created (by the IAB), the
stream manager for that new stream should - in principle - become a
member of the RSAB".
Cheers, Nevil

On Tue, Jul 13, 2021 at 6:00 AM Adrian Farrel <[email-masked]> wrote:
> Those that the IETF would like to exist
> Those that exist outwith the IETF
>
>
>
> --
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

-- 
-----------------------------------
Nevil Brownlee, Taupo, NZ

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Jul 2021 15:06:28 +1200

> RFC’s should not exist outside of the IETF or its designees.

So all RFCs before 1986 don't exist?

The IETF is not, and never has been, in charge of the IRTF, nor
in charge of independent submissions (even before the streams
were formally designated). The IAB created the streams, not
the IETF.

In short, the IETF does not, and never did, own the RFC series.

We have backed off from discussing whether an independent
RFC Series Foundation is needed, but if you'd like to spend
six months debating that question, let's do it. Personally
I think we're better off with the chain of responsibility
being RSWG->RSAB->IAB->ISOC (with an IPR side branch to
the IETF Trust and a financial side branch to IETF LLC).
But the IETF *is not* in the chain of responsibility and
never has been.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Jul 2021 15:25:32 +1200

Adrian,

> I’m struggling with this one a bit.

I suspect we are making it more complicated than it needs to be.
I fully agree with Peter that more (much more) material from RFC 4844
needs to be brought in. If we accept the mission statement from there:

   The RFC Series is the archival series dedicated to documenting
   Internet technical specifications, including general contributions
   from the Internet research and engineering community as well as
   standards documents.

that already sets a (fairly wide) boundary on what new streams might
exist. But I don't agonise about who has authority once we set up
the RSWG and RSAB: they do. We can charge them with ensuring that any
proposed new stream meets the above mission statement *and* is adequately
funded. So let's try a thought experiment. The people from the Martian
Internet (that's the Internet on planet Mars) start writing their own
standards and want to publish them as RFCs. However, after a while,
the Independent Stream no longer suits them and they propose to add a
Martian stream. The RSWG discusses this, does a polite cross-check
with the IESG, and decides there's no conflict.

Then the RSWG asks the RPC how much this would cost, and the answer
is far too much for IETF LLC to absorb. So they tell the Martians
they need to find 30 Bitcoins a year, and they never hear from Mars
again.
 
> Sadly, I think this is not the small question that it might appear from 
your email. To me it is essential to the definition of the “RFC Series” to define what streams exist.

Yes. But why wouldn't that be the ongoing responsibility of RSWG+RSAB?
If not, what are we doing here?

    Brian

P.S. This will not be a re-run of the ICANN/TLD horror show, for reasons
that seem obvious. Having your own vanity RFC stream will never be a thing.

> In class b) we could envision another SDO or forum that works on Internet specifications coming to the RSE and asking to be published as RFCs. I 
can see the IETF having a strong opinion on this, and I can see “the decision-maker” taking those opinions very seriously, but I can’t see why that would be the IETF’s decision or the IAB’s decision. The crunch here is “What is the RFC Series?” and I think we have been dodging this question despite it being fundamental to how we got here, today.
> *From:*Rfced-future <[email-masked]> *On Behalf Of *Eliot 
Lear
> *Sent:* 12 July 2021 10:47
> *To:* [email-masked]
> *Subject:* [Rfced-future] Issue #73 Who is responsible for creating new 
streams?
> Peter asks this question: is it beyond the remit of *this* group to decide that?  My gut says that this is not this group's decision but perhaps an IAB decision or IETF decision or something in between.  To say otherwise would seem the tail wagging the dog.  Unless people disagree with this logic, I'll close the issue.  Please comment by the 
26th.
> This having been said, I do think this may be an issue for Brian's 2850 
update doc, since the IAB has previously held authority to manage that process.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 14 Jul 2021 16:34:57 +1000

I'm leaning towards saying that we should explicitly NOT give the ability to create streams to any single body, or define a process. If a situation comes up where we want to do this (for some value of 'we'), the expectation should be that there's buy-in from all concerned -- RSAB/WG, IETF, LLC, ISOC, etc. We can figure out a process then.

> On 12 Jul 2021, at 7:46 pm, Eliot Lear <[email-masked]> wrote:
> 
> Hi there,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Lars Eggert <[email-masked]>
Date: Wed, 14 Jul 2021 10:22:46 +0300

> I'm leaning towards saying that we should explicitly NOT give the ability to create streams to any single body, or define a process. If a situation comes up where we want to do this (for some value…

+1

Creating a new stream is such a rare and often special event that I can't see us defining rules on this in the abstract.

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Wed, 14 Jul 2021 10:11:28 +0200

If I understand you both correctly, you are saying that we should defer 
this question until the next rare event.  With the understanding that 
there is very strong (albeit not perfect) consensus for a new stream for 
the RSWG/RSAB products, and that the existing process will prevail 
(e.g., IAB approval) for this new stream, then we can defer the rest for 
later, if that is what people want.

Eliot

---

From: Brian Carpenter <[email-masked]>
Date: Wed, 14 Jul 2021 21:55:09 +1200

We certainly shouldn't define a process, since every case would be
different anyway, and the question may never seriously arise. But I feel
the question of who has authority needs to be defined - or perhaps
explicitly stated to be undefined.

Regards,
    Brian Carpenter
    (via tiny screen & keyboard)

On Wed, 14 Jul 2021, 19:23 Lars Eggert, <[email-masked]> wrote:

> > I'm leaning towards saying that we should explicitly NOT give the
> ability to create streams to any single body, or define a process. If a
> situation comes up where we want to do this (for some value of 'we'), the
> expectation should be that there's buy-in from all concerned -- RSAB/WG,
> IETF, LLC, ISOC, etc. We can figure out a process then.
>
> +1
>
> Creating a new stream is such a rare and often special event that I can't
> see us defining rules on this in the abstract.
>
> Thanks,
> Lars
>
> --

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 14 Jul 2021 12:41:50 +0100

On 14/07/2021 07:34, Mark Nottingham wrote:
> ability to create streams to any single body, or define a process. If
> a situation comes up where we want to do this (for some value of
> 'we'), the expectation should be that there's buy-in from all
> concerned -- RSAB/WG, IETF, LLC, ISOC, etc. We can figure out a
> process then.

+1, though I'd maybe omit ISOC and add in the RSE, IRTF
and whomever is the proponent for a putative new stream.
Even better to not list those who need be involved though.

S.

>> I opened this issue, and while it is related to who sits on the
>> RSAB, it's a little different.  The question is really this: what
>> is the process to create / delete editorial streams?  Does it go
>> through the IETF process?  Does it go to the IAB?  Does it go
>> through th RSWG/RSAB process?
>> 
>> Peter asks this question: is it beyond the remit of this group to
>> decide that?  My gut says that this is not this group's decision
>> but perhaps an IAB decision or IETF decision or something in
>> between.  To say otherwise would seem the tail wagging the dog.
>> Unless people disagree with this logic, I'll close the issue.
>> Please comment by the 26th.
>> 
>> This having been said, I do think this may be an issue for Brian's
>> 2850 update doc, since the IAB has previously held authority to
>> manage that process.
>> 
>> Eliot
>> 
>> -- Rfced-future mailing list [email-masked] 
> -- Mark Nottingham   https://www.mnot.net/
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 14 Jul 2021 13:39:52 +0000

*   With the understanding that there is very strong (albeit not perfect) consensus for a new stream for the RSWG/RSAB products, and that the existing process will prevail (e.g., IAB approval) for this new stream, then we can defer the rest for later, if that is what people want.

Yes.

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 15 Jul 2021 10:15:18 +1000

On Wed, Jul 14, 2021, at 16:34, Mark Nottingham wrote:
> situation comes up where we want to do this (for some value of 'we'), 
> the expectation should be that there's buy-in from all concerned -- 
> RSAB/WG, IETF, LLC, ISOC, etc. We can figure out a process then.

Adding to the growing chorus of +1 here for saying nothing.  I don't even want to commit to a de facto status of the IAB deciding.  A change to the stream structure is a big enough deal that I'm happy to have that be a high energy event that -- if managed properly -- will garner support from all stakeholders.

It's been good to have the discussion, but it has confirmed for me that dictating a process could only make things worse and would be unlikely to improve the situation.

---

From: Russ Housley <[email-masked]>
Date: Thu, 15 Jul 2021 10:10:46 -0400

> On Jul 14, 2021, at 8:15 PM, Martin Thomson <[email-masked]> wrote:
> 

Maybe we want to require consensus among the existing stream managers to create a new stream.  That is the actual stream managers without delegation.

Russ

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 15 Jul 2021 11:20:22 -0700

On Thu, Jul 15, 2021 at 7:11 AM Russ Housley <[email-masked]> wrote:

> > Adding to the growing chorus of +1 here for saying nothing.  I don't
> even want to commit to a de facto status of the IAB deciding.  A change to
> the stream structure is a big enough deal that I'm happy to have that be a
> high energy event that -- if managed properly -- will garner support from
> all stakeholders.
> >
> > It's been good to have the discussion, but it has confirmed for me that
> dictating a process could only make things worse and would be unlikely to
> improve the situation.
>
> Maybe we want to require consensus among the existing stream managers to
> create a new stream.  That is the actual stream managers without delegation.
>

Can you say more about the reason for that?

Suppose, for instance, I found a new SDO, the EKR Engineering Task Force
(EETF) and I wish to publish my documents in the RFC series. What interest
does the IRTF (for example) have in whether I do so or not, as long as it
doesn't impact their operations?

-Ekr

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 15 Jul 2021 20:11:54 +0100

Hiya,

On 15/07/2021 15:10, Russ Housley wrote:
> Maybe we want to require consensus among the existing stream managers
> to create a new stream.  That is the actual stream managers without
> delegation.
I'd not be for making such a statement. Adding such a
requirement could easily be interpreted as being the
only requirement, which'd be a bad outcome IMO. If/when
we make a new stream I think all the communities we can
reach ought be ok with that and not only a handful of
people.

Cheers,
S.

---

From: Russ Housley <[email-masked]>
Date: Thu, 15 Jul 2021 15:22:39 -0400

EKR:

> 
> > On Jul 14, 2021, at 8:15 PM, Martin Thomson <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> Suppose, for instance, I found a new SDO, the EKR Engineering Task Force (EETF) and I wish to publish my documents in the RFC series. What interest does the IRTF (for example) have in whether I do so or not, as long as it doesn't impact their operations?

I think that the existing stream managers need to agree that the additional stream adds value to the RFC series.  So in your example, the EETF would needs to write documents to define the stream if the existing stream managers agree that the addition is a win-win outcome.  The end result would be a new stream (that includes the agreed phrase for the upper left corner of the title page), a new stream manager, and a new seat on the RSAB.

Russ

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Jul 2021 09:07:53 +1200

On 16-Jul-21 07:22, Russ Housley wrote:
>>     > Adding to the growing chorus of +1 here for saying nothing.  
I don't even want to commit to a de facto status of the IAB deciding.  
A change to the stream structure is a big enough deal that I'm happy to have that be a high energy event that -- if managed properly -- will garner support from all stakeholders.
> I think that the existing stream managers need to agree that the additional stream adds value to the RFC series.  So in your example, the EETF would needs to write documents to define the stream if…
on the RSAB.

Yes, it's quite normal for the members of a club to choose who may join the club. That's why it seems to me that *all* we need to say on this topic is that new streams would need approval by RSWG/RSAB/IAB and must have a funding model acceptable to the LLC.

   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 16 Jul 2021 10:36:51 +1000

> On 16 Jul 2021, at 7:07 am, Brian E Carpenter <[email-masked]> wrote:
> 

I think saying even that is dangerous -- it implies that these bodies can do so without community consultation or other considerations -- it effectively defines a process, and its brevity works against it.

I'd prefer a statement in the negative -- e.g., 'The bodies defined in this document cannot, on their own, introduce a new stream.' That's in-scope for this effort, makes the concerns expressed clear, and doesn't give any unwarranted permission. 

Cheers,

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Jul 2021 12:51:09 +1200

> I think saying even that is dangerous -- it implies that these bodies can do so without community consultation or other considerations -- it effectively defines a process, and its brevity works aga…

Hmm. RSWG *is* community consultation, so I don't really understand what else we could ever specify.

> I'd prefer a statement in the negative -- e.g., 'The bodies defined in this document cannot, on their own, introduce a new stream.' That's in-scope for this effort, makes the concerns expressed cle…

But it leaves open the question of who else has a voice. If the RSWG is open to everybody, who else *is* there? I'd rather say exactly nothing than this.

   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 16 Jul 2021 10:52:41 +1000

> On 16 Jul 2021, at 10:51 am, Brian E Carpenter <[email-masked]> wrote:
> 

Would a reformulation like this help?

> Consensus within the RSWG and/or approval by the RSAB are not sufficient to define a new stream; the requirements and process for doing so are out of scope in this document.

Cheers,

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Jul 2021 14:14:02 +1200

Hi Mark,
>> Consensus within the RSWG and/or approval by the RSAB are not sufficient to define a new stream; the requirements and process for doing so are out of scope in this document.

Yes, I think that kicks the can down the road quite effectively ;-)

Thanks
   Brian

---

From: Eliot Lear <[email-masked]>
Date: Fri, 16 Jul 2021 06:04:32 -0400

Hi

>> Consensus within the RSWG and/or approval by the RSAB are not sufficient to define a new stream; the requirements and process for doing so are out of scope in this document.

The second phrase seems fine. If we're not going to deal with it, let's 
not deal with it.  But let's not stick a toe in the water and start to 
deal with it and then not deal with it.

Eliot

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 16 Jul 2021 08:15:32 -0700

Just to be nitpicky, we agree there needs to be *some* path to create new
streams, right? Would the path be to write a document with that process in
RSWG, get consensus, have RSAB approve, and then actually run the process
for the new stream? Like this text doesn't foreclose the possibility
entirely?

-Ekr

On Fri, Jul 16, 2021 at 3:05 AM Eliot Lear <[email-masked]> wrote:

> >> Consensus within the RSWG and/or approval by the RSAB are not
> sufficient to define a new stream; the requirements and process for doing
> so are out of scope in this document.
>

---

From: Eliot Lear <[email-masked]>
Date: Fri, 16 Jul 2021 12:14:32 -0400

As I see it there are three choices (and maybe others can provide more):

1. we deal with the matter here;
2. it gets dealt with as part of the 2850 update;
3. It gets dealt with when the need arises

I am ok with any of the three.  As a chair my bias is twofold: to not take on more; but if we take on the work, to properly do the job.  My bias on the first is easily overcome if that’s what people want.

Eliot

> On Jul 16, 2021, at 11:16, Eric Rescorla <[email-masked]> wrote:
> 
> 
> Just to be nitpicky, we agree there needs to be *some* path to create new streams, right? Would the path be to write a document with that process in RSWG, get consensus, have RSAB approve, and then actually run the process for the new stream? Like this text doesn't foreclose the possibility entirely?
> 
> -Ekr
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 16 Jul 2021 09:35:07 -0700

On Fri, Jul 16, 2021 at 9:14 AM Eliot Lear <[email-masked]> wrote:

> I am ok with any of the three.  As a chair my bias is twofold: to not take
> on more; but if we take on the work, to properly do the job.  My bias on
> the first is easily overcome if that’s what people want.
>

I don't have a strong opinion. I'm just trying to avoid something that
effectively says "There is no way to create new streams ever" and then in
five years wanting to and having it be like "actually, these documents
totally preclude that and there's no way to update them"

-Ekr

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 17 Jul 2021 09:12:51 +1200

On balance, I think this would develop into an enormous and very tempting 
rathole if we attempted to solve it now, so I'd prefer to simply declare it out of scope and move on.

"The requirements and process for creating any additional RFC streams are 
out of scope in this document."

Regards
   Brian

On 17-Jul-21 04:14, Eliot Lear wrote:
>> On Fri, Jul 16, 2021 at 3:05 AM Eliot Lear <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     Hi
>>
>>     [email-masked] <mailto:[email-masked]>
>>     https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
>>
>> --

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 17 Jul 2021 10:43:48 +1000

WFM

> On 17 Jul 2021, at 7:12 am, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Jul 2021 14:35:57 -0600

> out of scope in this document."

Yes, this seems like the most sensible text to include.

Peter