Subject: [Rfced-future] Possible new issue: community review of performance

From: Brian E Carpenter <[email-masked]>
Date: Sun, 25 Jul 2021 09:10:35 +1200

At the moment, draft-iab-rfcefdp-rfced-model-00, section 5.1 "Roles and Processes", says:

   Community members who have concerns about the performance of the RPC
   can request that the IETF LLC look into the matter.  Even if the IETF
   LLC opts to delegate this activity, concerns should be raised with
   the IETF LLC.  The IETF LLC is ultimately responsible to the
   community via the mechanisms outlined in its charter.

Should we tweak that to say something about the RSWG/RSAB acting for the community in this respect? Should we even require a periodic review of RPC performance by the RSWG/RSAB on behalf of the community? I don't mean to undercut the LLC's normal role of overseeing execution, but the customer is always right. 

Regards
   Brian Carpenter

---

From: Russ Housley <[email-masked]>
Date: Sat, 24 Jul 2021 17:37:27 -0400

> Should we tweak that to say something about the RSWG/RSAB acting for the community in this respect? Should we even require a periodic review of RPC performance by the RSWG/RSAB on behalf of the com…

At the same time, the IETF LLC is clearly responsible for the contract and the budget, so they cannot be omitted from the process.

Russ

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 25 Jul 2021 14:17:44 +1200

> At the same time, the IETF LLC is clearly responsible for the contract and the budget, so they cannot be omitted from the process.

I completely agree.

   Brian

---

From: Christian Huitema <[email-masked]>
Date: Sat, 24 Jul 2021 21:43:46 -0700

> Should we tweak that to say something about the RSWG/RSAB acting for the community in this respect? Should we even require a periodic review of RPC performance by the RSWG/RSAB on behalf of the com…

I think that would be a bad idea. It would just ceate confusion, by 
hinting that the RSAB/RSWG might be responsible of checking the RPC 
performance, instead of keeping that responsibility squarely with the LLC.

-- Christian Huitema

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 25 Jul 2021 17:14:56 +1200

> performance, instead of keeping that responsibility squarely with the LLC.
I wouldn't attempt to dilute that responsibility. It just seems strange
to me that we have words about "community members" raising concerns
and yet we don't include the RSWG/RSAB which is our proxy for
the community.

Let me wordsmith:

If community members, including the RSWG and RSAB, have concerns about the performance of the RPC, they can request that the IETF LLC look into the matter.

   Brian

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 26 Jul 2021 11:10:41 +1000

On Sun, Jul 25, 2021, at 15:14, Brian E Carpenter wrote:
> If community members, including the RSWG and RSAB, have concerns about 
> the performance of the RPC, they can request that the IETF LLC look 
> into the matter.

I have no strong objection to the sentiment, but isn't this a non-statement?  Or is your intent to make it clear that RSxx are absolutely not authoritative in this regard?  (Just trying to avoid over-specification.)

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 26 Jul 2021 14:09:45 +1200

> I have no strong objection to the sentiment, but isn't this a non-statement?  Or is your intent to make it clear that RSxx are absolutely not authoritative in this regard?  (Just trying to avoid ov…

It's more of a hint than a specification. It doesn't allow anything new or create a new duty; it just makes it clear that performance issues don't necessarily come from individuals.

   Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Jul 2021 14:29:49 -0600

no hats

> It's more of a hint than a specification. It doesn't allow anything new or create a new duty; it just makes it clear that performance issues don't necessarily come from individuals.

True, but then we could mention IESG, IAB, IRTF, and various other
bodies (e.g., can a company that references RFCs in its procurement
process raise concerns as an organization?). I feel like we might be
opening a can of worms...

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 29 Jul 2021 08:36:38 +1200

> opening a can of worms...

If so, it's a can of worms that already exists in reality. OK, try:

If community members or community groups have concerns about 
the performance of the RPC, they can request that the IETF LLC look 
into the matter.

I just want to remove the implication that only individuals would raise concerns.

   Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Jul 2021 14:40:26 -0600

> I just want to remove the implication that only individuals would raise concerns.

Understood. I suggest the following small edit so that we avoid
confusion about "community groups" (which are a thing in other SDOs):

  If individuals or groups within the community have concerns about
  the performance of the RPC, they can request that the IETF LLC look
  into the matter.

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 29 Jul 2021 08:54:02 +1200

>   the performance of the RPC, they can request that the IETF LLC look

Yes!

Thanks
   Brian