Subject: Re: [Rfced-future] Consensus check: Issue 16: Appeals (RSWG)

From: Eric Rescorla <[email-masked]>
Date: Mon, 5 Jul 2021 09:22:36 -0700

On Mon, Jun 28, 2021 at 10:42 PM Eliot Lear <[email-masked]> wrote:

> Ok.  Then the text as it stands is as follows:
>
> Decisions of the RSWG can only be appealed on grounds of failure to
> follow the correct process. Appeals should be made within 30 days of
> any action, or in the case of failure to act, of notice having been
> given to the RSWG. The RSAB will then decide if the process was
> followed and will direct RSWG chairs as to what procedural actions are
> required.
>
> Any concerns?  Please respond by the 6th.
>

Yes. I don't think "direct" is appropriate. The RSWG is not subordinate to
the RSAB, so the RSAB should not be "directing" them.

The more I think about this, the more I am concerned about the structure
with appeals going to the RSAB.

It seems to me that at a high level, there are two ways in which you could
have an appeal:

- A document comes to the RSAB which did not follow the process
- Something else happens (e.g., the RSWG doesn't advance a document despite
consensus).

In the first case, the document is in front of the RSAB and we could simply
empower them to reject it. In the second case, however, I don't believe the
RSAB should be able to direct the WG to adopt/advance a document, but this
text verges on this.

What I would propose here is to dispense with appeals instead all the RSAB
to reject documents for process violations. If WG members feel that the
chairs are handling things badly in other ways, they can approach the
bodies which appointed those chairs and ask for their removal, as indicated
in S 3.1.1. This also gives us a handy answer to issue #72.

-Ekr

Eliot
> On 29.06.21 00:47, Brian E Carpenter wrote:
>
> On 28-Jun-21 23:31, Adrian Farrel wrote:
>
> Yeah, I can live with that.
>
> Ditto.
>
>
> Failure to act is always a tricksy one. I think you have it covered.
>
> Yes. Let us not forget that the first ever formal appeal in the IETF
> was an appeal against IESG inaction.
>
>    Brian
>
>
> A
>
> -----Original Message-----
> From: Eliot Lear <[email-masked]> <[email-masked]>
> Sent: 28 June 2021 08:33
> To: [email-masked]; [email-masked]
> Subject: Re: [Rfced-future] Consensus check: Issue 16: Appeals (RSWG)
>
> Hi Adrian,
>
> On 22.06.21 17:10, Adrian Farrel wrote:
>
> I completely agree with the sentiment, but I think the wording may have issues.
>
> What the proposal does is say what can be done "if there are concerns about the process followed by the RSWG." It does not say (but I think it is meant to imply) that the content of the decisions cannot be appealed.
>
> The "should" is also slightly ambiguous.
> And "any action" presumably means the action being appealed.
>
> I would...
>
> Decisions of the RSWG can only be appealed on grounds of failure to follow the correct process. Such an appeal must be made to the RSAB within 30 days of the action being appealed. The RSAB will then decide whether the process was followed correctly.
>
> One of the cases we were trying to cover was inaction of the chairs,
> such as their refusal either to call a question or declare [lack of]
> consensus.  Thus the wording as you saw it.  This leads to an
> interesting question: when does the 30 day clock start? Also,  I think
> the intent was to provide direction to the chairs in the case of an
> appeal being upheld.
>
> With all of this in mind, I propose a bit of a merge:
>
>
> Decisions of the RSWG can only be appealed on grounds of failure to
> follow the correct process. Appeals should be made within 30 days of
> any action, or in the case of failure to act, of notice having been
> given to the RSWG. The RSAB will then decide if the process was
> followed and will direct RSWG chairs as to what procedural actions are
> required.
>
> Does this make sense?
>
> Eliot
>
>
> Cheers,
> Adrian
>
> -----Original Message-----
> From: Rfced-future <[email-masked]> <[email-masked]> On Behalf Of Eliot Lear
> Sent: 22 June 2021 15:38
> To: [email-masked]
> Subject: [Rfced-future] Consensus check: Issue 16: Appeals (RSWG)
>
> The following text was proposed to address appeals of the RSWG:
>
>
> Appeals of RSWG decisions can be made to the RSAB if there are
> concerns about the process followed by the RSWG. Appeals should be
> made within 30 days of any action. The RSAB then decides if the
> process has been followed.
>
> Please raise concerns by 6 July if you have any.
>
> Eliot
>
>
>
>
> --
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 6 Jul 2021 08:12:05 +0200

Eric,

Thanks for your comments.  We are, I think, to the point on this issue 
where it would be good to have a renewed sense on where people stand.  I 
have two questions:

  * Assuming you are in the rough and that there would be an appeals
    process, would changing the word “direct” to “advise” address your
    concerns, and would other people find that acceptable?
  * Do people agree with EKR that an appeal process is not required?

As a reminder, we had a proposal earlier that did NOT have an appeals 
process.  It seems to me that at its core, as a matter of practicality, 
the issue here is whether chairs can be effectively managed from their 
constituent bodies or whether the RSAB might abuse its authority on 
appeal.  My suggestion to the group is in the form of general advice: 
absent strong opinions either way, less process is better ;-)

Given your comment, I propose to let this issue remain open for another 
two weeks, so that we can properly resolve this matter.

Eliot

On 05.07.21 18:22, Eric Rescorla wrote:
>
>
> On Mon, Jun 28, 2021 at 10:42 PM Eliot Lear <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> Yes. I don't think "direct" is appropriate. The RSWG is not 
> subordinate to the RSAB, so the RSAB should not be "directing" them.
>
> The more I think about this, the more I am concerned about the 
> structure with appeals going to the RSAB.
>
> It seems to me that at a high level, there are two ways in which you 
> could have an appeal:
>
> - Something else happens (e.g., the RSWG doesn't advance a document 
> despite consensus).
>
> In the first case, the document is in front of the RSAB and we could 
> simply empower them to reject it. In the second case, however, I don't 
> believe the RSAB should be able to direct the WG to adopt/advance a 
> document, but this text verges on this.
>
> What I would propose here is to dispense with appeals instead all the 
> RSAB to reject documents for process violations. If WG members feel 
> that the chairs are handling things badly in other ways, they can 
> approach the bodies which appointed those chairs and ask for their 
> removal, as indicated in S 3.1.1. This also gives us a handy answer to 
> issue #72.
>
> -Ekr
>
>     Eliot
>
>>>     From: Eliot Lear<[email-masked]>  <mailto:[email-masked]>  
>>>     Sent: 28 June 2021 08:33
>>>     To:[email-masked]  <mailto:[email-masked]>;[email-masked]  <mailto:[email-masked]>
>>>>     From: Rfced-future<[email-masked]>  <mailto:[email-masked]>  On Behalf Of Eliot Lear
>>>>     Sent: 22 June 2021 15:38
>>>>     To:[email-masked]  <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.iab.org/mailman/listinfo/rfced-future>
>
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 6 Jul 2021 09:45:55 -0400

Having listened to several rounds of discussion, I think there does need 
to be a way to appeal chair inaction.  Any such appeal will be 
difficult.  As it should be.  But if the chairs are pushing their view 
over the rough consensus of the RSWG, that needs to be remedied.  And as 
a practical matter, going back to the appointing bodies is going to be 
even mroe difficult, since most members of the appointing bodies are 
probably leaving the RSWG / RSAB work to those they have delegated.  So 
I think that appeal needs to go to the RSAB.

And if the appeal goes to the RSAB for inaction, then the RSAB needs to 
be able to do more than advise.  Because if the appeal takes place, and 
the RSAB agrees with the appeal, and the RSWG chairs ignore that, then 
it needs to be really clear that the chair or chairs need to be 
replaced.  There may be wording to say that short of "direct", but 
"advise" is not strong enough.

Yours,
Joel

---

From: Russ Housley <[email-masked]>
Date: Tue, 6 Jul 2021 14:41:18 -0400

Eliot:

I think an appeals process is needed.  As Adrian pointed out, if a concern is raised in the RSWG, but the chairs take no action, then some form of appeal is needed.  However, I observe that the 30 day requirement in the proposed paragraph is not really a good fit for failure-to-do-anything appeals.

Russ

> On Jul 6, 2021, at 2:12 AM, Eliot Lear <[email-masked]> wrote:
> 
> Eric,
> Thanks for your comments.  We are, I think, to the point on this issue where it would be good to have a renewed sense on where people stand.  I have two questions:
> 
> Assuming you are in the rough and that there would be an appeals process, would changing the word “direct” to “advise” address your concerns, and would other people find that acceptable?
> Do people agree with EKR that an appeal process is not required?  
> As a reminder, we had a proposal earlier that did NOT have an appeals process.  It seems to me that at its core, as a matter of practicality, the issue here is whether chairs can be effectively managed from their constituent bodies or whether the RSAB might abuse its authority on appeal.  My suggestion to the group is in the form of general advice: absent strong opinions either way, less process is better ;-)
> 
> Given your comment, I propose to let this issue remain open for another two weeks, so that we can properly resolve this matter.
> 
> Eliot
> 
>> On Mon, Jun 28, 2021 at 10:42 PM Eliot Lear <[email-masked] <mailto:[email-masked]>> wrote:
>> Yes. I don't think "direct" is appropriate. The RSWG is not subordinate to the RSAB, so the RSAB should not be "directing" them.
>> 
>> The more I think about this, the more I am concerned about the structure with appeals going to the RSAB.
>> 
>> It seems to me that at a high level, there are two ways in which you could have an appeal:
>> 
>> - Something else happens (e.g., the RSWG doesn't advance a document despite consensus).
>> 
>> In the first case, the document is in front of the RSAB and we could simply empower them to reject it. In the second case, however, I don't believe the RSAB should be able to direct the WG to adopt/advance a document, but this text verges on this.
>> 
>> What I would propose here is to dispense with appeals instead all the RSAB to reject documents for process violations. If WG members feel that the chairs are handling things badly in other ways, they can approach the bodies which appointed those chairs and ask for their removal, as indicated in S 3.1.1. This also gives us a handy answer to issue #72.
>> 
>> -Ekr
>> 
>> 
>> Eliot
>> 
>>>> From: Eliot Lear <[email-masked]> <mailto:[email-masked]> 
>>>> Sent: 28 June 2021 08:33
>>>> To: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
>>>>> From: Rfced-future <[email-masked]> <mailto:[email-masked]> On Behalf Of Eliot Lear
>>>>> Sent: 22 June 2021 15:38
>>>>> To: [email-masked] <mailto:[email-masked]>
>> https://www.iab.org/mailman/listinfo/rfced-future <https://www.iab.org/mailman/listinfo/rfced-future>
>> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 6 Jul 2021 15:38:34 -0700

My concern with this, as indicated above, is that it seems to make the RSWG
subordinate to the RSAB. What stops the RSAB from
directing/instructing/etc. the RSWG to advance some document which clearly
does not have consensus.

If we need an escalation process for the chairs not advancing documents
which they ought to advance, ISTM that the right escalation path is to the
body that appointed those chairs. Joel, can you say more about why you
think they will be too busy to do that? Do you have other concerns besides
that?

-Ekr

On Tue, Jul 6, 2021 at 6:45 AM Joel M. Halpern <[email-masked]> wrote:

> >>>>     To:[email-masked]  <mailto:[email-masked]>;
> [email-masked]  <mailto:[email-masked]>
> >>>>>     What the proposal does is say what can be done "if there are
> concerns about the process followed by the RSWG." It does not say (but I
> think it is meant to imply) that the content of the decisions cannot be
> appealed.
> >>>>>
> >>>>>     Decisions of the RSWG can only be appealed on grounds of failure
> to follow the correct process. Such an appeal must be made to the RSAB
> within 30 days of the action being appealed. The RSAB will then decide
> whether the process was followed correctly.
> >>>>>     From: Rfced-future<[email-masked]>  <mailto:
> [email-masked]>  On Behalf Of Eliot Lear
> >>>>>     Sent: 22 June 2021 15:38

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 6 Jul 2021 18:48:58 -0400

Fair question.   My concern with appealeing the chairs to the appointing 
body is several-fold.

First, the appointing bodies ONLY recourse is to fire the chairs.  I 
would hope for an appeals process that had soem resolution short of that.

Second is the matter of involvement.  It is not just a matter of "too 
busy" although that is relevant.  The RSAB members will have been 
involved in the RSWG and will understand the context of the discussion. 
   The other members of the appointing bodies will likely not be paying 
attention.  Part of the problem with the previous setup was that the IAB 
didn't really pay attention to the RSE / RPC activiites.  And this makes 
their involvement even worse.

I would note that if the RSAB directs an action on the basis that RSWG 
process requires it (the only basis they can rule on such an appeal) and 
if they are just making up what they want, then one can appeal the RSAB 
decision on process grounds to whomever we say such process appeals go to.

Yours,
Joel

On 7/6/2021 6:38 PM, Eric Rescorla wrote:
> My concern with this, as indicated above, is that it seems to make the 
> RSWG subordinate to the RSAB. What stops the RSAB from 
> directing/instructing/etc. the RSWG to advance some document which 
> clearly does not have consensus.
> 
> which they ought to advance, ISTM that the right escalation path is to 
> the body that appointed those chairs. Joel, can you say more about why 
> you think they will be too busy to do that? Do you have other concerns 
> besides that?
> 
> -Ekr
> 
> 
> On Tue, Jul 6, 2021 at 6:45 AM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     <mailto:[email-masked]>
>      >> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>
>      >>>>     From: Eliot Lear<[email-masked] <mailto:[email-masked]>> 
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>>>     Sent: 28 June 2021 08:33
>      >>>> To:[email-masked] <mailto:[email-masked]> 
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>;[email-masked]
>     <mailto:[email-masked]>  <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >>>>>     What the proposal does is say what can be done "if there
>     are concerns about the process followed by the RSWG." It does not
>     say (but I think it is meant to imply) that the content of the
>     decisions cannot be appealed.
>      >>>>>
>      >>>>>     Decisions of the RSWG can only be appealed on grounds of
>     failure to follow the correct process. Such an appeal must be made
>     to the RSAB within 30 days of the action being appealed. The RSAB
>     will then decide whether the process was followed correctly.
>      >>>>>     From: Rfced-future<[email-masked]
>     <mailto:[email-masked]>> 
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>  On Behalf Of Eliot Lear
>      >>>>>     Sent: 22 June 2021 15:38
>      >>>>> To:[email-masked] <mailto:[email-masked]> 
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>     <https://www.iab.org/mailman/listinfo/rfced-future
>     <https://www.iab.org/mailman/listinfo/rfced-future>>
>      >>
>      >>
>      >
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 6 Jul 2021 17:58:22 -0600

> would hope for an appeals process that had soem resolution short of that.

It's not clear to me that the only recourse is to fire the chairs. The
appointing bodies could certainly consult, advise, admonish, express
serious concerns, etc.

> involved in the RSWG and will understand the context of the discussion.

Given that the appointing bodies for the RSWG chairs each have a
representative on the RSAB, one hopes that those representatives will be
paying attention and can brief the rest of the body.

Peter

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 6 Jul 2021 20:17:12 -0400

In line...
Yours,
Joel

> appointing bodies could certainly consult, advise, admonish, express
<jmh>Hmmm.  Really?  The IESG or the IAB getting into giving advice and 
opinions on how the RSWG works seems to be an involvement we have been 
avoiding.  </jmh>

> paying attention and can brief the rest of the body.
<jmh>Then we might as well take the appeal to the RSAB, if it is those 
members who are going to drive the conversation anyway.</jmh>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 7 Jul 2021 16:19:02 +1200

On 06-Jul-21 18:12, Eliot Lear wrote:
>   * Assuming you are in the rough and that there would be an appeals process, would changing the word “direct” to “advise” address your concerns, and would other people find that acceptable?

I think in practice it matters little, so it's OK for me.

>   * Do people agree with EKR that an appeal process is not required?

No. We need checks and balances. 

    Brian

> 
> As a reminder, we had a proposal earlier that did NOT have an appeals process.  It seems to me that at its core, as a matter of practicality, the issue here is whether chairs can be effectively managed from their 
constituent bodies or whether the RSAB might abuse its authority on appeal.  My suggestion to the group is in the form of general advice: absent strong opinions either way, less process is better ;-)
>> What I would propose here is to dispense with appeals instead all the RSAB to reject documents for process violations. If WG members feel that the chairs are handling things badly in other ways, they can approach the 
bodies which appointed those chairs and ask for their removal, as indicated in S 3.1.1. This also gives us a handy answer to issue #72.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 7 Jul 2021 16:24:21 +1200

> opinions on how the RSWG works seems to be an involvement we have been 

True. But in any case, firing them is the ultimate sanction (just as a
recall in the IETF process is the ultimate sanction). As long as we have
firing as an option, "advise, admonish, express serious concerns" will
happen anyway, behind the scenes if not in public. I don't think we need
to write that down, because it would just happen if things went wrong.

   Brian

---

From: Michael StJohns <[email-masked]>
Date: Wed, 7 Jul 2021 00:59:16 -0400

> to write that down, because it would just happen if things went wrong.

The question to which I keep returning:   To whom is the RSWG 
accountable too if not the RSAB?    It's certainly not accountable to 
the community, even though it's made up of various permutations (over 
time) of the members of the community.  About all the community could do 
with a broken WG is to rerun the process we're currently doing and 
restructure yet again.  That seems both like overkill and a bad model.

The WG chairs can be replaced, but there is no equivalent recourse for 
participants proposing and approving harmful proposals or for that 
matter sitting on their hands and not proposing and creating necessary 
documents.   And now it sounds like EKR et al (sorry to single you out, 
but yours is the most recent push against RSAB checks and balances) are 
looking for a model where the RSAB can only push back on processes and 
not bad documents or ideas. Or not even that with the proposal to 
eliminate appeals from RSWG actions.

I know who all of the RSAB members will be - not the individuals, but 
their chains of authority and responsibility stemming from their 
positions and from their organizations.  I'm less sure of the RSWG 
chairs.   The rest of the crowd has no agreed upon individual 
responsibilities, but gets ultimate authority?  This model seems to be 
moving to less and less of a good balance of authority and 
responsibility the further we go.

Later, Mike

---

From: Martin J. Dürst <[email-masked]>
Date: Wed, 7 Jul 2021 16:24:19 +0900

> restructure yet again.  That seems both like overkill and a bad model.

If the community realizes that the overall structure is broken, that's 
what would have to be done, but see below.

> documents.

Let's first look at people sitting on their hands. That happens with a 
lot of stuff in a lot of IETF WGs, too. It's solved either by realizing 
that the 'necessary' stuff may not be that necessary, or by others 
coming in and doing the work if it's important enough for them.

As for approving harmful proposals, something similar applies. If 
there's a small group of people trying to push something harmful 
through, it's just up to others to come in and say no. That also has 
worked in many IETF WGs (not in all, I guess, and in many cases without 
many people realizing it).

Regards,   Martin.

> And now it sounds like EKR et al (sorry to single you out,

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 7 Jul 2021 10:28:32 -0700

On Tue, Jul 6, 2021 at 9:59 PM Michael StJohns <[email-masked]>
wrote:

> The question to which I keep returning:   To whom is the RSWG accountable
> too if not the RSAB?    It's certainly not accountable to the community,
> even though it's made up of various permutations (over time) of the members
> of the community.  About all the community could do with a broken WG is to
> rerun the process we're currently doing and restructure yet again.  That
> seems both like overkill and a bad model.
>
Well, I do think that it's *accountable* to the community but needs the
consent of the RSAB.

> participants proposing and approving harmful proposals or for that matter
> sitting on their hands and not proposing and creating necessary
> documents.   And now it sounds like EKR et al (sorry to single you out, but
> yours is the most recent push against RSAB checks and balances) are looking
> for a model where the RSAB can only push back on processes and not bad
> documents or ideas. Or not even that with the proposal to eliminate appeals
> from RSWG actions.
>
I just want to clarify that I am not arguing that that the RSAB should not
be able to push back on bad documents or ideas. What I'm saying is that the
RSAB should not be able to force the WG to advance ideas it thinks are good
even if the RSWG does not.

-Ekr

I know who all of the RSAB members will be - not the individuals, but their
> chains of authority and responsibility stemming from their positions and
> from their organizations.  I'm less sure of the RSWG chairs.   The rest of
> the crowd has no agreed upon individual responsibilities, but gets ultimate
> authority?  This model seems to be moving to less and less of a good
> balance of authority and responsibility the further we go.
>
> Later, Mike
>
>
>
> --

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 7 Jul 2021 14:34:06 -0400

I think I am missing something in your reasoning EKR.

We are discussing the case where the RSWG chairs are not advancing 
something in the presence of a claimed rough consensus in support of 
that thing.

And you are objecting to the RSAB being able to "force the WG to advance 
ideas it thinks are good even if the RSWG does not."

if there is rough consensus for the idea, then the RSWG thinks the idea 
is good, even if the chairs do not.  I believe the chairs should lose 
that fight.

The other alternative is that there is not rough consensus for the idea, 
but the RSAB claims there is.  That would seem to be subject to the 
already agreed rules for appealing RSAB actions.  Because in that 
situation the RSAB would not be following the process.

Why is that not sufficient?

Yours,
Joel

On 7/7/2021 1:28 PM, Eric Rescorla wrote:
> 
> 
> On Tue, Jul 6, 2021 at 9:59 PM Michael StJohns <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     accountable too if not the RSAB?    It's certainly not accountable
>     to the community, even though it's made up of various permutations
>     (over time) of the members of the community.  About all the
>     community could do with a broken WG is to rerun the process we're
>     currently doing and restructure yet again.  That seems both like
>     overkill and a bad model.
> 
>     The WG chairs can be replaced, but there is no equivalent recourse
>     for participants proposing and approving harmful proposals or for
>     that matter sitting on their hands and not proposing and creating
>     necessary documents.   And now it sounds like EKR et al (sorry to
>     single you out, but yours is the most recent push against RSAB
>     checks and balances) are looking for a model where the RSAB can only
>     push back on processes and not bad documents or ideas. Or not even
>     that with the proposal to eliminate appeals from RSWG actions.
> 
> I just want to clarify that I am not arguing that that the RSAB should 
> not be able to push back on bad documents or ideas. What I'm saying is 
> that the RSAB should not be able to force the WG to advance ideas it 
> thinks are good even if the RSWG does not.
> 
> -Ekr
> 
> 
>     I know who all of the RSAB members will be - not the individuals,
>     but their chains of authority and responsibility stemming from their
>     responsibilities, but gets ultimate authority?  This model seems to
>     be moving to less and less of a good balance of authority and

---

From: Eliot Lear <[email-masked]>
Date: Wed, 7 Jul 2021 21:23:54 +0200

If I may, Joel:

On 07.07.21 20:34, Joel M. Halpern wrote:
> And you are objecting to the RSAB being able to "force the WG to 
> advance ideas it thinks are good even if the RSWG does not."
>
> if there is rough consensus for the idea, then the RSWG thinks the 
> idea is good, even if the chairs do not.  I believe the chairs should 
> lose that fight.

Perhaps  EKR is worried about the case where people who serve on the 
RSAB make a proposal and then appeal to the RSAB to force the chairs to 
call consensus or to even declare consensus, and the the RSAB upholds 
the appeal.  This is similar to how people were concerned about the IAB 
imposing themselves on the IESG. Perhaps the group would want to 
consider some analog to the language used in 2119 to avoid excessive 
RSAB influence.

Eliot

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 7 Jul 2021 13:25:02 -0700

On Wed, Jul 7, 2021 at 12:24 PM Eliot Lear <[email-masked]> wrote:

> the appeal.

Yes, more or less.

  This is similar to how people were concerned about the IAB
> consider some analog to the language used in 2119 to avoid excessive

That might work.

-Ekr

Eliot

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 7 Jul 2021 13:28:48 -0700

> is good, even if the chairs do not.  I believe the chairs should lose

I'm generally fairly sympathetic to this position, though I would note that
in
the IETF the Chair's role seems a bit muddled here. See especially RFC 4858
S 3.1,
which I think implies that the chairs do have some substantive
responsibility for
document quality, not just procedural responsibilities.

> Why is that not sufficient?

Well, it's actually not clear to me that this *would* violate the process,
but perhaps
all that's needed is some sharpening of the text, as Eliot suggests.

-Ekr

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 7 Jul 2021 17:35:15 -0400

Do you think we need to include a sentence or two in the document saying 
that the chairs are required to follow the rough consensus of the 
working group?   And further that in process matters the RSAB is 
requried to respect the rough consensus of the working group?    If that 
will help get this issue unstuck, I am all for it.

Yours,
Joel

On 7/7/2021 4:28 PM, Eric Rescorla wrote:
> 
> 
> On Wed, Jul 7, 2021 at 11:34 AM Joel M. Halpern <[email-masked] 
>     advance
> I'm generally fairly sympathetic to this position, though I would note 
> that in
> the IETF the Chair's role seems a bit muddled here. See especially RFC 
> 4858 S 3.1,
> Well, it's actually not clear to me that this *would* violate the 
> process, but perhaps
>      > On Tue, Jul 6, 2021 at 9:59 PM Michael StJohns
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>>
>     wrote:
>      >

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 8 Jul 2021 10:08:17 +1200

> will help get this issue unstuck, I am all for it.

That makes sense to me.

   Brian

>>     if there is rough consensus for the idea, then the RSWG thinks the 
idea

>>      >>>     <jmh>Hmmm.  Really?  The IESG or 
the IAB getting into
>>     giving advice and
>>      >>>     opinions on how the RSWG works seems to be 
an involvement
>>     we have been
>>      >     checks and balances) are looking for a model 
where the RSAB
>>     can only
>>      >     push back on processes and not bad documents 
or ideas. Or not
>>     even
>>      >     positions and from their organizations.  
I'm less sure of the
>>     RSWG

---

From: Lucy Lynch <[email-masked]>
Date: Wed, 7 Jul 2021 16:30:25 -0700

> On Jul 7, 2021, at 3:08 PM, Brian E Carpenter <[email-masked]> wrote:
> 

This may be a tiny corner case but… what if the participants of a dominate stream determine the participant(s) of a smaller stream to be in the rough. What protects stream integrity?

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 7 Jul 2021 19:35:42 -0400

That is why I suggested the wording that the RSAB respects the RSWG 
rough consensus for procedural matters.  That still leaves the RSAB the 
right to raise the content objections taht we have agreed to.

At least, I hope I have split that hair properly.

Yours,
Joel

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 7 Jul 2021 18:17:20 -0700

This seems like an OK resolution to me.

---

From: Eliot Lear <[email-masked]>
Date: Thu, 8 Jul 2021 08:13:18 +0200

We really now must return to the appeals process from the RSAB. I'm 
going to start that discussion in a different thread.

Eliot

On 08.07.21 03:17, Eric Rescorla wrote:
> On Wed, Jul 7, 2021 at 2:35 PM Joel M. Halpern <[email-masked] 
>     > On Wed, Jul 7, 2021 at 11:34 AM Joel M. Halpern
>     <[email-masked] <mailto:[email-masked]>
>     > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >     The other alternative is that there is not rough consensus
>     for the
>     >     idea,
>     >      >
>     >      >
>     >      > On Tue, Jul 6, 2021 at 9:59 PM Michael StJohns
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >      > <mailto:[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>>>
>     >     wrote:
>     >      >
>     >      >     On 7/7/2021 12:24 AM, Brian E Carpenter wrote:
>     >      >>>     <jmh>Hmmm.  Really?  The IESG or the IAB getting into
>     >     giving advice and
>     >      >>>     opinions on how the RSWG works seems to be an
>     involvement
>     >     we have been
>     >      >>>     avoiding.  </jmh>
>     >      >>     True. But in any case, firing them is the ultimate
>     sanction
>     >     (just as a
>     >      >>     recall in the IETF process is the ultimate sanction). As
>     >     long as we have
>     >      >>     firing as an option, "advise, admonish, express serious
>     >     concerns" will
>     >      >>     happen anyway, behind the scenes if not in public. I
>     don't
>     >     think we need
>     >      >>     to write that down, because it would just happen if
>     things
>     >     went wrong.
>     >      >>
>     >      >>         Brian
>     >      >>
>     >      >
>     >      >     The question to which I keep returning: To whom is
>     the RSWG
>     >      >     accountable too if not the RSAB?    It's certainly not
>     >     accountable
>     >      >     to the community, even though it's made up of various
>     >     permutations
>     >      >     (over time) of the members of the community.  About
>     all the
>     >      >     community could do with a broken WG is to rerun the
>     process we're
>     >      >     currently doing and restructure yet again. That seems
>     both like
>     >      >     overkill and a bad model.
>     >      >
>     >      > Well, I do think that it's *accountable* to the community but
>     >     needs the
>     >      > consent of the RSAB.
>     >      >
>     >      >     The WG chairs can be replaced, but there is no equivalent
>     >     recourse
>     >      >     for participants proposing and approving harmful
>     proposals or for
>     >      >     that matter sitting on their hands and not proposing
>     and creating
>     >      >     necessary documents.   And now it sounds like EKR et
>     al (sorry to
>     >      >     single you out, but yours is the most recent push
>     against RSAB
>     >      >     checks and balances) are looking for a model where
>     the RSAB
>     >     can only
>     >      >     push back on processes and not bad documents or
>     ideas. Or not
>     >     even
>     >      >     that with the proposal to eliminate appeals from RSWG
>     actions.
>     >      >
>     >      > I just want to clarify that I am not arguing that that
>     the RSAB
>     >     should
>     >      > not be able to push back on bad documents or ideas. What I'm
>     >     saying is
>     >      > that the RSAB should not be able to force the WG to
>     advance ideas it
>     >      > thinks are good even if the RSWG does not.
>     >      >
>     >      > -Ekr
>     >      >
>     >      >
>     >      >     I know who all of the RSAB members will be - not the
>     individuals,
>     >      >     but their chains of authority and responsibility stemming
>     >     from their
>     >      >     positions and from their organizations. I'm less sure
>     of the
>     >     RSWG
>     >      >     chairs.   The rest of the crowd has no agreed upon
>     individual
>     >      >     responsibilities, but gets ultimate authority?  This
>     model
>     >     seems to
>     >      >     be moving to less and less of a good balance of
>     authority and
>     >      >     responsibility the further we go.
>     >      >
>     >      >     Later, Mike
>     >      >
>     >      >
>     >      >
>     >      >     --
>     >      >     Rfced-future mailing list
>     >      > [email-masked] <mailto:[email-masked]>
>     >     <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     >      > https://www.iab.org/mailman/listinfo/rfced-future
>     >      >     <https://www.iab.org/mailman/listinfo/rfced-future
>     <https://www.iab.org/mailman/listinfo/rfced-future>>>
>     >      >
>     >      >
>     >
>
>

---

From: Eliot Lear <[email-masked]>
Date: Fri, 23 Jul 2021 18:58:55 +0200

Hi,

On 07.07.21 23:35, Joel M. Halpern wrote:
> Do you think we need to include a sentence or two in the document 
> saying that the chairs are required to follow the rough consensus of 
> the working group?   And further that in process matters the RSAB is 
> requried to respect the rough consensus of the working group?    If 
> that will help get this issue unstuck, I am all for it.

I think the above text is what needs to get turned into I-D text at this 
point, but it seems this is what people want.

Eliot

>> I'm generally fairly sympathetic to this position, though I would 
>> note that in
>> the IETF the Chair's role seems a bit muddled here. See especially 
>> RFC 4858 S 3.1,
>>      > <mailto:[email-masked] <mailto:[email-masked]>>>
>>     wrote:
>>      >
>>      >>>     opinions on how the RSWG works seems to be an involvement
>>     we have been
>>      >>>     avoiding.  </jmh>
>>      >>     True. But in any case, firing them is the ultimate sanction
>>     (just as a
>>      >>     happen anyway, behind the scenes if not in public. I don't
>>     think we need
>>      >>     to write that down, because it would just happen if things
>>     went wrong.
>>      >>
>>      >>         Brian
>>      >>
>>      >
>>      >     The question to which I keep returning:   To whom is the RSWG
>>      >     (over time) of the members of the community. About all the
>>      >     for participants proposing and approving harmful proposals 
>> or for
>>      >     that matter sitting on their hands and not proposing and 
>> creating
>>      >     necessary documents.   And now it sounds like EKR et al 
>> (sorry to
>>      >     single you out, but yours is the most recent push against 
>> RSAB
>>      >     checks and balances) are looking for a model where the RSAB
>>     can only
>>      >     push back on processes and not bad documents or ideas. Or not
>>     even
>>      > I just want to clarify that I am not arguing that that the RSAB
>>     should
>>      > that the RSAB should not be able to force the WG to advance 
>> ideas it
>>      >     positions and from their organizations.  I'm less sure of the
>>     RSWG
>>      >     chairs.   The rest of the crowd has no agreed upon individual
>>      >     responsibilities, but gets ultimate authority? This model
>>     seems to
>>      >     be moving to less and less of a good balance of authority and

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 23 Jul 2021 12:38:17 -0600

> point, but it seems this is what people want.

Our I-D currently states:

   It is the responsibility of the chairs to encourage rough consensus
   within the RSWG and to follow that consensus in their decision
   making, for instance regarding advancement of proposals to the RSAB.

and

   The RFC Series Approval Board (RSAB) shall act as the approving body
   for proposals generated within the RSWG.  The sole function of RSAB
   is to review policy proposals generated by the RSWG; it shall have no
   independent authority to formulate policy on its own.  It is expected
   that the RSAB will respect the rough consensus of the RSWG wherever
   possible, without ceding its review function.

Does that address the issue?

Peter

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 23 Jul 2021 15:48:37 -0400

that seems sufficient to me.  In the earlier discussion, some folks had 
seemed to think those restrictions were not sufficiently clear.  So it 
is really up to them to speak up now if that is insufficient.

Yours,
Joel

---

From: Eliot Lear <[email-masked]>
Date: Sat, 24 Jul 2021 14:37:11 +0200

Hi Peter,

> Does that address the issue?

I'll ask others to consider this as well.  We have to be careful not to 
over-legislate.  I would slightly amend the above text by taking out the 
words "It is expected that".  If we're stating it in the draft, it is 
indeed already expected ;-)

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 25 Jul 2021 08:59:55 +1200

> indeed already expected ;-)

I support the text, with or without Eliot's tweak. It makes it clear that
the RSAB is not an executive body.

    Brian