Subject: [Rift] Thu core meet ...

From: Antoni Przygienda <[email-masked]>
Date: Mon, 1 Apr 2019 15:28:20 +0000

I'm back from IETF & ready to pick up on Thu. I have bunch small'ish things on the model based on ongoing deployment discussions, maybe Bruno has something on envelope already & I assume some more mcast? More topics? ...

--- tony

---

From: Bruno Rijsman <[email-masked]>
Date: Mon, 1 Apr 2019 13:10:03 -0300

I have not done any work on the envelope in RIFT-Python yet.

Right know I am looking into the port of RIFT-Python to Free Range Routing (FRR), in anticipation of an expected go-ahead on that project.

Most likely I will not attend the Thursday call on 4 April — I am off to the mountains again for a couple of weeks starting 4 April.

— Bruno

> On Apr 1, 2019, at 12:28 PM, Antoni Przygienda <prz=[email-masked]> wrote:
> 
> I'm back from IETF & ready to pick up on Thu. I have bunch small'ish things on the model based on ongoing deployment discussions, maybe Bruno has something on envelope already & I assume some more mcast? More topics? .... 
> 
> --- tony 
> _______________________________________________
> RIFT mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 1 Apr 2019 16:16:02 +0000

Multicast would be good. Jeffrey told me that we still have some disconnect, the paint is still fresh.

At least we seemed to reach an agreement with the room that differentiating routing for traffic depending on whether it arrives form north or south was problematic.
If the list confirms, then the choice of the BIDIR option is finalized. Building the trees to the subToF is piece of cake. The game is to form the NBMA RPL, built a tree there (call it NRT?). I presented my understanding of the latest discussions with Jeffrey, about making the NRT not too deep and not too fat either, and transporting the NRT root ID in the node TIE. Happy to chat more about it all, and very soon ready to produce text if we reach agreement.

All the best,

Pascal

From: RIFT <[email-masked]> On Behalf Of Antoni Przygienda
Sent: lundi 1 avril 2019 17:28
To: [email-masked]
Subject: [Rift] Thu core meet ...

--- tony

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 1 Apr 2019 17:34:21 +0000

I won't be able to attend this week (and the next week).

Please see zzh> below.

Juniper Confidential-Controlled Unclassified Information
From: RIFT <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, April 1, 2019 12:16 PM
To: Antoni Przygienda <prz=[email-masked]>; [email-masked]
Subject: Re: [Rift] Thu core meet ...

Zzh> The disconnect that I thought we had was whether we build (*,G-prefix) trees or do we just build a few (*,*) trees and then use group information to prune the forwarding.
Zzh> Before the meeting Pascal and I were focusing on how to connect the sub-trees at the top (what Pascal presented) and we did not get a chance to sync-up with others on building (*,G-prefixes) trees explicitly.
Zzh> I thought Pascal once mentioned just building a few (*,*) trees and then hash traffic onto different trees and use group information to prune. If Pascal did not mean that, and people do think it's good to build (*,G-prefix) trees (starting with a single (*,*) tree, and adding more (*,G-prefix) or (*,G) trees as needed), then there is no  disconnect.

Zzh> What does NRT stand for?
Zzh> Another thing that we need to settle is, whether we use RIFT's own TIE exchange to set up the tree or use (extended) PIM signaling/procedures. I remember Tony once preferred non-RIFT mechanism. I think it would be good to just use native RIFT signaling instead of carrying PIM baggage.

Zzh> Jeffrey

All the best,

Pascal

From: RIFT <[email-masked]<mailto:[email-masked]>> On Behalf Of Antoni Przygienda
Sent: lundi 1 avril 2019 17:28
To: [email-masked]<mailto:[email-masked]>
Subject: [Rift] Thu core meet ...

--- tony