Subject: Re: [Rift] Ipv4 and ipv6 cooperating in rift

From: Antoni Przygienda <[email-masked]>
Date: Tue, 9 Jul 2019 16:03:35 +0000

Hey Benchong, cc:'ing list, good questions obviously that pop out on implementation

  1.  sending LIE only with v4 will not give you a v6 address to send to (since the LIE source address gives the gateway for the AF, that's why we send LIE per AF) so you won't have a v6 GW address to send TIEs to ;-)
  2.  yes, every interface is independent. Observe that v6 support implies v4 as the spec says (since you can FW v4 without a v4 GW if you have a v6 gateway). However, if one side sends v6 only and the other side only v4 they'll never go 3-way since they won't be able to receive. We just added a sentence to the spec saying that if you don't send an AF LIE you MUST NOT receive the same AF LIE since we found that loose end in Bruno's implementation when testing security envelopes.  It will be in -07

<t>All RIFT routers MUST support IPv4 forwarding and MAY support IPv6
    forwarding. A three way adjacency over IPv6 addresses implies support
    for IPv4 forwarding. A node that does not process received IPv6 LIEs
    MUST NOT originate IPv6 LIEs.
    </t>

  1.  IPv6/IPv4 prefix can be mixed in Prefix TIEs. Prefix TIEs do NOT care which interface/AF they are sent over.
  2.  how you build forwarding table and which gateways you use is implemenation dependent but yes, you got the flavor. though your assumption of "Ipv6 destination with ipv4 nexthop" is optimistic. every silicon does v4 so v6 can imply v4, implying v4 fwd'ing allows v6 forwarding fails on good amount of silicon. But again, those are all implementation knobs, spec only says "v6 implies v4" which means "you better fwd. v4 over v6 nexthops if you see v6 LIEs only"

Observe that node TIEs are _not_ carrying the supported AFs on each interface since I think it would lead to undesirable attempts to deploy (some links can do v6) topologies which defeat the purpose of ZTP/simplicity of RIFT. v6 implies v4, if someone wants to fwd' v6 over a fabric where certain links are v4 computations get really weird and operationally such a thing is probably a nightmare anyway. And getting v6 working is trivial, just flip on ND and you're in business (at least control plane wise ;-)

The spec is noit giving implementation advice, it just specifies behavior. In case of doubt looks @ Bruno';s open source. Bruno implemented the whole LIE without ever talking to me and it interop'ed day one without problems.

When you're ready with your implementation to interop, Bruno's code has nice framework you can plug in against open source & Juniper implementation easily

--- tony
________________________________
From: [email-masked] <[email-masked]>
Sent: Tuesday, July 9, 2019 5:08 AM
To: Antoni Przygienda; Jeffrey (Zhaohui) Zhang; [email-masked]
Subject: [Rift] Ipv4 and ipv6 cooperating in rift

Hi

I have some questions about ipv4 and ipv6 cooperating in rift.

Ip head of the rift packet can be V4 or V6, and the prefix in TIE also suport V4 or v6.

Can it support the following situations:

1、A rift interface which send LIE with ipv4 head receiving LIE with IPv6 head;

A rift interface which send LIE with ipv6 head receiving LIE with IPv4 head;

Can they build 3-Way neighbor?

2、Some interfaces in a rift instance send ipv4 head packets， and others in the same instance send ipv6 head packets；

3、Ipv4 head TIE packet fill ipv6 prefix；

   Ipv6 head TIE packet fill ipv4 prefix；(RIFT-06 5.2.2: All RIFT routers MUST support IPv4 forwarding and MAY support IPv6

   forwarding.  A three way adjacency over IPv6 addresses implies

   support for IPv4 forwarding.)

4、In rib table of the rift:

   Ipv4 destination with ipv6 nexthop;

   Ipv6 destination with ipv4 nexthop;

   Ipv4 destination with both ipv4 nexthop and ipv6 nexthop;

   Ipv6 destination with both ipv4 nexthop and ipv6 nexthop;

5、The ip head type(v4 or v6) can be configured in rift interface or instance.

It will be better if there are clear instructions in rift protocol.

Thanks！

Benchong

---

From: <[email-masked]>
Date: Wed, 10 Jul 2019 16:56:12 +0800 (CST)

Tony, thank you for your reply

Can it be understood that after the ND is enabled, the v6 address needs to be used to build neighbor? In this case, the rift packet of the v4 header is not allowed to be sent and received, and both v4 and v6 routes have a v6 GW.

原始邮件

发件人：AntoniPrzygienda <[email-masked]>
收件人：徐本崇10065053;Jeffrey (Zhaohui)Zhang <[email-masked]>;张征00007940;[email-masked] <[email-masked]>;
日 期 ：2019年07月10日 00:09
主 题 ：Re: [Rift] Ipv4 and ipv6 cooperating in rift

 
sending LIE only with v4 will not give you a v6 address to send to (since the LIE source address gives the gateway for the AF, that's why we send LIE per AF) so you won't have a v6 GW address to send TIEs to ;-)

yes, every interface is independent. Observe that v6 support implies v4 as the spec says (since you can FW v4 without a v4 GW if you have a v6 gateway). However, if one side sends v6 only and the other side only v4 they'll never go 3-way since they won't  be able to receive. We just added a sentence to the spec saying that if you don't send an AF LIE you MUST NOT receive the same AF LIE since we found that loose end in Bruno's implementation when testing security envelopes.  It will be in -07

IPv6/IPv4 prefix can be mixed in Prefix TIEs. Prefix TIEs do NOT care which interface/AF they are sent over. 

how you build forwarding table and which gateways you use is implemenation dependent but yes, you got the flavor. though your assumption of "Ipv6 destination with ipv4 nexthop" is optimistic. every silicon does v4 so v6 can imply v4, implying v4 fwd'ing  allows v6 forwarding fails on good amount of silicon. But again, those are all implementation knobs, spec only says "v6 implies v4" which means "you better fwd. v4 over v6 nexthops if you see v6 LIEs only"

 --- tony 

--------------------------------------------------------------------------------

Hi 

 

 

 

 

   

 

 

Thanks！

Benchong

---

From: Antoni Przygienda <[email-masked]>
Date: Wed, 10 Jul 2019 15:04:40 +0000

Hey Benchong, that's an over-interpretation, the spec is looser than that but as far I saw sufficient. Section 5.2.2.

a) Specification does not prohibit RIFT from using _any_ valid IPv6 address on the interface to send IPv6 LIEs. The receiver is supposed to pick up that source address and use it as destination when sending LIEs over v6 and/or TIEs with the receving interface as gateway. Specification does NOT spell out what happens e.g. on mismatched IP subnets on both sides and so on, situation here is similar to ISIS and different scenarios such as unnumbered links and so on
b) If you want the "laziest" possible implementation then in fact yes, you can fall back on

"

   All RIFT routers MUST support IPv4 forwarding and MAY support IPv6
   forwarding.  A three way adjacency over IPv6 addresses implies
   support for IPv4 forwarding.

"

which makes v4ov6 forwarding inherent part of RIFT. That assumes however that receiving neighbor does support V6 (which the spec does NOT mandate) and nothing will happen if it doesn't. Therefore all RIFT implementation I saw so far send both v4 and v6 which allows the neighbor to only receive v4 and forward using v4 gateways if it doesn't support V6. In case both v4 and v6 AFs are established, it is up to the implementation which/how it resolves the gateways and there are many interesting advanced issues such as mixture of spines with v4 and v6 nexthops and how to form ECMP amongst them that the spec does obviously not address since it's all very implementation and silicon specific.

--- tony
________________________________
From: [email-masked] <[email-masked]>
Sent: Wednesday, July 10, 2019 1:56 AM
To: Antoni Przygienda
Cc: Jeffrey (Zhaohui) Zhang; [email-masked]; [email-masked]
Subject: Re:[Rift] Ipv4 and ipv6 cooperating in rift

原始邮件

--- tony

Hi

Thanks！

Benchong

---

From: <[email-masked]>
Date: Thu, 11 Jul 2019 11:39:40 +0800 (CST)

Hi tony

Thanks for your explanation, and I have already understood your opinion on v4v6 forwarding.

The difference between RIFT and other routing protocols is the consistency of packets AF and routes AF. Isis is in L2 encapsulation that solves different address families through multiple topologies. Ospf and rip are strictly distinguished in v4v6. Rift is actually closer to BGP.

When the interface has both v4 and v6 addresses (or ND enabled), the protocol uses v4 or v6 or v4v6 address encapsulation. It will be better if protocol gave the recommended behavior. Otherwise, different people will give different solutions, which will cause protocol conformance problem. 

The options we can choose are:

a) ND enable v6 first:

If v6 address valid AND ND enable:

     V6 packet

Else if v4 address valid:

     V4 packet

b) v4 first

If v4 address valid:

     V4 packet

Else if v6 address valid(AND ND enable):

     V6 packet

c) coexistence of v4v6

If v4 address valid:

     V4 packet

If v6 address valid(AND ND enable):

     V6 packet

Confused on both the sending and receiving sides.

c) will further have a GW selection problem, preferring to choose the nexthop of the same address family with the prefix, or v4 first.

I'd like the protocol recommends a default behavior and may provides a control method in yang.

Thanks!

Benchong

原始邮件

发件人：AntoniPrzygienda <[email-masked]>
收件人：徐本崇10065053;
抄送人：Jeffrey (Zhaohui) Zhang <[email-masked]>;张征00007940;[email-masked] <[email-masked]>;
日 期 ：2019年07月10日 23:12
主 题 ：Re: Re:[Rift] Ipv4 and ipv6 cooperating in rift

 

 
" All RIFT routers MUST support IPv4 forwarding and MAY support IPv6 forwarding. A three way adjacency over IPv6 addresses implies support for IPv4 forwarding. "

 
--- tony 

 

 

原始邮件

 

 

 --- tony 

Hi 

 

 

 

 

   

 

 

Thanks！

Benchong

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 11 Jul 2019 03:51:34 +0000

Benchong, what you seem to talk about is originating packets and it's the source that decides whether it sends v4 or v6 and the IP fabric with RIFT just forwards the packet, it cannot change in the middle the IP address family in which the packet is carried obviously so there is no decision to be made which IP AF is used, only which GW needs to be installed on the route nexthop. But yes, an implementaton can choose to forward v4 packets using the MAC address of a v6 gateway, a highly desirable behavior since with that, the fabric can be completely global address free without any config (just ND) and do v4 fine.

yes, an implementation may choose to prefer v4 GW for v4 packets and v6 GW for v6 packets but normally it's the same MAC unless the deployment is very strange @ which point knobs to control that may be necessary, something which is implementation specific.

So RIFT just floods the TIEs on any AF with prefixes of all AFs, the computation computes the route with directly attached next-hop which has to resolve to MAC in any AF really and then packet can be forwarded ...

implement it and play with it, we have @ least 2 implementations already that work fine doing that ...

Yes, the closest analogy is v4 in BGP with v6 nexthops if you really want to think that way but RIFT is much simpler since the nhop is always directly connected and we don't talk about anything like v4ov6 or v6ov4 tunneling and so on ...

makes sense?

--- tony

Sent: Wednesday, July 10, 2019 8:39 PM

Hi tony

a) ND enable v6 first:

     V6 packet

     V4 packet

b) v4 first

If v4 address valid:

     V4 packet

     V6 packet

c) coexistence of v4v6

If v4 address valid:

     V4 packet

     V6 packet

Thanks!

Benchong

原始邮件

"

   All RIFT routers MUST support IPv4 forwarding and MAY support IPv6    forwarding.  A three way adjacency over IPv6 addresses implies    support for IPv4 forwarding.

"

--- tony

原始邮件

--- tony

Hi

Thanks！

Benchong

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 11 Jul 2019 08:15:11 -0700

On July 10, 2019 at 11:05:40 AM, Antoni Przygienda (
prz=[email-masked]) wrote:

Hi!

I might be jumping in without proper context, but this text caught my
attention...

b) If you want the "laziest" possible implementation then in fact yes, you
can fall back on

"

"

…because the WG Charter says that "The protocol must support IPv6 and
should also support IPv4.”   So the text above contradicts the Charter.

Alvaro.

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 11 Jul 2019 15:49:00 +0000

Alvaro, protocol specification requirements and router running the protocol requirements are AFAIS not the same thing. And the distinction is meaningful here.

So, the protocol DOES support IPv6 and it DOES suppoort IPv4 so it does fulfill the charter you refer to perfectly.

not to the requirements _of devices runing RIFT_:  we cannot mandate that everyone in reality will run IPv6 forwarding on the fabric so the reality is that every silicon does IPv4 today and some does IPv6. And then IPv4 over IPv6 is reality while IPv6 over IPv4 is not (since IPv6 does ND anyway so why would you).  So it is very good for v6 here to basically make it an implicit transport for v4 (by saying running v6 does _automatically_ give you v4 forwarding) while making sure that v4 being-de-facto-what-e'one-can-do is the lowest common denominator of the router's running RIFT. RIFT being only usable if a router/switch can do IPv6 is simply not a practical proposition AFAIS.  We could arguably split it into a "RIFT router/switch requirements document" but that seems just paper bloat ...

So I think we are meeting the charter mandating protocol specification perfectly while @ the same the spec is aligning with reality of v4ov6 forwarding without v4 addresses. We could just as well remove the sentence and everything would work except we'd end up in lots of discussions/possibly non-interoperable implementations in regards to v4 forwarding when no v4 addresses are present and people considering things undeployable until all the silicon in the world does v6 and everyone runs v6 by default everywhere. Which may happen but not in a foreseable future I can discern ...

I hope I do make sense ...

--- tony

________________________________
From: Alvaro Retana <[email-masked]>
Sent: Thursday, July 11, 2019 8:15 AM
To: Antoni Przygienda; [email-masked]
Cc: [email-masked]; [email-masked]; Jeffrey (Zhaohui) Zhang
Subject: Re: [Rift] Ipv4 and ipv6 cooperating in rift

On July 10, 2019 at 11:05:40 AM, Antoni Przygienda (prz=[email-masked]<mailto:prz=[email-masked]>) wrote:

Hi!

I might be jumping in without proper context, but this text caught my attention...

"

"

…because the WG Charter says that "The protocol must support IPv6 and should also support IPv4.”   So the text above contradicts the Charter.

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 11 Jul 2019 11:42:11 -0700

Tony:

Hi!

As I said before, I may be jumping in without proper context…. I just want
to make sure that we don’t end up with discussions about the charter or how
much it may or may not reflect reality later in the process.  If a change
needs to be made, better sooner than later…if no change is needed, then
we’re good. :-)

Alvaro.

On July 11, 2019 at 11:49:12 AM, Antoni Przygienda ([email-masked]) wrote:

Alvaro, protocol specification requirements and router running the protocol
requirements are AFAIS not the same thing. And the distinction is
meaningful here.

So, the protocol DOES support IPv6 and it DOES suppoort IPv4 so it does
fulfill the charter you refer to perfectly.

not to the requirements _of devices runing RIFT_:  we cannot mandate that
everyone in reality will run IPv6 forwarding on the fabric so the reality
is that every silicon does IPv4 today and some does IPv6. And then IPv4
over IPv6 is reality while IPv6 over IPv4 is not (since IPv6 does ND anyway
so why would you).  So it is very good for v6 here to basically make it an
implicit transport for v4 (by saying running v6 does _automatically_ give
you v4 forwarding) while making sure that v4
being-de-facto-what-e'one-can-do is the lowest common denominator of the
router's running RIFT. RIFT being only usable if a router/switch can do
IPv6 is simply not a practical proposition AFAIS.  We could arguably split
it into a "RIFT router/switch requirements document" but that seems just
paper bloat ...

So I think we are meeting the charter mandating protocol specification
perfectly while @ the same the spec is aligning with reality of v4ov6
forwarding without v4 addresses. We could just as well remove the sentence
and everything would work except we'd end up in lots of
discussions/possibly non-interoperable implementations in regards to v4
forwarding when no v4 addresses are present and people considering things
undeployable until all the silicon in the world does v6 and everyone runs
v6 by default everywhere. Which may happen but not in a foreseable future I
can discern ...

--- tony

------------------------------
*From:* Alvaro Retana <[email-masked]>
*Sent:* Thursday, July 11, 2019 8:15 AM
*To:* Antoni Przygienda; [email-masked]
*Cc:* [email-masked]; [email-masked]; Jeffrey (Zhaohui) Zhang
*Subject:* Re: [Rift] Ipv4 and ipv6 cooperating in rift

Hi!

"

"

Alvaro.

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 11 Jul 2019 18:50:29 +0000

Alvaro, understood and I know you're here to guide with a loving but firm hand ;-) I tried to elucidate ;-) that AFAIS we follow the charter fine in this case but of course I'm waiting for others to chime in if they see things differently ...

thanks

--- tony

Sent: Thursday, July 11, 2019 11:42 AM

Tony:

Hi!

As I said before, I may be jumping in without proper context…. I just want to make sure that we don’t end up with discussions about the charter or how much it may or may not reflect reality later in the process.  If a change needs to be made, better sooner than later…if no change is needed, then we’re good. :-)

Alvaro.

On July 11, 2019 at 11:49:12 AM, Antoni Przygienda ([email-masked]<mailto:[email-masked]>) wrote:

--- tony

________________________________
From: Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, July 11, 2019 8:15 AM
To: Antoni Przygienda; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Jeffrey (Zhaohui) Zhang
Subject: Re: [Rift] Ipv4 and ipv6 cooperating in rift

Hi!

"

"

Alvaro.