Subject: Re: [Rift] Fw:Re: Re: Ipv4 and ipv6 cooperating in rift

From: Antoni Przygienda <[email-masked]>
Date: Thu, 11 Jul 2019 15:53:35 +0000

Gentlemen, cc'ing through rift WG, all comms please to the list ...

will also help next implementors looking @ Bruno's code ;-) which BTW is a great, clean, inter-op'ed reference implementation and that's why I suggested to refer to it

thanks

--- tony

________________________________
From: [email-masked] <[email-masked]>
Sent: Thursday, July 11, 2019 2:33 AM
To: [email-masked]
Cc: Antoni Przygienda
Subject: Fw:Re: Re:[Rift] Ipv4 and ipv6 cooperating in rift

Hi, Bruno

I read part of your RIFT code, thank you for your great job!

When sending LIE messages, as long as there is a v4 address, v4 will be used first, so we will get v4 next hop.

----------

    def action_start_flooding(self):

……

       # For sending flooding packets, use whatever IPv4 or IPv6 address we see first for the

        # neighbor, preferring the IPv4 address if we know both.

        if self.neighbor.ipv4_address is not None:

            self.rx_info("Start IPv4 flooding: send to address %s port %d",

                         self.neighbor.ipv4_address, tx_flood_port)

            self._flood_tx_ipv4_socket = self.create_socket_ipv4_tx_ucast(

                remote_address=self.neighbor.ipv4_address,

                port=tx_flood_port)

        else:

            assert self.neighbor.ipv6_address is not None

            scoped_ipv6_address = self.neighbor.ipv6_address

            if "%" not in self.neighbor.ipv6_address:

                scoped_ipv6_address += "%" + self.physical_interface_name

            self.rx_info("Start IPv6 flooding: send to address %s port %d",

                         scoped_ipv6_address, tx_flood_port)

            self._flood_tx_ipv6_socket = self.create_socket_ipv6_tx_ucast(

                remote_address=scoped_ipv6_address,

                port=tx_flood_port)

SPF calculation will calculate the nexthop of v4 and v6 at the same time.

-----------------

    def set_spf_predecessor(self, destination, nbr_tie_element, predecessor_system_id,

                            spf_direction):

        destination.add_predecessor(predecessor_system_id)

        if (nbr_tie_element is not None) and (predecessor_system_id == self.system_id):

            for link_id_pair in nbr_tie_element.link_ids:

                nhop = self.interface_id_to_ipv4_next_hop(link_id_pair.local_id)

                if nhop:

                    destination.add_ipv4_next_hop(nhop)

                nhop = self.interface_id_to_ipv6_next_hop(link_id_pair.local_id)

                if nhop:

                    destination.add_ipv6_next_hop(nhop)

        else:

            dest_table = self._spf_destinations[spf_direction]

            destination.inherit_next_hops(dest_table[predecessor_system_id])

The RIB table only selects the same AF nexthop

--------------

    def spf_install_routes_in_rib(self, spf_direction):

        ……

                prefix = dest_key

                if prefix.ipv4prefix is not None:

                    next_hops = dest.ipv4_next_hops

                    route_table = self._ipv4_rib

                else:

                    assert prefix.ipv6prefix is not None

                    next_hops = dest.ipv6_next_hops

                    route_table = self._ipv6_rib

                if next_hops:

                    rte = route.Route(prefix, owner, next_hops)

                    route_table.put_route(rte)

Is it possible to generate a valid v6 rib table as long as v4 address of the inteface is valid? Can it support ipv4 and ipv6 double stack?

Thanks!

Benchong

原始邮件
发件人：AntoniPrzygienda <[email-masked]>
收件人：徐本崇10065053;
抄送人：Jeffrey (Zhaohui) Zhang <[email-masked]>;张征00007940;[email-masked] <[email-masked]>;
日 期 ：2019年07月11日 11:52
主 题 ：Re: Re:[Rift] Ipv4 and ipv6 cooperating in rift
Benchong, what you seem to talk about is originating packets and it's the source that decides whether it sends v4 or v6 and the IP fabric with RIFT just forwards the packet, it cannot change in the middle the IP address family in which the packet is carried  obviously so there is no decision to be made which IP AF is used, only which GW needs to be installed on the route nexthop. But yes, an implementaton can choose to forward v4 packets using the MAC address of a v6 gateway, a highly desirable behavior since  with that, the fabric can be completely global address free without any config (just ND) and do v4 fine.

yes, an implementation may choose to prefer v4 GW for v4 packets and v6 GW for v6 packets but normally it's the same MAC unless the deployment is very strange @ which point knobs to control that may be necessary, something which is implementation specific.

So RIFT just floods the TIEs on any AF with prefixes of all AFs, the computation computes the route with directly attached next-hop which has to resolve to MAC in any AF really and then packet can be forwarded ...

implement it and play with it, we have @ least 2 implementations already that work fine doing that ...

Yes, the closest analogy is v4 in BGP with v6 nexthops if you really want to think that way but RIFT is much simpler since the nhop is always directly connected and we don't talk about anything like v4ov6 or v6ov4 tunneling and so on ...

makes sense?

--- tony

________________________________
From: [email-masked] <[email-masked]>
Sent: Wednesday, July 10, 2019 8:39 PM
To: Antoni Przygienda
Cc: Jeffrey (Zhaohui) Zhang; [email-masked]; [email-masked]
Subject: Re:[Rift] Ipv4 and ipv6 cooperating in rift

Hi tony

Thanks for your explanation, and I have already understood your opinion on v4v6 forwarding.

The difference between RIFT and other routing protocols is the consistency of packets AF and routes AF. Isis is in L2 encapsulation that solves different address families through multiple topologies. Ospf and rip are strictly distinguished in v4v6. Rift  is actually closer to BGP.

When the interface has both v4 and v6 addresses (or ND enabled), the protocol uses v4 or v6 or v4v6 address encapsulation. It will be better if protocol gave the recommended behavior. Otherwise, different people will give different solutions, which will  cause protocol conformance problem.

The options we can choose are:

a) ND enable v6 first:

If v6 address valid AND ND enable:

     V6 packet

Else if v4 address valid:

     V4 packet

b) v4 first

If v4 address valid:

     V4 packet

Else if v6 address valid(AND ND enable):

     V6 packet

c) coexistence of v4v6

If v4 address valid:

     V4 packet

If v6 address valid(AND ND enable):

     V6 packet

Confused on both the sending and receiving sides.

c) will further have a GW selection problem, preferring to choose the nexthop of the same address family with the prefix, or v4 first.

I'd like the protocol recommends a default behavior and may provides a control method in yang.

Thanks!

Benchong

原始邮件
发件人：AntoniPrzygienda <[email-masked]>
收件人：徐本崇10065053;
抄送人：Jeffrey (Zhaohui) Zhang <[email-masked]>;张征00007940;[email-masked]  <[email-masked]>;
日 期 ：2019年07月10日 23:12
主 题 ：Re: Re:[Rift] Ipv4 and ipv6 cooperating in rift
Hey Benchong, that's an over-interpretation, the spec is looser than that but as far I saw sufficient. Section 5.2.2.

a) Specification does not prohibit RIFT from using _any_ valid IPv6 address on the interface to send IPv6 LIEs. The receiver is supposed to pick up that source address and use it as destination when sending LIEs over v6 and/or TIEs with the receving interface   as gateway. Specification does NOT spell out what happens e.g. on mismatched IP subnets on both sides and so on, situation here is similar to ISIS and different scenarios such as unnumbered links and so on
b) If you want the "laziest" possible implementation then in fact yes, you can fall back on

"

   All RIFT routers MUST support IPv4 forwarding and MAY support IPv6    forwarding.  A three way adjacency over IPv6 addresses implies    support for IPv4 forwarding.

"

which makes v4ov6 forwarding inherent part of RIFT. That assumes however that receiving neighbor does support V6 (which the spec does NOT mandate) and nothing will happen if it doesn't. Therefore all RIFT implementation I saw so far send both v4 and v6 which   allows the neighbor to only receive v4 and forward using v4 gateways if it doesn't support V6. In case both v4 and v6 AFs are established, it is up to the implementation which/how it resolves the gateways and there are many interesting advanced issues such   as mixture of spines with v4 and v6 nexthops and how to form ECMP amongst them that the spec does obviously not address since it's all very implementation and silicon specific.

--- tony
________________________________
From: [email-masked] <[email-masked]>
Sent: Wednesday, July 10, 2019 1:56 AM
To: Antoni Przygienda
Cc: Jeffrey (Zhaohui) Zhang; [email-masked]; [email-masked]
Subject: Re:[Rift] Ipv4 and ipv6 cooperating in rift

Tony, thank you for your reply

Can it be understood that after the ND is enabled, the v6 address needs to be used to build neighbor? In this case, the rift packet of the v4 header is not allowed to be sent and received, and both v4 and v6 routes have a v6 GW.

原始邮件
发件人：AntoniPrzygienda <[email-masked]>
收件人：徐本崇10065053;Jeffrey (Zhaohui)Zhang <[email-masked]>;张征00007940;[email-masked]   <[email-masked]>;
日 期 ：2019年07月10日 00:09
主 题 ：Re: [Rift] Ipv4 and ipv6 cooperating in rift
Hey Benchong, cc:'ing list, good questions obviously that pop out on implementation

  1.  sending LIE only with v4 will not give you a v6 address to send to (since the LIE source address gives the gateway for the AF, that's why we send LIE per AF) so you won't have a v6 GW address to send TIEs to ;-)

  2.  yes, every interface is independent. Observe that v6 support implies v4 as the spec says (since you can FW v4 without a v4 GW if you have a v6 gateway). However, if one side sends v6 only and the other side only v4 they'll never go 3-way since they won't    be able to receive. We just added a sentence to the spec saying that if you don't send an AF LIE you MUST NOT receive the same AF LIE since we found that loose end in Bruno's implementation when testing security envelopes.  It will be in -07

<t>All RIFT routers MUST support IPv4 forwarding and MAY support IPv6
    forwarding. A three way adjacency over IPv6 addresses implies support
    for IPv4 forwarding. A node that does not process received IPv6 LIEs
    MUST NOT originate IPv6 LIEs.
    </t>

  1.  IPv6/IPv4 prefix can be mixed in Prefix TIEs. Prefix TIEs do NOT care which interface/AF they are sent over.

  2.  how you build forwarding table and which gateways you use is implemenation dependent but yes, you got the flavor. though your assumption of "Ipv6 destination with ipv4 nexthop" is optimistic. every silicon does v4 so v6 can imply v4, implying v4 fwd'ing    allows v6 forwarding fails on good amount of silicon. But again, those are all implementation knobs, spec only says "v6 implies v4" which means "you better fwd. v4 over v6 nexthops if you see v6 LIEs only"

Observe that node TIEs are _not_ carrying the supported AFs on each interface since I think it would lead to undesirable attempts to deploy (some links can do v6) topologies which defeat the purpose of ZTP/simplicity of RIFT. v6 implies v4, if someone    wants to fwd' v6 over a fabric where certain links are v4 computations get really weird and operationally such a thing is probably a nightmare anyway. And getting v6 working is trivial, just flip on ND and you're in business (at least control plane wise  ;-)

The spec is noit giving implementation advice, it just specifies behavior. In case of doubt looks @ Bruno';s open source. Bruno implemented the whole LIE without ever talking to me and it interop'ed day one without problems.

When you're ready with your implementation to interop, Bruno's code has nice framework you can plug in against open source & Juniper implementation easily

--- tony
________________________________
From: [email-masked] <[email-masked]>
Sent: Tuesday, July 9, 2019 5:08 AM
To: Antoni Przygienda; Jeffrey (Zhaohui) Zhang; [email-masked]
Subject: [Rift] Ipv4 and ipv6 cooperating in rift

Hi

I have some questions about ipv4 and ipv6 cooperating in rift.

Ip head of the rift packet can be V4 or V6, and the prefix in TIE also suport V4 or v6.

Can it support the following situations:

1、A rift interface which send LIE with ipv4 head receiving LIE with IPv6 head;

A rift interface which send LIE with ipv6 head receiving LIE with IPv4 head;

Can they build 3-Way neighbor?

2、Some interfaces in a rift instance send ipv4 head packets， and others in the same instance send ipv6 head packets；

3、Ipv4 head TIE packet fill ipv6 prefix；

   Ipv6 head TIE packet fill ipv4 prefix；(RIFT-06 5.2.2: All RIFT routers MUST support IPv4 forwarding and MAY support IPv6

   forwarding.  A three way adjacency over IPv6 addresses implies

   support for IPv4 forwarding.)

4、In rib table of the rift:

   Ipv4 destination with ipv6 nexthop;

   Ipv6 destination with ipv4 nexthop;

   Ipv4 destination with both ipv4 nexthop and ipv6 nexthop;

   Ipv6 destination with both ipv4 nexthop and ipv6 nexthop;

5、The ip head type(v4 or v6) can be configured in rift interface or instance.

It will be better if there are clear instructions in rift protocol.

Thanks！

Benchong

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 11 Jul 2019 15:57:28 +0000

Benchong, as to your last intersting question:

"

"

answer is "yes, but practically if your interface can fwd' IPv6 frames it also runs ND so you will have a v6 link local which seems much more natural as next-hop rather than maltreat v4 addresses to build v6 next-hops from ;-) Unless you have some funky silicon limitations where such a thing is a good thing ;-)

So, you see why the spec is written to the point it's written and silent on specification how to precisely build next-hops/gateways. It can be implemented in couple different ways which are very close to implementation techniques/HW used so trying to nail that in protocol spec would be over-specification which is almost as bad as under-specification ...

--- tony

Hi, Bruno

----------

……

                port=tx_flood_port)

        else:

                port=tx_flood_port)

-----------------

                            spf_direction):

                if nhop:

                if nhop:

        else:

--------------

        ……

                prefix = dest_key

                else:

                if next_hops:

Thanks!

Benchong

原始邮件

makes sense?

--- tony

Hi tony

a) ND enable v6 first:

     V6 packet

     V4 packet

b) v4 first

If v4 address valid:

     V4 packet

     V6 packet

c) coexistence of v4v6

If v4 address valid:

     V4 packet

     V6 packet

Thanks!

Benchong

原始邮件

"

"

--- tony

原始邮件

--- tony

Hi

Thanks！

Benchong

---

From: <[email-masked]>
Date: Fri, 12 Jul 2019 18:20:16 +0800 (CST)

Tony

I get the rule now, thank you!

It should send multi lies in same interface with different source address include v4 and v6 which we want to use the address as a gateway. It confused me in the previous discussion and I did't find it in the protocol. It is different with other protocols. Bruno's code has already implemented.

In this case, the 3-way state switching forword the rule in 5.2.2 

"

Observe further that the protocol does NOT support selective

   disabling of address families or any local address changes in three

   way state, i.e. if a link has entered three way IPv4 and/or IPv6 with

   a neighbor on an adjacency and it wants to stop supporting one of the

   families or change any of its local addresses, it has to tear down

   and rebuild the adjacency.  It also has to remove any information it

   stored about adjacency's' LIE source addresses seen.

"

Then the nexthop selection of the rib table depends on the device itself and I support this.

thank you!

Benchong

原始邮件

发件人：AntoniPrzygienda <[email-masked]>
收件人：徐本崇10065053;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年07月12日 00:38
主 题 ：Re: Fw:Re: Re:[Rift] Ipv4 and ipv6 cooperating in rift

 
"

"

 

--- tony 

--------------------------------------------------------------------------------

Hi, Bruno

----------

……

                port=tx_flood_port)

        else:

                port=tx_flood_port)

-----------------

                            spf_direction):

                if nhop:

                if nhop:

        else:

--------------

        ……

                prefix = dest_key

                else:

                if next_hops:

Thanks!

Benchong

原始邮件

 

 

 
makes sense? 

--- tony 

 
--------------------------------------------------------------------------------

Hi tony

a) ND enable v6 first:

     V6 packet

     V4 packet

b) v4 first

If v4 address valid:

     V4 packet

     V6 packet

c) coexistence of v4v6

If v4 address valid:

     V4 packet

     V6 packet

Thanks!

Benchong

原始邮件

 

 
" All RIFT routers MUST support IPv4 forwarding and MAY support IPv6 forwarding. A three way adjacency over IPv6 addresses implies support for IPv4 forwarding. "

 
--- tony 

--------------------------------------------------------------------------------

 

 

原始邮件

 
sending LIE only with v4 will not give you a v6 address to send to (since the LIE source address gives the gateway for the AF, that's why we send LIE per AF) so you won't have a v6 GW address to send TIEs to ;-)

yes, every interface is independent. Observe that v6 support implies v4 as the spec says (since you can FW v4 without a v4 GW if you have a v6 gateway). However, if one side sends v6 only and the other side only v4 they'll never go 3-way since they won't     be able to receive. We just added a sentence to the spec saying that if you don't send an AF LIE you MUST NOT receive the same AF LIE since we found that loose end in Bruno's implementation when testing security envelopes.  It will be in -07

IPv6/IPv4 prefix can be mixed in Prefix TIEs. Prefix TIEs do NOT care which interface/AF they are sent over. 

how you build forwarding table and which gateways you use is implemenation dependent but yes, you got the flavor. though your assumption of "Ipv6 destination with ipv4 nexthop" is optimistic. every silicon does v4 so v6 can imply v4, implying v4 fwd'ing     allows v6 forwarding fails on good amount of silicon. But again, those are all implementation knobs, spec only says "v6 implies v4" which means "you better fwd. v4 over v6 nexthops if you see v6 LIEs only"

 --- tony 

--------------------------------------------------------------------------------

Hi 

 

 

 

 

   

 

 

Thanks！

Benchong

---

From: Bruno Rijsman <[email-masked]>
Date: Fri, 12 Jul 2019 15:39:48 +0200

Hello Benchong,

Thank you!

RE> Is it possible to generate a valid v6 rib table as long as v4 address of the inteface is valid? 

My code needs an IPv6 address on the interface (which is allowed to be a link-local address) to install routes with an IPv6 destination prefix into the IPv6 RIB, because those routes currently need an IPv6 next-hop in my implementation.

And my code needs an IPv4 address on the interface to install routes with IPv4 prefixes into the IPv4 RIB, because those routes currently need an IPv4 next-hop in my implementation.

My code currently does not support installing routes with an IPv4 destination prefix into the IPv4 RIB with an IPv6 next-hop or vice versa, even on some hardware platforms that is technically feasible, albeit not very common. 

On some platforms you can install an IPv4 route with an IPv6 next-hop and the platform will resolve the IPv6 next-hop to an Ethernet MAC address which is then used to install the IPv4 route into the hardware (again - my code currently does not support this).

My code does support flooding IPv4 prefixes in a TIE packet which is carried in an IPv6 packet.  And vice versa, it also supports flooding IPv6 prefixes in aTIE packet which is carried in an IPv4 packet.

My code will always send both IPv4 and IPv6 LIEs on all adjacencies. Note that there is only one instance of the LIE finite state machine, not two (this is tricky corner of the protocol).

But for TIE flooding my code will send TIE/TIDE/TIRE packets either IPv4 or IPv6 on any given adjacency, depending on which LIEs it has seen from the neighbor. If it has seen both IPv4 and IPv6 LIEs from the neighbor, it will prefer IPv4.

RE> Can it support ipv4 and ipv6 double stack?

Yes, RIFT-Python can run on a dual-stack system that runs both IPv4 and IPv6. It can also run on an IPv4-only system as well as on an IPv6-only system.

As mentioned above, LIE packets will always be sent using IPv4 *and* IPv6, whereas flooding (TIDE/TIRE/TIE packets) will be sent *either* using IPv4 *or* IPv6, but either way the TIE packets will cary *both* IPv4 *and* IPv6 prefixes.

— Bruno

> On Jul 11, 2019, at 11:33 AM, [email-masked] wrote:
> 
> Hi, Bruno
>

---

From: Antoni Przygienda <[email-masked]>
Date: Fri, 12 Jul 2019 14:02:30 +0000

Benchong, ok, we're in sync then.

It seemed obvious to us that sending a v4 LIE will include a v4 source address and v6 equivalently a v6 source address (there is no other way) and obviously those are the directly connected so I omitted all that in the spec.

So spec says IMO enough as it is about the LIE issues including talking about same link locals on multiple links

"

An implementation MAY listen and send LIEs on IPv4 and/or
IPv6 multicast addresses.  LIEs on same link are considered
part of the same negotiation independent on the address family
they arrive on. Observe further
that the LIE source address may not identify
the peer uniquely in unnumbered or link-local address cases so
the response transmission MUST occur over the same interface the LIEs have been
received on. A node CAN use any of the adjacency's source addresses it
saw in
LIEs on the specific interface during adjacency formation to send TIEs.
That implies that an implementation MUST be ready to accept TIEs on
all addresses it used as source of LIE frames.

"

Yes, dynamic withdrawal of AFs is a rathole I would encourage e'one to stay away from. If AF goes away, we reset the adjacency.

--- tony
________________________________
From: [email-masked] <[email-masked]>
Sent: Friday, July 12, 2019 3:20 AM
To: Antoni Przygienda
Cc: [email-masked]; [email-masked]
Subject: Re:Fw:Re: Re:[Rift] Ipv4 and ipv6 cooperating in rift

Tony

"

"

thank you!

Benchong

原始邮件

"

"

--- tony

Hi, Bruno

----------

……

                port=tx_flood_port)

        else:

                port=tx_flood_port)

-----------------

                            spf_direction):

                if nhop:

                if nhop:

        else:

--------------

        ……

                prefix = dest_key

                else:

                if next_hops:

Thanks!

Benchong

原始邮件

makes sense?

--- tony

Hi tony

a) ND enable v6 first:

     V6 packet

     V4 packet

b) v4 first

If v4 address valid:

     V4 packet

     V6 packet

c) coexistence of v4v6

If v4 address valid:

     V4 packet

     V6 packet

Thanks!

Benchong

原始邮件

"

"

--- tony

原始邮件

--- tony

Hi

Thanks！

Benchong