Subject: [Rift] RFC 5549

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Jul 2019 20:16:03 +0000

https://tools.ietf.org/html/rfc5549

This is the BGP precedent for IPv4 forwarding over a v6 adjacency.

The next hop is resolved with AF v6 and the packet is v4.

I hope we can use that to avoid excessive amounts of text.

Regards,

Pascal

---

From: Bruno Rijsman <[email-masked]>
Date: Thu, 25 Jul 2019 22:52:31 +0200

Free Range Routing used this trick to support BGP routes with a destination IPv4 prefix but an IPv6 next-hop.

See https://www.theasciiconstruct.com/post/cumulus-basics-part-v-bgp-unnumbered <https://www.theasciiconstruct.com/post/cumulus-basics-part-v-bgp-unnumbered> (and search for the phrase "The NLRI describes an IPv4 subnet but the next hop is an IPv6 address.”).

— Bruno

> On Jul 25, 2019, at 10:16 PM, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> https://tools.ietf.org/html/rfc5549 <https://tools.ietf.org/html/rfc5549>
> 
> _______________________________________________
> RIFT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rift