Subject: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 13 Sep 2019 19:40:13 +0000

Hi RIFTers,

This email starts WG Last Call, IPR and implementation polling  for our base spec draft-ietf-rift-rift-08. It ends on 9/27.

Please thoroughly review the document and voice your support/objection.

If you’re a co-author/contributor, please explicitly respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR. The Document won't progress without answers from all the Authors and Contributors.

If you're not a co-author/contributor, you need to respond only if you are aware of any relevant IPR not yet disclosed in conformance with IETF rules.

Currently disclosed IPRs can be found here: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift.

We are also polling for any existing implementation.

Thanks!
Jeff and Jeffrey

-------------------------------

From: RIFT <[email-masked]> On Behalf Of Tony Przygienda
Sent: Monday, September 9, 2019 3:06 AM
To: [email-masked]
Subject: [Rift] LC version -08

LC ready version -08 has been posted 

Last few small changes based on input of people playing with both implementations in different scenarios

* A new prefix tie type has been added PositiveExternalDisaggregationPrefixTIEType since it is necessary to distinguish between normal prefix and external prefix being disaggregated to preserve priorities in complex redistribution scenarios. BTW, negative prefixes are always least preferred and hence they don't need to differentiate. 
* Link pair carries now indication whether BFD is up 9on the link. This allows at the top of the fabric not only see links that are secured and outer keys but also whether link is BFD protected/BFD is up
* NodeCapabilities are required now and minor protocol version is carried since there was no possiblity on adjacency building to check which minor verswion the peer speaks (major is carried in the envelope). Major version compatibility allows to aways decode the model but minor could be used in the future to understand minor schema variations

thanks 

--- tony

---

From: Alankar Sharma <[email-masked]>
Date: Fri, 13 Sep 2019 16:06:36 -0400

Support.
I am not aware of any undisclosed IPR.

Thanks,
Alankar Sharma

On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=
[email-masked]> wrote:

> Hi RIFTers,
>
> This email starts WG Last Call, IPR and implementation polling  for our
> base spec draft-ietf-rift-rift-08. It ends on 9/27.
>
> If you’re a co-author/contributor, please explicitly respond to this email
> and indicate whether or not you are aware of any relevant undisclosed IPR.
> The Document won't progress without answers from all the Authors and
> Contributors.
>
> If you're not a co-author/contributor, you need to respond only if you are
> aware of any relevant IPR not yet disclosed in conformance with IETF rules.
>
> Currently disclosed IPRs can be found here:
> https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift
> .
>
> * A new prefix tie type has been added
> PositiveExternalDisaggregationPrefixTIEType since it is necessary to
> distinguish between normal prefix and external prefix being disaggregated
> to preserve priorities in complex redistribution scenarios. BTW, negative
> prefixes are always least preferred and hence they don't need to
> differentiate.
> * Link pair carries now indication whether BFD is up 9on the link. This
> allows at the top of the fabric not only see links that are secured and
> outer keys but also whether link is BFD protected/BFD is up
> * NodeCapabilities are required now and minor protocol version is carried
> since there was no possiblity on adjacency building to check which minor
> verswion the peer speaks (major is carried in the envelope). Major version
> compatibility allows to aways decode the model but minor could be used in
> the future to understand minor schema variations
>
> thanks
>
> --- tony
> _______________________________________________
> RIFT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rift
>

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 13 Sep 2019 13:21:05 -0700

+1

not aware of any undisclosed IPR

On Fri, Sep 13, 2019 at 1:06 PM Alankar Sharma <[email-masked]> wrote:

>> If you’re a co-author/contributor, please explicitly respond to this
>> email and indicate whether or not you are aware of any relevant undisclosed
>> IPR. The Document won't progress without answers from all the Authors and
>> Contributors.
>>
>> If you're not a co-author/contributor, you need to respond only if you
>> are aware of any relevant IPR not yet disclosed in conformance with IETF
>> rules.
>>

---

From: Krzysztof Szarkowicz <[email-masked]>
Date: Fri, 13 Sep 2019 23:49:50 +0200

Support,

Not aware of any undisclosed IPR.

Thanks,
Krzysztof

> On 2019-Sep-13, at 22:21, Tony Przygienda <[email-masked]> wrote:
> 
> +1 
> 
> On Fri, Sep 13, 2019 at 1:06 PM Alankar Sharma <[email-masked] <mailto:[email-masked]>> wrote:
> Support. 
> On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=[email-masked] <mailto:[email-masked]>> wrote:
> Hi RIFTers,
> 
> Currently disclosed IPRs can be found here: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift <https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift>.
> 
> From: RIFT <[email-masked] <mailto:[email-masked]>> On Behalf Of Tony Przygienda
> To: [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>

---

From: magno <[email-masked]>
Date: Sat, 14 Sep 2019 00:01:15 +0200

Support please, customers are very interested.

Thanks
Max,

Il giorno ven 13 set 2019 alle ore 23:50 Krzysztof Szarkowicz <
[email-masked]> ha scritto:

>>> * NodeCapabilities are required now and minor protocol version is
>>> carried since there was no possiblity on adjacency building to check which
>>> minor verswion the peer speaks (major is carried in the envelope). Major
>>> version compatibility allows to aways decode the model but minor could be
>>> used in the future to understand minor schema variations
>>>
>>> thanks
>>>
>>> --- tony

---

From: Melchior Aelmans <[email-masked]>
Date: Sat, 14 Sep 2019 00:09:01 +0200

Support!

> Op 13 sep. 2019 om 21:40 heeft Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]> het volgende geschreven:
> 
> Hi RIFTers,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 14 Sep 2019 07:25:41 +0000

+1

Pascal

From: RIFT <[email-masked]> On Behalf Of Tony Przygienda
Sent: vendredi 13 septembre 2019 22:21
To: Alankar Sharma <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; [email-masked]; [email-masked]; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>
Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

+1

On Fri, Sep 13, 2019 at 1:06 PM Alankar Sharma <[email-masked]<mailto:[email-masked]>> wrote:
Support.
I am not aware of any undisclosed IPR.

Thanks,
Alankar Sharma

On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]<mailto:[email-masked]>> wrote:
Hi RIFTers,

Thanks!
Jeff and Jeffrey

From: RIFT <[email-masked]<mailto:[email-masked]>> On Behalf Of Tony Przygienda
Sent: Monday, September 9, 2019 3:06 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Rift] LC version -08

thanks

--- tony
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

---

From: Kazuki Shimizu <[email-masked]>
Date: Sun, 15 Sep 2019 04:51:04 +0900

+1

Regards,
Kazuki Shimizu

---

From: Kazuki Shimizu <[email-masked]>
Date: Sun, 15 Sep 2019 04:44:45 +0900

+1

Kazuki Shimizu

2019年9月14日(土) 16:26 Pascal Thubert (pthubert) <[email-masked]>:
> On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]> wrote:
>
> Hi RIFTers,
>

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 19 Sep 2019 09:09:58 -0700

As to implementation polling: Juniper has a -08 conform implementation

I think otherwise e'one's aware of the open source implementation on github
(it's @ -07, will need quick pulling up to -08)

thanks

--- tony

---

From: GangChen <[email-masked]>
Date: Fri, 20 Sep 2019 11:26:04 +0800

Support

Can anyone point me the prototype code link?  I would like to see the
functions how to fly.

Best Regards

Gang

Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]> 于2019年9月14日周六

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 19 Sep 2019 20:36:40 -0700

open source in

https://github.com/brunorijsman/rift-python

this is currently -07 version which is almost same as -08 (will be pulled
up shortly). Officially interoped at -07 level with Juniper (check IETF
proceedings for presos/docs). Best to learn the protocol, muck around,
contribute. Quite complete and extremely cleanly written.

Juniper's implementation (standalone packages for Linux and OSX) as free
download under

https://www.juniper.net/us/en/dm/free-rift-trial/

I'm aware of other efforts going on for a bit but no'one posted anything
yet

thanks

--- tony

On Thu, Sep 19, 2019 at 8:26 PM GangChen <[email-masked]> wrote:

> Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>
> 于2019年9月14日周六 上午3:40写道：
>
>> Hi RIFTers,
>>

---

From: <[email-masked]>
Date: Wed, 25 Sep 2019 14:21:33 +0800 (CST)

Support the advancement of this draft.

And ZTE is doing the implementation work about RIFT prototol.

Thanks,

Sandy

原始邮件

发件人：Jeffrey(Zhaohui)Zhang <zzhang=[email-masked]>
收件人：Jeff Tantsura <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年09月14日 03:41
主 题 ：[Rift] WGLC,IPR and Implementation polling for draft-ietf-rift-rift-08

Hi RIFTers,

Thanks!
Jeff and Jeffrey

thanks 

--- tony

---

From: Xufeng Liu <[email-masked]>
Date: Fri, 27 Sep 2019 09:44:55 -0400

Support.
Thanks,
- Xufeng

---

From: <[email-masked]>
Date: Sun, 29 Sep 2019 13:57:43 +0800 (CST)

Support ++

Best regards,

Corona Wei

原始邮件

发件人：XufengLiu <[email-masked]>
收件人：Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>;
抄送人：Jeff Tantsura <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年09月27日 22:29
主 题 ：Re: [Rift] WGLC,IPR and Implementation polling for draft-ietf-rift-rift-08

Support.
Thanks,
- Xufeng

Hi RIFTers,

Thanks!
Jeff and Jeffrey

thanks 

--- tony