Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

From: "don.fedyk" <[email-masked]>
Date: Sat, 14 Sep 2019 10:21:00 +0100

+1Not aware of any undisclosed IPR.DonSent via mobile. 
-------- Original message --------From: "Pascal Thubert (pthubert)" <[email-masked]> Date: 9/14/19  8:26 AM  (GMT+00:00) To: Tony Przygienda <[email-masked]>, Alankar Sharma <[email-masked]> Cc: Jeff Tantsura <[email-masked]>, [email-masked], [email-masked], "Jeffrey (Zhaohui) Zhang" <zzhang=[email-masked]> Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08 

+1 
 
not aware of any undisclosed IPR 
 
Pascal
 
From: RIFT <[email-masked]>
On Behalf Of Tony Przygienda
Sent: vendredi 13 septembre 2019 22:21
To: Alankar Sharma <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; [email-masked]; [email-masked]; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>
Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

+1 

not aware of any undisclosed IPR 

On Fri, Sep 13, 2019 at 1:06 PM Alankar Sharma <[email-masked]> wrote:

Support. 

I am not aware of any undisclosed IPR. 

Thanks,

Alankar Sharma 

On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]> wrote:

Hi RIFTers,

This email starts WG Last Call, IPR and implementation polling  for our base spec draft-ietf-rift-rift-08. It ends on 9/27.

Please thoroughly review the document and voice your support/objection.

If you’re a co-author/contributor, please explicitly respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR. The Document won't progress without answers from all the Authors and Contributors.

If you're not a co-author/contributor, you need to respond only if you are aware of any relevant IPR not yet disclosed in conformance with IETF rules.

Currently disclosed IPRs can be found here: 
https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift.

We are also polling for any existing implementation.

Thanks!
Jeff and Jeffrey

-------------------------------

From: RIFT <[email-masked]> On Behalf Of Tony Przygienda
Sent: Monday, September 9, 2019 3:06 AM
To: [email-masked]
Subject: [Rift] LC version -08

LC ready version -08 has been posted 

Last few small changes based on input of people playing with both implementations in different scenarios

* A new prefix tie type has been added PositiveExternalDisaggregationPrefixTIEType since it is necessary to distinguish between normal prefix and external prefix being disaggregated to preserve priorities in complex redistribution scenarios. BTW, negative prefixes
 are always least preferred and hence they don't need to differentiate. 
* Link pair carries now indication whether BFD is up 9on the link. This allows at the top of the fabric not only see links that are secured and outer keys but also whether link is BFD protected/BFD is up
* NodeCapabilities are required now and minor protocol version is carried since there was no possiblity on adjacency building to check which minor verswion the peer speaks (major is carried in the envelope). Major version compatibility allows to aways decode
 the model but minor could be used in the future to understand minor schema variations

thanks 

--- tony 
_______________________________________________
RIFT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rift

_______________________________________________
RIFT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rift

---

From: Bruno Rijsman <[email-masked]>
Date: Sat, 14 Sep 2019 16:15:51 +0200

I am not aware of any undisclosed IPR

— Bruno

> On Sep 14, 2019, at 11:21 AM, don.fedyk <[email-masked]> wrote:
> 
> +1
> 
> Not aware of any undisclosed IPR.
> 
> Don
> 
> 
> 
> Sent via mobile. 
> 
> -------- Original message --------
> From: "Pascal Thubert (pthubert)" <[email-masked]>
> Date: 9/14/19 8:26 AM (GMT+00:00)
> To: Tony Przygienda <[email-masked]>, Alankar Sharma <[email-masked]>
> Cc: Jeff Tantsura <[email-masked]>, [email-masked], [email-masked], "Jeffrey (Zhaohui) Zhang" <zzhang=[email-masked]>
> On Fri, Sep 13, 2019 at 1:06 PM Alankar Sharma <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Support. 
> 
> On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi RIFTers,
> 
> Currently disclosed IPRs can be found here: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift <https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift>.
> 
> From: RIFT <[email-masked] <mailto:[email-masked]>> On Behalf Of Tony Przygienda
> To: [email-masked] <mailto:[email-masked]>
> * A new prefix tie type has been added PositiveExternalDisaggregationPrefixTIEType since it is necessary to distinguish between normal prefix and external prefix being disaggregated to preserve priorities in complex redistribution scenarios. BTW, negative prefixes are always least preferred and hence they don't need to differentiate. 
> * NodeCapabilities are required now and minor protocol version is carried since there was no possiblity on adjacency building to check which minor verswion the peer speaks (major is carried in the envelope). Major version compatibility allows to aways decode the model but minor could be used in the future to understand minor schema variations
> 
> thanks 
> 
> --- tony 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>_______________________________________________
> RIFT mailing list
> [email-masked]

---

From: Oliver Steudler <[email-masked]>
Date: Sat, 14 Sep 2019 16:55:57 +0000

+1

Regards
Oliver

On 14 Sep 2019, at 16:16, Bruno Rijsman <[email-masked]<mailto:[email-masked]>> wrote:

— Bruno

On Sep 14, 2019, at 11:21 AM, don.fedyk <[email-masked]<mailto:[email-masked]>> wrote:

+1

Don

Sent via mobile.

-------- Original message --------
From: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
Date: 9/14/19 8:26 AM (GMT+00:00)
To: Tony Przygienda <[email-masked]<mailto:[email-masked]>>, Alankar Sharma <[email-masked]<mailto:[email-masked]>>
Cc: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, "Jeffrey (Zhaohui) Zhang" <zzhang=[email-masked]<mailto:zzhang=[email-masked]>>
Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

+1

Pascal

From: RIFT <[email-masked]<mailto:[email-masked]>> On Behalf Of Tony Przygienda
Sent: vendredi 13 septembre 2019 22:21
To: Alankar Sharma <[email-masked]<mailto:[email-masked]>>
Cc: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]<mailto:zzhang=[email-masked]>>
Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

+1

On Fri, Sep 13, 2019 at 1:06 PM Alankar Sharma <[email-masked]<mailto:[email-masked]>> wrote:
Support.
I am not aware of any undisclosed IPR.

Thanks,
Alankar Sharma

On Fri, Sep 13, 2019 at 3:40 PM Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]<mailto:[email-masked]>> wrote:
Hi RIFTers,

Currently disclosed IPRs can be found here: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift<https://urldefense.com/v3/__https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift__;!8WoA6RjC81c!VE1lTw-v0G41nXxHaCHMA4uk2W4gBWq1IbYUgUN1HWwa-Sl6XTYgp9RyI1hIE_srLA$>.

Thanks!
Jeff and Jeffrey

From: RIFT <[email-masked]<mailto:[email-masked]>> On Behalf Of Tony Przygienda
Sent: Monday, September 9, 2019 3:06 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Rift] LC version -08

thanks

--- tony
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!8WoA6RjC81c!VE1lTw-v0G41nXxHaCHMA4uk2W4gBWq1IbYUgUN1HWwa-Sl6XTYgp9RyI1grXLxBNA$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!8WoA6RjC81c!VE1lTw-v0G41nXxHaCHMA4uk2W4gBWq1IbYUgUN1HWwa-Sl6XTYgp9RyI1grXLxBNA$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!8WoA6RjC81c!VE1lTw-v0G41nXxHaCHMA4uk2W4gBWq1IbYUgUN1HWwa-Sl6XTYgp9RyI1grXLxBNA$

---

From: Randy Bush <[email-masked]>
Date: Sat, 14 Sep 2019 12:13:26 -0700

> I am not aware of any undisclosed IPR

occasionally, english is subtle.  it might be polite to point out that
there is disclosed ipr, see https://datatracker.ietf.org/ipr/3343/

randy