Subject: Re: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

From: Ilya Vershkov <[email-masked]>
Date: Thu, 3 Oct 2019 16:38:53 +0300

+1

not aware of any undisclosed IPR

Ilya

On Fri, 13 Sep 2019 at 22:40, Jeffrey (Zhaohui) Zhang <zzhang=
[email-masked]> wrote:

> Hi RIFTers,
>
> This email starts WG Last Call, IPR and implementation polling  for our
> base spec draft-ietf-rift-rift-08. It ends on 9/27.
>
> Please thoroughly review the document and voice your support/objection.
>
> If you’re a co-author/contributor, please explicitly respond to this email
> and indicate whether or not you are aware of any relevant undisclosed IPR.
> The Document won't progress without answers from all the Authors and
> Contributors.
>
> If you're not a co-author/contributor, you need to respond only if you are
> aware of any relevant IPR not yet disclosed in conformance with IETF rules.
>
> Currently disclosed IPRs can be found here:
> https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift
> .
>
> We are also polling for any existing implementation.
>
> Thanks!
> Jeff and Jeffrey
>
> -------------------------------
>
> From: RIFT <[email-masked]> On Behalf Of Tony Przygienda
> Sent: Monday, September 9, 2019 3:06 AM
> To: [email-masked]
> Subject: [Rift] LC version -08
>
> LC ready version -08 has been posted
>
> Last few small changes based on input of people playing with both
> implementations in different scenarios
>
> * A new prefix tie type has been added
> PositiveExternalDisaggregationPrefixTIEType since it is necessary to
> distinguish between normal prefix and external prefix being disaggregated
> to preserve priorities in complex redistribution scenarios. BTW, negative
> prefixes are always least preferred and hence they don't need to
> differentiate.
> * Link pair carries now indication whether BFD is up 9on the link. This
> allows at the top of the fabric not only see links that are secured and
> outer keys but also whether link is BFD protected/BFD is up
> * NodeCapabilities are required now and minor protocol version is carried
> since there was no possiblity on adjacency building to check which minor
> verswion the peer speaks (major is carried in the envelope). Major version
> compatibility allows to aways decode the model but minor could be used in
> the future to understand minor schema variations
>
> thanks
>
> --- tony
> _______________________________________________
> RIFT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rift
>

---

From: John E Drake <[email-masked]>
Date: Thu, 3 Oct 2019 13:34:15 +0000

I'm not aware of any IPR

Yours Irrespectively,

John

Juniper Business Use Only

> -----Original Message-----
> From: RIFT <[email-masked]> On Behalf Of Jeffrey (Zhaohui) Zhang
> Sent: Friday, September 13, 2019 3:40 PM
> To: Jeff Tantsura <[email-masked]>; [email-masked]; [email-masked]
> Subject: [Rift] WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08
> 
> Hi RIFTers,
> 
> This email starts WG Last Call, IPR and implementation polling  for our base spec
> draft-ietf-rift-rift-08. It ends on 9/27.
> 
> If you’re a co-author/contributor, please explicitly respond to this email and
> indicate whether or not you are aware of any relevant undisclosed IPR. The
> Document won't progress without answers from all the Authors and
> Contributors.
> 
> If you're not a co-author/contributor, you need to respond only if you are aware
> of any relevant IPR not yet disclosed in conformance with IETF rules.
> 
> https://urldefense.com/v3/__https://datatracker.ietf.org/ipr/search/?submit=d
> raft&id=draft-ietf-rift-
> rift__;!8WoA6RjC81c!QQna6FyHFRI_cYdCSL_wFGTMhhYpbMs80q6YgHBdQYE8F
> hHfr5AD9RRTgSdNd4g$ .
> 
> PositiveExternalDisaggregationPrefixTIEType since it is necessary to distinguish
> between normal prefix and external prefix being disaggregated to preserve
> priorities in complex redistribution scenarios. BTW, negative prefixes are always
> least preferred and hence they don't need to differentiate.
> * Link pair carries now indication whether BFD is up 9on the link. This allows at
> the top of the fabric not only see links that are secured and outer keys but also
> whether link is BFD protected/BFD is up
> * NodeCapabilities are required now and minor protocol version is carried since
> there was no possiblity on adjacency building to check which minor verswion the
> peer speaks (major is carried in the envelope). Major version compatibility
> allows to aways decode the model but minor could be used in the future to
> understand minor schema variations
> 
> thanks
> 
> --- tony
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!8W
> oA6RjC81c!QQna6FyHFRI_cYdCSL_wFGTMhhYpbMs80q6YgHBdQYE8FhHfr5AD9
> RRTdLJzx24$

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 3 Oct 2019 08:42:17 -0700

---

From: Alia Atlas <[email-masked]>
Date: Thu, 3 Oct 2019 15:13:46 -0400

I am not aware of any undisclosed IPR.

On Thu, Oct 3, 2019 at 11:43 AM Tony Przygienda <[email-masked]> wrote:

>> If you’re a co-author/contributor, please explicitly respond to this
>> email and indicate whether or not you are aware of any relevant undisclosed
>> IPR. The Document won't progress without answers from all the Authors and
>> Contributors.
>>
>> If you're not a co-author/contributor, you need to respond only if you
>> are aware of any relevant IPR not yet disclosed in conformance with IETF
>> rules.
>>

---

From: Dmitry Afanasiev <[email-masked]>
Date: Tue, 08 Oct 2019 19:49:47 +0300

+ rift@

- all

--

Dmitry

[skip]

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 9 Oct 2019 20:05:34 +0000

Hi,

Though with some delay in getting IPR statement from all co-authors, the WGLC for draft-ietf-rift-rift-08 has concluded with lots of support and no concerns raised.

There are two existing interoperable implementations as described in https://mailarchive.ietf.org/arch/msg/rift/0VpvFOUQ3M5p0JvtM1xGdCvp0_g, plus another ongoing implementation that we know of.
 
We now proceed to the next stage for the specification.

Thanks!
Jeff & Jeffrey

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang 
Sent: Friday, September 13, 2019 3:40 PM
To: Jeff Tantsura <[email-masked]>; [email-masked]; [email-masked]
Subject: WGLC, IPR and Implementation polling for draft-ietf-rift-rift-08

Hi RIFTers,

This email starts WG Last Call, IPR and implementation polling  for our base spec draft-ietf-rift-rift-08. It ends on 9/27.

If you’re a co-author/contributor, please explicitly respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR. The Document won't progress without answers from all the Authors and Contributors.

If you're not a co-author/contributor, you need to respond only if you are aware of any relevant IPR not yet disclosed in conformance with IETF rules.

Currently disclosed IPRs can be found here: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rift-rift.

Thanks!
Jeff and Jeffrey

Last few small changes based on input of people playing with both implementations in different scenarios

* A new prefix tie type has been added PositiveExternalDisaggregationPrefixTIEType since it is necessary to distinguish between normal prefix and external prefix being disaggregated to preserve priorities in complex redistribution scenarios. BTW, negative prefixes are always least preferred and hence they don't need to differentiate. 
* Link pair carries now indication whether BFD is up 9on the link. This allows at the top of the fabric not only see links that are secured and outer keys but also whether link is BFD protected/BFD is up
* NodeCapabilities are required now and minor protocol version is carried since there was no possiblity on adjacency building to check which minor verswion the peer speaks (major is carried in the envelope). Major version compatibility allows to aways decode the model but minor could be used in the future to understand minor schema variations

thanks 

--- tony