Subject: [Rift] ZTP FSM is accidentally LIE FSM?

From: Bruno Rijsman <[email-masked]>
Date: Wed, 11 Dec 2019 20:12:27 -0600

Hi Tony,

Whilst in the process of adding ASCII art (instead of dot files) for the state machines, I happened to look at section 4.2.7.5.  ZTP FSM in https://www.ietf.org/id/draft-ietf-rift-rift-09.txt <https://www.ietf.org/id/draft-ietf-rift-rift-09.txt>.

It seems to me that the text in <!-- begin generated output —> for the ZTP FSM accidentally contains the LIE FSM instead of the ZTP FSM. 

I am seeing states like OneWay, TwoWay, ThreeWay, but I was expecting to see states like UpdatingClients, HoldingDown, and ComputeBestOffer.

Copy-and-paste mistake on your side, or misreading on my side?

— Bruno

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 12 Dec 2019 06:20:02 +0000

Checking 😉

From: Bruno Rijsman <[email-masked]>
Date: Thursday, December 12, 2019 at 3:12 AM
To: Tony Przygienda <[email-masked]>, Antoni Przygienda <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: ZTP FSM is accidentally LIE FSM?

Hi Tony,

Whilst in the process of adding ASCII art (instead of dot files) for the state machines, I happened to look at section 4.2.7.5. ZTP FSM in https://www.ietf.org/id/draft-ietf-rift-rift-09.txt<https://urldefense.com/v3/__https:/www.ietf.org/id/draft-ietf-rift-rift-09.txt__;!!NEt6yMaO-gk!X1nKW8mngPInaaLu8E-pz80edew3boHfjpA4kTshngsf6YkI15Xohu14_p1SQQ$>.

It seems to me that the text in <!-- begin generated output
—>
for the ZTP FSM accidentally contains the LIE FSM instead of the ZTP FSM.

— Bruno