Subject: [Rift] Adoption call for draft-wei-rift-applicability-02

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 3 Feb 2020 20:22:47 +0000

Hi,

This starts a two-week adoption call for draft-wei-rift-applicability-02, ending on February 17.

Authors - please explicitly respond to the list if you're aware of any undisclosed IPRs.
Others - if you're aware of any undisclosed IPRs, please respond to the list as well.

Thanks!
Jeffrey

---

From: <[email-masked]>
Date: Tue, 4 Feb 2020 09:57:00 +0800 (CST)

Hi Chair,

As one of the authors, I am not aware of any undisclosed IPRs.

Best Regards,

Yuehua Wei

原始邮件

发件人：Jeffrey(Zhaohui)Zhang <zzhang=[email-masked]>
收件人：[email-masked] <[email-masked]>;
日 期 ：2020年02月04日 04:23
主 题 ：[Rift] Adoption call for draft-wei-rift-applicability-02

Hi,

Thanks!
Jeffrey

_______________________________________________
RIFT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rift

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 3 Feb 2020 18:32:24 -0800

support

On Mon, Feb 3, 2020 at 5:57 PM <[email-masked]> wrote:

> *Best Regards,*
> *发件人：*Jeffrey(Zhaohui)Zhang <zzhang=[email-masked]>
> *收件人：[email-masked] <[email-masked]>;
> *日 期 ：*2020年02月04日 04:23
> *主 题 ：**[Rift] Adoption call for draft-wei-rift-applicability-02*
> Hi,
>
>

---

From: <[email-masked]>
Date: Tue, 4 Feb 2020 11:48:29 +0800 (CST)

Support the adoption as co-author. I am not aware of any undisclosed IPRs.

Thanks,

Sandy

原始邮件

Hi,

Thanks!
Jeffrey

---

From: Bruno Rijsman <[email-masked]>
Date: Wed, 5 Feb 2020 07:34:24 -0600

I already sent a separate e-mail to express my support for adopting this as a working group document. (I forgot to mention that I am not aware of any undisclosed IPR.)

Here are my comments on the draft itself:

In general, this is a very well written document. 

[Editorial] Figure 1 label: use "RIFT" instead of "Rift".

"And RIFT eliminates the disadvantages of Link-State or Distance Vector: [...] Automatic Neighbor Detection." Can you rephrase or elaborate? It seems to me that legacy LS and DV also do "automatically detect neighbors". Maybe you mean "Automatic Detection of Miscabled Neighbors"?

[Editorial] "There are a bunch of more advantages" -> "There are additional advantages"

[Editorial] "This observations hold not only in case of RIFT but in the generic case of dynamic routing on Clos variants with multiple planes and failures in bi-sectional bandwidth, especially on the leafs." -> not sure what this sentence adds; suggest removing it.

The section "Vertical Shortcuts" is somewhat ambiguous. On the one hand it says that vertical shortcuts are supported. But on the other hand, it gives some general indications that they are a bad idea without getting too much into the details. Let's be clear. Either we support them and spell out what the disadvantages are. Or we don't support them and just say so.

I am not sure what an "isomorphic equivalent of a Clos topology" is. How is it different from just a regular Clos topology?

[Editorial] "rely on 1:/+1 protection schemes" -> "rely on 1:1 or 1+1 protection schemes"

"RIFT is neither IP specific and hence any link addressing connecting internal device subnets is conceivable." -> Can you elaborate? RIFT as it is defined today is in fact IP specific; it currently does not support any address families beyond IPv4 and IPv6.

[General comment] The document mentions "minimize blast radius" several times. It would be good to add a sentence somewhere to explain why (i.e. what attribute of RIFT causes it to have a smaller blast radius than traditional LS and DV protocols?)

"RIFT inherently solves many difficult problems associated with" -> This is a bit too vague. Be more specific (just list the specific problems, as is done later in the section.)

"Many further operational and design points collected over many years of routing protocol deployments have been incorporated in RIFT" -> This is a bit too vague. Be more specific (just list the specific enhancements, as is done later in the section.)

I would add two topics:

(1) We should mention that leaf nodes cannot reliably ping spine nodes (because they only have a default route). This is something to be aware of for operations. (Maybe you already mentioned it somewhere and I missed it.)

(2) We should mention something about upgrading software on the network. Currently, it is quite likely that the major version of the schema will have to be bumped when there is any significant enhancement to the the protocol. The capability negotiation mechanism has not yet proven itself (all changes in the protocol so far have been major version bumps.)

— Bruno

> On Feb 3, 2020, at 2:22 PM, Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]> wrote:
> 
> Hi,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 6 Feb 2020 08:20:06 +0000

Support for the reasons already posted on a different thread.

Q: Shouldn’t we aim for informational?

Pascal

From: RIFT <[email-masked]> On Behalf Of Tony Przygienda
Sent: mardi 4 février 2020 03:32
To: [email-masked]
Cc: [email-masked]; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>
Subject: Re: [Rift] Adoption call for draft-wei-rift-applicability-02

support

On Mon, Feb 3, 2020 at 5:57 PM <[email-masked]<mailto:[email-masked]>> wrote:

Hi Chair,

Best Regards,

Yuehua Wei

原始邮件
发件人：Jeffrey(Zhaohui)Zhang <zzhang=[email-masked]<mailto:[email-masked]>>
收件人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年02月04日 04:23
主 题 ：[Rift] Adoption call for draft-wei-rift-applicability-02
Hi,

Thanks!
Jeffrey

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 6 Feb 2020 08:52:40 +0000

Pushed the xml2rfc v3 converted file.

Corona, please:

* note when you publish to datatracker that you should only upload the xml file not he text file. There will be no need to rename the xml file, just do +1 in the document name in the xml source after the publication.
* check that the text is as expected (I did and found it OK but since you made changes from draft 02 you may still take a look.
* consider moving references that are not mandatory to understand the spec in the informational references section.

I can move on and start editing as soon as you (technically the chairs after the adoption) give me your green light to add myself as an author.
If you plan no change in the near future I can edit in the main repo, but if you prefer I can fork as well.

Please let me know;

Pascal

From: RIFT <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: jeudi 6 février 2020 09:20
To: Tony Przygienda <[email-masked]>; [email-masked]
Cc: [email-masked]; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]>
Subject: Re: [Rift] Adoption call for draft-wei-rift-applicability-02

Pascal

From: RIFT <[email-masked]<mailto:[email-masked]>> On Behalf Of Tony Przygienda
Sent: mardi 4 février 2020 03:32
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]<mailto:zzhang=[email-masked]>>
Subject: Re: [Rift] Adoption call for draft-wei-rift-applicability-02

support

Hi Chair,

Best Regards,

Yuehua Wei

原始邮件

Thanks!
Jeffrey

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 6 Feb 2020 15:47:10 -0800

Support the WG adoption.

Regards,
Greg

On Thu, Feb 6, 2020, 00:20 Pascal Thubert (pthubert) <[email-masked]>
wrote:

> *From:* RIFT <[email-masked]> *On Behalf Of *Tony Przygienda
> *Sent:* mardi 4 février 2020 03:32
> *To:* [email-masked]
> *Cc:* [email-masked]; Jeffrey (Zhaohui) Zhang <zzhang=
> [email-masked]>
> *Subject:* Re: [Rift] Adoption call for draft-wei-rift-applicability-02
>
>
>
> support
>
>
>
> *日* *期* *：*2020年02月04日 04:23
>
> *主* *题* *：**[Rift] Adoption call for draft-wei-rift-applicability-02*
>
> Hi,
>
>

---

From: Krzysztof Grzegorz Szarkowicz <[email-masked]>
Date: Thu, 20 Feb 2020 13:46:35 +0100

+1

> On 2020 -Feb-07, at 00:47, Greg Mirsky <[email-masked]> wrote:
> 
> Support the WG adoption. 
> 
> Regards,
> Greg
> 
> On Thu, Feb 6, 2020, 00:20 Pascal Thubert (pthubert) <[email-masked] <mailto:pthubert@cisco..com>> wrote:
> Support for the reasons already posted on a different thread..
> 
>  
> 
> From: RIFT <[email-masked] <mailto:[email-masked]>> On Behalf Of Tony Przygienda
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked] <mailto:[email-masked]>>
> On Mon, Feb 3, 2020 at 5:57 PM <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi Chair,
> 
> 发件人：Jeffrey(Zhaohui)Zhang <zzhang=[email-masked] <mailto:[email-masked]>>
> 
> 收件人：[email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>;
> 
> 日 期 ：2020年02月04日 04:23
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>
>  
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>_______________________________________________
> RIFT mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rift <https://www.ietf.org/mailman/listinfo/rift>

---

From: Alankar Sharma <[email-masked]>
Date: Thu, 20 Feb 2020 07:14:17 -0600

Support.

On Thu, Feb 20, 2020 at 6:47 AM Krzysztof Grzegorz Szarkowicz <
[email-masked]> wrote:

> On Thu, Feb 6, 2020, 00:20 Pascal Thubert (pthubert) <[email-masked]
> <pthubert@cisco..com>> wrote:
>

---

From: Kowalczyk Jarosław 2 - Hurt <[email-masked]>
Date: Thu, 20 Feb 2020 13:44:56 +0000

Chair,

As one of the draft-wei-rift-applicability-02  authors, I am not aware of any undisclosed IPRs.

Best regards,
Jaroslaw Kowalczyk

From: RIFT [mailto:[email-masked]] On Behalf Of Krzysztof Grzegorz Szarkowicz
Sent: Thursday, February 20, 2020 1:47 PM
To: [email-masked]
Subject: Re: [Rift] Adoption call for draft-wei-rift-applicability-02

+1

On 2020 -Feb-07, at 00:47, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Support the WG adoption.

Regards,
Greg

On Thu, Feb 6, 2020, 00:20 Pascal Thubert (pthubert) <[email-masked]<mailto:pthubert@cisco..com>> wrote:
Support for the reasons already posted on a different thread..

Pascal

Cc: [email-masked]<mailto:[email-masked]>; Jeffrey (Zhaohui) Zhang <zzhang=[email-masked]<mailto:[email-masked]>>

support

Best Regards,
Yuehua Wei

原始邮件

Thanks!
Jeffrey

---

From: Oliver Steudler <[email-masked]>
Date: Thu, 20 Feb 2020 13:57:22 +0000

+ 1

On 20 Feb 2020, at 13:47, Krzysztof Grzegorz Szarkowicz <[email-masked]> wrote:

 +1

Support the WG adoption.

Regards,
Greg

Pascal

support

Hi Chair,

Best Regards,
Yuehua Wei

原始邮件

Thanks!
Jeffrey

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

_______________________________________________
RIFT mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$

---

From: Fabian Prou <[email-masked]>
Date: Thu, 20 Feb 2020 14:28:22 +0000

+1

From: RIFT <[email-masked]> On Behalf Of Oliver Steudler
Sent: Thursday, 20 February, 2020 14:57
To: [email-masked]
Cc: Krzysztof Grzegorz Szarkowicz <[email-masked]>
Subject: Re: [Rift] Adoption call for draft-wei-rift-applicability-02

+ 1

On 20 Feb 2020, at 13:47, Krzysztof Grzegorz Szarkowicz <[email-masked]<mailto:[email-masked]>> wrote:
 +1

Support the WG adoption.

Regards,
Greg

Pascal

support

Best Regards,
Yuehua Wei

原始邮件

Thanks!
Jeffrey

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!WRAGuLDUeWZHpXzm3pSr8A4xKvjnFiB5e2Y7sc-4zjwyq2-FLdm4quhmYeL5uKOBTg$>

---

From: Dmitry Afanasiev <[email-masked]>
Date: Thu, 20 Feb 2020 18:53:47 +0300

Hi!

Support as a co-author and not aware of any undisclosed IPRs.

Regards,

Dmitry

03.02.2020, 23:22, "Jeffrey (Zhaohui) Zhang" <zzhang=[email-masked]>:

Hi,

Thanks!
Jeffrey

---

From: Jordan Head <[email-masked]>
Date: Thu, 20 Feb 2020 16:18:14 +0000

I support this for WG adoption.

Jordan Head
JNCIE-SP 2728 | JNCIE-DC 271
Resident Engineer – Staff
Cell: +1 (703) 732-5353
[email-masked]<mailto:[email-masked]>

From: RIFT <[email-masked]> on behalf of Krzysztof Grzegorz Szarkowicz <[email-masked]>
Date: Thursday, February 20, 2020 at 7:47 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Rift] Adoption call for draft-wei-rift-applicability-02

+1

Support the WG adoption.

Regards,
Greg

Pascal

support

Best Regards,
Yuehua Wei

原始邮件

Thanks!
Jeffrey

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!UiBgOJicbY8WuIysG5mmQfK9X-W_uNRs6ovF2JA-8BJQKmDu195oNk3KD0XtxKU$>

_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!UiBgOJicbY8WuIysG5mmQfK9X-W_uNRs6ovF2JA-8BJQKmDu195oNk3KD0XtxKU$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rift__;!!NEt6yMaO-gk!UiBgOJicbY8WuIysG5mmQfK9X-W_uNRs6ovF2JA-8BJQKmDu195oNk3KD0XtxKU$>
_______________________________________________
RIFT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rift

---

From: Melchior Aelmans <[email-masked]>
Date: Fri, 21 Feb 2020 10:39:12 +1100

I support this draft. Thanks for the effort so far!

On Fri, Feb 21, 2020 at 12:45 AM Kowalczyk Jarosław 2 - Hurt <
[email-masked]> wrote:

> *From:* RIFT [mailto:[email-masked]] *On Behalf Of *Krzysztof
> Grzegorz Szarkowicz
> *Sent:* Thursday, February 20, 2020 1:47 PM
> *To:* [email-masked]

---

From: Tom Verhaeg <[email-masked]>
Date: Fri, 21 Feb 2020 16:15:28 +0000

Hi,

I hereby support as a co-author and am not aware of any undisclosed IPR's.
 
Thanks,

Tom

    -----Original Message-----
    From: Jeffrey (Zhaohui) Zhang 
    Sent: Monday, February 3, 2020 3:23 PM
    To: [email-masked]
    Subject: Adoption call for draft-wei-rift-applicability-02
    
    Hi,

    
    Thanks!
    Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 21 Feb 2020 17:54:16 +0000

Hi,

We have received IPR statement from all co-authors and many support replies for the adoption. The document is now adopted.

Authors - please repost the -02 revision as WG document and change it to Information track as pointed out by Pascal.

Thanks.
Jeffrey

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang 
Sent: Monday, February 3, 2020 3:23 PM
To: [email-masked]
Subject: Adoption call for draft-wei-rift-applicability-02

Hi,

Thanks!
Jeffrey

---

From: <[email-masked]>
Date: Sat, 22 Feb 2020 17:18:24 +0800 (CST)

Hi

Thank chairs, co-authors and contributors.

I will repost the -02 revision as WG document and change it to Information track as soon as possible.

Best Regards,

魏月华 Corona Wei

M: +86 13851460269 E: [email-masked]

原始邮件

发件人：Jeffrey(Zhaohui)Zhang <zzhang=[email-masked]>
收件人：[email-masked] <[email-masked]>;魏月华00019655;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年02月22日 02:01
主 题 ：Re: [Rift] Adoption call for draft-wei-rift-applicability-02

Hi,

Thanks.
Jeffrey

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang 
Sent: Monday, February 3, 2020 3:23 PM
To: [email-masked]
Subject: Adoption call for draft-wei-rift-applicability-02

Hi,

Thanks!
Jeffrey