Subject: Re: [Rift] RIB to FIB conversion for Negative Disaggregation

From: Tony Przygienda <[email-masked]>
Date: Fri, 3 Apr 2020 09:53:40 -0700

That was fast ;-)

BTW, I'm cc:ing [email-masked] list which I recommend to keep in loop on the
progress, you may get help, good early comments, other reactions from
community ;-)

I ran the stuff, would benefit from printing the table out between steps in
the tests for easier understanding when people look @ it.

Yes, negative preconditions patricia (there are other structures taht keep
parents but they far less common) and I was mildly surprised to find one
was written in python already. not an easy structure to get right ...

--- tony

On Fri, Apr 3, 2020 at 8:07 AM Mariano Scazzariello <
[email-masked]> wrote:

> Dear all,
> me and Tommaso (CC) finished to implement a proof of concept code for the
> RIB=>FIB conversion that handles negative disaggregation. Code is attached
> to this email.
>
> This code is completely independent from the rift-python, and its only
> purpose is to validate our idea.
> The RIB uses the pytricia <https://github.com/jsommers/pytricia> Python
> library as already mentioned in the last meeting with Bruno.
> We included a file called test.py (runnable with pytest) based on the
> negative disaggregation examples in Pascal slides (55-61). Of course, we
> also added other scenarios that we think are important but probably we
> still forgot to consider some others.
>
> Please review our code and idea and if you have any suggestions we're
> happy to discuss about them.
>
> Thanks for your time,
> Mariano.
>
>

---

From: Mariano Scazzariello <[email-masked]>
Date: Fri, 3 Apr 2020 19:48:02 +0200

Hi Tony,
sorry I'll include mailing list next time!

The test.py file was designed to be run in pytest. However, you can call 
the test_* functions individually and use 
`rib.get_rib_fib_representation()`. This function prints the resulting 
RIB/FIB.

The pytricia library works quite well out of the box, maybe a 
"large-scale" performance test is needed. If anyone has other ideas (or 
other Python libraries to suggest), we're open to try new things!

Thanks,
Mariano.

Il 03/04/2020 18:53, Tony Przygienda ha scritto:
> That was fast ;-)
>
> BTW, I'm cc:ing [email-masked] <mailto:[email-masked]> list which I 
> recommend to keep in loop on the progress, you may get help, good 
> early comments, other reactions from community ;-)
>
> I ran the stuff, would benefit from printing the table out between 
> steps in the tests for easier understanding when people look @ it.
>
> Yes, negative preconditions patricia (there are other structures taht 
> keep parents but they far less common) and I was mildly surprised to 
> find one was written in python already. not an easy structure to get 
> right ...
>
> --- tony
>
> On Fri, Apr 3, 2020 at 8:07 AM Mariano Scazzariello 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     Dear all,
>     me and Tommaso (CC) finished to implement a proof of concept code
>     for the RIB=>FIB conversion that handles negative disaggregation.
>     Code is attached to this email.
>
>     This code is completely independent from the rift-python, and its
>     only purpose is to validate our idea.
>     The RIB uses the pytricia <https://github.com/jsommers/pytricia>
>     Python library as already mentioned in the last meeting with Bruno.
>     We included a file called test.py (runnable with pytest) based on
>     the negative disaggregation examples in Pascal slides (55-61). Of
>     course, we also added other scenarios that we think are important
>     but probably we still forgot to consider some others.
>
>     Please review our code and idea and if you have any suggestions
>     we're happy to discuss about them.
>
>     Thanks for your time,
>     Mariano.
>

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 3 Apr 2020 12:37:33 -0700

Mariano,

I have added you to RIFT filter-list, however please do subscribe to RIFT mailing-list.

Cheers,
Jeff
On Apr 3, 2020, 12:36 PM -0700, Mariano Scazzariello <[email-masked]>, wrote:
> The test.py file was designed to be run in pytest. However, you can call the test_* functions individually and use `rib.get_rib_fib_representation()`. This function prints the resulting RIB/FIB.
>
> The pytricia library works quite well out of the box, maybe a "large-scale" performance test is needed. If anyone has other ideas (or other Python libraries to suggest), we're open to try new things!
>
> Thanks,
> Mariano.
> > BTW, I'm cc:ing [email-masked] list which I recommend to keep in loop on the progress, you may get help, good early comments, other reactions from community ;-)
> >
> > I ran the stuff, would benefit from printing the table out between steps in the tests for easier understanding when people look @ it.
> >
> > Yes, negative preconditions patricia (there are other structures taht keep parents but they far less common) and I was mildly surprised to find one was written in python already. not an easy structure to get right ...
> >
> > --- tony
> >
> > > On Fri, Apr 3, 2020 at 8:07 AM Mariano Scazzariello <[email-masked]> wrote:
> > > > Dear all,
> > > > me and Tommaso (CC) finished to implement a proof of concept code for the RIB=>FIB conversion that handles negative disaggregation. Code is attached to this email.
> > > >
> > > > This code is completely independent from the rift-python, and its only purpose is to validate our idea.
> > > > The RIB uses the pytricia Python library as already mentioned in the last meeting with Bruno.
> > > > We included a file called test.py (runnable with pytest) based on the negative disaggregation examples in Pascal slides (55-61). Of course, we also added other scenarios that we think are important but probably we still forgot to consider some others.
> > > >
> > > > Please review our code and idea and if you have any suggestions we're happy to discuss about them.
> > > >
> > > > Thanks for your time,
> > > > Mariano.
> > > >
> _______________________________________________
> RIFT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rift

---

From: Bruno Rijsman <[email-masked]>
Date: Thu, 9 Apr 2020 18:01:02 -0600

See my initial comments in the attached word document.

The document refers to some example code, which is also attached.

— Bruno

> On Apr 8, 2020, at 11:57 AM, Mariano Scazzariello <[email-masked]> wrote:
> 
> Hi Bruno,
> we hope you're doing fine in Guatemala.
> 
> Tomorrow we'll present our Fat Tree Tools at the RIFT Virtual Meeting and we'll show our progresses about the negative disaggregation implementation. Will you attend to the meeting?
> 
> Also, have you checked our proof of concept code for RIB=>FIB conversion? We attach a new version (with some bug fixes and a demo.py file which outputs the RIB/FIB for each scenario described in Pascal slides).
> 
> About the implementation, we're waiting for your reviews on Trello. Leo from Uruguay implemented the print in the special SPF Table (check the comments of that task please!!!).
> 
> Hope to hear you soon, stay well.
> 
> Mariano and Tommaso.