Subject: [Rift] Negative disaggregation implemented

From: Bruno Rijsman <[email-masked]>
Date: Sun, 3 May 2020 10:55:13 -0600

Mariano Scazzariello and Tommaso Caiazzi informed me that they completed the implementation negative disaggregation in the open source RIFT-Python implementation (including new unit tests).

I want to extend a heart-felt “thank you very much!” to Mariano and Tommaso for their excellent work and their generous contribution of this important feature!  

I wish them good luck in using the newly implemented code in their further research on Kathará (https://www.youtube.com/watch?v=ionEpKjv3Vk <https://www.youtube.com/watch?v=ionEpKjv3Vk>) and Megalos (https://www.youtube.com/watch?v=XvInh-kujrA <https://www.youtube.com/watch?v=XvInh-kujrA>).

I have merged all of their code into my master branch: https://github.com/brunorijsman/rift-python <https://github.com/brunorijsman/rift-python>

My next steps are:

1) Do additional testing off negative disaggregation and polish up the code if needed.

2) Update the meta-topology generation tools to support east-west links in multi-plane topologies.

3) Write a feature guide for negative disaggregation, similar to the existing feature guide for positive disaggregation (https://github.com/brunorijsman/rift-python/blob/master/doc/positive-disaggregation-feature-guide.md <https://github.com/brunorijsman/rift-python/blob/master/doc/positive-disaggregation-feature-guide.md>).

4) Write an article on disaggregation (positive or negative) and submit for publication in the Internet Protocol Journal or similar.

5) Do interoperability testing with Juniper.

— Bruno

---

From: Tony Przygienda <[email-masked]>
Date: Sun, 3 May 2020 11:00:10 -0700

that was pretty fast ... wow ...

-- tony

On Sun, May 3, 2020 at 9:55 AM Bruno Rijsman <[email-masked]> wrote:

> Mariano Scazzariello and Tommaso Caiazzi informed me that they completed
> the implementation negative disaggregation in the open source RIFT-Python
> implementation (including new unit tests).
>
> I want to extend a heart-felt “thank you very much!” to Mariano and
> Tommaso for their excellent work and their generous contribution of this
> important feature!
>
> I wish them good luck in using the newly implemented code in their further
> research on Kathará (https://www.youtube.com/watch?v=ionEpKjv3Vk) and
> Megalos (https://www.youtube.com/watch?v=XvInh-kujrA).
>
> I have merged all of their code into my master branch:
> https://github.com/brunorijsman/rift-python
>
> My next steps are:
>
> 3) Write a feature guide for negative disaggregation, similar to the
> existing feature guide for positive disaggregation (
> https://github.com/brunorijsman/rift-python/blob/master/doc/positive-disaggregation-feature-guide.md
> ).
>
> 4) Write an article on disaggregation (positive or negative) and submit
> for publication in the Internet Protocol Journal or similar.
>

---

From: Bruno Rijsman <[email-masked]>
Date: Mon, 4 May 2020 11:10:05 -0600

> On May 3, 2020, at 10:55 AM, Bruno Rijsman <[email-masked]> wrote:
> 

The topology generator now supports generating inter-plane east-west links, see following example diagram: