Subject: Re: [Rift] I-D Action: draft-ietf-rift-applicability-01.txt

From: Melchior Aelmans <[email-masked]>
Date: Mon, 12 Oct 2020 15:38:34 +0200

Hi,

I don't believe the below was corrected in the -02 version as it still
reads "more a specific" instead of "a more specific".

Cheers,
Melchior

On Sun, May 3, 2020 at 9:37 PM Melchior Aelmans <[email-masked]> wrote:

> Dear authors,
>
> I've spotted a small typo in section 4.6. Positive vs. Negative
> Disaggregation:
>
> Disaggregation is the procedure whereby [RIFT <https://tools.ietf.org/html/draft-ietf-rift-applicability-01#ref-RIFT>] advertises more a specific route Southwards as an exception to the aggregated fabric-default North.
>
>
> I think you are trying to say "advertises a more sepcific".
>
> Cheers,
> Melchior
>
> On Fri, Apr 3, 2020 at 10:54 AM <[email-masked]> wrote:
>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>> This draft is a work item of the Routing In Fat Trees WG of the IETF.
>>
>>         Title           : RIFT Applicability
>>         Authors         : Yuehua Wei
>>                           Zheng Zhang
>>                           Dmitry Afanasiev
>>                           Tom Verhaeg
>>                           Jaroslaw Kowalczyk
>>                           Pascal Thubert
>>         Filename        : draft-ietf-rift-applicability-01.txt
>>         Pages           : 29
>>         Date            : 2020-04-03
>>
>> Abstract:
>>    This document discusses the properties, applicability and operational
>>    considerations of RIFT in different network scenarios.  It intends to
>>    provide a rough guide how RIFT can be deployed to simplify routing
>>    operations in Clos topologies and their variations.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-rift-applicability/
>>
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-rift-applicability-01
>> https://datatracker.ietf.org/doc/html/draft-ietf-rift-applicability-01
>>
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-rift-applicability-01
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>>
>> _______________________________________________
>> RIFT mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rift
>>
>

---

From: <[email-masked]>
Date: Tue, 13 Oct 2020 16:58:02 +0800 (CST)

Hi

Will reflect the correction to version -03.

Thank you so much!

Best Regards,

Yuehua Wei

ZTE Corporation

南京市软件大道50号/No.50, Software Avenue, Nanjing, 210012, P. R. China

M: +86 13851460269 E: [email-masked]

原始邮件

发件人：MelchiorAelmans
收件人：[email-masked];
抄送人：[email-masked];
日 期 ：2020年10月12日 21:38
主 题 ：Re: [Rift] I-D Action: draft-ietf-rift-applicability-01.txt

Hi,

I don't believe the below was corrected in the -02 version as it still reads "more a specific" instead of "a more specific".

Cheers,
Melchior

Dear authors,

I've spotted a small typo in section 4.6. Positive vs. Negative Disaggregation:

Disaggregation is the procedure whereby [RIFT] advertises more a specific route Southwards as an exception to the aggregated fabric-default North.

Cheers,

Melchior

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing In Fat Trees WG of the IETF.

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

---

From: Melchior Aelmans <[email-masked]>
Date: Thu, 15 Oct 2020 22:08:02 +0200

Thanks for taking into account my suggestions.

I'm rereading the draft again and section 4.10 "Dual Homing Servers"
doesn't really make it clear to me what the benefits are for dual homing
servers to a RIFT fabric.

First, in this specific section you start using Spine and ToR to refer to
this level where in other places in the draft you only refer to this as
Spine. For easier reading I would suggest picking Spine.

Second, although I agree that the loss of a Spine results in more specifics
would they in this example hit the server? From the server perspective the
default still points to the Leaf. The Leaf would indeed need to have more
specifics in order to avoid the blakhole at Spine level but I'm not sure
they are propagated to the servers.

Also, it might be interesting to emphasize little more on the advantages of
multi-homing servers to a RIFT fabric especially when they partake in RIFT;
the avoidance of L2 in between Leaf and server, easier IP mobility, etc.

Looking forward to hearing what you think.
If you are interested I'm willing to (re)write something for this section.

Cheers,
Melchior

On Tue, Oct 13, 2020 at 10:58 AM <[email-masked]> wrote:

> <[email-masked]>
> *发件人：*MelchiorAelmans
> *收件人：[email-masked];
> *抄送人：[email-masked];
> *日 期 ：*2020年10月12日 21:38
> *主 题 ：**Re: [Rift] I-D Action: draft-ietf-rift-applicability-01.txt*

---

From: <[email-masked]>
Date: Wed, 21 Oct 2020 17:33:52 +0800 (CST)

Hi Melchior,

Thank you! Please find my comments inline start with "Wei>>>>"

Best Regards,

Yuehua Wei

ZTE Corporation

原始邮件

发件人：MelchiorAelmans
收件人：魏月华00019655;
抄送人：[email-masked];[email-masked];
日 期 ：2020年10月16日 04:08
主 题 ：Re: [Rift] I-D Action: draft-ietf-rift-applicability-01.txt

I'm rereading the draft again and section 4.10 "Dual Homing Servers" doesn't really make it clear to me what the benefits are for dual homing servers to a RIFT fabric.

First, in this specific section you start using Spine and ToR to refer to this level where in other places in the draft you only refer to this as Spine. For easier reading I would suggest picking Spine.
Wei>>>> I am using ToR1&ToR2 and SV(1, ...,n) to describe an example of a fat-tree structure in a data center scenario for a more intuitive understanding. The SVs are leaves.Second, although I agree that the loss of a Spine results in more specifics would they in this example hit the server? From the server perspective the default still points to the Leaf. The Leaf would indeed need to have more specifics in order to avoid the blakhole at Spine level but I'm not sure they are propagated to the servers.
Wei>>>> In this figure, the SVs are leaves.Also, it might be interesting to emphasize little more on the advantages of multi-homing servers to a RIFT fabric especially when they partake in RIFT; the avoidance of L2 in between Leaf and server, easier IP mobility, etc.

If you are interested I'm willing to (re)write something for this section.
Wei>>>>comments are welcome.

Cheers,
Melchior

Hi

Thank you so much!

Best Regards,

Yuehua Wei

ZTE Corporation

原始邮件

发件人：MelchiorAelmans

Hi,

Cheers,
Melchior

Dear authors,

Cheers,

Melchior

Abstract: