Subject: [Rift] draft-ietf-rift-applicability-05 Comments

From: Jordan Head <[email-masked]>
Date: Mon, 3 May 2021 14:30:56 +0000

Pascal pointed out that I forgot the rest of the WG on feedback provided on applicability-05, sorry about that.  Text copied below.

No major issued with regard to content, just some comments / nits that are easy to address.  I think Section 4.4 (ZTP) is much clearer and does a good job of conveying that an operator could set related items via configuration, but why they shouldn’t with strong correlating examples. Other than what I mention below, I think it’s ready for WGLC.

Section 1: Introduction

"how RIFT corrects topology mis-cablings"

JH
RIFT does not 'correct' topology mis-cablings.  One could say something like 'identifies' (allowing operators to fix) or 'accounts for' (by not establishing the adjacency).

Section 2: Problem Statement of Routing in Modern IP Fabric Fat Tree Networks

              JH
The bulleted list describes individual points as to how traditional routing protocols behave when applied to fat tree networks.  Bullet 4 is basically a continuation of bullet 3 and could be combined to better convey the intended cause/effect.  I'd suggest something like:

“They flood significant amounts of duplicate link state information between spine and leaf nodes during topology updates and convergence events, requiring that additional CPU and link bandwidth be consumed.  This may impact the stability and scalability of the fabric and prevent the use of cheaper hardware at the lower levels (i.e. spine and leaf nodes).”

Section 3.1: Overview of RIFT

“RIFT is a dynamic routing protocol that is specifically tailored for
   use in Clos and Fat Tree network topologies.”

JH
Many of the challenges that RIFT tries to solve for were conceived due to today's datacenter topologies (Clos/Fat-Tree).  I also realize that non-Clos/FT variants are mentioned later, but this sentence sends the wrong message to the reader too early, in my opinion.  We spend a great deal of time explaining how it can be implemented _outside_ of the datacenter and unintentionally sets the expectation that items in section 3.3 and section 4.15 should be viewed as "exceptions to the rule".

I think something like this would send a clearer message:

"RIFT is a dynamic routing protocol that is tailored for use in Clos, Fat-Tree, and other anisotropic topologies."  (or something similar)

nits:

    A few examples of RIFT not being fully capitalized.  For example, Section 4.12 and Figure 1's title.

 Jordan Head

Juniper Business Use Only

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 3 May 2021 15:03:14 +0000

Hello Jordan

I do agree that we’re ready for WGLC.

Many thanks for your review! I’m good with the proposed changes and made a pull request https://github.com/RIFT-WG/RIFT-Applicability/pull/10

Keep safe;

Pascal

From: RIFT <[email-masked]> On Behalf Of Jordan Head
Sent: lundi 3 mai 2021 16:31
To: [email-masked]
Subject: [Rift] draft-ietf-rift-applicability-05 Comments

Section 1: Introduction

JH

              JH

JH

nits:

 Jordan Head