Subject: [rmcat] Next phase of RMCAT

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 23 Jun 2014 13:25:37 +0000

Hi RMCAT WG,

we've been making slow but steady progress on our first milestones:

* The cc-requirements draft is with the IESG.

* The eval-criteria draft(s) are taking shape, as do the group-cc draft(s). For the latter (set of) documents, we'll likely ask for WG adoption shortly.

* As for rtcp-requirements, it seems that we may not need a document here. (This was a tentative milestone to begin with.)

* For app-interactions, we have a first -00 proposal, but much more work is needed.

At any event, the chairs believe that at this stage, we can probably move the WG into the next phase. In this next phase, the goal is to see different candidate congestion control algorithms that fulfill the cc-requirements specified and evaluated, with the goal of publishing some of them that are deemed safe for widespread experimentation on the Internet as Experimental RFCs.

The specification and evaluation for some of these candidates has already been underway for quite a while (e.g., NADA, Google), whereas others are much newer (e.g., SCREAM).

We'd very much like the different groups proposing these algorithms to (1) clarify their specifications based on WG discussion, (2) evaluate them according to at least the eval-criteria (but possibly also in other scenarios), (3) ideally also implement and evaluate at least one other "competitor" in their respective test setup, and (4) report the results back to the WG for discussion.

I'd like to highlight the importance of step (3). We really need folks to experiment with not only their own proposal, but also try and implement someone else's proposal specification. Reproducibility of results is key. This will eliminate ambiguities in the spec, but will more importantly bring unstated assumptions, quirks of individual test setups and other issues to light.

I'd also like to remind folks that we are NOT doing these evaluations at this time in order to pick a "winner" for Standards track publication - that comes later. The purpose of the current evaluation phase is to ensure that those candidates that we publish as Experimental RFCs are safe for widespread experimentation on the Internet. So the focus should be on whether they fulfill (some of) the goals laid out in cc-requirements while being safe to use on live networks. So the focus of the experimentation is probably more on whether candidate algorithms can get into states where they seriously misbehave, rather than comparing which algorithm is "better" under which conditions.

After we've come to consensus on which algorithms are safe to experiment with in the wild, we'll publish those specs as experimental RFCs and begin collecting evaluation results from those live deployments. Once we feel we have a good understanding on how those algorithms behave in the real world, we'll begin the discussion of which one(s) we recommend to move to the Standards track.

A quick word on timing. We have a handful of algorithms proposals that can now enter the initial evaluation stage together, which is useful. I don't think we want to close the door on evaluating any other proposals that might be proposed to the WG in the future, but if there is anyone out there with a proposal that hasn't been described in an Internet-Draft yet, it would be really useful if that would happen sooner rather than later, so it can be part of the evaluation phase we're about to enter next.

Also, a short reminder that folks obviously need to comply to the IETF's IPR rules, and promptly disclose any IPR that may be associated with their contributions. It's always painful for all involved when disclosures come late in the process. The chairs are very happy to clarify the IETF's IPR policies, if there are questions.

I hope the above clarifies a bit how the chairs see the next phase of work in RMCAT. Comments welcome. We will also discuss this in more detail during the Toronto meeting (we asked for some extra time for this); we can also discuss whether our current milestones and charter need updating.

Lars

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Mon, 23 Jun 2014 15:51:39 +0200

+1, and I think it is good to have the milestones updated.

BR

Zahed

> I hope the above clarifies a bit how the chairs see the next phase of work in RMCAT. Comments welcome. We will also discuss this in more detail during the Toronto meeting (we asked for some extra t…

-