Subject: [rmcat] I-D Action: draft-ietf-rmcat-wireless-tests-00.txt

From: [email-masked]
Date: Fri, 12 Jun 2015 04:42:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the RTP Media Congestion Avoidance Techniques Working Group of the IETF.

        Title           : Evaluation Test Cases for Interactive Real-Time Media over Wireless Networks
        Authors         : Zaheduzzaman Sarker
                          Ingemar Johansson
	Filename        : draft-ietf-rmcat-wireless-tests-00.txt
	Pages           : 12
	Date            : 2015-06-12

Abstract:
   It is evident that to ensure seamless and robust user experience
   across all type of access networks multimedia communication suits
   should adapt to the changing network conditions.  There is an ongoing
   effort in IETF RMCAT working group to standardize rate adaptive
   algorithm(s) to be used in the real-time interactive communication.
   In this document test cases are described to evaluate the
   performances of the proposed endpoint adaptation solutions in LTE
   networks and Wi-Fi networks.  It is aimed that the proposed solutions
   should be evaluated using the test cases defined in this document to
   select most optimal solutions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rmcat-wireless-tests/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-rmcat-wireless-tests-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Fri, 12 Jun 2015 11:49:34 +0000

Hi everyone,

Now we have uploaded the new version of the wireless test case draft. Yes, unfortunately the test cases for the Wi-Fi network is still missing.

This version ref. to NS-3 LTE simulator where the proposed cellular test cases can be implemented.
I am looking into creating an example simulation program for NS-3. You will be notified when I am done with it.

BR

Zahed

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: den 12 juni 2015 13:42
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-rmcat-wireless-tests-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 18 Jun 2015 15:39:29 +0200

Hi all,

thanks Zahed for submitting. 

We as chairs think that it is, however, also very important to have some basic WiFi test cases. Please provide input to Zahed if you have already implemented a WiFi test case for your own evaluation!

@Xiaoqing: Do you already have something here?

Mirja

> Am 12.06.2015 um 13:49 schrieb Zaheduzzaman Sarker <[email-masked]>:
> 
> Hi everyone,
>

---

From: Stefan Holmer <[email-masked]>
Date: Thu, 18 Jun 2015 14:28:24 +0000

Hi,

We have used a packet arrival time recording which we made on a tricky WiFi
network (attached). It doesn't contain packet order or size, but assuming
around 1000 bytes packets corresponds to ~3 Mbps.

/Stefan

On Thu, Jun 18, 2015 at 3:39 PM Mirja Kühlewind <
[email-masked]> wrote:

> We as chairs think that it is, however, also very important to have some
> basic WiFi test cases. Please provide input to Zahed if you have already
> implemented a WiFi test case for your own evaluation!
>
> > Now we have uploaded the new version of the wireless test case draft.
> Yes, unfortunately the test cases for the Wi-Fi network is still missing.
> >
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Thu, 18 Jun 2015 14:51:50 +0000

Hi, 

Agree that Wi-Fi based test cases are important.  My colleagues and I are
currently working on those, still tuning what basic scenarios we should
test one.  Will share once we converge on those.

Thanks,
Xiaoqing

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 18 Jun 2015 17:01:29 +0200

Hi Stefan,

are those traces available somewhere, can they be made available (we can also put them on our rmcat wiki…)?

Which simulator are you using to re-play those traces?

Mirja

> Am 18.06.2015 um 16:28 schrieb Stefan Holmer <[email-masked]>:
> 
> Hi,
> 
> We have used a packet arrival time recording which we made on a tricky WiFi network (attached). It doesn't contain packet order or size, but assuming around 1000 bytes packets corresponds to ~3 Mbps.
> 
> /Stefan
> 
> On Thu, Jun 18, 2015 at 3:39 PM Mirja Kühlewind <[email-masked]> wrote:
> Hi all,
> 
> <google-wifi-3mbps.rx>

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 18 Jun 2015 17:03:07 +0200

Great, thanks!

Do you already know when you’ll be ready to share? While you be able to provide something before the next submission cut-off (July 6)?

Mirja

> Am 18.06.2015 um 16:51 schrieb Xiaoqing Zhu (xiaoqzhu) <[email-masked]>:
> 
> Hi, 
>

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Thu, 18 Jun 2015 21:52:05 +0000

Let me double check before getting back to you whether we can make for the
Jul-6 deadline Š

-Xiaoqing

On 6/18/15, 10:03 AM, "Mirja Kühlewind" <[email-masked]>
wrote:

>Great, thanks!
>
>Do you already know when you¹ll be ready to share? While you be able to
>provide something before the next submission cut-off (July 6)?
>
>Mirja
>
>

---

From: Stefan Holmer <[email-masked]>
Date: Fri, 19 Jun 2015 10:01:58 +0000

> also put them on our rmcat wiki…)?

The trace I attached is the one we have mainly been using. If we are going
to record more we should probably work out a specification of how exactly
we want the recordings to be made (regarding load, packet sizes, etc.)?

> Which simulator are you using to re-play those traces?

We are using our own simulator which can be found under the webrtc.org
repository
<https://chromium.googlesource.com/external/webrtc/+/master/webrtc/modules/remote_bitrate_estimator/test/>.
Specifically, the code to play back a trace can be found here
<https://chromium.googlesource.com/external/webrtc/+/master/webrtc/modules/remote_bitrate_estimator/test/bwe_test_framework.cc>
on
lines 485 - 622.

> > We have used a packet arrival time recording which we made on a tricky
> WiFi network (attached). It doesn't contain packet order or size, but
> assuming around 1000 bytes packets corresponds to ~3 Mbps.
> >
> > /Stefan
> >

---

From: Mirja Kühlewind <[email-masked]>
Date: Fri, 19 Jun 2015 12:42:53 +0200

Hi Stefan,

> Am 19.06.2015 um 12:01 schrieb Stefan Holmer <[email-masked]>:
> 
> 
> 
> On Thu, Jun 18, 2015 at 5:01 PM Mirja Kühlewind <[email-masked]> wrote:
> Hi Stefan,
> 
> The trace I attached is the one we have mainly been using. If we are going to record more we should probably work out a specification of how exactly we want the recordings to be made (regarding load, packet sizes, etc.)?

Sorry didn’t realize that the trace was attached. Is it okay if I put the trace in our wiki?

Actually a description how the traces where captured would be useful. Should we put some text on the wiki as well for now…?

> We are using our own simulator which can be found under the webrtc.org repository. Specifically, the code to play back a trace can be found here on lines 485 - 622.

Great! Will put the link to the simulator on the wiki as well!

Mirja

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Mon, 22 Jun 2015 13:50:15 +0200

Hi Stefan and Mirja,

> Actually a description how the traces where captured would be useful. Should we put some text on the wiki as well for now…?

I am also interested in getting description of the "tricky WiFi 
network". The wireless testcase draft can have such description of WiFi 
networks that we consider to be tricky and have impact of the perceived 
media quality. One can then decide whether to use a trace based 
simulator or have an event based simulator to realize the network setup. 
I am however, yet to be convinced that a trace based simulator is good 
enough for wireless networks. The reaction to the congestion and 
behavior (mobility, traffic pattern etc) of the wireless endpoints have 
impact on the network state. This plays significant role in radio 
network like LTE.

-- 
Zahed

==================================================
ANM ZAHEDUZZAMAN SARKER

Ericsson AB
Services, Media and Network Features
Laboratoriegränd 11
97128 Luleå, Sweden
Phone +46 10 717 37 43
Fax +46 920 996 21
SMS/MMS +46 76 115 37 43
[email-masked]
www.ericsson.com

==================================================