Subject: [Rmt] PGMCC window manager computation

From: BABONNEAU Gérard FTRD/DMI/REN <[email-masked]>
Date: Fri, 25 Jul 2003 13:45:41 +0200

Hi,
 
Algorithm in section 2.2 seems ambiguous.
For "ACK RECEPTION, LOSS DETECTED", order is important: if I suppose there are only one T variable and one W variable:

*	If I compute first T = T - W/2, I use the previous value of W
*	If I compute T after W, I use the new value of W

The same problem exist also in the token computation without losses.
 
Is there something missing in the draft, or do I misunderstand?
 
Regards,
Gérard BABONNEAU 

france telecom R&D 
4, rue du Clos Courtel - BP 59 - 35512 Cesson Sevigné Cedex 
Tel : +33 2 99 12 40 08  -  Fax : +33 2 99 12 40 98 
e-mail : [email-masked]

---

From: Gianluca Iannaccone <[email-masked]>
Date: Mon, 28 Jul 2003 08:44:32 -0700

gerard,

the order is certainly important and the draft reads: 

      T = T - W/2, W = W/2 

where the comma indicates the order. so a sender decreases
the tokens by half-window and then cuts by half the current
window size. 

however, if it makes the draft more readable we could use 
two lines:

      T = T - W/2;
      W = W/2; 

cheers, 
gianluca

----------------------------------------------------------
Gianluca Iannaccone      '         [email-masked]
Sprint ATL               '           tel +1 (650) 375-4198
1 Adrian Court           '           fax +1 (650) 375-4079
Burlingame, CA 94010     '    www.sprintlabs.com/~gianluca

-----Original Message-----
From: BABONNEAU Gérard FTRD/DMI/REN
[mailto:[email-masked]] 
Sent: Friday, July 25, 2003 4:46 AM
To: [email-masked]
Subject: [Rmt] PGMCC window manager computation

Hi,   Algorithm in section 2.2 seems ambiguous. For "ACK RECEPTION, LOSS
DETECTED", order is important: if I suppose there are only one T variable
and one W variable:   
If I compute first T = T - W/2, I use the previous value of W 
If I compute T after W, I use the new value of W
  The same problem exist also in the token computation without losses.   Is
there something missing in the draft, or do I misunderstand?   Regards, 
Gérard BABONNEAU 

france telecom R&D 

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt