Subject: RE: [Rmt] Fully-specified or Under-Specified Reed-Solomon

From: "Sami Peltotalo" <[email-masked]>
Date: Fri, 1 Oct 2004 08:16:45 +0300

Hi All,

Seems that this issue doesn't raise very much conversation. Why? Seems that
there is only very few "active" members at the RMT group. Do we now have
consensus about this issue? People have had three weeks time (or three
months) to say their opinion. The initial proposal was Under-Specified FEC
scheme. Now we have got two votes for Fully-Specified FEC scheme (Luby and
Chapweske). Is this enough to change to Fully-Specified?

Cheers, Sami

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Justin Chapweske
> Sent: 17. syyskuuta 2004 22:22
> To: Michael Luby
> Cc: Rmt@ietf. org
> Subject: Re: [Rmt] Fully-specified or Under-Specified Reed-Solomon
>
>
> I agree that it should be a Fully Specific scheme, though it would take
> someone a bit of work to document the various polynomials used for 8 and
> 16 bit codes, exactly how the matrices are generated, etc.
>
> To date, Luigi's code is the only real "documentation" of these
> parameters and it would be nice to see documentation that would allow
> interoperable implementation from a fresh code base.
>
> Thanks,
>
> -Justin
>
> On Fri, 2004-09-10 at 18:05 -0700, Michael Luby wrote:
> > RMTers,
> >
> > One question that has come up in off-line discussions is how to
> develop a
> > Reed-Solomon based FEC codec, i.e. as either a Fully-Specified
> FEC scheme or
> > as an Under-Specified FEC scheme.
> >
> > I'm personally in favor of a Fully-Specified FEC scheme for a lot of
> > reasons, but there are arguments on both sides.  The purpose of
> this email
> > is not to provide those arguments, but to open up the dialog so
> that in this
> > email thread individuals can make the arguments on both sides
> with the goal
> > of finding a consensus answer to this question.
> >
> > Best, Mike
> >
> >
> > _______________________________________________
> > Rmt mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/rmt
> --
> Justin Chapweske <[email-masked]>
>
>
> _______________________________________________
> Rmt mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rmt

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

---

From: Andrew Marlow <[email-masked]>
Date: Sat, 02 Oct 2004 16:38:47 +0100

Sami Peltotalo <[email-masked]> on 01 October 2004 at 06:16 +0000
wrote:
>Hi All,
>
>Seems that this issue doesn't raise very much conversation. Why? 

well I have a theory about that. 
The limited amount of discussion that does take
place seems to be just in this mailing list.
USENET stays pretty much silent and the RMT-related
web sites remain as cobweb sites. When there are RMT developments
perhaps these could be mentioned with a relevant URL, in various
USENET groups. There are C/C++ experimental  implementations,
e.g the one by Brian Adamson, so mentions on comp.lang.c++ etc might
generate more interest. Multicast is frequently raised on other forums
such as the one on ACE (where they are currently experimenting with PGM)
so a mention there would not go amiss, IMO.

Regards,

Andrew Marlow
----
There is an emerald here the size of a plover's egg!