Subject: Re: [Rmt] EXP2ST: FLUTE FDT extension by element should be allowed

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Sep 2005 13:45:08 +0200

Hi,

For your knowledge in the update of the FDT extensions used in 3GPP we 
also documented the Flute FDT schema we have based our extensions on. It 
contains the following changes:
- Fix of the postfixed name space indicators.
- change of target name space from "http://www.example.com/flute" to 
"urn:IETF:metadata:2005:FLUTE:FDT". Usage of www.example.com seems very 
wrong, it it should be in URL format I think www.ietf.org should have 
been used.
- Addition of extensibility of both elements and attributes both on file 
and global level.

I would hope that this is a schema that you can use as is and we simply 
remove our copy of it with an reference to the updated FLUTE spec. If 
this is not okay we need to know it as soon as possible as how the 
agreed one looks. Before November would be good.

cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
<?xml version="1.0" encoding="UTF-8"?>
<xs:schema 
	xmlns="urn:IETF:metadata:2005:FLUTE:FDT" 
	xmlns:xs="http://www.w3.org/2001/XMLSchema" 
	targetNamespace="urn:IETF:metadata:2005:FLUTE:FDT" 
	elementFormDefault="qualified">
	<xs:element name="FDT-Instance" type="FDT-InstanceType"/>
	<xs:complexType name="FDT-InstanceType">
		<xs:sequence>
			<xs:element name="File" type="FileType" maxOccurs="unbounded"/>
			<xs:any namespace="##other" processContents="skip" minOccurs="0" maxOccurs="unbounded"/>
		</xs:sequence>
		<xs:attribute name="Expires" type="xs:string" use="required"/>
		<xs:attribute name="Complete" type="xs:boolean" use="optional"/>
		<xs:attribute name="Content-Type" type="xs:string" use="optional"/>
		<xs:attribute name="Content-Encoding" type="xs:string" use="optional"/>
		<xs:attribute name="FEC-OTI-FEC-Encoding-ID" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="FEC-OTI-FEC-Instance-ID" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="FEC-OTI-Maximum-Source-Block-Length" type="xs:unsignedLong" 
			use="optional"/>
		<xs:attribute name="FEC-OTI-Encoding-Symbol-Length" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="FEC-OTI-Max-Number-of-Encoding-Symbols" type="xs:unsignedLong" 
			use="optional"/>
		<xs:attribute name="FEC-OTI-Scheme-Specific-Info" type="xs:base64Binary" use="optional"/>
		<xs:anyAttribute processContents="skip"/>
	</xs:complexType>
	<xs:complexType name="FileType">
		<xs:sequence>
			<xs:any namespace="##other" processContents="skip" minOccurs="0" maxOccurs="unbounded"/>
		</xs:sequence>
		<xs:attribute name="Content-Location" type="xs:anyURI" use="required"/>
		<xs:attribute name="TOI" type="xs:positiveInteger" use="required"/>
		<xs:attribute name="Content-Length" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="Transfer-Length" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="Content-Type" type="xs:string" use="optional"/>
		<xs:attribute name="Content-Encoding" type="xs:string" use="optional"/>
		<xs:attribute name="Content-MD5" type="xs:base64Binary" use="optional"/>
		<xs:attribute name="FEC-OTI-FEC-Encoding-ID" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="FEC-OTI-FEC-Instance-ID" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="FEC-OTI-Maximum-Source-Block-Length" type="xs:unsignedLong" 
			use="optional"/>
		<xs:attribute name="FEC-OTI-Encoding-Symbol-Length" type="xs:unsignedLong" use="optional"/>
		<xs:attribute name="FEC-OTI-Max-Number-of-Encoding-Symbols" type="xs:unsignedLong" 
			use="optional"/>
		<xs:attribute name="FEC-OTI-Scheme-Specific-Info" type="xs:base64Binary" use="optional"/>
		<xs:anyAttribute processContents="skip"/>
	</xs:complexType>
</xs:schema>
_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

---

From: [email-masked]
Date: Fri, 16 Sep 2005 07:48:11 +0300

Thanks Mangus - this is indeed the right schema. There were a couple of
bugs in the 3GPP example XML, but since we'll do our own example without
"3gpp" strings I'm happy it's bug free :)

Please expect this schema to appear in the FLUTEbis.

The FLUTEbis will be ready for WGLC this month (unless major issues
arise) - Lorenzo probably has the best idea when the actual WGLC is best
timed. Naturally, there's no crystal ball good enough to know when an
RFC would be published after this. The target specified in IETF63 is
that it would only have the RFC Editor hurdle left by year end.

Cheers, Rod.

>-----Original Message-----
>From: ext Magnus Westerlund [mailto:[email-masked]] 
>Sent: 15 September, 2005 14:45
>To: Magnus Westerlund
>Cc: Walsh Rod (Nokia-NRC/Tampere); [email-masked]
>Subject: Re: [Rmt] EXP2ST: FLUTE FDT extension by element 
>should be allowed
>
>Hi,
>
>For your knowledge in the update of the FDT extensions used in 
>3GPP we also documented the Flute FDT schema we have based our 
>extensions on. It contains the following changes:
>"urn:IETF:metadata:2005:FLUTE:FDT". Usage of www.example.com 
>seems very wrong, it it should be in URL format I think 
>www.ietf.org should have been used.
>- Addition of extensibility of both elements and attributes 
>both on file and global level.
>
>I would hope that this is a schema that you can use as is and 
>we simply remove our copy of it with an reference to the 
>updated FLUTE spec. If this is not okay we need to know it as 
>soon as possible as how the agreed one looks. Before November 
>would be good.
>
>cheers
>
>Magnus Westerlund
>