Subject: [Rmt] Should RS FEC I-D be a working group item?

From: Vincent Roca <[email-masked]>
Date: Wed, 09 Nov 2005 19:48:56 +0100

Dear collegues,

Following the recommendation of Lorenzo on monday, during the RMT WG 
session,
we are asking you whether you see any good reason to make the Reed-Solomon
FEC I-D a working group item or not.
Cheers,

    Jérome, Vincent, Sami and Jani.

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

---

From: "Michael Luby" <[email-masked]>
Date: Wed, 9 Nov 2005 11:06:29 -0800

Hi Vincent,
Sorry, not having been at the RMT meeting, it would be good to know a little
more context on the question you asked.

(1) What was submitted as a "Reed-Solomon" code to the current IETF was not
a Reed-Solomon code (not MDS, for example).  Is the plan to prepare and
submit a true Reed-Solomon code proposal?

(2) Is the plan to do a fully-specified FEC Encoding ID? (At some point
there was also a submittal of an Under-Specified FEC Encoding ID for a
Reed-Solomon code.)

(3) If the answer to (1) is yes, then is there also a plan to also go
forward with the proposal that was Reed-Solomon-like but that was not a
Reed-Solomon proposal?

Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Vincent Roca
Sent: Wednesday, November 09, 2005 10:49 AM
To: [email-masked]
Subject: [Rmt] Should RS FEC I-D be a working group item?

Dear collegues,

---

From: Brian Adamson <[email-masked]>
Date: Wed, 9 Nov 2005 11:06:54 -0800

I think it is an important item since one or more 
fully-specified RS schemes can provide for more 
compact FEC Payload ID header fields (and 
corresponding FEC OTI) than the corresponding 
Unspecified schemes ...

On this note, I also think it might be 
appropriate to perhaps document 2 distinct 
fully-specified RS schemes, one for up to GF(8) 
and a separate sheme for up to GF(16) RS codes to 
allow a compact FEC Payload ID format support 
larger objects (providing more bits for "block 
number") in the case of GF(8) codes than if the 
same format were specified for both GF(8) through 
GF(16) codes?

At 7:48 PM +0100 11/9/05, Vincent Roca wrote:
>Dear collegues,
>
>Following the recommendation of Lorenzo on monday, during the RMT WG session,

-- 
Brian
__________________________________
Brian Adamson
<http://cs.itd.nrl.navy.mil/5522>
<mailto:[email-masked]>

---

From: Vincent Roca <[email-masked]>
Date: Wed, 09 Nov 2005 20:19:51 +0100

Hello Mike,

Sorry, I forgot to add the explanations that I gave during the session, 
Monday.

1- Yes the final I-D aims to be 100% compatible with Luigi's codec, 
version 2, July 1998,
and this one is MDS. We've been confused by version 1...

2- Yes, the proposal defines a fully specified FEC Enc ID.

3- Our plan is to only consider the fully MDS scheme, forgotting 
completely the other one.

Cheers,

  Vincent

---

From: Mark Pullen <[email-masked]>
Date: Wed, 9 Nov 2005 14:29:21 -0500 (EST)

Under these terms, I'm in favor.

Mark

On Wed, 9 Nov 2005, Vincent Roca wrote:

> !DSPAM:43724c41152851364027241!
>

---

From: "Michael Luby" <[email-masked]>
Date: Wed, 9 Nov 2005 11:35:07 -0800

Thanks.  This looks good to me.

-----Original Message-----
From: Vincent Roca [mailto:[email-masked]] 
Sent: Wednesday, November 09, 2005 11:20 AM
To: Michael Luby
Cc: [email-masked]
Subject: Re: [Rmt] Should RS FEC I-D be a working group item?

Hello Mike,

Cheers,

  Vincent