Subject: Re: [Rmt] last call on Raptor publication

From: "Mike Luby" <[email-masked]>
Date: Tue, 6 Jun 2006 14:47:31 -0700

Marshall,

What DF proposes to do is to revise the DF IPR statement for Raptor in
RMT and add language along lines that Mark outlined in his original
email (which appears at the bottom of this email), i.e.

"Although Digital Fountain is not able to offer RAND terms independent
of market and application, Digital Fountain offers RAND terms for
specific standards such as 3GPP MBMS and DVB-H IPDC, and intends to
offer RAND terms for additional specific standards in the future."

Regards, Mike

From: Marshall Eubanks [[email-masked]]
Sent: Tuesday, June 06, 2006 8:38 AM
To: Lorenzo Vicisano
Cc: [email-masked]
Subject: Re: [Rmt] last call on Raptor publication

Can I inquire just what the DF IPR statement actually is ?

The draft
http://www3.ietf.org/proceedings/05aug/IDs/draft-ietf-rmt-bb-fec-
raptor-object-01.txt
says

8.  Intellectual Property

    Digital Fountain does have intellectual property rights associated
    with the technology described in this document, and intends to
    provide a full IPR statement specific to this document to the IETF
    that will satisfy the requirements of the IETF.

(BTW, this draft is apparently no longer on the RMT charter page under
any version.)

Digging I find this
https://datatracker.ietf.org/public/ipr_detail_show.cgi?ipr_id=702
with

The Patent Holder states that its position with respect to licensing any
patent claims contained in the patent(s) or patent application(s)
disclosed above that would necessarily be infringed by implementation of
the technology required by the relevant IETF specification ("Necessary
Patent Claims"), for the purpose of implementing such specification, is
as follows(select one licensing declaration option
only):
Unwilling to Commit to the Provisions.
-----

Is there an actual IPR statement ? I thought that there was, but I am
perturbed not to be able to find one. I am talking to SMPTE people about
this and have nothing really I can show them.

If there is not, then I would change my support to be in favor of option
c, "experimental"

Regards
Marshall

On Jun 5, 2006, at 3:14 PM, Lorenzo Vicisano wrote:

> As you know, Digital Fountain changed the IPR statement for the FEC ID

> Raptor (draft-ietf-rmt-bb-fec-raptor-object) withdrawing the "RAND"
> terms (please see the email that Mark Watson sent to this list, 
> attached below).
>
> This thread is to settle once for all the position of the RMT WG on 
> this issue, in particular regarding whether and how the WG wants to 
> sponsor raptor for publication.
>
> We have the options of:
>
>   a) asking the IESG to publish raptor as a Standard-Track document
>      (as originally planned).
>   b) abandoning raptor as a WG standard
>   c) asking the IESG to publish raptor as experimental or
>      informational. Note that this might create problems with the
>      IANA allocation of FEC IDs etc.
>
> This issue was already discussed on this list and at the last IETF 
> meeting (Dallas). So far we have had some comments in favor of option
> a) and no comments against it.
>
> Please express your opinion by June 19th. If we have no feedback by 
> then, we will assume that the WG wishes to go for a), given the 
> previous discussions.
>
> 	thank you,
> 	Lorenzo
>
> ################# Mark's email attached below #######################
>
> All,
>
>
>
> As most of you are aware, Digital Fountain has to date been promoting 
> our core technology, DF Raptor, as an open standard in IETF RMT and 
> elsewhere, for any and all applications.  This mail is to let you know

> about a change to that strategy: As a result of a recent, significant 
> new relationship that is crucial to Digital Fountain with a prime 
> contractor in the defense industry, our approach going forward will be

> to promote Raptor as an open standard for specific markets and 
> applications  including of course 3GPP and DVB standards where Raptor 
> has already been adopted and others in future.
>
>
>
> However, this means revising the IPR statement that we have made to 
> the IETF regarding draft-ietf-rmt-bb-fec-raptor-object because, whilst

> we still offer RAND terms for specific standards such as 3GPP and DVB,

> we are no longer able to offer RAND terms independent of market and 
> application.
>
>
>
> Going forward, there are several options regarding 
> draft-ietf-rmt-fec-raptor-object, including not publishing it at all.
> This is of course a decision for the IETF and Digital Fountain will 
> not take a position in that discussion.
>
>
>
> Best regards,
>
>
>
> Mark Watson
>
> Digital Fountain
>
> _______________________________________________
> Rmt mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rmt

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 6 Jun 2006 21:15:39 -0400

Hello Mike;

Thanks for this clarification.

With this revision, I support Option "a".

Regards
Marshall

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 14 Jun 2006 16:29:20 +0200

Hi,

I think people know my personal opinion on this, which is (A). However 
it is the WG's decision on what you want to do with the document. So 
don't count me for more than a participant in this case.

If we go with A. I (as an AD) will ensure that the writeup includes the 
WG's position and the fact that there is known IPR.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 14 Jun 2006 10:55:44 -0400

Just because I think the options should go with the email thread,  
here they are again :

"We have the options of:

      IANA allocation of FEC IDs etc."

And I support option a.

Regards
Marshall Eubanks

On Jun 14, 2006, at 10:29 AM, Magnus Westerlund wrote:

> Hi,
>
> I think people know my personal opinion on this, which is (A).  
> However it is the WG's decision on what you want to do with the  
> document. So don't count me for more than a participant in this case.
>
> If we go with A. I (as an AD) will ensure that the writeup includes  
> the WG's position and the fact that there is known IPR.
>
> Cheers
>
> Magnus Westerlund
>

---

From: "Mark Handley" <[email-masked]>
Date: Wed, 14 Jun 2006 16:09:55 +0100

> WG's position and the fact that there is known IPR.

I'm not very happy about this IPR issue, but it's important to
maintain perspective.

This document is entirely about Raptor.  It's not like standardizing
this BB codepoint compels anyone to use it in other protocols - the
IPR issues may well affect any other protocols that choose to use this
BB codepoint, but that's an issue for those protocols, not for this
document itself.   So, I don't believe it's a showstopper for this
particular document.

I vote for (a).

 - Mark